[Support] Linuxserver.io - Deluge


Recommended Posts

I'm trying to clean up in my torrents and delete older stuff using "Remove torrent -> Remove with data", however whenever I do this I loose connection with the webui, and when it reloads I have deleted just 3-4 torrents out of the hundred i selected. Even if I select just a single torrent the webui crashes. 

 

Any ideas?

  • Like 1
Link to comment
  • 1 month later...

Hello,

 

I have just installed Deluge as a docker app.

I would like to seed whole directories.

Is that even possible? Or do I need to do it file by file which is out of the question?

If I seed files how is my anonymity impacted if I am not using a VPN?

I tried to seed one single file of 1.5Gb but as soon as it started "scanning" it my Unraid started to act clogged, the cache disk was overwhelmed and eventually Deluge crashed or at least became unresponsive so I reset it.

I don't even know if I am doing it right.

I never seeded files before apart from freshly downloaded torrents, an then I was using Transmission.

 

Thank for any help

Link to comment

Hello Folks,

 

i am relatively new to Unraid and a complete Unix/Linux noob - i can use a terminal app from windows to comandos but i do not know them ....

my question - could anyone help me with the installation and the config part of deluge and how i use deluge on my unraid server ....

 

cheers - ahab666

Link to comment
  • 3 weeks later...

I've been getting this error constantly and my deluge container is crashing repeatedly. I get errors all the time with connecting and torrent downloads. Any ideas?

 

 kernel: deluged[20403]: segfault at 2b29722f5000 ip 00002b2979713ba7 sp 00002b29722f4118 error 6 in libtorrent-rasterbar.so.8.0.0[2b29795bb000+46f000]

 

 

Link to comment

also this massively:

 

Connection lost to daemon at 127.0.0.1:58846 reason: Connection was closed cleanly.
[INFO ] 21:35:33 client:217 Connecting to daemon at 127.0.0.1:58846..
[INFO ] 21:35:33 client:121 Connected to daemon at 127.0.0.1:58846..
[INFO ] 21:35:33 client:224 Connection lost to daemon at 127.0.0.1:58846 reason: Connection was closed cleanly.
[INFO ] 21:35:34 client:217 Connecting to daemon at 127.0.0.1:58846..
[INFO ] 21:35:34 client:121 Connected to daemon at 127.0.0.1:58846..
[INFO ] 21:35:34 client:224 Connection lost to daemon at 127.0.0.1:58846 reason: Connection was closed cleanly.
[INFO ] 21:35:38 client:217 Connecting to daemon at 127.0.0.1:58846..
[INFO ] 21:35:38 client:121 Connected to daemon at 127.0.0.1:58846..
[INFO ] 21:35:38 client:224 Connection lost to daemon at 127.0.0.1:58846 reason: Connection was closed cleanly.
[INFO ] 21:35:38 client:217 Connecting to daemon at 127.0.0.1:58846..
[INFO ] 21:35:38 client:121 Connected to daemon at 127.0.0.1:58846..
[INFO ] 21:35:38 client:224 Connection lost to daemon at 127.0.0.1:58846 reason: Connection was closed cleanly.
[INFO ] 21:35:43 client:217 Connecting to daemon at 127.0.0.1:58846..
[INFO ] 21:35:43 client:121 Connected to daemon at 127.0.0.1:58846..

Link to comment

Hey guys, I have been having a really odd issue that has stumped me, and I am looking for some help!

 

I've got everything setup quite well, except for the issue below and another (SimpleExtractor unchecks "Extract In-place" from time-to-time. Weird.).

 

Currently, Deluge will start downloading Torrents via Radarr and Sonarr, and most of the time this works flawlessly. The other handful of times, I run into this problem with Radarr+Deluge:

  • Radarr Torrent download starts in Deluge
  • Radarr Torrent download will complete in Deluge
  • Deluge will report an error with the torrent, but it shows 100% completion and Seeding
  • I force a re-check of the Torrent in Deluge, and it shows as 98.xx% complete (or something like that)
  • It turns out the Torrent's .rar file (not the .r## files) is missing data
  • Force re-check and resume, Deluge shows status Downloading as it downloads the .rar file
  • After download is complete, I check the size of the .rar file and it's back down to the wrong file size of ~1 MB when it should be ~90 MB
  • Repeat this for the same result

I've been having to manually grab the Torrent file and download the single file on a separate client and copy the file over to my unRAID share.

 

Any thoughts on this? The Deluge docker is kept up-to-date, can't say the same for unRAID though.

Link to comment
  • 3 weeks later...

Hi all, I'm trying to setup my Windows box to have the full Deluge interface (there's somethings I just can't do via the WebUI) and I'm trying to follow this guide here: http://dev.deluge-torrent.org/wiki/UserGuide/ThinClient 

 

however I'm stuck at the point of adding/modifying the auth file - it doesn't seem to work. I go to my addpdata/deluge/auth and edit it and add a user/pass and auth level but i still can't connect.

 

Also more importantly, after I modified the auth file and restarted the Deluge container all my torrents are gone?! 

Link to comment
35 minutes ago, CorneliousJD said:

Hi all, I'm trying to setup my Windows box to have the full Deluge interface (there's somethings I just can't do via the WebUI) and I'm trying to follow this guide here: http://dev.deluge-torrent.org/wiki/UserGuide/ThinClient 

 

however I'm stuck at the point of adding/modifying the auth file - it doesn't seem to work. I go to my addpdata/deluge/auth and edit it and add a user/pass and auth level but i still can't connect.

 

Also more importantly, after I modified the auth file and restarted the Deluge container all my torrents are gone?! 

 

I've had Deluge lose my state data of ~100 torrents twice today now...

I got the thin client part setup and working fine but I've lost state again as I was testing a few things.

 

Is there a way to prevent this from happening? Losing the state of 100 torrents is a major pain to go through and re-add everything... :/ 

Link to comment
On 1/20/2018 at 5:53 PM, CHBMB said:

Are you stopping deluge before you edit the file?  And are you ensuring the file owner and permissions are the same after you've finished editing?

 

You know, I may not have stopped it, but it was definitely running w/ torrents again and i did a stop/start just for kicks w/out doing anything in between and it lost data again the day. I haven't stopped/started it since in fear of losing all the torrents again. They're all in the state folder for me to re-add, but it takes time/effort to do so each time.

Link to comment
  • 3 weeks later...
On 10/5/2017 at 2:46 PM, Fredrick said:

I'm trying to clean up in my torrents and delete older stuff using "Remove torrent -> Remove with data", however whenever I do this I loose connection with the webui, and when it reloads I have deleted just 3-4 torrents out of the hundred i selected. Even if I select just a single torrent the webui crashes. 

 

Any ideas?

 

I find that you can only about 5 files at a time or this container chokes. Same goes for manually adding files.
And I have that same issue when trying to add a very large (50+GB) file.

I'm going to try another Deluge docker container and see if that works better.

  • Like 1
Link to comment
14 hours ago, deuxcolors said:

I'm going to try another Deluge docker container and see if that works better.

 

Please report back :)

 

I'd also be interested in other torrent clients, but as far as I can tell Deluge is the best option. Considering running it on a VM to at least have the option for remote desktop if I need to other things than just monitoring torrents. 

  • Like 1
Link to comment

I'm trying to get this running on a Synology NAS. Worked through a couple of issues but am running into errors like (there are a lot of these):

2018-02-09 13:39:04,379 DEBG 'start-script' stderr output:
RTNETLINK answers: Operation not permitted

2018-02-09 13:39:04,454 DEBG 'start-script' stdout output:
[info] Docker network defined as    172.17.0.0/16

2018-02-09 13:39:04,458 DEBG 'start-script' stderr output:
iptables v1.6.1: can't initialize iptables table `filter': Permission denied (you must be root)
Perhaps iptables or your kernel needs to be upgraded.

and then after apparently getting the connection to the VPN provider it ends up with:

2018-02-09 13:39:04,854 DEBG 'start-script' stdout output:
Fri Feb  9 13:39:04 2018 [202da2cd08402d7854d06faa991eaf61] Peer Connection Initiated with [AF_INET]209.205.124.166:1198

2018-02-09 13:39:06,035 DEBG 'start-script' stdout output:
Fri Feb  9 13:39:06 2018 auth-token received, disabling auth-nocache for the authentication token

2018-02-09 13:39:06,036 DEBG 'start-script' stdout output:
Fri Feb  9 13:39:06 2018 ERROR: Cannot ioctl TUNSETIFF tun: Operation not permitted (errno=1)
Fri Feb  9 13:39:06 2018 Exiting due to fatal error

I don't believe this needs to run as root itself. But I'm not sure what is wrong. 

Link to comment
  • 2 weeks later...
On 10/5/2017 at 8:46 AM, Fredrick said:

I'm trying to clean up in my torrents and delete older stuff using "Remove torrent -> Remove with data", however whenever I do this I loose connection with the webui, and when it reloads I have deleted just 3-4 torrents out of the hundred i selected. Even if I select just a single torrent the webui crashes. 

 

Any ideas?

 

Did you ever get this solved? I'm having the same issue. 

Link to comment

Not sure anyone is still monitoring this, but I’ve been trying to install a neat plugin that modifies the built in Execute plugin.  It looks like it installs but it keeps defaulting to the built in plugin in the webgui.  The thin client has new settings but they don’t take.  Is there a way to modify/remove the built in plugins in the docker?  Below is the link to plugin I can’t seem to get working in unraid docker.  

 

https://github.com/ultnrg/deluge-execute/releases

Link to comment
16 minutes ago, ThornburyWN said:

Everytime I cycle my array, the torrents loaded into deluge are gone. My appdata is on its own drive, I'm not noticing anything else gone after I cycle the array. It appears this issue is related to this deluge docker, anyone else seen this before? Maybe a setting to modify? 

 

 

Link to comment
  • 1 month later...
On 31/12/2017 at 12:15 AM, Ramenator said:

Hey guys, I have been having a really odd issue that has stumped me, and I am looking for some help!

 

I've got everything setup quite well, except for the issue below and another (SimpleExtractor unchecks "Extract In-place" from time-to-time. Weird.).

 

Currently, Deluge will start downloading Torrents via Radarr and Sonarr, and most of the time this works flawlessly. The other handful of times, I run into this problem with Radarr+Deluge:

  • Radarr Torrent download starts in Deluge
  • Radarr Torrent download will complete in Deluge
  • Deluge will report an error with the torrent, but it shows 100% completion and Seeding
  • I force a re-check of the Torrent in Deluge, and it shows as 98.xx% complete (or something like that)
  • It turns out the Torrent's .rar file (not the .r## files) is missing data
  • Force re-check and resume, Deluge shows status Downloading as it downloads the .rar file
  • After download is complete, I check the size of the .rar file and it's back down to the wrong file size of ~1 MB when it should be ~90 MB
  • Repeat this for the same result

I've been having to manually grab the Torrent file and download the single file on a separate client and copy the file over to my unRAID share.

 

Any thoughts on this? The Deluge docker is kept up-to-date, can't say the same for unRAID though.

Its seems the issue is how they packed it. I'm guessing you are unpacking it to the same location as the rar files. if you unpack it in a different folder then it will work. Im having the same issues on some of the torrents. So i unpack it manually or uncheck the box under extracter plugin and then do a recheck and when its done i move the file from root folder to the same folder as the rar files are so it gets moved correctly.

Link to comment
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.