[Support] Linuxserver.io - NZBGet


469 posts in this topic Last Reply

Recommended Posts

  • Replies 468
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Application Name: NZBGet Application Site: http://nzbget.net/ Docker Hub: https://hub.docker.com/r/linuxserver/nzbget/ Github: https://github.com/linuxserver/docker-nzbget   P

Thank you CHBMB!   To summarize, in NZBGet go to: Settings  > Extensions Scripts. In the field labeled ShellOverride enter the following: .py=/usr/bin/python3 This worked perfectly

I was so focused on the download path that I didn't realize it was my category paths that were screwing me up.   Everything is finally working now.   Thanks for the help trurl!  I've been working on t

Posted Images

How do I configure a VPN with this or do I need to get the "nzbgetvpn" version?   I also have binhex-delugevpn installed (and configured) which works with Transmission to force all traffic to go through the VPN does binhex-delugevpn also work with nzbget in this way?

 

Thanks

Nate

Link to post

Hey, I have a quick question. This isn't about the docker but the app. I've been using this docker for a long time and its been great. I've been having a problem for the past 2 months and I don't know how to fix it. 

 

I have downloads that are failing and Sonarr keeps grabbing them as being a successful downloading. Before when something failed, it would notify Sonarr and Sonarr would try to download a different version. 

 

Any idea what setting I might have messed up?

 

Thanks!

Link to post
56 minutes ago, mgworek said:

Hey, I have a quick question. This isn't about the docker but the app. I've been using this docker for a long time and its been great. I've been having a problem for the past 2 months and I don't know how to fix it. 

 

I have downloads that are failing and Sonarr keeps grabbing them as being a successful downloading. Before when something failed, it would notify Sonarr and Sonarr would try to download a different version. 

 

Any idea what setting I might have messed up?

 

Thanks!

Go to settings>Incoming NZBS and see if DupeCheck is set to yes.

You haven't cleared your HIDDEN History, have you? I think that also keeps a record of what has already downloaded. (Correct me if I am wrong).

Link to post
49 minutes ago, Plunky said:

Go to settings>Incoming NZBS and see if DupeCheck is set to yes.

You haven't cleared your HIDDEN History, have you? I think that also keeps a record of what has already downloaded. (Correct me if I am wrong).

 

It is set to Yes. I never manually clean the history. I just looked at another one that failed this morning. "47 of 3106 article downloads failed" Its marked as failed in the history but the log shows Nothing to unpack for..., Moving completed files...., Parking file..... then sonarr grabs it. 

Link to post
8 hours ago, mgworek said:

 

It is set to Yes. I never manually clean the history. I just looked at another one that failed this morning. "47 of 3106 article downloads failed" Its marked as failed in the history but the log shows Nothing to unpack for..., Moving completed files...., Parking file..... then sonarr grabs it. 

SOunds like a question for the NZBGet forums then. Sorry bud

Link to post
On 7/13/2018 at 6:13 PM, Plunky said:

SOunds like a question for the NZBGet forums then. Sorry bud

 

Just thought I would update this in case anyone else has this problem. It is a known bug when using the nzb.su indexer. I have disabled it the indexer and will be keeping my eye on it for the next few days.

Link to post
  • 4 weeks later...

I'm still learning about dockers and so this question might be really silly but hopefully someone can help me out. I'm trying to apply nice and ionice to the unrarcmd in nzbget. The problem is that if I try to do it like this

 

${AppDir}/nice -n 10 ionice -c2 -n4 unrar

 

The unpack just fails saying it can't find ${AppDir}/nice

I solved this by just making symlinks in the appdir folder pointing to /bin/nice and /bin/ionice but these symlinks will get destroyed every time the docker updates, won't they? Is there a better way to do this? I don't know if the path can be modified somehow to make it able to access nice and ionice without the symlink or maybe i'm just doing it completely wrong.

Edited by figurefive
Link to post
  • 4 weeks later...
3 minutes ago, deaerator said:

For some strange reason NZBGet seems to be spitting this error out now.

 


Could not create file /downloads/tmp/nzb-2.tmp

No matter what NZB File I add it will spit out this error.

I checked the permissions on the location and it seem to all right.

 


drwxrwxrwx 4 root   root        44 Sep 12 14:51 tmp/

 

I haven't looked at the diagnostics.

 

You say you checked the permissions, but it is unclear how you checked them. Did you go into console inside the container?

Link to post

I'm having issues with the scripts showing up in nzbget.  I've put the "videosort" folder inside the "ppscripts" folder within the nzbget config directory.

 

I've also tried re-mapping the directory within the docker settings.  


Lastly, tried to change permissions. 

 

Not sure if I input the correct commands, however.

 

Anyone have any tips on getting scripts to show up on my nzbget docker?

Link to post

I have a weird problem when NZBGet is unpacking a download it causes everything else on my Unraid server to stop responding until it's finished. It happens whether the download is going to my SSD cache drive or to the array. Anyone know what could be causing this?

 

My server is an i5 3470 using an LSI 9211-8i for the array drives while the parity and cache drive are connected to the motherboard's 6Gb ports.

Edited by Taddeusz
Link to post

Anyone using nzbToMedia?

I'm getting this error which causes everything to download but not process.

 

nzbToMedia: Exception TypeError: "'NoneType' object is not callable" in <bound method PosixProcess.__del__ of <core.nzbToMediaUtil.PosixProcess object at 0x148737796710>> ignored

 

Link to post

Will we see a unrar version bump from 5.5 beta 4 to 5.6 beta 1 ?

 

5.6 beta 1 fixes a nasty bugs: 

 

b) memory management bug in the password dialog could lead to access to already freed memory followed by crash. This issue may be also associated with security risks;

c) fixed a crash when processing corrupt RAR archives. This issue may be also associated with security risks;

Edited by Dazog
Link to post
1 hour ago, Dazog said:

Will we see a unrar version bump from 5.6 beta 4 to 5.6 beta 1 ?

 

5.6 beta 1 fixes a nasty bugs: 

 

b) memory management bug in the password dialog could lead to access to already freed memory followed by crash. This issue may be also associated with security risks;

c) fixed a crash when processing corrupt RAR archives. This issue may be also associated with security risks;

i'm really confused what you're asking for here.

 

you say an update from 5.6 beta 4 to 5.6 beta 1, that's going backwards surely ? 

 

Edited by sparklyballs
Link to post
i'm really confused what you're asking for here.

 

you say an update from 5.6 beta 4 to 5.6 beta 1, that's going backwards surely ? 

 

Glad you said that, confused me too.....

 

Sources would be useful too.....

 

Sent from my Mi A1 using Tapatalk

 

 

 

Link to post
3 hours ago, CHBMB said:

Glad you said that, confused me too.....

 

Sources would be useful too.....

 

Sent from my Mi A1 using Tapatalk

 

 

 

Sorry it was a mistype.

 

Current version in the docker is 5.5 b4

 

Latest version is 5.6 b1

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.