[Support] Linuxserver.io - Sonarr


Recommended Posts

9 hours ago, binhex said:

 

look into a utility called jq, this can parse json, possibly not installed but maybe you can use the built in package manager to install it?.

 

https://stedolan.github.io/jq/

 

edit - looks like its available for alpine (base os for this image?) https://pkgs.alpinelinux.org/package/edge/main/x86/jq

I did actually see that first but didn't look into it since modifying the base image would cause problems every time it is updated. I was looking for something built into the base image. But once I did look at it I realized it's just a single binary so I put it in the config folder and can call it from there. Thanks.

Link to comment

Hi guys, I'm having some strange permission issues with Sonarr. When sonarr creates files in the shares i have created. it creates the files as:

 

Owner Name: nobody

Group Name: users

 

sonarr is set with defaults as far as i can tell:

 

Set permissions = Yes

File CHMOD mask: 0644

Folder chmod mask: 0755

 

however from a windows machine i cant edit the files it creates:

 

"you require permission from Unix user\nobody to make changes to this file."

 

Any ideas?

 

I've checked the file permissions from unraid for files being created by Couchpotato and the files show up the same as they do for files created by sonarr (ownername = nobody | Group Name = users) And files editted from windows created by couchpotato edit fine. From windows the couchpotato files look like this:

 

Security tab on a file shows:

 

Everyone - Read & Execute, Read, Write, Special permissions greyed

nobody  - Read & Execute, Read, Write, Special permissions greyed

users  - Read & Execute, Read, Write, Special permissions greyed

 

however in sonarr they look like this:

 

Everyone - Read

nobody -  Read, Write

users - Read

 

The shares look identical from within Unraid any ideas why NTFS/ACL's arn't being set properly? i've tried setting sonarr as 

 

Set permissions = Yes

File CHMOD mask: 0777

Folder chmod mask: 0777

 

and

 

Set permissions = No 

File CHMOD mask: 0777

Folder chmod mask: 0777

 

Am i ment to be specifying the following values within sonarr with "99" & "100" or anything?

 

chown user 

chown group

 

 

Edited by thestraycat
Link to comment
10 hours ago, thestraycat said:

Set permissions = Yes

File CHMOD mask: 0777

Folder chmod mask: 0777

 

This is what you want.

 

But, any pre-existing files moved before the change won't get changed to the proper permissions.  You need to install Fix Common Problems, and then run Tools - Docker Safe New Permissions

 

Link to comment
8 minutes ago, Squid said:

Your mileage varies depending upon the source zip, dl client.  You never have problems reading / playing the file.  Its only when you go to modify it or delete it that the permissions from sonarr pop into play.

 

I use Sonarr w/ torrents (delugeVPN). I've never had any issues playing, moving, deleting any files organized by it. My shares are all set to public though (not sure if that makes a difference).

Link to comment

I've got a quick question, my sonarr is working as it should but when I go to the log there is a recurring error message and I'd like to know if it indicates a permissions error that may be a problem for me later, it says: Thanks in advance...

Couldn't get total space for /UNRAID/var/lib/docker/btrfs/subvolumes/5be4b4d0c230dc13296a55f9b4a81589d9fc8cdc33fffb0b99b7df23a4fd7bb0: Permission denied

The exception block says:

System.InvalidOperationException: Permission denied ---> Mono.Unix.UnixIOException: Permission denied [EACCES].
  --- End of inner exception stack trace ---
  at Mono.Unix.UnixDriveInfo.Refresh (Boolean throwException) <0x41fbdec0 + 0x000e3> in <filename unknown>:0 
  at Mono.Unix.UnixDriveInfo.Refresh () <0x41fbde90 + 0x00013> in <filename unknown>:0 
  at Mono.Unix.UnixDriveInfo.get_TotalSize () <0x42016a30 + 0x0000f> in <filename unknown>:0 
  at NzbDrone.Mono.Disk.ProcMount.get_TotalSize () [0x00000] in M:\BuildAgent\work\b69c1fe19bfc2c38\src\NzbDrone.Mono\Disk\ProcMount.cs:37 
  at NzbDrone.Mono.Disk.DiskProvider.GetTotalSize (System.String path) [0x00064] in M:\BuildAgent\work\b69c1fe19bfc2c38\src\NzbDrone.Mono\Disk\DiskProvider.cs:106
Link to comment

My Sonarr has been working perfectly for quite some time now up until about an hour ago.  It stopped responding so I restarted it but I didn't have access.  I removed the docker and the image thinking that would do the trick, but it is still giving me an error saying:

 

[Info] AppFolderInfo: Data directory is being overridden to [/config]
[Error] PidFileProvider: Unable to write PID file /config/nzbdrone.pid

and notably:

 

[Fatal] ConsoleApp: EPIC FAIL!

 

I uploaded the full log with more info in case it is needed.  How can I fix this?

 

Thanks.

 

sonarr error.txt

Link to comment
10 hours ago, fonzie said:

My Sonarr has been working perfectly for quite some time now up until about an hour ago.  It stopped responding so I restarted it but I didn't have access.  I removed the docker and the image thinking that would do the trick, but it is still giving me an error saying:

 

[Info] AppFolderInfo: Data directory is being overridden to [/config]
[Error] PidFileProvider: Unable to write PID file /config/nzbdrone.pid

and notably:

 

[Fatal] ConsoleApp: EPIC FAIL!

 

I uploaded the full log with more info in case it is needed.  How can I fix this?

 

Thanks.

 

sonarr error.txt

It says the disk is full:
 

Quote

[v2.0.0.4689] System.IO.IOException: Disk full. Path /config/nzbdrone.pid

 

But that may just mean it cannot write to the location. If it isn't full, it seems like a permissions issue, as if it cannot write to the /config folder.

Link to comment
56 minutes ago, fonzie said:

I noticed that error. It has happened to me before where there was write permissions and I had to reset them. How do I go about doing so without breaking the other dockers? 

 

It shouldn't break the other containers. Each docker should have its own config directory. Try this:

 

chmod 755 -R -f /your/sonarr/config/directory

 

Link to comment
4 hours ago, bobbintb said:

 

It shouldn't break the other containers. Each docker should have its own config directory. Try this:


chmod 755 -R -f /your/sonarr/config/directory

 

So if my Sonarr folder is located in an Appdata share, it would be:

 

chmod 755 -R -f /user/mnt/appdata/sonarr

 

where would I input this?

Link to comment
Just now, CHBMB said:

Wow, my post has crossed the space-time continuum. I replied to your post and mine has ended up first....... 

 

haha no I deleted my original post to include your quote and by the time I had re-posted, your response was above mine.

 

I hope this mysterious issue doesn't cause any more hiccups down the line.

 

command permissions.PNG

Link to comment
1 minute ago, fonzie said:

 

haha no I deleted my original post to include your quote and by the time I had re-posted, your response was above mine.

 

I hope this mysterious issue doesn't cause any more hiccups down the line.

 

command permissions.PNG

 

I still maintain that if that's the command you've run, then unless you're actually storing your appdata in /user/mnt/appdata/sonarr/ then this command will be as effective as snake-oil.  I love Linux, don't get me wrong, but it can't predict which folder you actually meant by that command and it means the permissions in /mnt/user/appdata/sonarr/ will be unchanged by that command.  

 

I can only surmise that a container restart has fixed the issue rather than that command.

Link to comment

My Sonarr started acting strange yesterday, and then after my server became unresponsive and I had to hard reset it, Sonarr was doing weird things like saying it was downloading a file that was 1.6GB but when it moved that file to a share it was half the size. I messed around with quality settings and after manually re downloading some episodes two or three times it was doing it properly. Now this  morning I went to refresh the calendar and its taking forever to respond. I tried to stop the docker and that is not working again. What can I do? I can't launch the docker either, so I can't stop it, reload it or launch it at this point.

Edited by ashman70
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.