Jump to content
linuxserver.io

[Support] Linuxserver.io - Sonarr

1220 posts in this topic Last Reply

Recommended Posts

If its getting late then we're obviously in different time zones so it's a flip of the coin of I'm online at the time. But there's a ton of other people here too.

Sent from my LG-D852 using Tapatalk

Share this post


Link to post

Hi Squid, I solved the problem!

 

When searching I'll find out that some episodes did get imported. Episodes begin with A --> M was no problem, but episodes beginning with N --> Z did not get imported, and gave the message disk full. The problem was I only selected disk1, disk2, disk3 in the disk included checkbox. So I also selected disk4 and disk5 and problem solved!!! :)

Screen Shot 2017-06-12 at 19.50.07.png

Share this post


Link to post

sonarr is really stupid.

 

Not stupid in the "its garbage," sense, but stupid in the "its dumb as a box of hammers" sense.

 

I've had a show, complete, that is over 30 years old, on my server, for about four years.

 

Tonight Sonarr downloaded almost every episode from almost every season.  For a show I already have.  And have had.  For years.  Complete.

 

What the heck?

 

(This happens all the time btw, usually one or two episodes at a time in almost all shows, after a few months I end up with a ton of dupes that I constantly have to seek out and find and remove)

 

What setting is causing this?
 

Share this post


Link to post

A better quality became available, and you didn't have sonarr to to cut off at your existing quality

 

And, if you're winding up with dupes, then as far as sonarr is concerned, the existing file doesn't show as being within sonarr, so it will naturally download any missing episodes.  Have sonarr rescan the disks for episodes

 

Share this post


Link to post

Technically Sonarr only does what it's told to do.....

Just saying......

Sent from my LG-H815 using Tapatalk

Share this post


Link to post
3 hours ago, CHBMB said:

Technically Sonarr only does what it's told to do.....

Just saying......

Sent from my LG-H815 using Tapatalk
 

 

Just saying....

Share this post


Link to post

So does it automatically delete the lower-quality files?  That's not happening, if it is.

 

Share this post


Link to post

If it knows about it, then it will.  If it does not (ie: episode was marked as being missing) then it will not.

Share this post


Link to post

Hello, 

 

I would like to switch my docker container from needo to the Linuxserver one as I haven't had an update in a very long time with needo. Is there a way to switch without losing all my Sonarr settings?

 

Thank you in advance!

Share this post


Link to post
9 minutes ago, littlered said:

Hello, 

 

I would like to switch my docker container from needo to the Linuxserver one as I haven't had an update in a very long time with needo. Is there a way to switch without losing all my Sonarr settings?

 

Thank you in advance!

You can export and import your Sonarr settings.

Share this post


Link to post

Hi,

 

I have a bit of a weird situation. Sonarr is complaining about a missing root folder, but if I check by entering the sonarr container there is no problem. If I go into the "tv" folder I see all of my tv shows. This tv show folder is mounted with unassigned devices. The only differences I see is that the owner is "root:root" and not "abc:users" which is the case with the "downloads" folder. Any idea?

Screen Shot 2017-06-19 at 13.03.39.png

Edited by MvL

Share this post


Link to post
7 hours ago, MvL said:

Sonarr is complaining about a missing root folder

Go to the offending series, "mb - the search" in this example, and edit it. Change the series location to one that actually exists in the docker's view.

Share this post


Link to post

Hi Jonathan,

 

That was a great suggestion. It solved the problem! Never tough about doing this with the offending series. I did go to the series editor, and selected the root tv folder for all series, but that didn't helped.

 

I still have a problem with permission I'll see the error in the screenshot. I'm not sure if it is possible to set permission, and if it is necessary cause if I'm correct it's already 0777. I also see this behaviour with headphones.

 

5947ea020aa97_ScreenShot2017-06-19at17_05_13.thumb.png.ef3a33094fdea4494287a60cd2721285.png

Share this post


Link to post

Sonarr is now throwing warning that they are going to be removing the Done Factory Option.   How are we suppose to integrate this to your SABNZBD docker, or will you be making a new one?

 

NM, I use the drone factory because I convert to MP4

Edited by bakes82

Share this post


Link to post
11 minutes ago, bakes82 said:

Sonarr is now throwing warning that they are going to be removing the Done Factory Option.   How are we suppose to integrate this to your SABNZBD docker, or will you be making a new one?

 

Same way as you always have.  Drone factory has never afaik been the way to set things up.  

Share this post


Link to post
Just now, CHBMB said:

 

Same way as you always have.  Drone factory has never afaik been the way to set things up.  

 

Yeah I converting to MP4 before I import.  Why I was using the drone factory.

Share this post


Link to post

Well until you know for certain what changes are going to happen, anything would be speculation.

Share this post


Link to post

My sonarr/sab installation continues to be a complete and total trainwreck.  I am posting this in the sonarr forum because, using sickbeard and later sickrage, I never had these issues, so I assume its a sonarr issue, although I don't know for sure.

 

As stated in previous posts, I continue to see duplicate folder names ("TV Show" "TV show" "tv show"), some of which contain duplicate episodes (some are simply empty except for show clipart and nfo files).  Sometimes clip art will go in "TV Show" while the actual episodes will go in "tv show."  I also continue to see dupes such as "TV-Show" and "TV Show" that are completely empty -- ie, shows added moments ago that haven't had anything downloaded yet, yet two, and sometimes three different directories have been created.  I also have hundreds (literally) of dupes in the form of "S01E01.mkv" in the show's root directory, followed by a folder called "S01E01-obfuscated" etc with a file in that folder that is the exact same episode, only with an obviously obfuscated filename.  I also have tons of dupes like "S01E01.mkv" "S01E01(1).mkv" "S01E01.mkv(1)" and "S01E01-(author's name).mkv' etc.  Hundreds of dupes.  I am literally spending hours a week going through thousands of episodes to find and remove dupes, organize directories, rename as needed, etc.  

 

It should be noted that sonarr is being specifically told that a show should go into "/tv_shows/show" and yet I have dupe episodes in "/tv_shows/show" as well as "/tv_shows/Show" with different download dates, often from the same author, but sometimes from different authors (same filesize and presumably same quality etc).

 

Everything is all over the place and I am at a complete and total loss.  I am using the same sab settings I've been using for five years.  The only new addition, as of going on a year ago, is sonarr.

 

I've tried nearly everything I can think of short of a complete and total reinstall of the docker.  I am at my wit's end here.

 

Any advice appreciated.

Share this post


Link to post

hello all, i've been having issue with my sonarr docker lately. it'll just randomly stop working. the logs don't show too much. the docker still appears to be running in the unraid gui, but i cannot access the webui and also it is not pulling anything.

 

i've tried removing and readding the docker container/image and also rebuilding my docker.img from scratch. one thing i am noticing in the docker logs are multiple "[Trace] Owin: SQLite error (5): database is locked" errors. is my db corrupted?

 

EDIT: readding logs, had to remove API keys. also it seems those sqlite errors are normal based on a quick google search.

 

i'm not sure if this matters, but when the problem first started happening, i went to turn on trace logs, but saw that it was already enabled, for who knows how long. could this cause issues? maybe the logs are filling up and breaking something. there's plenty of room on the docker img and the location where my appdata is, but possibly the logs are saved to memory?

 

docker.log

sonarr.txt

Edited by drawde

Share this post


Link to post

I just switched all my plugins (SABnzbd, Sonarr, Plex) over to dockers and added Radarr as a docker and most things are working correctly, but I'm running into a couple of snags with Radarr and Sonarr

 

I've been using Sonarr for some time use the Drone Factory for my TV download folder that SAB puts TV downloads into. While I was updating things, I saw that Sonarr and Radarr now have "Complete Download Handling". From what I understand, you can turn off the drone folder and just have SAB and Radarr/Sonarr communicating when downloads are finished. Then Radarr will process the movie, move it to the movie folder, and clean up the folders. 

PROBLEMS
 

1. TV Series are no longer processing. I think I can sometimes get them to process when it's in the drone folder, but not consistently
2. After they are processed I'm left with folder containing leftover junk files. They don't get cleaned up.

3. If I try to use complete download handling the movies/tv shows get downloaded to the appropriate folders, but then nothing happens.

 

See configuration in image attached. 

I'd really appreciate any help!

2017-07-01_13-25-25.thumb.png.289e131f6cc96ae60d1aff27d8ea1deb.png

2017-07-01_13-09-41.png

Edited by cypres0099

Share this post


Link to post

I just completed my upgrade from v5.05 to 6.3.5.  

 

All went pretty smoothly, until I tried to get the Sonarr docker to work.  I was previously using Phaze's plugin for v5, but was looking forward to the docker functionality.  

My config directory is on an SSD which I'm mounting to /mnt/disks/ssd using the Unassigned Devices plugin by dlandon.  This is a holdover from how I had it setup with the plugin, so I wasn't always spinning up my SATA drives.  That's where SABnzbd lives too (I did successfully install the SABnzbd linuxserver's docker successfully).  

 

At any rate - my problem is that Sonarrr is unable to access the TV share.  Oddly enough, when configuring the template, I can browse to where it is:  /mnt/user/TV-Series/, but when the docker starts, and I access Sonarr, it complains about not being able to find the TV root directory.  OK - so I try to Add an Existing Series, but when I try to browse the filesystem, I can see /mnt, but nothing under that.

 

It seems like it might be a permissions issue, but I've checked, and the share directory "TV-Series" is 777 and owned by nobody.users, which matches the UID and GID of the docker.

 

I've attached my template config - any help you can provide would be appreciated.  Thanks!

 

 

sonarr-template.PNG

Edited by mst3kroqs

Share this post


Link to post
1 hour ago, mst3kroqs said:

At any rate - my problem is that Sonarrr is unable to access the TV share.  Oddly enough, when configuring the template, I can browse to where it is:  /mnt/user/TV-Series/, but when the docker starts, and I access Sonarr, it complains about not being able to find the TV root directory. OK - so I try to Add an Existing Series, but when I try to browse the filesystem, I can see /mnt, but nothing under that.

sonarr-template.PNG

 

That's because it's not in /mnt/user/TV-series, it's in /tv. Take a look at your mappings again.

Edited by bobbintb

Share this post


Link to post

With regard to sab downloading a file, what does the prefix "PROPAGATED 234876 min" mean?  Almost all of them are doing this now and none are downloading.

Share this post


Link to post
10 hours ago, bobbintb said:

 

That's because it's not in /mnt/user/TV-series, it's in /tv. Take a look at your mappings again.

 

Thanks - I think I was in denial.  What this meant was that I had to go into my existing Sonarr database and edit the path for every TV series, in order to avoid having to rebuild the entire thing from scratch, and lose all my watch/monitor status flags.  Sigh.

 

-- and then I found this ---

 

https://forums.sonarr.tv/t/change-root-folder-for-all-series-solved/2419

 

Double sigh.  Moving on!

 

Edited by mst3kroqs
Add Sonarr tip for changing root folder globally

Share this post


Link to post

Hello, Noob here.. I have a qnap NAS capable of running container station. Ive been told that sonarr performs best in this environment, but I am really in the dark on how to get it up and running.. my linux chops are basic at best.. would someone be willing to talk me through getting sonarr setup. Eventually I would get the other services going as well (SABnzb, Radarr or CP) but I imagine the process is the same. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.