Jump to content
linuxserver.io

[Support] Linuxserver.io - Sonarr

1191 posts in this topic Last Reply

Recommended Posts

1 hour ago, Gronsak said:

while copying the files stopping me from doing anything else with the server.

Have you tried updating to unRaid 6.8?

Share this post


Link to post
8 hours ago, Squid said:

Have you tried updating to unRaid 6.8?

Yes, currently running 6.8.0 rc7 to see if it fixes the propblem, it did not so far

 

edit: So I got IOWait on all cores which is what's blocking all threads, assigned the docker to only one physical core to try and mitigate the issue

Edited by Gronsak

Share this post


Link to post

So I'm having the malformed database issues that others have posted about. I've upgrade to 6.8, and even changed /config to point to /mnt/cache/appdata/sonarr. The issue is still there. Any ideas on what I should do to fix this?

Edit:

Solved the problem after a bit. This was the helpful portion of the log: "unable to load the following field: 'LastRssSyncReleaseInfo'" and then the data that was in there. See log:

[v2.0.0.5338] Marr.Data.DataMappingException: The DataMapper was unable to load the following field: 'LastRssSyncReleaseInfo' value: '{
"guid": "magnet:?xt=urn:btih:b7c222ca1ab2b7d5714c4025f37e99a86a34e6fd&dn=Godfather.of.Harlem.S01E10.Chickens.Come.Home.to.Roost.1080p.AMZN.WEBRip.DDP5.1.x264-NTb%5Brartv%5D&tr=http%3A%2F%2Ftracker.trackerfix.com%3A80%2Fannounce&tr=udp%3A%2F%2F9.rarbg.me%3A2710&tr=udp%3A%2F%2F9.ra J�K�@��(�J{���
UCU!�|Time Bokan: The Villains Strike BacktimebokanvillainsstrikebackTime Bokan: The Villains Strike BackXemServiceY���~
;3;!{Ame-iro Cocoa in HawaiiameirococoainhawaiiAme-iro Cocoa in HawaiiXemServicea���}
?;?!{雨色ココア in Hawaii雨色ココアinhawaii雨色ココア in HawaiiXemServiceT���|
97!{Rainy Cocoa in HawaiirainycocoainhawaiiRainy Cocoa in HawaiiXemServiceT���{
9-9!{Rainy Cocoa: Ame-con!!rainycocoaameconRainy Cocoa: Ame-con!!XemService����z
a[a!{雨色ココアシリーズ あめこん!!雨色ココアシリースあめこん雨色ココアシリーズ あめこん!!XemServicem���y
K;K!{Ame-iro Cocoa Series: Ame-con!!ameirococoaseriesameconAme-iro Cocoa Series: Ame-con!!XemService0���x
!{Ame-con!!ameconAme-con!!XemService{���w
SGS!{Rainy Cocoa: Welcome to Rainy ColorrainycocoawelcometorainycolorRainy Cocoa: Welcome to Rainy ColorXemService'. Unterminated string. Expected delimiter: ". Path 'guid', line 11, position 122. ---> Newtonsoft.Json.JsonReaderException: Unterminated string. Expected delimiter: ". Path 'guid', line 11, position 122.
at Newtonsoft.Json.JsonTextReader.ReadStringIntoBuffer (System.Char quote) [0x00099] in <c5b8b1476b514bcaad468ae001c1fb99>:0

That field is in the table IndexerStatus for Sonarr. Looks like somehow one of the indexers had invalid data, because all the other rows had magnetId rather than guid, like this row had. So I had to stop Sonarr, make a backup of the .db file, then load the file into a sqlite viewer and modify that row. I opted to delete that row and the associated indexer. That fixed my problem. When I started Sonarr back up, I just re-added the indexer I had removed.

Edited by J_Hizzal
Following up with fix.

Share this post


Link to post

I've been running Sonarr v3 using lsiodev/sonarr-preview for quite a while, but I ran into some problems over the last couple of days which I finally fixed when I tried using linuxserver/sonarr:preview as mentioned on the sonarr page: https://sonarr.tv/#downloads-v3-docker

 

Looking at the versions lsiodev/sonarr-preview was at 3.0.0.348 and linuxserver/sonarr:preview was at 3.0.3.679, so probably quite old

 

1.  Should I use linuxserver/sonarr:preview now?

2. Was it safe to just switch the repository in docker? It worked, but I kept a backup just in case

 

Thanks in advance.

Share this post


Link to post
2 hours ago, DZMM said:

1.  Should I use linuxserver/sonarr:preview now?

Yes

2 hours ago, DZMM said:

2. Was it safe to just switch the repository in docker? It worked, but I kept a backup just in case

Yes, albeit, running a preview build, stuff goes wrong, you're on your own.

Share this post


Link to post
1 hour ago, CHBMB said:

Yes

Yes, albeit, running a preview build, stuff goes wrong, you're on your own.

Thanks.  The previews (sonarr and radarr) have been stable for the last couple of months for me.  Radarr V3 in particular has been a godsend, as my library/indexers/something was too big for it and it wouldn't open sometimes for days and if did, was almost impossible to use.

Share this post


Link to post

I am having issues with Sonarr using 100% of the CPU after running for several hours.  The only way to stop this is to restart the docker container.  Looking at "top" in terminal I see 100% CPU usage for the process "MONO".  Has anyone else experienced this and is there a fix for this issue?

 

Share this post


Link to post
14 hours ago, amb5014 said:

I am having issues with Sonarr using 100% of the CPU after running for several hours.  The only way to stop this is to restart the docker container.  Looking at "top" in terminal I see 100% CPU usage for the process "MONO".  Has anyone else experienced this and is there a fix for this issue?

 

@amb5014  Yes. If you're using a SOCKS proxy, try switching to HTTPS or running without and see if that solves your issue.  That's what did it for me.

Share this post


Link to post

For this and any Docker, if the app has a shutdown feature within the app itself, should I do that before updating the Docker from unRAID?

Share this post


Link to post
18 hours ago, Iceman24 said:

For this and any Docker, if the app has a shutdown feature within the app itself, should I do that before updating the Docker from unRAID?

No, I've never known that to be necessary and due to the init system used in the container, it's probably futile.

Share this post


Link to post
On 1/5/2020 at 4:35 AM, CHBMB said:

Yes

Just checked what I am on and it says "lsiodev/sonarr-preview". Can I switch this directly to "linuxserver/sonarr:preview" or will this break my settings?

 

Is there also a preview for radarr? I am currently on "linuxserver/radarr".

 

Thanks in advance!

Share this post


Link to post

Unable to connect Rutorrent seedbox to my local Sonarr instance

 

Seedbox: Seedboxes.cc running Rutorrent 
Local NAS: Unraid 6.8.0

 

How would i go about doing this? I tried following these instructions but I had no luck https://community.seedboxes.cc/articles/how-to-setup-sonarr. I also tried entering the rutorrent web UI info. provided by my seedbox. I have tried inputting /RPC2 as well as /rutorrent/plugins/rpc/rpc.php for the url path. Neither SSL nor non-ssl credentials work. Is this happening due to the programs being on separate networks?

 

The Sonarr error: Unknown exception: Unable to connect to rTorrent, please check your settings

Sonarr log error: https://pastebin.com/zHk4iEGJ 

Edited by mason1171
Problem solved using Wireguard vpn

Share this post


Link to post

Somehow my Sonarr shows only de / folder under disk space, meanwhile i've created a shows folder. If I choose to import the folder, it will show up en shows me the free space but only the / folder shows up under disk space. How is this possible?

 

The path in the docker container is /media/shows and in the host it's /mnt/user/media/shows.

Share this post


Link to post

I keep getting this error both with automatic import als manual import. But it only happens with upgrades to files:

 

Quote

Couldn't import episode /downloads/tv/Black.Sails.S03E01.XIX.1080p.BluRay.DD5.1.x264-SA89/121fcb5e9a1830912b96e6c54cf23baa.mkv: Access to the path "/tv/Black Sails/Season 3/Black Sails - S03E01 - XIX.mp4" is denied.

Sab and Sonarr are pointing to the same directory and new series work fine, it's only when an existing file needs to be upgraded. Below the docker runs of sab and sonarr. Hopefully someone has an idea?

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='sonarr' --net='br0.90' --log-opt max-size='10m' --log-opt max-file='1' -e TZ="Europe/Berlin" -e HOST_OS="Unraid" -e 'TCP_PORT_8989'='8989' -e 'PUID'='99' -e 'PGID'='100' -v '/dev/rtc':'/dev/rtc':'ro' -v '/mnt/user/mount_unionfs/Tdrive/Series/':'/tv':'rw' -v '/mnt/user/mount_unionfs/Tdrive/Downloads/':'/downloads':'rw' -v '/mnt/user/mount_unionfs/':'/unionfs':'rw,slave' -v '/mnt/cache/appdata/sonarr':'/config':'rw' 'linuxserver/sonarr:preview'
root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='sabnzbd' --net='br0.90' --ip='192.168.90.10' --log-opt max-size='10m' --log-opt max-file='1' -e TZ="Europe/Berlin" -e HOST_OS="Unraid" -e 'TCP_PORT_8080'='8080' -e 'TCP_PORT_9090'='9090' -e 'PUID'='99' -e 'PGID'='100' -v '/mnt/user/mount_unionfs/Tdrive/Downloads/':'/downloads':'rw' -v '/mnt/user/mount_unionfs/Tdrive/Downloads/Incompleet/':'/incomplete-downloads':'rw' -v '/mnt/user/mount_unionfs/':'/unionfs':'rw,slave' -v '/mnt/cache/appdata/sabnzbd':'/config':'rw' 'linuxserver/sabnzbd' 

 

Share this post


Link to post

I have had my server running for a while and noticed a problem using the "Remote Path Mappings". I have the external share set to "/home11/mihcox/files/Completed/", but when i go to the import page i get the following error:

 

I have my "Remote Path Mappings set to a remote path of: /home11/mihcox/files/Completed/
What i see on the Activity page: No files found are eligible for import in /home11/mihcox/files/Doctor.Who.2005.S12E05.HDTV.x264-PHOENiX[eztv].mkv
Error Shows: Import failed, path does not exist or is not accessible by Sonarr: /home11/mihcox/files/Doctor.Who.2005.S12E05.1080p.HDTV.H264-MTB[rarbg]

Why does the location i have configured not match the location it is looking in, it is missing the “completed” folder

Share this post


Link to post

Apologies if i have to return to the question host path vs. container path.

I have the following problem: The (container) path of my indexer is /downloads. The (container) path of my download client is /data. Both container paths are mapped to the same host path.

Sonarr can't pick up the donloaded files because the container paths are not aligned. So I renamed the /data container path to /downloads in the container settings.

Still nothing happening. Am I misunderstandiong anything?

Edited by whauk

Share this post


Link to post
13 hours ago, jonathanm said:

 

12 hours ago, mihcox said:

That is not my issue. See the screenshots. The location that i set in "Remote Path Mappings does not match the path it is looking for.

 

Capture.PNG

 

Capture1.PNG

I dont see how what you linked explains why the location i set does not match the location it displays back to me. This external location i have confirmed exists,but it does not list this EXACT location as the location it is looking in. 

Share this post


Link to post
2 hours ago, whauk said:

Apologies if i have to return to the question host path vs. container path.

I have the gollowing problem: The (container) path of my indexer is /downloads. The (container) path of my download client is /data. Both container paths are mapped to the same host path.

Sonarr can't pick up the donloaded files because the container paths are not aligned. So I renamed the /data container path to /downloads in the container settings.

Still nothing happening. Am I misunderstandiong anything?

dumb question but did you tell your downloader to use /downloads instead of /data?

What is the error message in the application?  If you open a command prompt in both dockers, you should be able to see the file uing the same path.

Share this post


Link to post
16 minutes ago, mihcox said:

 

I dont see how what you linked explains why the location i set does not match the location it displays back to me. This external location i have confirmed exists,but it does not list this EXACT location as the location it is looking in. 

Radarr is looking for the file /home11/mih... but it doesn't have access to that.  It only has access to /downloads.  The link @jonathanm gave you applies

Edited by Gog

Share this post


Link to post
2 hours ago, Gog said:

Radarr is looking for the file /home11/mih... but it doesn't have access to that.  It only has access to /downloads.  The link @jonathanm gave you applies

Maybe i dont understand what youre suggesting. This is for "(AKA Linking between containers)". This is not my case, i have one local container, and one external container on a seedbox. I used the following guide for setup from spaceinvaderone: 

 

Again, apologies if that applies to me too.

Share this post


Link to post
2 hours ago, Gog said:

dumb question but did you tell your downloader to use /downloads instead of /data?

What is the error message in the application?  If you open a command prompt in both dockers, you should be able to see the file uing the same path.

Yes, I did. The path within the downloader is /downloads or downloads/incomplete respectively. Otherwise the client would just stall because the download path is non-existent/inaccessible.

There is no error message, sonarr just does nothing. It initiates new downloads, though, which the download client puts in the /downloads directory.

I don't quite get the point about the command prompt: When I open one in each container they show the same thing that Krusader shows: All's well, the downloads land in the correct path.

Edited by whauk

Share this post


Link to post
22 minutes ago, whauk said:

Yes, I did. The path within the downloader is /downloads or downloads/incomplete respectively. Otherwise the client would just stall because the download path is non-existent/inaccessible.

There is no error message, sonarr just does nothing. It initiates new downloads, though, which the download client puts in the /downloads directory.

Is the download still in sonarr's activity list?  what if you hover on the image tag on the left of the download?  Either way, the sonarr logs should have info on the processing of the completed download.

Quote

I don't quite get the point about the command prompt: When I open one in each container they show the same thing that Krusader shows: All's well, the downloads land in the correct path.

Good, it was to double-check that from the container's point of vue the file exists for everyone.

Share this post


Link to post
31 minutes ago, mihcox said:

Maybe i dont understand what youre suggesting. This is for "(AKA Linking between containers)". This is not my case, i have one local container, and one external container on a seedbox. I used the following guide for setup from spaceinvaderone: 

 

Again, apologies if that applies to me too.

Whoa, context switch, I was probably wrong then.  Thinking about it...

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.