[Support] Linuxserver.io - Sonarr

Recommended Posts

UMASK value and files permissions incorrectly set, or at least I believe them to be.


I originally had the Binhex version of Sonarr installed, but wanted to use v3, so I 'migrated' to the linuxserver version by changing the Repository value to linuxserver/sonarr:preview and hitting apply. This all worked without a hitch and all data was kept and everything worked as it should.


I recently noticed that a lot of my file permissions on unRAID were set incorrectly, so I fixed all those using chmod and chown. After noticing this I set all relevant dockers; NZBGet, Radarr, NZBHydra and Sonarr to have the UID = 99, GID = 100 and UMASK = 002. Based on all the info I've read a mask value of 002 should give 664 for files -rw-rw-r--. However, after the file is imported by Sonarr and renamed, the file permissions keep showing up as 644, -rw-r--r--.


I did notice that the Binhex version of Sonarr has the UMASK key value as "UMASK", where this version is "UMASK_SET". I have since modified this, reloaded the docker, but the files keep showing up with -rw-r--r--.


My last ditch effort would be to completely remove Sonarr, install it again, and start over to see if this fixes the issue.


I figured I might as well ask here 1st to see if anyone has any input as to why this would occur. I looked at the file through the terminal, while it was still in NZBGet and the file permissions are what they should be -rw-rw-r--.


Anyone have any ideas?

Edited by unRAIDuser7
add info
Link to comment
  • 3 weeks later...
6 minutes ago, LateNight said:

@unRAIDuser7 @TexasUnraid have you tried the "Set Permissions" option in Sonarr, as explained at: 


I saw those options but no explanation of how they work so I didn't mess with them. Still pretty new to linux and don't fully understand the permissions.


From what I know 777 is full permissions and what I would want on the files, so why does that show 0644 and 0755? Wouldn't that limit permissions in some way?


Also, seems there are 2 ways to adjust permissions in linux, one allows you to set permissions and the other only allows you to subtract permissions? I was not sure which one this used.

Link to comment
  • 4 weeks later...
13 hours ago, bevinet said:

My Sonarr container is huge compared to radarr - 88GB vs 515MB.

Is there anywhere I can look to check why this is so large. I have increased the size of the docker image, but it doesn't help, as it just grows to fill the image space.

The usual reason for writing into docker.img is specifying a path in an application that doesn't correspond to a container path in your mappings. Common mistakes are not using the same upper/lower case as your container path, or using a relative path (not beginning in /).

Link to comment
  • 3 weeks later...

Hi All


Im getting an error on Sonarr at the moment and the port is confirmed to not be in use. Even changing the port doesnt work. It seems its an error internal to the docker. Any suggestions?

[Fatal] ConsoleApp: Address already in use. This can happen if another instance of Sonarr is already running another application is using the same port (default: 8989) or the user has insufficient permissions


Link to comment

Good evening all


Was wondering if anyone else have had this problem. im running unraid 6.8.3. and running sonar V3. 

The Sonarr app stopped working. when i try to go on to the webui i get "ERR_CONNECTION_REFUSED". this happened over the night. i did not install any new containers when it started. when i looked at the log it gave me the error " Epic Fail!" (I dont see anything epic about it)

Here is the log i get.


EPIC FAIL! System.InvalidCastException: Specified cast is not valid.
at System.Data.SQLite.SQLiteDataReader.VerifyType (System.Int32 i, System.Data.DbType typ) [0x000cd] in <61a20cde294d4a3eb43b9d9f6284613b>:0
at System.Data.SQLite.SQLiteDataReader.GetInt32 (System.Int32 i) [0x0002b] in <61a20cde294d4a3eb43b9d9f6284613b>:0
at NzbDrone.Core.Datastore.Migration.add_configurable_qualities.ConvertQualities (System.Data.IDbConnection conn, System.Data.IDbTransaction tran) [0x00038] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Datastore\Migration\037_add_configurable_qualities.cs:42
at FluentMigrator.Runner.Processors.SQLite.SQLiteProcessor.Process (FluentMigrator.Builders.Execute.PerformDBOperationExpression expression) [0x00038] in <137fb96feee44f379d6a8fba4e172d1c>:0
at FluentMigrator.Builders.Execute.PerformDBOperationExpression.ExecuteWith (FluentMigrator.IMigrationProcessor processor) [0x00000] in <c16130ff2bfb4746b4fb36de17115e3e>:0
at FluentMigrator.Runner.MigrationRunner+<>c__DisplayClass72_0.<ExecuteExpressions>b__1 () [0x00011] in <137fb96feee44f379d6a8fba4e172d1c>:0
at FluentMigrator.Runner.StopWatch.Time (System.Action action) [0x00006] in <137fb96feee44f379d6a8fba4e172d1c>:0
at FluentMigrator.Runner.MigrationRunner.AnnounceTime (System.String message, System.Action action) [0x0000c] in <137fb96feee44f379d6a8fba4e172d1c>:0
at FluentMigrator.Runner.MigrationRunner.ExecuteExpressions (System.Collections.Generic.ICollection`1[T] expressions) [0x000a5] in <137fb96feee44f379d6a8fba4e172d1c>:0
at FluentMigrator.Runner.MigrationRunner.ExecuteMigration (FluentMigrator.IMigration migration, System.Action`2[T1,T2] getExpressions) [0x0005a] in <137fb96feee44f379d6a8fba4e172d1c>:0
at FluentMigrator.Runner.MigrationRunner.ApplyMigrationUp (FluentMigrator.Infrastructure.IMigrationInfo migrationInfo, System.Boolean useTransaction) [0x0010f] in <137fb96feee44f379d6a8fba4e172d1c>:0
at FluentMigrator.Runner.MigrationRunner.MigrateUp (System.Boolean useAutomaticTransactionManagement) [0x000af] in <137fb96feee44f379d6a8fba4e172d1c>:0
at NzbDrone.Core.Datastore.Migration.Framework.MigrationController.Migrate (System.String connectionString, NzbDrone.Core.Datastore.Migration.Framework.MigrationContext migrationContext) [0x000a2] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Datastore\Migration\Framework\MigrationController.cs:51
at NzbDrone.Core.Datastore.DbFactory.CreateMain (System.String connectionString, NzbDrone.Core.Datastore.Migration.Framework.MigrationContext migrationContext) [0x0000b] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Datastore\DbFactory.cs:117
at NzbDrone.Core.Datastore.DbFactory.Create (NzbDrone.Core.Datastore.Migration.Framework.MigrationContext migrationContext) [0x00027] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Datastore\DbFactory.cs:82
at NzbDrone.Core.Datastore.DbFactory.Create (NzbDrone.Core.Datastore.Migration.Framework.MigrationType migrationType) [0x00000] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Datastore\DbFactory.cs:70
at NzbDrone.Core.Datastore.DbFactory.RegisterDatabase (NzbDrone.Common.Composition.IContainer container) [0x00000] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Datastore\DbFactory.cs:48
at NzbDrone.Host.NzbDroneServiceFactory.Start () [0x00037] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Host\ApplicationServer.cs:60
at NzbDrone.Host.Router.Route (NzbDrone.Host.ApplicationModes applicationModes) [0x0007f] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Host\Router.cs:56
at NzbDrone.Host.Bootstrap.Start (NzbDrone.Host.ApplicationModes applicationModes, NzbDrone.Common.EnvironmentInfo.StartupContext startupContext) [0x0003d] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Host\Bootstrap.cs:78
at NzbDrone.Host.Bootstrap.Start (NzbDrone.Common.EnvironmentInfo.StartupContext startupContext, NzbDrone.Host.IUserAlert userAlert, System.Action`1[T] startCallback) [0x0007f] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Host\Bootstrap.cs:41
at NzbDrone.Console.ConsoleApp.Main (System.String[] args) [0x0002e] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Console\ConsoleApp.cs:41
Press enter to exit...
[Info] Bootstrap: Starting Sonarr - /app/sonarr/bin/Sonarr.exe - Version

and after i tried to delete the container and the image it gives me the same message. it loops until it gives up. just for funn i tried V2, and that worked like a charm. but i would like to stay on V3 if at all possible 


Im unable to find a solution on my own so i hope anyone else have seen this and have some magic we can sprinkle over this problem. 


in advance, thanks for your time 

Edited by Parabux
Link to comment
  • 3 weeks later...
On 5/19/2019 at 8:58 AM, thatsthefrickenlightning said:

Thank you for this! Fixed my hardlink problem without too much headache.


Summing up for any lurkers/Googlers: I removed all volume mounts in the docker settings except for config aka appdata for both sonarr/radarr and my torrent client. Then I pointed /mnt/ to /mnt/ for both my torrent client docker and radarr/sonarr, and now hardlinks are automatically created succesfully. This can be verified with Krusader by opening a terminal in either your torrents folder or your episode/film folder and typing 'stat *filename*'. Among the output is the Links count, which should say 2, meaning the data is linked to by 2 files in total: a hardlink.


Feel free to correct me if I got anything wrong there.

Does that mean deleting Host Path 2 and Host Path 3 and creating a new Host Path called /mnt or just changing them both to /mnt/


  • Thanks 1
Link to comment
5 hours ago, thatsthefrickenlightning said:

I left /data and /config alone, deleted /media and created /mnt ( = /mnt) for Sonarr, Radarr and qBitTorrentvpn.

Massive thanks!
I just did a quick test with one TV show and it works! Now I just need to check/fix everything that I downloaded since moving to unraid.

Link to comment
16 hours ago, LeGourmand said:

Massive thanks!
I just did a quick test with one TV show and it works! Now I just need to check/fix everything that I downloaded since moving to unraid.

You're very welcome! Perhaps this is a bit of hillbilly tech, but if you have your entire library in your torrent client and in your plex server and they should be hardlinked, you could just delete your whole Plex library. If the files are hardlinked, there should be no change in the drive space indication in unraid.

Link to comment
  • 4 weeks later...

I am all of a sudden getting the "Import failed, path does not exist or is not accessible by Sonarr" in the log. Also started happening in Radarr. Previously the setup has run flawlessly since the time I set it up.


Sonarr Version is


I've tried the Set permissions features listed above(0666, 0777, 99, 100) and still the issue persists.


Manual Imports work just fine.


The only thing that I can think might have changed before this started happening was that I update my Qbittorrent docker.


Looking for some hand holding/ suggestions on how to proceed as my typical Googling and forum reading hasn't been able to crack the issue thus far.


**Disclaimer I'm still a relative novice when it comes to Linux and Docker.**


Stumbled across some notes on Reddit that there is issues with Qbt versions higher that 4.2.5 and the work around is to upgrade Sonarr to V3. I will give this a try.



Edited by MEF
Link to comment

Remote path issue?

I'm using Deluge and everything is working with Sonarr triggering downloads and labeling but I'm having an issue having the completed files get picked up and moved to the final folder where my TV shows are by Sonarr. Sonar can see the most recent download in the completed downloads folder but won't import it and is throwing the error:


Import failed, path does not exist or is not accessible by Sonarr: /Downloads/completed/Real.Time.with.Bill.Maher.S18E34.720p.WEB.H264-JEBAITED[TGx]. Ensure the path exists and the user running Sonarr has the correct permissions to access this file/folder


From research I believe I need to do a remote path mapping and have set that up but something is still not right. I've attached my settings for the remote path mapping in Sonarr and Docker setups.




Remote Path.PNG

Link to comment
  • 2 weeks later...

Been trying to move from v2 to v3 but during database conversion, it keeps erroring out on the following. Deleting the database gets Sonarr v3 to properly start. Restoring the database fails with the same error. Still searching on a way to fix this issue.


20-12-16 23:32:43.2|Info|MigrationLogger|*** 139: add_download_history migrating ***
20-12-16 23:32:43.2|Info|add_download_history|Starting migration to 139
20-12-16 23:32:43.3|Error|MigrationLogger|Newtonsoft.Json.JsonReaderException: After parsing a value an unexpected character was encountered: a. Path 'downloadUrl', line 12, position 3. (Json snippet '  "<--error-->audioLanguages": "En') ---> Newtonsoft.Json.JsonReaderException: After parsing a value an unexpected character was encountered: a. Path 'downloadUrl', line 12, position 3.
  at Newtonsoft.Json.JsonTextReader.ParsePostValue (System.Boolean ignoreComments) [0x0019a] in <d47de75a7e3f422ca4ca64a654c80495>:0 
  at Newtonsoft.Json.JsonTextReader.Read () [0x0005a] in <d47de75a7e3f422ca4ca64a654c80495>:0 

Link to comment

Has anyone ever found a solution to the "disk image is malformed" problem?  I've tried every solution and trick I can find (doing the "mv logs.db logs.old" trick, restoring from backup, moving it all onto a single disk, etc) and it still breaks literally every day.


I updated to the latest version of unRAID, v6.8.3, and I do not have a cache disk.


Maybe I need to revert back to v6.6.7?  I heard it worked in that version...


Any other way to fix it?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.