[Support] Linuxserver.io - Sonarr


Recommended Posts

can anyone help me with radarr and sonarr docker.  When new folders are being made by docker container they do not have correct permissions.  I get errors when sonarr and radarr try to migrate files to plex server.  When i reset permission in tools section of unraid I am then ok, but the following day same thing happens again.  Thank you

Link to comment
On 10/6/2023 at 8:19 PM, ashkasto said:

can anyone help me with radarr and sonarr docker.  When new folders are being made by docker container they do not have correct permissions.  I get errors when sonarr and radarr try to migrate files to plex server.  When i reset permission in tools section of unraid I am then ok, but the following day same thing happens again.  Thank you

Under settings and then Media Management (make sure you enable show advanced) there's a section if you scroll down so that you can set permissions.

Link to comment
  • 2 weeks later...
On 8/31/2023 at 10:24 PM, JonathanM said:

Docker run commands for each of the containers, be sure to redact any credentials.

Hi 🙂

Thankyou.  I have still been trying to fix now writer's strike is over.

Plex, SABnzbdvpn & Sonarr commands and other:

Where am I going wrong that Sonarr can't pick up the downloaded file and drag to Plex?

 

Cheers 🙂

EDITED BIT: Uploaded incorrect pic, had creds.

857039567_Screenshot2023-10-22at20_21_48.thumb.png.74fc58f12aa14e0b59f819e26d2ac049.png857039567_Screenshot2023-10-22at20_21_48.thumb.png.74fc58f12aa14e0b59f819e26d2ac049.png

Screenshot 2023-10-22 at 20.15.26.png

Screenshot 2023-10-22 at 21.09.28.png

Screenshot 2023-10-22 at 21.14.54.png

Screenshot 2023-10-22 at 21.16.03.png

Screenshot 2023-10-22 at 21.26.46.png

 

Edited by RadRom
Link to comment
3 hours ago, RadRom said:

Where am I going wrong that Sonarr can't pick up the downloaded file and drag to Plex?

sonarr and sab must have a common path mapping. Right now you have /downloads->/mnt/user/downloads/complete and /data->/mnt/user/downloads.

 

Change one or the other to match, both host and container parts of both mappings must be identical. You have neither part identical right now.

  • Thanks 1
Link to comment
  • 4 weeks later...

Sonarr and MP4 Automator - How to get post Sonarr processing to optimize for direct play under this docker? I'm new to unraid and still have Python and MP4 Automator installed running postsonarr.py on my other machine. Is there a way to replicate while still keeping unraid stock and not getting setup wiped in future docker updates? I've seen mentions of a handbrake docker using a drop folder, but not familiar how to workflow from Sonarr to completed downloads folder, then moves to final tv folder tree with the show name. I'm a little confused on all this. My setup is on a mini pc homelab with an AMD igpu, so I'd love my ...arr files to be direct play optimized from the get go. Thanks all and sorry if I missed above or elsewhere.

Link to comment
  • 1 month later...

Sonarr container is offline. Getting some ugly database errors on startup. Pasting the main bits here and attaching the full log.

 

While Processing:
"INSERT INTO "Commands_temp" ("Id", "Name", "Body", "Priority", "Status", "QueuedAt", "StartedAt", "EndedAt", "Duration", "Exception", "Trigger", "Result") SELECT "Id", "Name", "Body", "Priority", "Status", "QueuedAt", "StartedAt", "EndedAt", "Duration", "Exception", "Trigger", "Result" FROM "Commands""
 ---> code = Constraint (19), message = System.Data.SQLite.SQLiteException (0x800027AF): constraint failed
NOT NULL constraint failed: Commands_temp.Body

[Info] NzbDrone.Core.Datastore.Migration.Framework.NzbDroneSQLiteProcessor: Rolling back transaction 

[Fatal] ConsoleApp: EPIC FAIL! 

[v4.0.0.748] NzbDrone.Common.Exceptions.SonarrStartupException: Sonarr failed to start: Error creating main database
 ---> System.Exception: constraint failed
NOT NULL constraint failed: Commands_temp.Body
While Processing:
"INSERT INTO "Commands_temp" ("Id", "Name", "Body", "Priority", "Status", "QueuedAt", "StartedAt", "EndedAt", "Duration", "Exception", "Trigger", "Result") SELECT "Id", "Name", "Body", "Priority", "Status", "QueuedAt", "StartedAt", "EndedAt", "Duration", "Exception", "Trigger", "Result" FROM "Commands""
 ---> code = Constraint (19), message = System.Data.SQLite.SQLiteException (0x800027AF): constraint failed
NOT NULL constraint failed: Commands_temp.Body

Press enter to exit...
Non-recoverable failure, waiting for user intervention...

 

Any ideas what may be happening here? Seems it started a few days ago when I did an update this past weekend and did not realize it was down.

 

More data I found in the logs when the database problem started:

 

2023-12-28 06:19:11.1|Info|ExistingOtherExtraImporter|Found 0 existing other extra files
2023-12-28 06:19:11.1|Info|ExistingExtraFileService|Found 0 possible extra files, imported 0 files.
2023-12-28 06:20:50.7|Error|CommandExecutor|Error occurred while executing task MessagingCleanup

[v3.0.10.1567] code = Corrupt (11), message = System.Data.SQLite.SQLiteException (0x800007EF): database disk image is ma
lformed
database disk image is malformed
  at System.Data.SQLite.SQLite3.Reset (System.Data.SQLite.SQLiteStatement stmt) [0x00088] in <cf516e4846354910b3d60749c8
94b1bf>:0 
  at System.Data.SQLite.SQLite3.Step (System.Data.SQLite.SQLiteStatement stmt) [0x0006e] in <cf516e4846354910b3d60749c89
4b1bf>:0 
  at System.Data.SQLite.SQLiteDataReader.NextResult () [0x00174] in <cf516e4846354910b3d60749c894b1bf>:0 
  at System.Data.SQLite.SQLiteDataReader..ctor (System.Data.SQLite.SQLiteCommand cmd, System.Data.CommandBehavior behave
) [0x0008e] in <cf516e4846354910b3d60749c894b1bf>:0 
  at (wrapper remoting-invoke-with-check) System.Data.SQLite.SQLiteDataReader..ctor(System.Data.SQLite.SQLiteCommand,Sys
tem.Data.CommandBehavior)
  at System.Data.SQLite.SQLiteCommand.ExecuteReader (System.Data.CommandBehavior behavior) [0x0000c] in <cf516e484635491
0b3d60749c894b1bf>:0 
  at System.Data.SQLite.SQLiteCommand.ExecuteNonQuery (System.Data.CommandBehavior behavior) [0x00006] in <cf516e4846354
910b3d60749c894b1bf>:0 

 

sonarr_database_error.txt

Edited by snowboardjoe
Link to comment

Found the resources on how to restore and did that from backup on 27 Dec. Had to roll back to earlier version to match that backup. WebUI is restored and performing updates, but still seems like there is corruption in the database.

 

23:11	HousekeepingService	Error running housekeeping task: CleanupCommandQueue: database disk image is malformed database disk image is malformed	
23:11	CommandExecutor	Error occurred while executing task MessagingCleanup: database disk image is malformed database disk image is malformed	
23:10	EventAggregator	CommandQueueManager failed while processing [ApplicationStartedEvent]: database disk image is malformed database disk image is malformed

 

Link to comment

Ok, managed to fix mine.

 

I have the Appdata backup plugin. I deleted the docker, restored it to a backup from 25/12/23, and redownloaded the docker with forcing it to version "3.0.10.1567-ls218".

 

I noticed that version was issued ~2 weeks ago, and the latest version from ~2 days ago is some 4.XXX version. Looks like the corruption must have happened with the new main version #. Looks like i'll be sticking with forcing the current version to be safe!

Link to comment
1 hour ago, snowboardjoe said:

Yeah, going to dig back to older backups too and see if I can get past the corruption. Check your event log and make sure there are no new errors involving the database. I wish I had know there was a problem much earlier.

 

Still not working very well. Jumped to a backup from almost a month ago and still showing database errors. Sonarr is running, but constant database error events.

Link to comment
  • 3 weeks later...

+Also ran into upgrade issues with the update to v4. Per the v4 sonarr release notes I was able to uncorrupt database and it is now working fine.

 

"

Issues when upgrading

If you had a lot of preferred words in Sonarr v3 then you will see many migrated custom formats in v4. These will need to be edited or deleted and readded. The {Preferred Words} naming token is also replaced with the {Custom Formats} token. Check your naming strings.

Due to multiple database migrations we’ve seen that some corrupt databases that were doing OK in v3 have broken in v4. You can try to follow our corrupt database repair guide Useful Tools | Servarr Wiki 102 or reach out to one of our Support channels."6

Link to comment

Ok, yes I know this is the Sonarr Support thread, but I'm using both Sonarr and Radarr from Linuxserver.io and I'm having issues.

It's one of the most common issues we have around here.  And I've done everything I can think of but I'm very obviously missing a setting or several settings some where.

Issue:

When qBittorrent finishes downloading a file, it's suppose to move it from /mnt/user/Media/Torrents to /mnt/user/Media/Torrents/Completed.  Once it does that, Radarr (or Sonarr) is suppose to pick it up and move it to /mnt/user/Media/Plex/4K Movies (or 4K TV Shows).  That isn't happening. Radarr will show the file as green/available, with it's path as "/downloads/(movie folder name)". So Plex never see's it.  It's also suppose to rename the file. It does rename it and create a proper folder for it (Title (year)), but it leaves it in /mnt/user/Media/Torrents.

Using just Radarr as my example for now, I've mapped /movies to /mnt/user/Media/Plex/4K Movies and /downloads to /mnt/user/Media/Torrents/.

With in Radarr, I've added the root path "/movies" and in qBT I have the following settings
Downloads Tab:

-Default Torrent Management Mode: Automatic

-When Torrent Category changed: Relocate Torrent
-When Default Save Path Changed: Relocate affected torrents.
-When Category Save Path Changed: Relocate affected torrents

- Use Subcategories: Checked
-Default Save Path: /downloads/Completed
-Keep incomplete torrents in: /downloads/incomplete

BitTorrent Tab:
-Seeing Limits
--When Ratio reaches: 1
Then Pause Torrent

There's clearly something I'm missing because I have Sonarr set up the exact same way, except with 4K TV Shows folder instead of 4K Movies.

Any advice on where to look?
 

unraid.png

Edited by Meller
Left out where Radarr says the path is
Link to comment
  • 2 weeks later...

So I feel like I'm having a similar issue to some others, but I'm just not smart enough to figure it out... lol

Everything has been working perfectly up until maybe a couple weeks ago, although I'm just realizing that I have a problem today.

Nothing in my config has changed, other than various dockers updating along the way, as they do.

like most others, I have Radarr, Sonarr, Jackett and Plex all working together, along with SabNZB and qBit handling the downloading.

As I said, everything has been great, until recently.

Today, I ran a manual search for a certain show.  The results came back as usual, and I selected one for download.  It was an NZB.  A few minutes later, I saw that it was complete, but not showing up in Sonarr.  I looked in the unraid file manager, and the file is there, but it's not being moved or acknowledged in any way by Sonarr, as best as I can tell.  The odd thing is that there are no errors in Sonarr This is a key difference from previous times I've had trouble.  Before, it's always been that Sonarr saw the file, but had some permissions or mapping issue.  This time, it's like it doesn't knw the file exists, even though it was the one that initiated the download request.

As I said, now that I look, I see that I have lots of files backing up in the downloads folder, waiting to be imported, but Sonarr doesn't seem to know they are there.

I'm not even sure where to begin looking.  I'm not good at parsing logs, or even finding them always.  I'm happy to provide info, if anyone can tell me what you need to see....

I saw a mention above about there being an update from v3 to v4, and custom preference tags causing some issue?  How can I tell what version I'm on?  I do use preference tags, in an attempt to get Sonarr to pull smaller x264/x265 files, rather than huge 1080p rips.  Could that be part of the issue?

 

EDIT/SOLUTION:  So I found the solution, at least for my specific issue.  Maybe this is your problem as well.  It seems that in the update to Sonarr v4, it's now aggressively enforcing the "Category" thing, whatever that is.  I've never needed, cared or wanted to know anything about "Categories", but without assigning one, Sonarr just refused to import my files.  I found this out by digging through my settings, looking for what I thought was maybe a bad mapping, based on the comments above.  Everything looked okay, though, and had been working just fine for many months.  On the Settings > Download Clients > SABnzbd screen, I tried to run a [test] and got a warning.  It said "Adding a category specific to Sonarr avoids conflicts with unrelated non-Sonarr downloads. Using a category is optional, but strongly recommended.

A category is recommended".

In this case "recommended" means, 100% will not work until you assign one.

I knew nothing about what it wanted for input, so I tried "Sonarr", which it rejected, since it didn't exist in SAB already.  Okay... to I went over to SAB, checked the [Categories] tab, and noticed that they were more like {TV}, {Movies}, etc...

Fine, I went back to Sonarr, put in "tv", and clicked [test].  I got a green check, so I manually ran the tasks, and lo and behold, all my files are importing!

This really could be documented a bit better.  Or better yet, just left alone! :/

 

TL;DR - put "tv" into the [category] field of SABnzbd's settings (within Sonarr), and see if that fixes your import issues.

Edited by Elmojo
added solution/update
Link to comment
  • 3 weeks later...
2 hours ago, Squid said:

If it’s still there in docker edit it (if not previous apps and actions reinstall) and you have a path sitting in there that doesn’t have an entry next to it.  Remove that path

Thank you! Removing the empty "tv" and "downloads" paths worked. But not sure why the sonarr docker update went belly up the first place... Could be related that I previously had updated Unraid from 6.12.6 to 6.12.8?

Link to comment
On 2/17/2024 at 9:28 AM, AlphaXL said:

Removing the empty "tv" and "downloads" paths worked.

I'm curious, what is your use case that works with no media or incoming files? I'm having a hard time understanding what you use sonarr for if it doesn't have access to those folders.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.