[support] rix's Docker Repository


rix

273 posts in this topic Last Reply

Recommended Posts

@rix I took a look at the docker file.  I think the answer to my question 1 above is the last line of that file tells docker to expose 53, so thats why Unraid shows it exposed.   I assume this is not going to get in the way, but also not breaking it technically, if I am set up for port 54? I'm kinda raw on this.

 

2. Why doesn't path resolution work?

Link to post
  • Replies 272
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

rix's Repository https://github.com/rix1337/docker-templates   Some of my containers are based on linuxserver.io's alpine baseimages. Support their cause at https://www.linuxserver.io/donati

Any apostrophes or the like in the username / password?

Thank you for your response! It looks like that was a hardware failure on my end that appears any time I try to rip one particular CD. Thank you though! I'll look into ways to modify the .sh file to

Posted Images

@rix

 

Hey i set up your Synclounge docker, i loved the idea of having it all automated. Yet when i go to my url the automation just doesn't work. My settings:

 

Can you help me out?

 

error.png

 

Edited by Mirano
Link to post
  • 2 weeks later...
On 3/17/2020 at 2:35 AM, zachrybaker said:

@rix I took a look at the docker file.  I think the answer to my question 1 above is the last line of that file tells docker to expose 53, so thats why Unraid shows it exposed.   I assume this is not going to get in the way, but also not breaking it technically, if I am set up for port 54? I'm kinda raw on this.

 

2. Why doesn't path resolution work?

Hi.. sorry i don't have an answer for you, but have you figured this out ? i am also having trouble w/ getting this docker to work. thnaks

Link to post
On 3/20/2020 at 9:07 AM, Mirano said:

@rix

 

Hey i set up your Synclounge docker, i loved the idea of having it all automated. Yet when i go to my url the automation just doesn't work. My settings:

 

Can you help me out?

 

error.png

 

I found out his docker is 7 months behind so I made it work by using the official docker container...

Link to post
On 3/29/2020 at 5:18 PM, derpingit said:

Hi.. sorry i don't have an answer for you, but have you figured this out ? i am also having trouble w/ getting this docker to work. thnaks

Sounds like you have the exact same questions I do.  The lack of response here should tell us something, I guess.  Either @rix is busy, doesn't know, doesn't care. Bummer.

Link to post
On 4/5/2020 at 5:42 AM, zachrybaker said:

Sounds like you have the exact same questions I do.  The lack of response here should tell us something, I guess.  Either @rix is busy, doesn't know, doesn't care. Bummer.

Nice attitude. Apart from that, I was abroad and now am managing the COVID-19 thing at work. Lack of responsiveness for another few weeks included.

 

I will take a look at your questions, if there is time.

Link to post
On 4/4/2020 at 8:15 PM, EmilionDK said:

I found out his docker is 7 months behind so I made it work by using the official docker container...

Can you please explain more? I am trying to get this setup with nginx proxy manager and cannot figure how to pass thru  the ports needed as there are multiple. thank you

Link to post

Hey rix, thanks for developing all the containers and continuing to support them, and helping manage the COVID-19 crisis wherever you are. 

 

I am using the ripper container, and I get very mixed results with it. I have run probably 300 DVDs/Blurays through the jlesage/makemkv container in the past few weeks, since I am now sitting at my home desk all day. Many of the same discs I have attempted through Ripper, but the type is not detected correctly, or the rip is unsuccessful. For example, a bluray disc is detected, but immediately ejected with a finished in the log, but no data is created.

*** Running /etc/my_init.d/ripper.sh...
Using MakeMKV beta key: T-UWwbYn781f1gjZcH5NOsJkGgWHnUkQsr2IduoSJ8sssNXOqclsWhowNWTclkBjHIMH
12.04.2020 04:42:25 : Starting Ripper. Optical Discs will be detected and ripped within 60 seconds.
12.04.2020 04:45:38 : Data-Disk detected: Saving ISO
12.04.2020 04:45:51 : Done! Ejecting Disk
12.04.2020 04:46:58 : Disk tray open
12.04.2020 04:48:00 : Disk tray open
12.04.2020 04:49:02 : Disk tray open
12.04.2020 04:50:05 : Disk tray open
12.04.2020 04:51:07 : Disk tray open
12.04.2020 04:52:09 : Disk tray open
12.04.2020 04:53:11 : Disk tray open
12.04.2020 04:54:13 : Disk tray open
12.04.2020 04:55:15 : Disk tray open
12.04.2020 04:56:17 : Disk tray open
12.04.2020 04:57:20 : Disk tray open
12.04.2020 04:58:23 : Disk tray open
12.04.2020 04:59:25 : Disc still loading
12.04.2020 05:00:33 : BluRay detected: Saving MKV
'/out/Ripper/BluRay/BRAVE' -> '/out/Ripper/BluRay/finished/'
12.04.2020 05:00:37 : Done! Ejecting Disk
12.04.2020 05:01:42 : Disk tray open

 image.png.10cbd05735face32761fd0bb977e6401.png

 

A small datadisk I did want, did rip successfully. It seems to have no issues making an .iso of discs from SeattleFilmWorks (defunct photo processing company, that my inlaws have dozens of discs from that they want to backup the pictures from). 

 

Audio disks generally have been detected as data, and fail to rip. 

 

Is there extra debug information I could find somewhere, either to present here, or to attempt digging in myself? I appreciate any support you might be able to offer. 

 

 

 

Link to post
On 4/4/2020 at 9:15 PM, EmilionDK said:

I found out his docker is 7 months behind so I made it work by using the official docker container...

Any advice on this? Not able to make the automation work even with the official docker. Keep getting bad gateway if I enable autojoin.

Link to post

Hi Rix,

First, I hope you are ok and that you are safe. I has also been in the front line during the SARS-CoV-2 virus "outbreak", so I can relate to your situation.

 

Maybe another can help in Rix' absence?

My issue is I have 2 DVD-drives and 1 BluRay-drive and I am trying to rip my old DVD collection. I have trawled through this thread and saw I need to have a separate container for each drive. It works like a charm with only 1 drive but when I add another drive (and container) it doesn't seem to work for drive 2.

 

My settings are as follows (for my second drive):

Name: Ripper1

Extra Parameters: --device=/dev/sr1:/dev/sr0

Optical Drive: /dev/sr1

Output Dir: /mnt/user/rips/ripper1/

Config Dir: /mnt/user/appdata/ripper1

 

I have tried to make sure that everything gets its own directory, but I still cannot get it to work.

 

Have I made an error somewhere?

 

/Alphahelix

Link to post
On 4/29/2020 at 12:36 AM, Alphahelix said:

Hi Rix,

First, I hope you are ok and that you are safe. I has also been in the front line during the SARS-CoV-2 virus "outbreak", so I can relate to your situation.

 

Maybe another can help in Rix' absence?

My issue is I have 2 DVD-drives and 1 BluRay-drive and I am trying to rip my old DVD collection. I have trawled through this thread and saw I need to have a separate container for each drive. It works like a charm with only 1 drive but when I add another drive (and container) it doesn't seem to work for drive 2.

 

My settings are as follows (for my second drive):

Name: Ripper1

Extra Parameters: --device=/dev/sr1:/dev/sr0

Optical Drive: /dev/sr1

Output Dir: /mnt/user/rips/ripper1/

Config Dir: /mnt/user/appdata/ripper1

 

I have tried to make sure that everything gets its own directory, but I still cannot get it to work.

 

Have I made an error somewhere?

 

/Alphahelix

Are the extra parameters correct? Did you try swapping the sr1 and sr0?

Edited by administrator
Link to post

Hey guys. I am doing fine and am hereby back again.

The last few weeks have made me aware of what matters most. I will stop supporting tools that I do not use my own and have since removed the following repos, images and their respective templates.

 

grafik.png.d7701a47fe8dc9531cb97505fc42d1bb.png

 

From this day forth I will only be able to help you with

  • RSScrawler
  • Ripper
  • GoogleMusicManager
  • MyJDApi
Link to post
On 5/3/2020 at 6:32 AM, administrator said:

Are the extra parameters correct? Did you try swapping the sr1 and sr0?

Have you tried just passing through /dev/sr1 as /dev/sr1 and modifying the ripper.sh for your second container to point to /dev/sr1 ? That should work. Have just one optical drive, hence I cannot test this.

Link to post
On 4/25/2020 at 12:06 AM, EmilionDK said:

 

PgRgCSf1Uu.png.d989ccf3a411c76f097a6c28cbb92e54.png

 

On 4/21/2020 at 8:58 PM, constellation said:

Any advice on this? Not able to make the automation work even with the official docker. Keep getting bad gateway if I enable autojoin.

 

Due to inactivity on my side and no further time to support this I have now removed Synclounge from my repos.

Link to post
On 4/14/2020 at 5:42 PM, codebone said:

Hey rix, thanks for developing all the containers and continuing to support them, and helping manage the COVID-19 crisis wherever you are. 

 

I am using the ripper container, and I get very mixed results with it. I have run probably 300 DVDs/Blurays through the jlesage/makemkv container in the past few weeks, since I am now sitting at my home desk all day. Many of the same discs I have attempted through Ripper, but the type is not detected correctly, or the rip is unsuccessful. For example, a bluray disc is detected, but immediately ejected with a finished in the log, but no data is created.


*** Running /etc/my_init.d/ripper.sh...
Using MakeMKV beta key: T-UWwbYn781f1gjZcH5NOsJkGgWHnUkQsr2IduoSJ8sssNXOqclsWhowNWTclkBjHIMH
12.04.2020 04:42:25 : Starting Ripper. Optical Discs will be detected and ripped within 60 seconds.
12.04.2020 04:45:38 : Data-Disk detected: Saving ISO
12.04.2020 04:45:51 : Done! Ejecting Disk
12.04.2020 04:46:58 : Disk tray open
12.04.2020 04:48:00 : Disk tray open
12.04.2020 04:49:02 : Disk tray open
12.04.2020 04:50:05 : Disk tray open
12.04.2020 04:51:07 : Disk tray open
12.04.2020 04:52:09 : Disk tray open
12.04.2020 04:53:11 : Disk tray open
12.04.2020 04:54:13 : Disk tray open
12.04.2020 04:55:15 : Disk tray open
12.04.2020 04:56:17 : Disk tray open
12.04.2020 04:57:20 : Disk tray open
12.04.2020 04:58:23 : Disk tray open
12.04.2020 04:59:25 : Disc still loading
12.04.2020 05:00:33 : BluRay detected: Saving MKV
'/out/Ripper/BluRay/BRAVE' -> '/out/Ripper/BluRay/finished/'
12.04.2020 05:00:37 : Done! Ejecting Disk
12.04.2020 05:01:42 : Disk tray open

 image.png.10cbd05735face32761fd0bb977e6401.png

 

A small datadisk I did want, did rip successfully. It seems to have no issues making an .iso of discs from SeattleFilmWorks (defunct photo processing company, that my inlaws have dozens of discs from that they want to backup the pictures from). 

 

Audio disks generally have been detected as data, and fail to rip. 

 

Is there extra debug information I could find somewhere, either to present here, or to attempt digging in myself? I appreciate any support you might be able to offer. 

 

 

 

Run

makemkvcon -r --cache=1 info disc:9999 | grep DRV:0

inside the container. This will help you modify ripper.sh accordingly.

Link to post
18 hours ago, rguinn said:

@rixwould you be able to share you users script for GooglePhoto Sync mine is not working I sure I doing it wrong new to user scripts 

Sure:

#!/bin/bash
docker exec GooglePhotosSync gphotos-sync /storage

 

but it does not seem to work (running the command outside user scripts does!).

I will try to add a cron entry through container variables, so everyone can set this up by themselves.

Link to post
On 5/9/2020 at 8:35 AM, rix said:

Sure:


#!/bin/bash
docker exec GooglePhotosSync gphotos-sync /storage

 

but it does not seem to work (running the command outside user scripts does!).

I will try to add a cron entry through container variables, so everyone can set this up by themselves.

That cmd works for me within user scripts. Just had an update yesterday to user scripts though. Didn't test before.

Link to post
2 minutes ago, CSeK said:

That cmd works for me within user scripts. Just had an update yesterday to user scripts though. Didn't test before.

For me too, have just tested it. Enjoy the container!

Link to post

Hey, is there any chance now that freedb is no longer an active service that the CDDB provider be switched to MusicBrainz in ripit? I've tried to figure out how to do it myself but I can't find concrete documentation on ripit either now that the author has left it for dead.

Link to post
On 5/15/2020 at 7:20 AM, Flatfire said:

Hey, is there any chance now that freedb is no longer an active service that the CDDB provider be switched to MusicBrainz in ripit? I've tried to figure out how to do it myself but I can't find concrete documentation on ripit either now that the author has left it for dead.

Afaik this is something only ripit can fix. If there is another tool that can be included instead of ripit I will consider migrating over.

What I'd need is the tools name and how it needs to be called.

Link to post
On 5/16/2020 at 6:02 AM, rix said:

Afaik this is something only ripit can fix. If there is another tool that can be included instead of ripit I will consider migrating over.

What I'd need is the tools name and how it needs to be called.

The best tool I've seen for the job has been Whipper since it uses MusicBrainz as a default. The github page for the tool is here: https://github.com/whipper-team/whipper

Link to post
3 minutes ago, bar1 said:

can the google photos sync support more then 1 account?

if there is an official way, it should be mentioned on the project page: https://github.com/gilesknap/gphotos-sync

 

if not, you need to run two separate instances of this container with different names and config folders. this should essentially result in two different containers where you can log into each of your accounts seperately.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.