Jump to content
linuxserver.io

[Support] Linuxserver.io - Unifi

902 posts in this topic Last Reply

Recommended Posts

1 hour ago, scubieman said:

Mine is down alot. I clean up appdata.

 

Won't make a difference.  Appdata is not part of what the size display is showing, and anything that the Cleanup Appdata plugin offers to delete isn't an installed app anyways.

Share this post


Link to post

It shows cleaning unifi logs

 

Squid is the screenshot....

1 hour ago, Squid said:
Won't make a difference.  Appdata is not part of what the size display is showing, and anything that the Cleanup Appdata plugin offers to delete isn't an installed app anyways.

image.png.40e52fd63e8a75135a4deee162b9b490.png


Sent from my Pixel 2 XL using Tapatalk
 

 

Edited by scubieman

Share this post


Link to post

Why is the stable release not running 5.9.29 as it seems it has been the stable release since october. 

Share this post


Link to post

Change Repository to linuxserver/unifi:unstable if you want to run 5.9 series.

 

Share this post


Link to post
14 hours ago, fc0712 said:

Why is the stable release not running 5.9.29 as it seems it has been the stable release since october. 

LSIO considers the "stable" release to be whatever Ubiquiti designates as the LTS (long-term support) stable release.  That is currently 5.6.39.

 

The Ubiquiti Stable release branch is accessed by using the "unstable" tag as bonienl mentioned.  Ubiquiti uses the "stable" term very, very loosely.  Their "stable" releases usually have many bugs in the earlier versions.  I started using the "unstable" tag a couple of months ago (after there had been several 5.9.x releases and after monitoring the Ubiquiti forums for a few weeks) and have not found any big problems with the 5.9.29 release; although other users continue to have problems with it as noted in their forums.

Share this post


Link to post

Hey all, 

 

Sorry for my ignorance but after trying to run Unifi from a docker I can't for the life of me figure out how to get out of this disconnected / adopted loop I'm currently experiencing with my USG and AP Lite. They appear in Unifi's device list without any issue but after letting them just sit after initially hitting "adopt" they just disconnect and then go to "adopting" again. 

 

I see some of you guys experienced something similar back in March with a new update at the time. I had them previously set up with a Windows version of Unifi and both units were adopted quickly without issue. Server/docker uptime has not been an issue. 

 

The only modifications I've made to the docker are the port # due to a conflict. Everything else is pretty standard (USG at 192.168.1.1, etc.).

 

Am I just totally missing something? Thanks again!

Share this post


Link to post
Hey all, 
 
Sorry for my ignorance but after trying to run Unifi from a docker I can't for the life of me figure out how to get out of this disconnected / adopted loop I'm currently experiencing with my USG and AP Lite. They appear in Unifi's device list without any issue but after letting them just sit after initially hitting "adopt" they just disconnect and then go to "adopting" again. 
 
I see some of you guys experienced something similar back in March with a new update at the time. I had them previously set up with a Windows version of Unifi and both units were adopted quickly without issue. Server/docker uptime has not been an issue. 
 
The only modifications I've made to the docker are the port # due to a conflict. Everything else is pretty standard (USG at 192.168.1.1, etc.).
 
Am I just totally missing something? Thanks again!

Don’t change the ports. If it’s any issue change it to br0 and give the docker it’s own IP


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
40 minutes ago, viperguy212 said:

Sorry for my ignorance but after trying to run Unifi from a docker I can't for the life of me figure out how to get out of this disconnected / adopted loop

That often means that the devices can't find the inform server (the controller running in the docker).  SSH into each device and run the following command:

 

set-inform http://ip-of-controller:8080/inform

 

In this case, ip-of-the controller will be the IP address of your unRAID server if you are running the docker in bridge mode or whatever IP address you assigned to the docker if you have it on a custom network.

 

Note:  You SSH to the devices with the username and password defined in the Site>Device Authentication section of the controller and not with the controller username and password.

 

image.png.32aef8e7949f34f9a35581659b67fded.png

Edited by Hoopster

Share this post


Link to post

I have also had my access points work fine for days then go to adopting then disconnecting over and over.  Doing what Hoopster wrote does fix things.   Out of curiosity, I have my Unifi Docker set to auto update daily, I have noticed that this adoption/disconnect issue happens after an update.   Do most users have auto-update turned off for the Unifi Docker?

 

Thanks,

Dan

Share this post


Link to post
I have also had my access points work fine for days then go to adopting then disconnecting over and over.  Doing what Hoopster wrote does fix things.   Out of curiosity, I have my Unifi Docker set to auto update daily, I have noticed that this adoption/disconnect issue happens after an update.   Do most users have auto-update turned off for the Unifi Docker?
 
Thanks,
Dan

I have no issues. I run mine in host with auto update. I also host for 6 other locations.


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post

I just noticed that mine is running under bridge.   Based on your comment...maybe I should change to host in my docker settings?   Was also considering using custom:bro and assigning it an ip address.

 

 

 

Share this post


Link to post
I just noticed that mine is running under bridge.   Based on your comment...maybe I should change to host in my docker settings?   Was also considering using custom:bro and assigning it an ip address.
 
 
 

I have other dockers that use the same ports as unifi and I just change the other dockers. I see other say they have the same issue and change unifi. If you have ports clashing and can’t change the other dockers then use br0


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
3 hours ago, goinsnoopin said:

I just noticed that mine is running under bridge.   Based on your comment...maybe I should change to host in my docker settings?   Was also considering using custom:bro and assigning it an ip address.

 

 

 

When I initially set up the UniFi docker, I ran it in host mode.  This was necessary to get the devices recognized, adopted and connected.  After this was done the first time, I changed it back to bridge mode (I at one time also had it assigned a custom IP on br0, but this produced macvlan call traces on my server).  It has been running in bridge mode ever since and has gone through many controller updates and the addition of new devices without the need to switch the docker  back to host mode.

Edited by Hoopster

Share this post


Link to post

Hoopster....interesting.   Before reading your post I did the custom IP on bro and was having issues with home assistant, which has a unifi device tracker component that connects to the controller.  I was getting errors in homeassistant that it could not configure the unifi component.   So I then went to host mode and all is running.   Now I am wondering if I should switch to bridge like you are suggesting.   In bridge mode are you using all that standard ports?   On my previous attempt at running in bridge mode I had some port mappings that were non standard due to conflicts with other dockers.   This afternoon I changed the port mappings on my other dockers and am now using all unifi default ports.

 

Dan

Share this post


Link to post
52 minutes ago, goinsnoopin said:

In bridge mode are you using all that standard ports?

Yes, all UniFi ports are the standard ports.

 

These are the current settings on my UniFi docker:

 

image.png.bd7908d8ba45f99e33d6d388f907cb38.png

Share this post


Link to post

How can I restore this? I completely removed the docker. All I have is the logs.

 

Is there anyway to restore my settings?

Share this post


Link to post
1 hour ago, scubieman said:

How can I restore this? I completely removed the docker. All I have is the logs.

 

Is there anyway to restore my settings?

Unless you have the config files from the mounted volume or a backup of them, there is no way of restoring settings.

Share this post


Link to post
2 minutes ago, sparklyballs said:

Unless you have the config files from the mounted volume or a backup of them, there is no way of restoring settings.

Not sure where the config files would be located. If i look at the folder it shows the log files only in the appdata.

Share this post


Link to post
Not sure where the config files would be located. If i look at the folder it shows the log files only in the appdata.

Then it’s gone


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
On 1/12/2019 at 3:46 PM, goinsnoopin said:

Hoopster....interesting.   Before reading your post I did the custom IP on bro and was having issues with home assistant, which has a unifi device tracker component that connects to the controller.  I was getting errors in homeassistant that it could not configure the unifi component.   So I then went to host mode and all is running.   Now I am wondering if I should switch to bridge like you are suggesting.   In bridge mode are you using all that standard ports?   On my previous attempt at running in bridge mode I had some port mappings that were non standard due to conflicts with other dockers.   This afternoon I changed the port mappings on my other dockers and am now using all unifi default ports.

 

Dan

Hey Dan,

 

Were you able to figure this out? I recently added a Unifi switch to my setup and am having similar issues. Whenever the docker restarts I have to go in and

set-inform http://controllerIP:8080/inform

And it's super annoying!

 

I've been running this docker with zero issues for over a year, so idk why its just now doing this. I also installed the unifi video docker, but they don't share ports...

 

Edit: After lots of digging, I've discovered all of my unifi devices are being passed "http://172.17.0.9:8080/inform" when the docker container restarts. Just so happens that is the internal IP of the docker container!

 

Now the question for someone smarter than I am: How do I ensure the devices get the correct IP address of "192.168.1.8" OR make sure http://unifi:8080/inform works?

Edited by lrx345

Share this post


Link to post
1 hour ago, lrx345 said:

Now the question for someone smarter than I am: How do I ensure the devices get the correct IP address of "192.168.1.8" OR make sure http://unifi:8080/inform works?

Perhaps you need to enable the "Override inform host with controller hostname/IP" option in the Controller Settings.

 

My devices pick up the Controller IP OK without it but, if your devices are getting the docker IP, maybe enabling this option will fix it for you.

 

image.png.26d1fedf7cca2583d85c7e554e0885e7.png

Share this post


Link to post
27 minutes ago, Hoopster said:

Perhaps you need to enable the "Override inform host with controller hostname/IP" option in the Controller Settings.

 

My devices pick up the Controller IP OK without it but, if your devices are getting the docker IP, maybe enabling this option will fix it for you.

 

image.png.26d1fedf7cca2583d85c7e554e0885e7.png

I notice you also have Make Controller discoverable on L2 network enabled. Do i need that enabled for home use?

 

Edit: I want to confirm that checking "override inform host with controller hostname/IP" worked for me. Thank you for that.

 

Now if anyone can explain WHY that works, I would love to know :). Really just wondering why my controller is broadcasting the docker local IP instead of the NIC IP. My cloud access is broken as a result. It's trying the docker IP, and well... that isn't gonna work

Edited by lrx345

Share this post


Link to post
2 minutes ago, lrx345 said:

I notice you also have Make Controller discoverable on L2 network enabled. Do i need that enabled for home use?

I had made a post about this in the last few pages. I'm mobile but I also screebshot it too, follow that And you should be good!

Share this post


Link to post
1 minute ago, CorneliousJD said:

I had made a post about this in the last few pages. I'm mobile but I also screebshot it too, follow that And you should be good!

This one?

 

 

Share this post


Link to post
I notice you also have Make Controller discoverable on L2 network enabled. Do i need that enabled for home use?

Yes, you should enable that. I guess I thought you already had it enabled so I referenced the other option.


Sent from my iPhone using Tapatalk

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now