Unraid doesn't recognise my pci-e Sata Controller (SOLVED)


Recommended Posts

Hi Guys.


I've just added an IOCrest IO-PCE9215-4I SATA controller to my unraid box. I ordered this on the backround of the hardware compatability page found here.


But my 3TB WD red drive isn't recognised, it spins up, but doesn't show on either "main" menu or dashboard.


The documentation states that "Linux distributions with kernel version 2.6.19 and above include inbox drivers for IDE/ATA device" (attached).


I have had the drive connected via the primary sata controller onboard and there it shows, I have used another sata cable from the secondary pci-e satacontroller to the drive, still nothing.


Does any of you have a suggestion?


Best regards




Link to comment

Thank you for the swift reply.


The odd thing is that none of my drives are being shown in the POST (Picture attached) from here it just jumps to the unRaid boot screen.

I've just updated the BIOS on my motherboard, still no luck.


Next step I'll check if the sata controller is detectable in another system

!UPDATE! SATA controller is DOA, it didn't show on my other system aswell.



Link to comment
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.