Unable to start VM


Recommended Posts

Have tried creating a VM with a variety of settings and get the same error each time.  I've tried enabling and disabling PCIe ACS override, I've tried using SeaBIOS and OVMF as well as several different OS ISO's (Ubuntu server 15.04, lubuntu, slack) with no luck.  Same message every time.  I'm not trying to pass-through any devices....yet.  What am I doing wrong?


char device redirected to /dev/pts/0 (label charserial0)

qemu: terminating on signal 15 from pid 10844

2016-01-02 17:09:09.357+0000: shutting down

2016-01-02 17:13:08.717+0000: starting up libvirt version: 1.2.18, qemu version: 2.3.0

Domain id=1 is tainted: high-privileges

Domain id=1 is tainted: host-cpu

char device redirected to /dev/pts/0 (label charserial0)


I have run Unraid 6 with VM's on this exact hardware.  Only thing that changed was Unraid config.  I started fresh with my flash drive.  Things had become a bit messy after 5 or so years of running various plugins, docker containers, vm's and a multitude of shares.


Any ideas?

Link to comment

yes!  I didn't try disabling that, although it worked before.  I'll disable it and see if that helps.


I wouldn't have thought disabling it would make any difference, if anything, less likely to work...


Changed anything in your BIOS?  Might be worth checking...

Link to comment

1. Yes, bridge is definitely created and is br0

2. The VM starts to boot.  I get the bootloader screen but then vnc exits and the log shows

2016-01-02 20:26:01.456+0000: starting up libvirt version: 1.2.18, qemu version: 2.3.0

Domain id=3 is tainted: high-privileges

Domain id=3 is tainted: host-cpu

char device redirected to /dev/pts/0 (label charserial0)

2016-01-02T20:26:10.794940Z qemu-system-x86_64: Guest moved used index from 4 to 33319

2016-01-02 20:26:10.847+0000: shutting down


Here's the XML


<domain type='kvm'>




    <vmtemplate name="Custom" icon="ubuntu.png" os="ubuntu"/>


  <memory unit='KiB'>2097152</memory>

  <currentMemory unit='KiB'>262144</currentMemory>





  <vcpu placement='static'>2</vcpu>


    <vcpupin vcpu='0' cpuset='0'/>

    <vcpupin vcpu='1' cpuset='1'/>



    <type arch='x86_64' machine='pc-q35-2.3'>hvm</type>

    <loader type='pflash'>/usr/share/qemu/ovmf-x64/OVMF-pure-efi.fd</loader>






  <cpu mode='host-passthrough'>

    <topology sockets='1' cores='2' threads='1'/>


  <clock offset='utc'>

    <timer name='rtc' tickpolicy='catchup'/>

    <timer name='pit' tickpolicy='delay'/>

    <timer name='hpet' present='no'/>







    <disk type='file' device='disk'>

      <driver name='qemu' type='raw' cache='writeback'/>

      <source file='/mnt/user/vmstore/MediaManager/vdisk1.img'/>

      <target dev='hdb' bus='virtio'/>

      <boot order='1'/>

      <address type='pci' domain='0x0000' bus='0x02' slot='0x04' function='0x0'/>


    <disk type='file' device='cdrom'>

      <driver name='qemu' type='raw'/>

      <source file='/mnt/user/iso/ubuntu-15.10-server-amd64.iso'/>

      <target dev='hda' bus='usb'/>


      <boot order='2'/>


    <controller type='usb' index='0' model='ich9-ehci1'>

      <address type='pci' domain='0x0000' bus='0x02' slot='0x02' function='0x7'/>


    <controller type='usb' index='0' model='ich9-uhci1'>

      <master startport='0'/>

      <address type='pci' domain='0x0000' bus='0x02' slot='0x02' function='0x0' multifunction='on'/>


    <controller type='sata' index='0'>

      <address type='pci' domain='0x0000' bus='0x00' slot='0x1f' function='0x2'/>


    <controller type='pci' index='0' model='pcie-root'/>

    <controller type='pci' index='1' model='dmi-to-pci-bridge'>

      <address type='pci' domain='0x0000' bus='0x00' slot='0x1e' function='0x0'/>


    <controller type='pci' index='2' model='pci-bridge'>

      <address type='pci' domain='0x0000' bus='0x01' slot='0x01' function='0x0'/>


    <controller type='virtio-serial' index='0'>

      <address type='pci' domain='0x0000' bus='0x02' slot='0x03' function='0x0'/>


    <interface type='bridge'>

      <mac address='52:54:00:ec:c5:7f'/>

      <source bridge='br0'/>

      <model type='virtio'/>

      <address type='pci' domain='0x0000' bus='0x02' slot='0x01' function='0x0'/>


    <serial type='pty'>

      <target port='0'/>


    <console type='pty'>

      <target type='serial' port='0'/>


    <channel type='unix'>

      <source mode='bind' path='/var/lib/libvirt/qemu/channel/target/MediaManager.org.qemu.guest_agent.0'/>

      <target type='virtio' name='org.qemu.guest_agent.0'/>

      <address type='virtio-serial' controller='0' bus='0' port='1'/>


    <input type='tablet' bus='usb'/>

    <input type='mouse' bus='ps2'/>

    <input type='keyboard' bus='ps2'/>

    <graphics type='vnc' port='-1' autoport='yes' websocket='-1' listen='' keymap='en-us'>

      <listen type='address' address=''/>



      <model type='cirrus' vram='16384' heads='1'/>

      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x0'/>


    <memballoon model='virtio'>

      <address type='pci' domain='0x0000' bus='0x02' slot='0x05' function='0x0'/>





Link to comment

Try setting the memory to the same amount in both min and max if you have enabled advanced mode in the template.

You have set the current memory to only 262 MB it looks like. That is too little. Set it 2GB and try again.


Wow... eagle eyes there...  ;D

Ha! More like glasses  8)

Link to comment
  • 5 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.