Jump to content
Lacehim

cache permissions issues

5 posts in this topic Last Reply

Recommended Posts

Hi,

 

I built myself a new server ages ago on V6 and put a cache drive in for the first time (I was using a self mounted apps drive).  I copied all my data over from my old server (now my backup) and installed docker and plugin apps.  Works great.

 

The only issue I have is a permissions issues.  I've created a .apps folder and put all my docker apps data in separate folders, but I can't edit, or delete or anything on the cache drive.  It says I need permission from nobody to delete a file for example (that using Win 7 in explorer to delete).

 

If I run the permissions script on the cache drive it fixes it, but anything new downloaded has the new permissions from nobody error.  It's it a little annoying.  The array is fine, and I have no permissions issues with it at all.

 

Is there a way to fix this permanently?  Seems to be that there's a setting somewhere that's giving new files the wrong permissions on the cache drive only.

 

Thank you.

Share this post


Link to post

Does no one else have this issue?  First cache drive, and this is driving me crazy.  Maybe it's caused by the docker apps... might look into that.

Share this post


Link to post

Does no one else have this issue?  First cache drive, and this is driving me crazy.  Maybe it's caused by the docker apps... might look into that.

This is almost certainly caused by a docker app or plugin not setting permissions correctly.  What dockers/plugins are you running that would be downloading files?

Share this post


Link to post

yes will be a docker issue for example SABnzdb has a setting under config/folders for permissions for completed downloads. Set it to 777

 

see attached pic

sab.png.b8a5f7985efcf9e096b4f5dfe27944c8.png

Share this post


Link to post

Thank you!  That was it.  SAB was missing that permissions setting!  I must have missed it when I set it all up manually for the docker!

 

Thank you so much!  Sanity can be restored now! haha! :)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.