[Plug-In] unBALANCE

Recommended Posts

1 hour ago, AnnabellaRenee87 said:

unBALANCE is crashing out on me when I hit the "Plan" button, I have to go to settings --> unBALANCE and re-start the service. (disable it and re-enable it to get the site to load again)

What logs would you need for this? Just the standard Diagnostics Logs? (attached them just in case its a yes)



Same here .. as soon as i hit the "Plan" button it gets stuck with "PLANNING: Getting items ... "

Link to comment

AnnabellaRenee87/SheepContoller, can you send me /boot/logs/unbalance.log ?


Also please try the following:

cd /usr/local/emhttp/plugins/unbalance
killall unbalance

then try the plan operation


Let me know what the command line output is and if possible, check the browser's developer console  for any error.

Link to comment
11 hours ago, Brettv said:


I just installed the new version, and i cant access the web ui. I get - > ERR_SSL_PROTOCOL_ERROR

I run unraid on port 447





I assume your server's SSL setting is either 'yes' or 'auto' right ?


Are you clicking on the Open Web UI link from the plugin's page ?


What's the url when you get this error ?

Link to comment
11 minutes ago, jbrodriguez said:


I assume your server's SSL setting is either 'yes' or 'auto' right ?


Are you clicking on the Open Web UI link from the plugin's page ?


What's the url when you get this error ?

That's right, it is set as 'yes'

Also correct, I am clicking on the Open Web UI link.

The URL is - https://servo.local:6237/

Here is the screenshot






Link to comment

Ok, the logs show the plugin thinks the server is on http, not https.


In /var/local/emhttp/var.ini, in the NAME line, is servo in upper or lower case ?


Since the fs is case sensitive, if the server name in var.ini is in lower case and the filename is in upper case, then it wouldn't detect it and assume it's an http installation.


Let me know if that's the case.



Link to comment

Same with me, crashing when i hit the "Plan" button, not using SSL at all.

The problem seems to be new in 5.1.0, could you provide the link to the .plg file for the 5.0.0 version while you try to find the issue?


To add a bit of info, i get the following terminal error:


I: 2018/05/11 16:15:58 planner.go:376: issues:owner(0):group(0):folder(168):file(1674)
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x38 pc=0x6e0784]

goroutine 34 [running]:
jbrodriguez/unbalance/server/src/services.getItems.func2(0xc42023a5b0, 0x6a)
        /Volumes/Users/kayak/.cix/builds/src/jbrodriguez/unbalance/server/src/services/planner.go:342 +0xe4
jbrodriguez/unbalance/server/src/lib.Shell2(0xc42028e240, 0x55, 0xc4203d16e0, 0x2, 0x2)
        /Volumes/Users/kayak/.cix/builds/src/jbrodriguez/unbalance/server/src/lib/shell.go:198 +0x1cf
jbrodriguez/unbalance/server/src/services.getItems(0x1, 0x1000, 0xc4200992c0, 0xc420219480, 0xa, 0xc4202199f0, 0x10, 0x68a, 0x0, 0x0, ...)
        /Volumes/Users/kayak/.cix/builds/src/jbrodriguez/unbalance/server/src/services/planner.go:336 +0x6ec
jbrodriguez/unbalance/server/src/services.(*Planner).getItemsAndIssues(0xc420153620, 0x1, 0x1000, 0xc4200992c0, 0xc420099400,0xc4203d1ca8, 0x1, 0x1, 0xc4201aa5c0, 0x1, ...)
        /Volumes/Users/kayak/.cix/builds/src/jbrodriguez/unbalance/server/src/services/planner.go:383 +0x864
jbrodriguez/unbalance/server/src/services.(*Planner).scatter(0xc420153620, 0xc4201b2ae0)
        /Volumes/Users/kayak/.cix/builds/src/jbrodriguez/unbalance/server/src/services/planner.go:90 +0x4c3
        /Volumes/Users/kayak/.cix/builds/src/jbrodriguez/unbalance/server/src/services/planner.go:52 +0x34
jbrodriguez/unbalance/server/vendor/github.com/jbrodriguez/actor.(*Actor).dispatch(0xc420106be0, 0x7a4045, 0x10, 0xc4201b2ae0)        /Volumes/Users/kayak/.cix/builds/src/jbrodriguez/unbalance/server/vendor/github.com/jbrodriguez/actor/actor.go:43 +0x65
        /Volumes/Users/kayak/.cix/builds/src/jbrodriguez/unbalance/server/vendor/github.com/jbrodriguez/actor/actor.go:37 +0x70
created by jbrodriguez/unbalance/server/src/services.(*Planner).Start
        /Volumes/Users/kayak/.cix/builds/src/jbrodriguez/unbalance/server/src/services/planner.go:55 +0x12f

Edited by asgarder
Link to comment
1 hour ago, jbrodriguez said:

Do you get the same error or something different ?


Can you try another browser ?


I tried both firefox and chrome, same thing. I think it was something in the latest release that broke it, this never happened to me before.

As i said up there, it would be great if u could share the link for the .plg file for build 5.0.0 to see if that would fix the issue.

Link to comment

I haven't tried it, but the 5.0.0 plg should be


The comment about browser was meant for brettv


In any case, I think I found what the issue is and will be releasing a patch momentarily

Link to comment

Awesome, sorry I didn't get to send the logs, but after the update it runs perfectly fine.


The folder with 17k+ files?


PLANNING: Elapsed: 13.565s


Really can't complain here.

It will not open on SSL connection, but that's nothing that's really bothering me, honestly.


So here's you 5-star :)

Link to comment
2 hours ago, jbrodriguez said:

v2018.05.11 (5.1.1) is out !


- Fix planner issues
- Add debug logging


This should fix the crashes.


Brettv, whenever you update to this version, please send me the log to check it out.


Planning works again!

Thank you!

Link to comment
4 minutes ago, Brettv said:

ok ive updated. This time I can access the WEB UI if i type my IP and the port But if i click the plugin webui link i get the same ssl error as before. 


(tried it in IE as well)




Ok, the issue is that the plugin doesn't find the SERVO_unraid_bundle.pem file.


What's the output of 

ls -al /boot/config/ssl/certs/SERVO_unraid_bundle.pem

unBALANCE runs as 'nobody' by default, I guess certs are now created so that only root can see them ?

Link to comment
root@Nexus:~# ls -al /boot/config/ssl/certs/
total 32
drwxrwxrwx 2 root root 8192 Apr  8 16:36 ./
drwxrwxrwx 3 root root 8192 Mar  6 16:57 ../
-rwxrwxrwx 1 root root 2847 Apr  8 16:36 Nexus_unraid_bundle.pem*
-rwxrwxrwx 1 root root 2823 Mar  6 16:57 Tower_unraid_bundle.pem*

I assume your machine is called SERVO? Mine was Tower, now called Nexus, maybe unBalance is looking for a fixed name?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.