New Emby Docker


597 posts in this topic Last Reply

Recommended Posts

Took an update to the beta Emby container, now Emby seems broken (won't connect, seems to hang UnRAID WebUI also).  :-[

 

I see you posted this in the Linux thread (not specifically the Docker one) on Emby website that "Yes some of the repos became corrupt. They had to be completely purged and rebuilt." https://emby.media/community/index.php?/topic/13029-ubuntu/page-40.

 

Not sure if this is still the case, I tried removing image and reinstalling, with the same result.

Anyway to put in the old base image so that I can get the beta version back up and running?

 

I stopped the beta Docker and installed the stable release and it worked without issue.

 

Link to post
  • Replies 596
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi Guys,   We the developers of Emby have started the development of new container for Emby, right now this is consider testing but it is very stable. Please see the following for more info:   h

Are you running embyserver:beta ? I got the same error but only with the latest beta (4.6.0.34)   You can wait for a fix or specify the previous beta in Repository: emby/embyserver:4.6.

It's in the beta. Switch your repository to emby/embyserver:beta or wait for the next release.

Posted Images

My post was for the Ubuntu thread. Had nothing to so with the docker thread. If you're looking for stability my recommendation is stay on the stable repo. The beta and dev repo are for testing things out, there will always be a lot changes that will have negative effects on those branches.

 

Sent from my ONEPLUS A3000 using Tapatalk

 

 

Link to post

I understand, and appreciate the support here.

 

However, for me anyhow after the update and also trying a fresh install, the Beta version is completely hosed at the moment..  :o

I'm pretty certain you've moved away from UnRAID (thank you for the continued support BTW!), so I'm uncertain if you can test this or not.

I updated to 6.3RC4, and also took the update showing for the EmbyServerBeta Docker.

Reboot, Emby won't connect at all.

Put back my week old backed up /config folder (local appdata user location) thinking that would help, start the Docker, nope, still nothing, refuses to connect.

Stop that Docker, install a fresh copy of the stable version, connects right away.

 

So unless I did something, I think the Beta Docker we're currently pulling doesn't work. Or somehow it is just me, IDK, I wouldn't think so, but who knows!

 

Link to post

If I can provide any information from attaching to the Docker, or the log from it that would be helpful in diagnosing this issue, please let me know. Been running the beta for 6+ months now without any issues that were this large of an issue (in that for me it isn't working at all currently).

Link to post

Bungee, I know today and tomorrow I will be doing some pretty big changes to the dev and beta containers. Additionally, I know Luke the main developer is making massive changes to Emby as we speak. I do not believe any of the issues you are experiencing are due to the container itself. Since no changes have been made to the container. Instead they are most likely due to the changes being made to Emby itself. I would advise you hit the Emby forums and make a thread under the one of the beta subforums.

 

Sent from my ONEPLUS A3000 using Tapatalk

 

 

Link to post

Bungee, I know today and tomorrow I will be doing some pretty big changes to the dev and beta containers. Additionally, I know Luke the main developer is making massive changes to Emby as we speak. I do not believe any of the issues you are experiencing are due to the container itself. Since no changes have been made to the container. Instead they are most likely due to the changes being made to Emby itself. I would advise you hit the Emby forums and make a thread under the one of the beta subforums.

 

Yeah, I was hoping to complete a fresh install to checkout the DB improvements Luke has been bragging about.  :P

Hmm...... Well I'm uncertain, just know it is completely dead for me at the moment and I grab a fresh image and get the same thing.

I wouldn't think it's the changes to Emby itself, since I rolled back to a backup from last week (which was certainly working), and had the same issue(s).

I'm attaching the log entry from the Docker log in UnRAID hoping there is something obvious in there. Currently any trying to run the beta container causes me enough issue with UnRAID UI that I have to issue an SSH docker stop EmbyServerBeta in order for things to work again.

I have no idea how I could have broken this, but if it is working for others then I'm at a miss.

I may post on the Emby forum, if not may just have to run the stable for now.

 

I currently see this in the log, repeats multiple times:

Info, Main, Emby
Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /config -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartpath /usr/lib/emby-server/restart.sh
Operating system: Unix 4.8.7.0
64-Bit OS: True
64-Bit Process: True
Mono: 4.6.1 (Stable 4.6.1.5/ef43c15 Sat Oct 22 13:52:40 UTC 2016)
Processor count: 12
Program data path: /config
Application Path: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe
Info, ImageMagick, ImageMagick version: ImageMagick 6.9.5-5 Q8 x86_64 2016-10-01 http://www.imagemagick.org

appHost.Init
Info, App, Application version: 3.1.218.0

Info, App, Application configuration:
{"EnableUPnP":true,"PublicPort":8096,"PublicHttpsPort":8920,"HttpServerPortNumber":8096,"HttpsPortNumber":8920,"EnableHttps":false,"EnableInternetProviders":true,"IsPortAuthorized":false,"EnableCaseSensitiveItemIds":false,"SeasonZeroDisplayName":"Specials","SaveLocalMeta":false,"PreferredMetadataLanguage":"en","MetadataCountryCode":"US","SortReplaceCharacters":[".","+","%"],"SortRemoveCharacters":[",","&","-","{","}","'"],"SortRemoveWords":["the","a","an"],"MinResumePct":5,"MaxResumePct":90,"MinResumeDurationSeconds":300,"LibraryMonitorDelay":60,"EnableDashboardResponseCaching":true,"EnableDashboardResourceMinification":true,"ImageSavingConvention":"Compatible","MetadataOptions":[{"ItemType":"Book","ImageOptions":[{"Type":"Backdrop","Limit":1,"MinWidth":1280}],"DisabledMetadataSavers":[],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":[],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"Movie","ImageOptions":[{"Type":"Backdrop","Limit":1,"MinWidth":1280},{"Type":"Art","Limit":0,"MinWidth":0},{"Type":"Disc","Limit":0,"MinWidth":0},{"Type":"Primary","Limit":1,"MinWidth":0},{"Type":"Banner","Limit":0,"MinWidth":0},{"Type":"Thumb","Limit":1,"MinWidth":0},{"Type":"Logo","Limit":1,"MinWidth":0}],"DisabledMetadataSavers":[],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":[],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"MusicVideo","ImageOptions":[{"Type":"Backdrop","Limit":1,"MinWidth":1280},{"Type":"Art","Limit":0,"MinWidth":0},{"Type":"Disc","Limit":0,"MinWidth":0},{"Type":"Primary","Limit":1,"MinWidth":0},{"Type":"Banner","Limit":0,"MinWidth":0},{"Type":"Thumb","Limit":1,"MinWidth":0},{"Type":"Logo","Limit":1,"MinWidth":0}],"DisabledMetadataSavers":[],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":[],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"Series","ImageOptions":[{"Type":"Backdrop","Limit":1,"MinWidth":1280},{"Type":"Art","Limit":0,"MinWidth":0},{"Type":"Primary","Limit":1,"MinWidth":0},{"Type":"Banner","Limit":1,"MinWidth":0},{"Type":"Thumb","Limit":1,"MinWidth":0},{"Type":"Logo","Limit":1,"MinWidth":0}],"DisabledMetadataSavers":[],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":[],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"MusicAlbum","ImageOptions":[{"Type":"Backdrop","Limit":0,"MinWidth":1280},{"Type":"Disc","Limit":0,"MinWidth":0}],"DisabledMetadataSavers":[],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":["TheAudioDB"],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"MusicArtist","ImageOptions":[{"Type":"Backdrop","Limit":1,"MinWidth":1280},{"Type":"Banner","Limit":0,"MinWidth":0},{"Type":"Art","Limit":0,"MinWidth":0},{"Type":"Logo","Limit":0,"MinWidth":0}],"DisabledMetadataSavers":[],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":["TheAudioDB"],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"BoxSet","ImageOptions":[{"Type":"Backdrop","Limit":1,"MinWidth":1280},{"Type":"Primary","Limit":1,"MinWidth":0},{"Type":"Thumb","Limit":1,"MinWidth":0},{"Type":"Logo","Limit":1,"MinWidth":0},{"Type":"Art","Limit":0,"MinWidth":0},{"Type":"Disc","Limit":0,"MinWidth":0},{"Type":"Banner","Limit":0,"MinWidth":0}],"DisabledMetadataSavers":[],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":[],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"Season","ImageOptions":[{"Type":"Backdrop","Limit":0,"MinWidth":1280},{"Type":"Primary","Limit":1,"MinWidth":0},{"Type":"Banner","Limit":0,"MinWidth":0},{"Type":"Thumb","Limit":0,"MinWidth":0}],"DisabledMetadataSavers":[],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":["The Open Movie Database","TheMovieDb"],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"Episode","ImageOptions":[{"Type":"Backdrop","Limit":0,"MinWidth":1280},{"Type":"Primary","Limit":1,"MinWidth":0}],"DisabledMetadataSavers":[],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":["The Open Movie Database"],"MetadataFetcherOrder":[],"DisabledImageFetchers":["TheMovieDb"],"ImageFetcherOrder":[]}],"EnableAutomaticRestart":true,"SkipDeserializationForBasicTypes":false,"SkipDeserializationForPrograms":false,"SkipDeserializationForAudio":false,"PathSubstitutions":[],"UICulture":"en-us","PeopleMetadataOptions":{"DownloadActorMetadata":true,"DownloadDirectorMetadata":true,"DownloadProducerMetadata":false,"DownloadWriterMetadata":false,"DownloadComposerMetadata":false,"DownloadOtherPeopleMetadata":false,"DownloadGuestStarMetadata":false},"SaveMetadataHidden":false,"ContentTypes":[],"RemoteClientBitrateLimit":0,"SharingExpirationDays":30,"Migrations":[],"MigrationVersion":0,"SchemaVersion":0,"SqliteCacheSize":0,"EnableAnonymousUsageReporting":true,"EnableStandaloneMusicKeys":false,"EnableLocalizedGuids":true,"EnableFolderView":true,"EnableGroupingIntoCollections":false,"DisplaySpecialsWithinSeasons":true,"DisplayCollectionsView":false,"LocalNetworkAddresses":[],"CodecsUsed":[],"EnableChannelView":false,"EnableExternalContentInSuggestions":true,"EnableSimpleArtistDetection":false,"ImageExtractionTimeoutMs":0,"EnableDebugLevelLogging":false,"EnableAutoUpdate":true,"SystemUpdateLevel":"Release","LogFileRetentionDays":3,"RunAtStartup":false,"IsStartupWizardCompleted":false}
Error, Main, UnhandledException

*** Error Report ***

Version: 3.1.218.0

Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /config -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartpath /usr/lib/emby-server/restart.sh
Operating system: Unix 4.8.7.0
64-Bit OS: True
64-Bit Process: True
Mono: 4.6.1 (Stable 4.6.1.5/ef43c15 Sat Oct 22 13:52:40 UTC 2016)
Processor count: 12
Program data path: /config
Application Path: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe
One or more errors occurred.
System.AggregateException
at System.Threading.Tasks.Task.WaitAll (System.Threading.Tasks.Task[] tasks, System.Int32 millisecondsTimeout, System.Threading.CancellationToken cancellationToken) [0x00242] in <dca3b561b8ad4f9fb10141d81b39ff45>:0
at System.Threading.Tasks.Task.WaitAll (System.Threading.Tasks.Task[] tasks, System.Int32 millisecondsTimeout) [0x00000] in <dca3b561b8ad4f9fb10141d81b39ff45>:0
at System.Threading.Tasks.Task.WaitAll (System.Threading.Tasks.Task[] tasks) [0x00000] in <dca3b561b8ad4f9fb10141d81b39ff45>:0
at MediaBrowser.Server.Mono.MainClass.RunApplication (Emby.Server.Core.ServerApplicationPaths appPaths, MediaBrowser.Model.Logging.ILogManager logManager, Emby.Server.Core.StartupOptions options) [0x00166] in <23532ed855cb4ae29716d75e2cb84a3f>:0
at MediaBrowser.Server.Mono.MainClass.Main (System.String[] args) [0x0008a] in <23532ed855cb4ae29716d75e2cb84a3f>:0
InnerException: System.IO.FileNotFoundException
Could not load file or assembly or one of its dependencies.
at Emby.Common.Implementations.BaseApplicationHost`1[TApplicationPathsType].DiscoverTypes () [0x0000b] in <844fc8ef344c43128068ee1b7b9c24a8>:0
at Emby.Common.Implementations.BaseApplicationHost`1+<Init>d__104[TApplicationPathsType].MoveNext () [0x0010c] in <844fc8ef344c43128068ee1b7b9c24a8>:0

UnhandledException
One or more errors occurred.
System.AggregateException
at System.Threading.Tasks.Task.WaitAll (System.Threading.Tasks.Task[] tasks, System.Int32 millisecondsTimeout, System.Threading.CancellationToken cancellationToken) [0x00242] in <dca3b561b8ad4f9fb10141d81b39ff45>:0
at System.Threading.Tasks.Task.WaitAll (System.Threading.Tasks.Task[] tasks, System.Int32 millisecondsTimeout) [0x00000] in <dca3b561b8ad4f9fb10141d81b39ff45>:0
at System.Threading.Tasks.Task.WaitAll (System.Threading.Tasks.Task[] tasks) [0x00000] in <dca3b561b8ad4f9fb10141d81b39ff45>:0
at MediaBrowser.Server.Mono.MainClass.RunApplication (Emby.Server.Core.ServerApplicationPaths appPaths, MediaBrowser.Model.Logging.ILogManager logManager, Emby.Server.Core.StartupOptions options) [0x00166] in <23532ed855cb4ae29716d75e2cb84a3f>:0
at MediaBrowser.Server.Mono.MainClass.Main (System.String[] args) [0x0008a] in <23532ed855cb4ae29716d75e2cb84a3f>:0
InnerException: System.IO.FileNotFoundException
Could not load file or assembly or one of its dependencies.
at Emby.Common.Implementations.BaseApplicationHost`1[TApplicationPathsType].DiscoverTypes () [0x0000b] in <844fc8ef344c43128068ee1b7b9c24a8>:0
at Emby.Common.Implementations.BaseApplicationHost`1+<Init>d__104[TApplicationPathsType].MoveNext () [0x0010c] in <844fc8ef344c43128068ee1b7b9c24a8>:0

EmbyServerBeta-DockerLog.txt

Link to post

Definitely interesting. Please post on the forums with the logs and link it here. I will read into it. Which database improvements. I know someone was working on postgres, but I was not made aware that these changes had been merged. If postres is now the default on beta and dev then that would cause a lot of havoc.

 

Sent from my ONEPLUS A3000 using Tapatalk

 

Link to post

He's bragging about it here https://emby.media/community/index.php?/topic/40166-new-install-db-performance/page-1  ;)

 

Since I can't get to Emby manage server/logs to grab a server log (the way I typically do this when needed) Is there a way to complete this attaching to the container and entering a command to download it? Or is it just sitting in my /config directory for the container and I can grab/attach from there?

Link to post

Bungee, talk to Luke. He says he knows there is a major issue on beta and dev right now. And hopes to have it fix this evening.

 

Sent from my ONEPLUS A3000 using Tapatalk

 

That would explain it!..  I can't exactly "dial his digits" but will see what's what on the Emby forum. Thanks for checking into it for me!

Link to post

The issue I reported has been fixed, nothing I could do on my end so whatever Luke did worked out well.

From the logs it seemed as if a dependency or file was missing, causing all kinds of issues.

Just pulled a new beta version, all is well.

I reported this here https://emby.media/community/index.php?/topic/41416-docker-beta-does-not-connect-seems-to-hang-system/ Luke acted all sly about it..  :P

Link to post

So I had a notification for an update but the update failed and now I think the docker service thinks the emby docker is running but it doesn't seem to be since the stop and kill commands (even from command line) do nothing.  Now the webui shows the docker is running but doesn't know which version (see attached).

 

I probably need to reboot the server but I'm in the middle of a preclear and would like to get my emby server running again before the long weekend is over (and my preclear)!

embyserver.JPG.564aa4b0806ec3da6eeb3e86d1717506.JPG

emby.JPG.def3c093980ffbd4fe8de99421254e73.JPG

Link to post

Your best bet is to fix it at the command line. Use docker commands

 

Sent from my ONEPLUS A3000 using Tapatalk

 

I've tried the stop, kill and remove container commands from command line to no avail. Stop and kill just hang and remove says it removed image. Force update fails as shown in attached jpeg from previous post.

Link to post

Stop the docker service all together

 

Sent from my ONEPLUS A3000 using Tapatalk

 

Ok, that was my next thing to try. However, I noticed the container id was a lot longer than what I was trying to use to kill the container so when I used the full id, it finally worked!

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.