Jump to content
Yoshiofthewire

[Support] urlxl - HDHomeRun DVR [20190815beta1]

119 posts in this topic Last Reply

Recommended Posts

4 hours ago, CoZ said:

Well it was working before..... not sure if I'm the only one with the issue?  No one else has chimed in...

I had the same issue and rolled back to another docker with version 20190417 and it now properly shows in my.hdhomerun.com

Share this post


Link to post

I do not have any issues with my docker and the dvr is working fine.  I have updated the docker recently, and still everything is working.  I'm running the latest docker.

 

unraid 6.6.7

image.png.e1f59966516330d5290d60ba39e62253.png

 

However, if I go to the docker and then the hdhomerun WebUI, I see a message at the top that says No DVR detected.  That is just a advertisement to purchase their dvr service.

image.png.211d2f5ab6b90b025740e910d4aea17b.png

 

I just confirmed that shows are recording to my unraid / hdhomerun docker with no issues.

 

Let me know if there is something you want me to check, as it does seem that you are the only one reporting this missing dvr issue.

 

Share this post


Link to post

@Switchblade I'm traveling for work right now so can't post up screenshots. But the thing you can an "advertisement" for the DVR service is there because Silicon Dust can't detect your DVR due to the change in the docker. If it was detected, you'd have the version number listed of your DVR. I've emailed S.D. about the issue and they aren't able to detect my DVR service/subscription due to the change in the docker. 

 

I think if you were to delete a recording rule and/or try to record something you're watching live TV , you'll notice the record bottom is missing off the GUI of the official HDHomerun App.  

 

And the user "Italy#####" also mentioned he is having an issue and had to roll back his docker.  So I'm not the only user with the problem. I tend to think you also have an issue but just don't realize it....?

 

 

Share this post


Link to post
38 minutes ago, Yoshiofthewire said:

OK, I just reverted the change.

Let me know if that seems to fix things, then we can look at the update in a week or two

Just got back from Traveling for work before I head off to Paris tomorrow for more work.  Pulled down your update.  Navigated to my.hdhomerun.com it now shows an active DVR subscription with Version 20190417!

 

Thanks!

Share this post


Link to post

Mine has been working all this time.  The record button is there and I can record.

 

I just got another update today and now it does not have the message about No DVR, so it sees it now.  Even though, I never had a issue that I know of.

 

Share this post


Link to post

I think the problem was the addition of StorageID to hdhomerun.conf.  It needs to match the ID of the existing record engine.  In my setup, the record engine adds the StorageID automatically to /etc/hdhomerun.conf since it's a writable file.  Ideally, hdhomerun.conf should be moved to an external directory (e.g., /hdhomerun/hdhomerun.conf) and added as an argument to hdhomerun_record_x64 (e.g., /opt/hdhomerun/hdhomerun_record_x64 --conf=/hdhomerun/hdhomerun.conf).

Share this post


Link to post
On 5/26/2019 at 1:05 PM, Switchblade said:

I do not have any issues with my docker and the dvr is working fine.  I have updated the docker recently, and still everything is working.  I'm running the latest docker.

 

unraid 6.6.7

image.png.e1f59966516330d5290d60ba39e62253.png

 

However, if I go to the docker and then the hdhomerun WebUI, I see a message at the top that says No DVR detected.  That is just a advertisement to purchase their dvr service.

image.png.211d2f5ab6b90b025740e910d4aea17b.png

 

I just confirmed that shows are recording to my unraid / hdhomerun docker with no issues.

 

Let me know if there is something you want me to check, as it does seem that you are the only one reporting this missing dvr issue.

 

I'm having this exact issue now and are unable to record anything. I can see a file being written to the Live folder when watching Live TV but nothing will program. Is there anything I need to do to fix this? Thanks

Share this post


Link to post
2 hours ago, djsnafu said:

I'm having this exact issue now and are unable to record anything. I can see a file being written to the Live folder when watching Live TV but nothing will program. Is there anything I need to do to fix this? Thanks

Silicondust pushed out a firmware update to the DVR record engine last week I believe.  Until the OP updates his docker with the new firmware, I think that's the issue currently.

Share this post


Link to post

I just forked and updated the DVR if anyone is interested.

 

You can update it by changing the repository path to: 

 

eatemalive/hdhomerun-dvr:latest

 

Or if starting from scratch make sure you select host networking and create the /hdhomerun path.

Edited by eatemalive
typo

Share this post


Link to post
4 hours ago, eatemalive said:

I just forked and updated the DVR if anyone is interested.

Just changed to your repo.  So far everything appears to be in working order.  My.hdhomerun.com is reporting that the DVR is currently using Version 20190715beta1

 

Hopefully it records now ;)

 

Thanks for stepping up.

Share this post


Link to post
10 hours ago, eatemalive said:

I just forked and updated the DVR if anyone is interested.

 

You can update it by changing the repository path to: 

 

eatemalive/hdhomerun-dvr:latest

 

Or if starting from scratch make sure you select host networking and create the /hdhomerun path.

Just tried it and got "The command failed." when applying it

Share this post


Link to post
6 hours ago, djsnafu said:

Just tried it and got "The command failed." when applying it

I just removed mine and re added without issue.

 

Try going through community applications fresh install. You don't loose anything.

 

my setup looks like this:

 

 

 

Capture.JPG

Edited by eatemalive

Share this post


Link to post
On 8/29/2019 at 8:09 PM, Yoshiofthewire said:

OK, Trying to update again.

I'm push out 20190815beta1, let me know if it breaks things.

 

Just switched back to your repo.  my.hdhomerun.com reports I'm using Version 20190417 with a big red X next to it.

 

Somehow I also lost the ports switching repos.... anyone know what the ports were?

Edited by CoZ

Share this post


Link to post

Hey all, I am trying to run this docker on my Unraid system, and I get a couple of errors. The first is that the docker log shows this:

 

2019-09-25 17:46:42,310 INFO spawned: 'hdhomerun_dvr' with pid 8
HDHomeRun RECORD started
2019-09-25 17:46:42,335 INFO exited: hdhomerun_dvr (exit status 0; not expected)
2019-09-25 17:46:43,337 INFO spawned: 'hdhomerun_dvr' with pid 17
HDHomeRun RECORD already running
2019-09-25 17:46:43,339 INFO exited: hdhomerun_dvr (exit status 0; not expected)
2019-09-25 17:46:45,661 INFO spawned: 'hdhomerun_dvr' with pid 18
HDHomeRun RECORD already running
2019-09-25 17:46:45,838 INFO exited: hdhomerun_dvr (exit status 0; not expected)
2019-09-25 17:46:49,192 INFO spawned: 'hdhomerun_dvr' with pid 19
HDHomeRun RECORD already running
2019-09-25 17:46:49,194 INFO exited: hdhomerun_dvr (exit status 0; not expected)
2019-09-25 17:46:50,195 INFO gave up: hdhomerun_dvr entered FATAL state, too many start retries too quickly

I believe from reading in here that this is just some Docker oddness, as the DVr does seem to be running and linking to the Silicondust online system.

 

The DVR does seem to be recording, but when I try and play back a recording, I get a blank screen. Poking into Syslog reveals that there are repeated errors:

 

Sep 25 17:14:05 Norbert nginx: 2019/09/25 17:14:05 [error] 4291#4291: *228717 connect() to unix:/var/tmp/hdhomerundvr.sock failed (111: Connection refused) while connecting to upstream, client: 192.168.1.216, server: , request: "GET /dockerterminal/hdhomerundvr/ws HTTP/1.1", upstream: "http://unix:/var/tmp/hdhomerundvr.sock:/ws", host: "192.168.1.103"

192.168.1.216 is the client, an iPad. 192.168.1.103 is Norbert, the Unraid system. 

 

Any ideas on that? The Docker is set to host mode.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.