Jump to content
dlandon

Unassigned Devices - Managing Disk Drives Outside of The unRAID Array

2470 posts in this topic Last Reply

Recommended Posts

Ok, I will try your release tomorrow.

 

Merci beaucoup. 8)

 

I found the release that said to re-enter users and passwords: http://lime-technology.com/forum/index.php?topic=29096.msg260091#msg260091

 

This was one of the V5 releases.

 

4. If present, delete these files from the flash (sorry, you will need to re-enter all your users after upgrade):

  - 'config/passwd'

  - 'config/shadow'

  - 'config/smbpasswd'

Ok, i didn't see this step when i went from 4.7 to 5rc11 in 2013! Not easy to follow all the instructions for a french guy.

 

Thanks to your warning, I will soon make a clean install and probably get a new drive and convert my drives to XFS. Just have to find the time...

But at this time, your last release works fine with my "old" config files.

 

Good job dlandon.;)

 

Merci.

 

The way I made the change is a much better way of getting the users and a lot more robust.  That's the way I like things.

 

The good news is that you are now aware of some issues that will probably cause more problems.

 

I do recommend that you change your drives to Xfs.  I did some time ago and couldn't be happier.

Share this post


Link to post

First of all, thanks for the awesome plug in!

 

Is there anything I need to do to get a mounted drive available in the "Primary vDisk Location" drop down when setting up a VM? My drive isn't appearing under /mnt/Disks/, but I know it's formatted correctly and works because I can read/write to it as a share from another machine.

Share this post


Link to post

First of all, thanks for the awesome plug in!

 

Is there anything I need to do to get a mounted drive available in the "Primary vDisk Location" drop down when setting up a VM? My drive isn't appearing under /mnt/Disks/, but I know it's formatted correctly and works because I can read/write to it as a share from another machine.

 

It shows up for me.  I just browse down to it.

Share this post


Link to post

First of all, thanks for the awesome plug in!

 

Is there anything I need to do to get a mounted drive available in the "Primary vDisk Location" drop down when setting up a VM? My drive isn't appearing under /mnt/Disks/, but I know it's formatted correctly and works because I can read/write to it as a share from another machine.

 

It shows up for me.  I just browse down to it.

 

Strange, I don't see mine at all. They're mounted, spun up, formatted XFS, nothing unusual, but they never appear under /Disks/ in the drop down.

Share this post


Link to post

The old plugin worded for me until I upgraded to 6.1.7, then my 2 SSDs used for VMs show as historical with missing status. Reverting unraid to 6.1.6 fixed the problem.

 

I have uninstalled the old plugin, rebooted and installed the new one and I still have the same problem after the upgrade to 6.1.7, both SSDs show as historical with status as missing. Am I doing something wrong? Is there anything I can post to help troubleshooting?

 

It's probably a device serial number (identification) issue.  Remove the historical device and let it be found again.

 

I have removed them, should a reboot be required to have them found? I am not seeing them after rescanning disks.

 

That should work.  It looks to me like unraid is not recognizing the disk.  Try a couple things.

 

1) Remove the unassigned devices plugin and see if the drive in question shows up in the default unassigned devices tab.

 

2) On the command line 'ls /dev/disk/by-id/' and see if the drive in question is showing up.

 

If it does not show up in either case, unraid does not recognize it.

 

You were right! My sata controller card that I used for my VM SSDs kicked the bucket, it just did it sporadically. I'm now on your version of the plugin and 6.1.7 and everything is good. Thanks for the help!

 

Share this post


Link to post

First of all, thanks for the awesome plug in!

 

Is there anything I need to do to get a mounted drive available in the "Primary vDisk Location" drop down when setting up a VM? My drive isn't appearing under /mnt/Disks/, but I know it's formatted correctly and works because I can read/write to it as a share from another machine.

 

It shows up for me.  I just browse down to it.

 

Strange, I don't see mine at all. They're mounted, spun up, formatted XFS, nothing unusual, but they never appear under /Disks/ in the drop down.

 

On a command line 'ls /mnt/disks'.  You should see your disks.  If not, let me know what you see.

Share this post


Link to post

The old plugin worded for me until I upgraded to 6.1.7, then my 2 SSDs used for VMs show as historical with missing status. Reverting unraid to 6.1.6 fixed the problem.

 

I have uninstalled the old plugin, rebooted and installed the new one and I still have the same problem after the upgrade to 6.1.7, both SSDs show as historical with status as missing. Am I doing something wrong? Is there anything I can post to help troubleshooting?

 

It's probably a device serial number (identification) issue.  Remove the historical device and let it be found again.

 

I have removed them, should a reboot be required to have them found? I am not seeing them after rescanning disks.

 

That should work.  It looks to me like unraid is not recognizing the disk.  Try a couple things.

 

1) Remove the unassigned devices plugin and see if the drive in question shows up in the default unassigned devices tab.

 

2) On the command line 'ls /dev/disk/by-id/' and see if the drive in question is showing up.

 

If it does not show up in either case, unraid does not recognize it.

 

You were right! My sata controller card that I used for my VM SSDs kicked the bucket, it just did it sporadically. I'm now on your version of the plugin and 6.1.7 and everything is good. Thanks for the help!

 

That would do it.  Glad to hear you're up and running again.

Share this post


Link to post

First of all, thanks for the awesome plug in!

 

Is there anything I need to do to get a mounted drive available in the "Primary vDisk Location" drop down when setting up a VM? My drive isn't appearing under /mnt/Disks/, but I know it's formatted correctly and works because I can read/write to it as a share from another machine.

 

It shows up for me.  I just browse down to it.

 

Strange, I don't see mine at all. They're mounted, spun up, formatted XFS, nothing unusual, but they never appear under /Disks/ in the drop down.

 

On a command line 'ls /mnt/disks'.  You should see your disks.  If not, let me know what you see.

 

I get no return when running that command:

login as: root
Last login: Wed Jan 27 12:17:52 2016 from 10.0.1.11
Linux 4.1.15-unRAID.
root@KingsLanding:~# ls /mnt/disks
root@KingsLanding:~#

 

The GUI shows them as mounted. I've tried rebooting, unmount/mounting, and reformatting. Any ideas?

 

UD.png.3a616bc20d326e5d1085e3d35f7b9a51.png

Share this post


Link to post

First of all, thanks for the awesome plug in!

 

Is there anything I need to do to get a mounted drive available in the "Primary vDisk Location" drop down when setting up a VM? My drive isn't appearing under /mnt/Disks/, but I know it's formatted correctly and works because I can read/write to it as a share from another machine.

 

It shows up for me.  I just browse down to it.

 

Strange, I don't see mine at all. They're mounted, spun up, formatted XFS, nothing unusual, but they never appear under /Disks/ in the drop down.

 

On a command line 'ls /mnt/disks'.  You should see your disks.  If not, let me know what you see.

 

I get no return when running that command:

login as: root
Last login: Wed Jan 27 12:17:52 2016 from 10.0.1.11
Linux 4.1.15-unRAID.
root@KingsLanding:~# ls /mnt/disks
root@KingsLanding:~#

 

The GUI shows them as mounted. I've tried rebooting, unmount/mounting, and reformatting. Any ideas?

 

You have the mount point set to SSD_VM.  It should be /mnt/disks/SSD_VM.  This is one of the things I don't like about the renaming feature and will probably change it so this won't happen.

 

EDIT: I made a change so the mount point cannot be changed from /mnt/disks/.  If you enter just a mount point name 'MyDisk', it will be changed to /mnt/disks/MyDisk.  The mount point has to be at /mnt/disks/ for everything to work properly.  This will be fixed in the next release.

Share this post


Link to post

You have the mount point set to SSD_VM.  It should be /mnt/disks/SSD_VM.  This is one of the things I don't like about the renaming feature and will probably change it so this won't happen.

 

FWIW, I mount my 2 disks to /mnt/vmdisk and /mnt/vmdisk-2. I prefer not to have to go into the mnt/disks/ folder to access my shares. If you do decide to change the renaming feature, it would be nice to not be limited to only using the /mnt/disk folder. just my 2 cents  ;D

Share this post


Link to post

or can you let us know how to get around the disks limitation or like mentioned limit us to only /mnt/

I've had an instance when I mounted mine to /mnt/user/ because of what I was doing at that time, but typically I do mount to /mnt/disks/

 

Options are always nice, but I do think /mnt/ unless your worried somebody is going to mess up disk shares some how with the incorrect mounting.

Share this post


Link to post

... but I do think /mnt/ unless your worried somebody is going to mess up disk shares some how with the incorrect mounting.

You can count on it. ;D

Share this post


Link to post

You have the mount point set to SSD_VM.  It should be /mnt/disks/SSD_VM.  This is one of the things I don't like about the renaming feature and will probably change it so this won't happen.

 

FWIW, I mount my 2 disks to /mnt/vmdisk and /mnt/vmdisk-2. I prefer not to have to go into the mnt/disks/ folder to access my shares. If you do decide to change the renaming feature, it would be nice to not be limited to only using the /mnt/disk folder. just my 2 cents  ;D

 

Why do you feel the need to do that?

Share this post


Link to post

You have the mount point set to SSD_VM.  It should be /mnt/disks/SSD_VM.  This is one of the things I don't like about the renaming feature and will probably change it so this won't happen.

 

FWIW, I mount my 2 disks to /mnt/vmdisk and /mnt/vmdisk-2. I prefer not to have to go into the mnt/disks/ folder to access my shares. If you do decide to change the renaming feature, it would be nice to not be limited to only using the /mnt/disk folder. just my 2 cents  ;D

 

Why do you feel the need to do that?

 

1. Because I am difficult

2. Because it is less mouse clicks and looks nice when browsing to my unRAID network shares (see photo).

Capture.PNG.a0ad900f2df7f15c474b0faf83de6b03.PNG

Share this post


Link to post

... but I do think /mnt/ unless your worried somebody is going to mess up disk shares some how with the incorrect mounting.

You can count on it. ;D

 

Yes.  And all the support issues when someone does it wrong.

Share this post


Link to post

You have the mount point set to SSD_VM.  It should be /mnt/disks/SSD_VM.  This is one of the things I don't like about the renaming feature and will probably change it so this won't happen.

 

FWIW, I mount my 2 disks to /mnt/vmdisk and /mnt/vmdisk-2. I prefer not to have to go into the mnt/disks/ folder to access my shares. If you do decide to change the renaming feature, it would be nice to not be limited to only using the /mnt/disk folder. just my 2 cents  ;D

 

Why do you feel the need to do that?

 

1. Because I am difficult

2. Because it is less mouse clicks and looks nice when browsing to my unRAID network shares (see photo).

 

If you mount them at /mnt/disks and then share them, you get the same result.

Share this post


Link to post

If you mount them at /mnt/disks and then share them, you get the same result.

 

I actually don't map any network drives, I just browse to my unRAID network share from the side menu. I feel like it is slightly more secure if some sort of virus tries to infect my computer. There is a chance it might only look for attached network drives...

Share this post


Link to post

... but I do think /mnt/ unless your worried somebody is going to mess up disk shares some how with the incorrect mounting.

You can count on it. ;D

 

Yes.  And all the support issues when someone does it wrong.

 

What if by default you make it /mnt/disks but if the user goes into settings and turns on "advanced mounting" they then have the option to use /mnt/ but it still forces the user to use /mnt/ (that way if someone does pick "extra" as there share name it would force it to /mnt/extra) That should prevent most issues.

Share this post


Link to post

Well in that case do what you think is right and I'll adapt. ;)

 

I just like the ability to mount and treat it like a share so everything in my network can seemlessly see the device opposed to having to remap everything because its not treated like a share mapping to /mnt/user/

 

However like I said that's just me and I'll figure out a plan B for the greater good.

Share this post


Link to post

... but I do think /mnt/ unless your worried somebody is going to mess up disk shares some how with the incorrect mounting.

You can count on it. ;D

 

Yes.  And all the support issues when someone does it wrong.

 

What if by default you make it /mnt/disks but if the user goes into settings and turns on "advanced mounting" they then have the option to use /mnt/ but it still forces the user to use /mnt/ (that way if someone does pick "extra" as there share name it would force it to /mnt/extra) That should prevent most issues.

 

And as well a note saying something to the fact. "Incorrect Mounting can.............."

Share this post


Link to post

First of all, thanks for the awesome plug in!

 

Is there anything I need to do to get a mounted drive available in the "Primary vDisk Location" drop down when setting up a VM? My drive isn't appearing under /mnt/Disks/, but I know it's formatted correctly and works because I can read/write to it as a share from another machine.

 

It shows up for me.  I just browse down to it.

 

Strange, I don't see mine at all. They're mounted, spun up, formatted XFS, nothing unusual, but they never appear under /Disks/ in the drop down.

 

On a command line 'ls /mnt/disks'.  You should see your disks.  If not, let me know what you see.

 

I get no return when running that command:

login as: root
Last login: Wed Jan 27 12:17:52 2016 from 10.0.1.11
Linux 4.1.15-unRAID.
root@KingsLanding:~# ls /mnt/disks
root@KingsLanding:~#

 

The GUI shows them as mounted. I've tried rebooting, unmount/mounting, and reformatting. Any ideas?

 

You have the mount point set to SSD_VM.  It should be /mnt/disks/SSD_VM.  This is one of the things I don't like about the renaming feature and will probably change it so this won't happen.

 

EDIT: I made a change so the mount point cannot be changed from /mnt/disks/.  If you enter just a mount point name 'MyDisk', it will be changed to /mnt/disks/MyDisk.  The mount point has to be at /mnt/disks/ for everything to work properly.  This will be fixed in the next release.

 

Worked, thanks! And I agree on the change, sorry for the hassle.  ;D

Share this post


Link to post

I updated to the latest version (thanks dlandon for updating this)

 

I am converting drives from RFS to XFS, and I added a drive to the array, formatted it XFS and then pulled it out of the array and connected it via this plugin.  This newly formatted XFS drive will not mount at all when connected to my Areca card, but when moved back to the motherboard port, it will mount fine.

 

I have an Areca 1280 with a bunch of 3tb drives on it and it works fine with unRaid.  Other Areca connected RFS drives mount fine with this unassigned devices plugin too.  But this newly formatted 3TB WD EZRS drive would not.

Share this post


Link to post

I am converting drives from RFS to XFS, and I added a drive to the array, formatted it XFS and then pulled it out of the array and connected it via this plugin.  This newly formatted XFS drive will not mount at all when connected to my Areca card, but when moved back to the motherboard port, it will mount fine.

 

Now after moving the drive back and forth between an Areca port and a motherboard port it won't mount in either place ??  The RFS drives are still happily mounted on the Areca.

Share this post


Link to post

I updated to the latest version (thanks dlandon for updating this)

 

I am converting drives from RFS to XFS, and I added a drive to the array, formatted it XFS and then pulled it out of the array and connected it via this plugin.  This newly formatted XFS drive will not mount at all when connected to my Areca card, but when moved back to the motherboard port, it will mount fine.

 

I have an Areca 1280 with a bunch of 3tb drives on it and it works fine with unRaid.  Other Areca connected RFS drives mount fine with this unassigned devices plugin too.  But this newly formatted 3TB WD EZRS drive would not.

 

You have not said you rebooted or just plugged the drive in.  If you didn't reboot, it may be a hot plug problem.

 

The best way to see if a drive is recognized by unraid and subsequently by unassigned devices is to go to the 'Dashboard' and look at the row labeled 'Unassigned".  You will see the disks that unraid sees as unassigned.  If it does not show there, unassigned devices will not recognize it.

Share this post


Link to post

First of all, thanks for the awesome plug in!

 

Is there anything I need to do to get a mounted drive available in the "Primary vDisk Location" drop down when setting up a VM? My drive isn't appearing under /mnt/Disks/, but I know it's formatted correctly and works because I can read/write to it as a share from another machine.

 

It shows up for me.  I just browse down to it.

 

Strange, I don't see mine at all. They're mounted, spun up, formatted XFS, nothing unusual, but they never appear under /Disks/ in the drop down.

 

On a command line 'ls /mnt/disks'.  You should see your disks.  If not, let me know what you see.

 

I get no return when running that command:

login as: root
Last login: Wed Jan 27 12:17:52 2016 from 10.0.1.11
Linux 4.1.15-unRAID.
root@KingsLanding:~# ls /mnt/disks
root@KingsLanding:~#

 

The GUI shows them as mounted. I've tried rebooting, unmount/mounting, and reformatting. Any ideas?

 

You have the mount point set to SSD_VM.  It should be /mnt/disks/SSD_VM.  This is one of the things I don't like about the renaming feature and will probably change it so this won't happen.

 

EDIT: I made a change so the mount point cannot be changed from /mnt/disks/.  If you enter just a mount point name 'MyDisk', it will be changed to /mnt/disks/MyDisk.  The mount point has to be at /mnt/disks/ for everything to work properly.  This will be fixed in the next release.

 

Worked, thanks! And I agree on the change, sorry for the hassle.  ;D

 

I'm glad you worked it out.

 

It's a very easy thing to happen.  The plugin should not allow this situation.  Your situation has highlighted a hole that needs to be addressed.

 

This is part of what I am trying to accomplish with the work I'm doing on the plugin.  I'm adding and changing log entries for clarification, and adding code to make things more robust.  When there is a problem, it should either be handled or the user should be told what is happening.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now