Jump to content
binhex

[Support] binhex - DelugeVPN

4112 posts in this topic Last Reply

Recommended Posts

Thank you for this docker!

 

At first, I did order a 3 months of AirVPN.  Now that my 3 months is almost over, I was about to renew when I remember that my Usenet Provider included VPN! So i'm using newshosting.com.  I looked inside my client area, and they had openVPN support :)  So I just follow the custom VPN and it worked at the first try ! :)

 

Super easy, and free VPN (bundled with my Usenet sub.), way to go !

 

It seems I spoke too soon :)

 

My private tracker told me that my port 32767 is closed.  How can I open that on the docker? Do I just map this port on the host and then forward that port from my router ?  (don't think so, the port is closed from my VPN IP...)

 

This is going to be down to your vpn provider, as you rightly said above changing the port forward on your router will have no affect on deluge, as this is using a vpn tunnel with port forwarding defined by the end point, i.e. the provider, so you would need to see if you can specify the incoming port for your connection. I know airvpn does give you some configuration for this, PIA doesnt allow you define a static port number, not sure about your provider.

 

Basically you need to investigate how your provider hands out incoming ports (some providers dont allow incoming ports at all), and manually configure deluge to use this, good luck.

 

This is what I can see from the FAQ.  I know that i use the port 1194 from the logs.  Does that means that my incoming port is  443 ?

 

6. Do I need to change any of my firewall settings for the VPN?

You should not need to manually configure any ports or adjust your firewall settings as OpenVPN utilizes port 443 and PPTP uses port 1723; by default these ports are open on most firewalls.

Share this post


Link to post

Ok, apparently it didn't like my password for some reason and would fail with it.  I used a randomly generated 20 digit password.  I changed the password and the new password works fine. 

 

Any idea why 4l%3OsZb0$sX$^K0GKPy would cause it to fail?

 

 

 

Double and triple checked, no trailing spaces on username/password.

 

are you copy/pasting the username/pass, if so watch for trailing spaces.

 

Probably the % or $ or ^.

Share this post


Link to post

@binhex

 

In Deluge Settings, I uncheck "use random ports" for incoming and for outgoing.  I specified only port 443.  How should I edit the config to enable the port 443 ?  Do I just specify the port in the "Ports" config in docker GUI ?  Do I have to manually edit a config file? (probably the one for IPTABLES ?)  if so, what should I add to iptables command to enable port 443 in both direction ?

Share this post


Link to post

@binhex

 

In Deluge Settings, I uncheck "use random ports" for incoming and for outgoing.  I specified only port 443.  How should I edit the config to enable the port 443 ?  Do I just specify the port in the "Ports" config in docker GUI ?  Do I have to manually edit a config file? (probably the one for IPTABLES ?)  if so, what should I add to iptables command to enable port 443 in both direction ?

 

No i think your misreading this, 443 will be the port you connect to when establishing the tunnel, i very much doubt this will be your incoming port.

 

To answer your questions though, once you know what the incoming port is then you would define the incoming port in the deluge webui, you dont need to alter iptables at all as all traffic is allowed inbound and outbound for the tunnel.

 

edit - hmm just done some googling for newshosting and i cant find anything relating to incoming port, if i were you i would email them and ask then outright, do you allow incoming ports for the vpn, if so how you do find out what the port is and/or define it?.

 

my gut feeling is that they dont support incoming ports, in which case they are pretty useless for torrents.

Share this post


Link to post

Can anyone provide guidance on how to configure this docker to use VyprVPN? https://support.goldenfrog.com/hc/en-us

 

I believe that I am not configuring the .opvn file correctly.

 

Many thanks!

 

pm replied to, for anybody else use VyperVPN, here is the link to the zip containing all the ovpn config files for all endpoints:-

 

https://www.goldenfrog.com/openvpn/VyprVPNOpenVPNFiles.zip

Share this post


Link to post

Ok, apparently it didn't like my password for some reason and would fail with it.  I used a randomly generated 20 digit password.  I changed the password and the new password works fine. 

 

Any idea why 4l%3OsZb0$sX$^K0GKPy would cause it to fail?

 

 

 

Double and triple checked, no trailing spaces on username/password.

 

are you copy/pasting the username/pass, if so watch for trailing spaces.

 

Probably the % or $ or ^.

 

i think mr-hexen is most probably right, did some research and it looks like you should escape usernames and passwords for OpenVPN auth files, so i have now built this into delugevpn to do this automatically, hopefully that will be last time we see this particular issue.

Share this post


Link to post

In my logs, I see this frequently.

 

2016-02-02 20:32:21,017 DEBG 'deluge' stdout output:

[warn] PIA incoming port is not an integer, downloads will be slow, check if remote gateway supports port forwarding

 

Is there a way that this can be configured to use PIA's port forwarding feature?

 

https://www.privateinternetaccess.com/forum/discussion/3359/port-forwarding-without-application-pia-script-advanced-users

Share this post


Link to post

In my logs, I see this frequently.

 

2016-02-02 20:32:21,017 DEBG 'deluge' stdout output:

[warn] PIA incoming port is not an integer, downloads will be slow, check if remote gateway supports port forwarding

 

Is there a way that this can be configured to use PIA's port forwarding feature?

 

https://www.privateinternetaccess.com/forum/discussion/3359/port-forwarding-without-application-pia-script-advanced-users

 

The docker image is scripted to automatically do the port forwarding for you (PIA only), i can only assume you are connected to a gateway that doesn't support port forwarding, as not all gateways do, which gateway are you connecting to?.

Share this post


Link to post

I was connected to US East, I will try one of the others that support port forwarding and see what happens.  Thanks

Share this post


Link to post

I reconnected using New York which is listed as supporting port forwarding.

 

it seemed to redownload the image, now when I run it I get the error

 

2016-02-03 09:59:01,656 DEBG 'start' stdout output:
[crit] LAN network not defined, please specify via env variable LAN_NETWORK

Share this post


Link to post

I think I found it.  I removed it and reinstalled and one of the environment variables changed from LAN_RANGE to LAN_NETWORK

Share this post


Link to post

You were right, the port forwarding worked without issue when I connected to the netherlands, but not to the US servers so far. 

 

In my logs, I see this frequently.

 

2016-02-02 20:32:21,017 DEBG 'deluge' stdout output:

[warn] PIA incoming port is not an integer, downloads will be slow, check if remote gateway supports port forwarding

 

Is there a way that this can be configured to use PIA's port forwarding feature?

 

https://www.privateinternetaccess.com/forum/discussion/3359/port-forwarding-without-application-pia-script-advanced-users

 

The docker image is scripted to automatically do the port forwarding for you (PIA only), i can only assume you are connected to a gateway that doesn't support port forwarding, as not all gateways do, which gateway are you connecting to?.

Share this post


Link to post

IMPORTANT - Existing users read

 

Hi all, i have made some changes to DelugeVPN which will mean if you pull down the latest image you will now need to alter the name environment variable "LAN_RANGE" to "LAN_NETWORK", you will also now need to define this as <lan network>/<cidr notation>

 

Example CIDR notation below:-

 

subnet mask 255.255.255.0  = CIDR /24
subnet mask 255.255.0.0 = CIDR /16
subnet mask 255.0.0 = CIDR 8

 

So the env var in the unRAID webui Docker section would end up looking like this:-

 

Variable Name: Variable Value:
LAN_NETWORK    192.168.1.0/24

 

For other configurations please calculate the CIDR using this online calculator http://www.subnet-calculator.com/cidr.php

 

So you might be asking why ive made this change, the reason is that this vastly simplifies the iptables configuration, it also gets around the limitation that the linux kernel has to have iptable_mangle module loaded, which is not a default for most linux distros

Share this post


Link to post

IMPORTANT - Existing users read

 

Hi all, i have made some changes to DelugeVPN which will mean if you pull down the latest image you will now need to alter the name environment variable "LAN_RANGE" to "LAN_NETWORK", you will also now need to define this as <lan network>/<cidr notation>

 

Example CIDR notation below:-

 

subnet mask 255.255.255.0  = CIDR /24
subnet mask 255.255.0.0 = CIDR /16
subnet mask 255.0.0 = CIDR 8

 

So the env var in the unRAID webui Docker section would end up looking like this:-

 

Variable Name: Variable Value:
LAN_NETWORK    192.168.1.0/24

 

For other configurations please calculate the CIDR using this online calculator http://www.subnet-calculator.com/cidr.php

 

So you might be asking why ive made this change, the reason is that this vastly simplifies the iptables configuration, it also gets around the limitation that the linux kernel has to have iptable_mangle module loaded, which is not a default for most linux distros

 

sorry if this is a dumb question, but I updated and then came here when the webgui wouldn't start....

I made the following change in the docker config, but it doesn't seem to be working.  Did I miss something?

 

LAN_NETWORK              192.168.1.0/24

 

Thanks in advance for your help.

 

edit: in checking my logs it seems my PIA auth is failing, but nothing changed there on my side.  Thoughts?

 

edit2:  It seems my PIA password is getting changed in my credentials.conf file.  Everytime I correct it and restart the docker the password gets changed and I get an AUTH FAIL....

 

Anyone else experiencing this problem?  I've learned a lot today about other things I've been meaning to dig into, but not why this is happening.....

Capture.JPG.8960dea5b90d2993a880975d4ec8ffd6.JPG

Share this post


Link to post

i think ive spotted an issue, just building now, please do an update in 30 mins. If the issue persists after the update then please post your entire supervisord.log file in /config.

 

 

Share this post


Link to post

i think ive spotted an issue, just building now, please do an update in 30 mins. If the issue persists after the update then please post your entire supervisord.log file in /config.

 

My Bad Binhex.....sorry.....I'll wait and try later.

 

Thanks for all your efforts!!

Share this post


Link to post

edit2:  It seems my PIA password is getting changed in my credentials.conf file.  Everytime I correct it and restart the docker the password gets changed and I get an AUTH FAIL....

 

My password aswell. It had an !  (in it ie password!)  then in credentials.conf had / infront of !  (ie password/!)

 

Changed my pia password on the site to not have ! and all is fine now

Share this post


Link to post

edit2:  It seems my PIA password is getting changed in my credentials.conf file.  Everytime I correct it and restart the docker the password gets changed and I get an AUTH FAIL....

 

My password aswell. It had an !  (in it ie password!)  then in credentials.conf had / infront of !  (ie password/!)

 

Changed my pia password on the site to not have ! and all is fine now

 

I have a "!" in my password too.  I'm going to change it on the PIA site as you suggested and see if I have the same success....

 

Thanks a ton for sharing your information!

Share this post


Link to post

edit2:  It seems my PIA password is getting changed in my credentials.conf file.  Everytime I correct it and restart the docker the password gets changed and I get an AUTH FAIL....

 

My password aswell. It had an !  (in it ie password!)  then in credentials.conf had / infront of !  (ie password/!)

 

Changed my pia password on the site to not have ! and all is fine now

 

That solved it for me as well!  THANKS!!

Share this post


Link to post

edit2:  It seems my PIA password is getting changed in my credentials.conf file.  Everytime I correct it and restart the docker the password gets changed and I get an AUTH FAIL....

 

My password aswell. It had an !  (in it ie password!)  then in credentials.conf had / infront of !  (ie password/!)

 

Changed my pia password on the site to not have ! and all is fine now

 

That solved it for me as well!  THANKS!!

 

hm looks like the escaping mentioned in the openvpn doc isnt standard bash escaping, for now ive removed this and building a new image right now, either change your password or sit tight and pull down the image in 30 mins.

Share this post


Link to post

for now ive removed this and building a new image right now

 

Thanks for all your work you do for us Binhex. Much appreciated

Share this post


Link to post

for now ive removed this and building a new image right now

 

Thanks for all your work you do for us Binhex. Much appreciated

 

DITTO... THANKS BINHEX :)

Share this post


Link to post

Now that I have this resolved, I'm wondering if anyone can provide some guidance on getting Couch to connect to DelugeVPN...

 

I've read thru the thread, and I've made the changes as outlined, but I have never been able to connect.  I should also say I always have to reset the preferences whenever I update or even just restart DelugeVPN on my unRaid server.  Each time I stop and start, I need to go in, reapply the download directory, my seeding preferences, if I want to allow remote connections, labels, etc.  Any thoughts on what I could be doing wrong? 

 

I know a lot of users aren't having this problem so it has to be something on my side in terms of config.  Any suggestions are appreciated.

 

fyi, in Couch I have tried to connect to "localIP:58846", "127.0.0.1:58846" and "localhost:58846".  I also tried changing the port number in deluge and in couch but no luck.  In the beginning of this thread in the FAQ Binhex says to "enable remote connections, then restart".  In my case, every restart resets to unchecked and I have to check again - so now I"m thinking whatever is keeping my preferences from staying might be a contributing factor.

 

Thanks again for any help.

Share this post


Link to post

Each time I stop and start, I need to go in, reapply the download directory, my seeding preferences, if I want to allow remote connections, labels, etc.  Any thoughts on what I could be doing wrong? 

 

This sounds like a classic case of the share your using not being marked a "cache only", what this means if you dont do this is the internal unraid process called mover comes along and moves all your files in that share to the array, then when you restart the docker you have no config again, and so the cycle repeats. The way to solve this is to mark the share as "cache only", this tells the mover not to touch any files/folders contained within this share, go to unraid ui/shares/click on share/select from dopdown "use cache disk" the value "only", save and your done.

 

fyi, in Couch I have tried to connect to "localIP:58846", "127.0.0.1:58846" and "localhost:58846".  I also tried changing the port number in deluge and in couch but no luck.  In the beginning of this thread in the FAQ Binhex says to "enable remote connections, then restart".  In my case, every restart resets to unchecked and I have to check again - so now I"m thinking whatever is keeping my preferences from staying might be a contributing factor.

 

ok this will depend on where couchpotato is installed and how its installed, for now im going to assume couchpotato is installed as another docker on the unraid host, if this is the case then read FAQ Q1 in post #2 of this thread and follow it carefully.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now