[Support] binhex - DelugeVPN


8731 posts in this topic Last Reply

Recommended Posts

If i do a curl localhost:8112 or sub.domain.com:8112 on the server via ssh, I get a response from deluge:

 

<head>
<title>Deluge: Web UI 1.3.15</title>

<link rel="shortcut icon" href="/icons/deluge.png" type="image/png" />
<link rel="icon" href="/icons/deluge.png" type="image/png" />
<link rel="apple-touch-icon-precomposed" media="screen and (resolution: 163dpi)" href="/icons/apple-pre-57.png" />
<link rel="apple-touch-icon-precomposed" media="screen and (resolution: 132dpi)" href="/icons/apple-pre-72.png" />
<link rel="apple-touch-icon-precomposed" media="screen and (resolution: 326dpi)" href="/icons/apple-pre-114.png" />

<!-- Stylesheets -->
<link rel="stylesheet" type="text/css" href="/css/ext-all-notheme.css" />
<link rel="stylesheet" type="text/css" href="/themes/css/xtheme-gray.css" />
<link rel="stylesheet" type="text/css" href="/css/ext-extensions.css" />
<link rel="stylesheet" type="text/css" href="/css/deluge.css" />

<script type="text/javascript">
deluge = {
author: 'Damien Churchill <damoxc@gmail.com>',
version: '1.3.15',
  .....

 

but if i do it from my PC i get a timeout. And i cant for the life of me get the 58846 to connect with my Deluge thin client app. but im guessing the 2 problems are related :(

 

if i run with VPN off everything works ...

Edited by saitoh183
Link to post
  • Replies 8.7k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

OK guys, multi remote endpoint support is now in for this image please pull down the new image (this change will be rolled out to all my vpn images shortly).   What this means is that the im

There has been an issue raised on GitHub related to tracker announce request IP leakage under certain circumstances, after careful review of iptables i have tightened up the rules to prevent this. A n

I wanted to summarize how I got Mullvad working with DelugeVPN as I had to piece together several "solutions" from different comments in this thread and there was some incorrect info; likely old.

Posted Images

6 hours ago, strike said:

Also I hope you have set up authentication for your services behind the reverse proxy, or else anybody can mess with them. Specially now when you have published your domain name and all. You might want to get on that asap if you don't have authentication set up.

 

its not the real domain name :)

Link to post
8 hours ago, strike said:

No, I mean on the remote router, port 58846 needs to be forwarded to your server. I assume you (or someone where your server is located) has forwarded ports on the remote router before. Because in order to get the jwilder nginx container to work port 443 needs to be forwarded to your server, and your container is obviously working so someone must have done it.

@Spike

via iptables? I tried a few things in there but to no avail 

 

iptables -t nat -A PREROUTING -p tcp --dport 58846 -j REDIRECT --to-port 58846
iptables -A OUTPUT -p tcp --dport 58846 -j ACCEPT
iptables -A INPUT -p tcp --dport 58846 -j ACCEPT
iptables --append FORWARD --match tcp --protocol tcp --sport 58846 --dport 58846 --jump ACCEPT

 

Edited by saitoh183
Link to post

I'm trying to getting it to work with PureVPN on my Synology DS1511+, but i can't figure out what is wrong.

 

I've added tls-cipher "DEFAULT:@SECLEVEL=0" to my ovpn file, else i'me getting "VERIFY ERROR: depth=0, error=CA signature digest algorithm too weak: C=HK, ST=HK, L=HongKong, O=PureVPN, OU=IT, CN=PureVPN, name=PureVPN, emailAddress=mail@host.domain".

supervisord.log

 

I'm getting ERROR: Linux route add command failed: external program exited with error status: 2 and i can't figure out where this comes from. It is not possible to call the ui.

Edited by cfrets
Added more info
Link to post

I just setup DelugeVPN with a public IP from a VPN provider. How do i save iptables so and can at least setup a basic firewall?

 

HOWTO save iptables for TUN0 in this docker? i would love to have block all but two ports (deluge ports) on the TUN0.

Edited by DigitalLF
2 line
Link to post
15 hours ago, DigitalLF said:

I just setup DelugeVPN with a public IP from a VPN provider. How do i save iptables so and can at least setup a basic firewall?

 

HOWTO save iptables for TUN0 in this docker? i would love to have block all but two ports (deluge ports) on the TUN0.

 

This container already has iptables rules set up so you don't need to worry about that. 

Link to post

Got this message via email-

Error response from daemon: driver failed programming external connectivity on endpoint binhex-delugevpn (4ffca8522d65eb52cdce4c3166862eb1f2d2de5a375c2d150430ea3bef76a14c): Error starting userland proxy: listen udp 0.0.0.0:58946: bind: address already in use
Error: failed to start containers: binhex-delugevpn

Now the docker fails to start.

 

FirefoxScreenSnapz012.thumb.jpg.7ef0d0f061447cbd902f8a88b73f3b65.jpg

 

supervisord.log.txt

Edited by wgstarks
Link to post
12 hours ago, wgstarks said:

Got this message via email-


Error response from daemon: driver failed programming external connectivity on endpoint binhex-delugevpn (4ffca8522d65eb52cdce4c3166862eb1f2d2de5a375c2d150430ea3bef76a14c): Error starting userland proxy: listen udp 0.0.0.0:58946: bind: address already in use
Error: failed to start containers: binhex-delugevpn

Now the docker fails to start.

 

FirefoxScreenSnapz012.thumb.jpg.7ef0d0f061447cbd902f8a88b73f3b65.jpg

 

supervisord.log.txt

 

you already have another container running thats using port 58946 on the host side, thus the container cannot start as the ports already in use.

Link to post
10 hours ago, DigitalLF said:

 

Not over the TUN0? I ran a portscan and all was open!

 

all outgoing ports are open for the tunnel, correct, if you start messing with outgoing connections you will be in a world of pain trying to get deluge working correctly, as for incoming ports, the only open port will be the port forward so not sure how you are port scanning this?. keep in mind this is running a single application, no other processes run, you aren't going to be wanting to secure this in the same way you would secure a vm, but if you want to do this im afraid you are going to be on your own.

Edited by binhex
Link to post
2 hours ago, binhex said:

 

you already have another container running thats using port 58946 on the host side, thus the container cannot start as the ports already in use.

No. No other containers are using that port. Not sure what happened. Got the initial warning after the container had been running for an extended period. After 3 or 4 reboots and a couple of hours the docker is now working again.

Link to post
1 minute ago, wgstarks said:

No. No other containers are using that port. Not sure what happened. Got the initial warning after the container had been running for an extended period. After 3 or 4 reboots and a couple of hours the docker is now working again.

 

*shrug* well that's what the error message is saying and its coming straight from the docker engine, maybe there is a bug in dynamix where it doesn't remove the old container and its left in a temporary state causing the port clash, anyway glad its now working again.

Link to post

Edit: SOLVED , but I'll leave it here in case someone runs into the same problem. You can use either command and just use your container ID. You may need to add sudo in front of it.

 

@binhex

There is a bug affecting me on the latest docker version that will be fixed in the next one.

https://github.com/docker/for-linux/issues/211

https://github.com/moby/moby/issues/36145

 

There's a workaround for now but I don't know how to change the command to my needs. Below are two examples the docker dev has given but they look different and I'm a noob. ;-)

docker-containerd-ctr --address /run/docker/containerd/docker-containerd.sock --namespace moby c rm <containerd id> 
docker-containerd-ctr --namespace moby --address /run/docker/containerd/docker-containerd.sock c rm b62020cb44e1ed3307195ca4402cdf23ed817c35c52a30da858909398898c8b6

I know my container ID. How would the right command look like for your container?

Thanks!
 

Edited by TombRaider
words
Link to post
On 3/1/2018 at 11:42 AM, binhex said:

 

all outgoing ports are open for the tunnel, correct, if you start messing with outgoing connections you will be in a world of pain trying to get deluge working correctly, as for incoming ports, the only open port will be the port forward so not sure how you are port scanning this?. keep in mind this is running a single application, no other processes run, you aren't going to be wanting to secure this in the same way you would secure a vm, but if you want to do this im afraid you are going to be on your own.

yeah the outgoing should be open. but i wore talking about the incoming. i checked your scripts a bit! DAMN you clearly know what you are doing :D Thank you! :)

 

But i still have problem with seeding and i don't know why.. but I'm new when it comes to unRAID and Docker.

 

When i press "Test Active Port" it shows a green icon but still not seeding.

Edited by DigitalLF
Link to post

Hi gang,

 

I'm fairly new to Unraid. I have been using Binhex deluge VPN for a couple months now and after adding a cache drive to my array following Spaceinvaders instructions for setup I can't get deluge to start at all. I tried uninstalling and adding it again but I still can't get it to work. Any help would be much appreciated.

Link to post
1 minute ago, monano said:

Hi gang,

 

I'm fairly new to Unraid. I have been using Binhex deluge VPN for a couple months now and after adding a cache drive to my array following Spaceinvaders instructions for setup I can't get deluge to start at all. I tried uninstalling and adding it again but I still can't get it to work. Any help would be much appreciated.

 

 

Tools - Diagnostics, post complete zip

 

Link to post
7 hours ago, trurl said:

So are you still having a problem? Are your other dockers working?

Yes, I still can't get deluge to start. My other dockers work fine. It started once and let me into the webui. But after that it would look started and when i couldn't access the webui I would refresh the docker page and deluge would not be running.

Link to post

It keeps saying

Quote

[info] Deluge not running
[info] Attempting to start Deluge...

 

2018-03-03 16:48:47,427 DEBG 'deluge-script' stdout output:
[info] Deluge listening interface currently defined as 213.5.69.108
[info] Deluge listening interface will be changed to 213.5.69.108
[info] Saving changes to Deluge config file /config/core.conf...

 

2018-03-03 16:48:48,522 DEBG 'deluge-script' stdout output:
[info] Deluge started

 

2018-03-03 16:48:48,526 DEBG 'deluge-script' stdout output:
[debug] VPN incoming port is 
[debug] VPN IP is 213.5.69.108
[debug] Deluge incoming port is 
[debug] Deluge IP is 213.5.69.108

 

2018-03-03 16:49:18,530 DEBG 'deluge-script' stdout output:
[debug] Waiting for valid IP address from tunnel...

 

2018-03-03 16:49:18,746 DEBG 'deluge-script' stdout output:
[debug] Valid IP address from tunnel acquired '213.5.69.108'

 

2018-03-03 16:49:18,767 DEBG 'deluge-script' stdout output:
[info] Deluge not running

 

2018-03-03 16:49:18,769 DEBG 'deluge-script' stdout output:
[info] Attempting to start Deluge...

 

It makes no difference if i disables OpenVPN or not.

I have other container running on my Synology with success.

supervisord (2).log

Link to post
1 hour ago, monano said:

Yes, I still can't get deluge to start. My other dockers work fine. It started once and let me into the webui. But after that it would look started and when i couldn't access the webui I would refresh the docker page and deluge would not be running.

 

follow the procedure in the link below:-

 

https://lime-technology.com/topic/44108-support-binhex-general/?do=findComment&comment=435831

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.