Jump to content
binhex

[Support] binhex - DelugeVPN

5167 posts in this topic Last Reply

Recommended Posts

Thanks for helping strike.

 

Nope.  That didn't make a difference.  Has never been an issue in the past.  Tried a different endpoint too.

 

Any other ideas?

Share this post


Link to post

also add udp to the remote line so it looks like this: "remote gw1.atl3.slickvpn.com 443 udp"

 

Edit: please post a new debug log if it doesn't work. From the log you posted earlier there were issues determining the protocol 

and yeah you might wanna try the IP insted of the hostname "remote 23.239.17.108 443 udp"

 

You may also have to remove/comment this line after adding udp to the remote line

"proto udp"

 

Edited by strike

Share this post


Link to post

Nope. No luck.  Does the ovpn  need to be executable? 

 

Edited by ZoZat

Share this post


Link to post

Is it possible to run Deluge with Privoxy using a custom network interface (br0)?  

 

I tried doing this and I wasn't able to connect to the WebGUI nor the Privoxy port.  Example:  My server is 10.1.1.99/24 and I set the docker network type to Custom (br0) and set the IP to static 10.1.1.98. 

 

I can ping 10.1.1.98 from any host on my local LAN (10.1.1.0/24) but cannot connect to webGUi or Privoxy.  I have the LAN network set to 10.1.1.0/24.

 

Everything is working fine using Network Type: Bridge.

Share this post


Link to post

All torrents "paused", unable to resume. I can add new torrents via Sonarr, Radarr, or directly in the Deluge web UI, however they do not start and are perpetually in "paused" state.

  • I have followed Spaceinveader's tutorial on DelugeVPN, including the connection with Sonarr and Radarr: https://www.youtube.com/watch?v=5AEzm5y2EvM
  • VPN is configured in the docker (PIA)
  • docker volume mappings:
    • /data  <-> /mnt/user/Downloads/
    • /config <-> /mnt/user/appdata/binhex-delugevpn

Any advice appreciated.

Share this post


Link to post
28 minutes ago, noties said:

Everything is working fine using Network Type: Bridge.

I tried setting up a custom network a while back. Ran into the same issues. Never could get it to work.

Share this post


Link to post
22 minutes ago, Odessa said:

All torrents "paused", unable to resume. I can add new torrents via Sonarr, Radarr, or directly in the Deluge web UI, however they do not start and are perpetually in "paused" state.

  • I have followed Spaceinveader's tutorial on DelugeVPN, including the connection with Sonarr and Radarr: https://www.youtube.com/watch?v=5AEzm5y2EvM
  • VPN is configured in the docker (PIA)
  • docker volume mappings:
    • /data  <-> /mnt/user/Downloads/
    • /config <-> /mnt/user/appdata/binhex-delugevpn

Any advice appreciated.

What endpoint are you using?

Share this post


Link to post
1 hour ago, ZoZat said:

Does the ovpn  need to be executable?

idk actually, but mine is anyway

 

You should change your password tho as you forgot to redact that in your last log. Good news is that the warnings from your last log are gone. But I think you're missing some files in your openvpn folder. If it's not baked into your .ovpn file you usually have to have a .crt file and a .pem or .key file in your openvpn folder. You'll get them form your vpn provider. 

 

The other thing that could be an issue is your username. If you are able to change it you should, please use only 0-9, a-z, A-Z if you're able to change it. 

 

 

Share this post


Link to post
35 minutes ago, noties said:

Is it possible to run Deluge with Privoxy using a custom network interface (br0)?  

I'm using br0 with a static ip with no issues. Only thing I did was to set it in the template

Share this post


Link to post

Everything is baked into ovpn.  I've never needed anything else.  I've been successfully doing it this way since I started using Unraid.

Share this post


Link to post
3 minutes ago, ZoZat said:

Everything is baked into ovpn.  I've never needed anything else.  I've been successfully doing it this way since I started using Unraid.

Then I'm stumped. You better wait for the expert @binhex to chime in

Share this post


Link to post
6 minutes ago, Odessa said:

@strike @wgstarks I replaced Netherlands with Switzerland ovpn file, restarted array and docker. All torrents still stuck paused.

Did you replace all 3 files? I ran into similar issues when I changed mine. Had to download a new openvpn package and use the new crt pem and ovpn files.

Share this post


Link to post

If that doesn't help you should search the thread and you'll find at least a couple users having the same issue. I don't remember how/if they solved it tho. If all else fails nuke your docker image and reinstall all your containers, usually helps with weird issues.

Share this post


Link to post

I deleted the docker image and reinstalled.  No difference.  Same problem. 

 

I really need  @binhex to take a look at this.

 

I've included a new log.

supervisord.log

Edited by ZoZat

Share this post


Link to post

I doubt he'll respond today, he normally doesn't work weekends. You'll just have to chill til tomorrow if nobody else will take a shot. Why do you use slickvpn anyway? From what I can see they don't support port forwarding so torrenting is gonna be slow and peers can't really connect with you. You and everybody else would be better off if you switch to another provider which supports port forwarding.

Share this post


Link to post

Actually, all there servers support port forwarding as of Nov 2017.  My speeds have been good (3.5 mb) before I started having troubles.  Now my speeds max out at 680 kb.

Share this post


Link to post
5 minutes ago, ZoZat said:

Actually, all there servers support port forwarding as of Nov 2017.  My speeds have been good (3.5 mb) before I started having troubles.  Now my speeds max out at 680 kb.

 

Oh, then my bad.. Doesn't say on their website, at least what I could see

Edited by strike

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.