[Support] binhex - DelugeVPN


8729 posts in this topic Last Reply

Recommended Posts

7 hours ago, raf7913 said:

 

Thanks for the helpful comment. 

 

I saw this listed as the support forum for it on the docker hub and didn't see that it was platform dependent. (and I figured since he had stuff about other platforms in his FAQ, it wouldn't be a big deal either) my bad

You're welcome. It's not technically platform dependent, but since the vast majority of development is done on unraid or generic linux systems, troubleshooting other platforms is hit or miss. It's not like the developer (singular) has access to a bunch of different proprietary systems to work with.

 

It's not that big of a deal, just letting you know.

 

unraid has a free one month trial, if you have some spare hardware it wouldn't take long to set it up and see if the symptoms are the same, or if it's truly a platform issue. If you get the same symptoms on unraid, then tracking down the cause may be easier since the diagnostics are familiar to more people running it.

Link to post
  • Replies 8.7k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

OK guys, multi remote endpoint support is now in for this image please pull down the new image (this change will be rolled out to all my vpn images shortly).   What this means is that the im

There has been an issue raised on GitHub related to tracker announce request IP leakage under certain circumstances, after careful review of iptables i have tightened up the rules to prevent this. A n

I wanted to summarize how I got Mullvad working with DelugeVPN as I had to piece together several "solutions" from different comments in this thread and there was some incorrect info; likely old.

Posted Images

Edit: Again, I solved the problem on my own. Hate it when that happens ;)

What I did was to replace the ovpn file with a newly created one. I don't why this works but maybe someone finds a hint in the log.

 

Anyone else  having problems with privoxy and torrents? I can't find any errors in the logs but privoxy doesn't seem to work at all. Websites do not load when accessed through it. On top of that, all connections to different trackers get canceled in Deluge (Operation canceled). The VPN is working though.

 

 

Edited by TombRaider
solved
Link to post

Hi,

 

I've been trying to get it to work, it seems to be running. But can't connect to the webgui, I seem to be missing something trivial probably. 

Hope you can help! I attached some screenshots of my Docker container on DSM 6.1

My local NAS IP is: 192.168.178.24

 

Regards,

Justin

 

Schermafbeelding 2018-06-04 om 12.54.17.png

Schermafbeelding 2018-06-04 om 12.54.23.png

Schermafbeelding 2018-06-04 om 12.54.40.png

supervisord-export.log

Edited by JustinM
Link to post
7 hours ago, JustinM said:

Hi,

 

I've been trying to get it to work, it seems to be running. But can't connect to the webgui, I seem to be missing something trivial probably. 

Hope you can help! I attached some screenshots of my Docker container on DSM 6.1

My local NAS IP is: 192.168.178.24

 

Regards,

Justin

 

 

 

 

supervisord-export.log

 

Have you added the port when you tried accessing the WebGUI?

http://localhost:8112

 

Link to post

I saw a few others report this issue and figured I'd mention I'm also having it. Deluge use to work when assigning it an IP address without issues. The last few weeks now the web UI refuses to connect. Works fine in Bridge mode, but almost all my containers have their own IP so that wont work. I dont expect this to get fixed anytime soon or ever, but I'm sure it affects a  number of people.

Link to post

Does anyone know how well this works with the 'Hardlink instead of copy' option found in Sonarr and Radarr? I only have one torrent tracker attached to Sonarr/Radarr, and it's a private tracker that I want to be permaseeding on. I just wasn't sure if anyone has confirmed that it will keep seeding in deluge in this setup, after Sonarr/Radarr have ingested it on their end.

 

Edit: Also, I'm curious to know if it actually hardlinks, or if it's going to resort to copying between folders on the unraid server, which would mean taking double the space for every torrent downloaded.

Edited by Magic815
Link to post
18 hours ago, Kaninm said:

I saw a few others report this issue and figured I'd mention I'm also having it. Deluge use to work when assigning it an IP address without issues. The last few weeks now the web UI refuses to connect. Works fine in Bridge mode, but almost all my containers have their own IP so that wont work. I dont expect this to get fixed anytime soon or ever, but I'm sure it affects a  number of people.

 

15 hours ago, JustinM said:

You assigned an IP address? I use it in Bridge mode, so it should have the IP address of my NAS where Docker is running right?

 

 

I am using this container with an assigned IP address since I installed it a few months ago w/o any apparent issues...! 

 

7 hours ago, Magic815 said:

Does anyone know how well this works with the 'Hardlink instead of copy' option found in Sonarr and Radarr? I only have one torrent client attached to Sonarr/Radarr, it's a private tracker that I want to be permaseeding on. I just wasn't sure if anyone has confirmed that it will keep seeding in deluge in this setup, after Sonarr/Radarr have ingested it on their end.

 

Edit: Also, I'm curious to know if it actually hardlinks, or if it's going to resort to copying between folders on the unraid server, which would mean taking double the space for every torrent downloaded.

I couldn't make any PVR container as Radarr or Medusa to use "Hardlinks" successfully! The log mentions something as both locations not being on the same machine...

I use mostly newsgroups, so this is not a big of a deal for me at the moment, but if someone got "Hardlinks" working, please come forward and tell us what can we be doing wrong. 

 

 

Link to post

Was hoping that someone could take a look at my logs and figure out what's going wrong with the delugevpn docker that I have on my Synology NAS. Have been using it for a few months and had it working perfectly but it started not working last night for some reason. I'm able to start up the docker but am not able to access deluge either via the WebGUI or through the remote Deluge thin client on my laptop. Only thing I can think of is the LAN_NETWORK variable but I've tried the IP for both my home LAN Network (192.168.0.1) and the docker bridge network (172.17.0.1) without any luck. I previously had that variable set as the docker bridge network when I had the docker working. 

supervisord.log

Link to post
On 6/5/2018 at 7:17 PM, Magic815 said:

Does anyone know how well this works with the 'Hardlink instead of copy' option found in Sonarr and Radarr? I only have one torrent tracker attached to Sonarr/Radarr, and it's a private tracker that I want to be permaseeding on. I just wasn't sure if anyone has confirmed that it will keep seeding in deluge in this setup, after Sonarr/Radarr have ingested it on their end.

 

Edit: Also, I'm curious to know if it actually hardlinks, or if it's going to resort to copying between folders on the unraid server, which would mean taking double the space for every torrent downloaded.

 

Yes, the hardlinks option in sonarr/radarr should work for seeding with deluge and won't take double the space. I've had this setup running with sonarr/radarr and deluge for a few months with hardlinks for seeding.

Link to post
On 5/31/2018 at 1:51 PM, Gog said:

Hi there

 

In you deluge settings, in sonarr, does the test button work? 

Was the torrent fetched by sonarr?

Under what label is it under in deluge?

In Sonarr->activity, do you see it?

In sonarr->system->logs do you see an entry about that file? 





Hi,

Thank you for the response. Sonarr seems to have temporarily fixed itself, however, Radarr is now doing the same thing.

 

1. The test button works.

2. Torrent fetched by Radarr. 

3. No label in Deluge, despite set to movies.

4. In Radarr activity I see that it is grabbed.

5. 

Couldn't add report to download queue. Wind.River.2017.1080p.BluRay.H264.AAC-RARBG: Unable to connect to Deluge, please check your settings
NzbDrone.Core.Download.Clients.DownloadClientException: Unable to connect to Deluge, please check your settings ---> System.Net.WebException: The request timed out
  at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00059] in /build/mono/src/mono/mcs/class/System/System.Net/HttpWebRequest.cs:1033 
  at System.Net.HttpWebRequest.GetResponse () [0x0000e] in /build/mono/src/mono/mcs/class/System/System.Net/HttpWebRequest.cs:1045 
  at NzbDrone.Common.Http.Dispatchers.ManagedHttpDispatcher.GetResponse (NzbDrone.Common.Http.HttpRequest request, System.Net.CookieContainer cookies) [0x0012b] in C:\projects\radarr-usby1\src\NzbDrone.Common\Http\Dispatchers\ManagedHttpDispatcher.cs:74 
  at NzbDrone.Common.Http.Dispatchers.FallbackHttpDispatcher.GetResponse (NzbDrone.Common.Http.HttpRequest request, System.Net.CookieContainer cookies) [0x000cc] in C:\projects\radarr-usby1\src\NzbDrone.Common\Http\Dispatchers\FallbackHttpDispatcher.cs:58 
  at NzbDrone.Common.Http.HttpClient.ExecuteRequest (NzbDrone.Common.Http.HttpRequest request, System.Net.CookieContainer cookieContainer) [0x0007e] in C:\projects\radarr-usby1\src\NzbDrone.Common\Http\HttpClient.cs:114 
  at NzbDrone.Common.Http.HttpClient.Execute (NzbDrone.Common.Http.HttpRequest request) [0x00008] in C:\projects\radarr-usby1\src\NzbDrone.Common\Http\HttpClient.cs:50 
  at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.ExecuteRequest[TResult] (NzbDrone.Common.Http.JsonRpcRequestBuilder requestBuilder, System.String method, System.Object[] arguments) [0x0000e] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:213 
   --- End of inner exception stack trace ---
  at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.ExecuteRequest[TResult] (NzbDrone.Common.Http.JsonRpcRequestBuilder requestBuilder, System.String method, System.Object[] arguments) [0x0006f] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:234 
  at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.ProcessRequest[TResult] (NzbDrone.Core.Download.Clients.Deluge.DelugeSettings settings, System.String method, System.Object[] arguments) [0x00008] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:180 
  at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.SetLabel (System.String hash, System.String label, NzbDrone.Core.Download.Clients.Deluge.DelugeSettings settings) [0x00000] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:158 
  at NzbDrone.Core.Download.Clients.Deluge.Deluge.AddFromMagnetLink (NzbDrone.Core.Parser.Model.RemoteMovie remoteMovie, System.String hash, System.String magnetLink) [0x00025] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\Deluge\Deluge.cs:42 
  at NzbDrone.Core.Download.TorrentClientBase`1[TSettings].DownloadFromMagnetUrl (NzbDrone.Core.Parser.Model.RemoteMovie remoteMovie, System.String magnetUrl) [0x00048] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\TorrentClientBase.cs:214 
  at NzbDrone.Core.Download.TorrentClientBase`1[TSettings].Download (NzbDrone.Core.Parser.Model.RemoteMovie remoteMovie) [0x000f1] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\TorrentClientBase.cs:103 
  at NzbDrone.Core.Download.DownloadService.DownloadReport (NzbDrone.Core.Parser.Model.RemoteMovie remoteMovie, System.Boolean foceDownload) [0x000a3] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\DownloadService.cs:64 
  at NzbDrone.Core.Download.ProcessDownloadDecisions.ProcessDecisions (System.Collections.Generic.List`1[T] decisions) [0x00183] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\ProcessDownloadDecisions.cs:88 
Link to post
12 hours ago, mcjfauser said:

NzbDrone.Core.Download.Clients.DownloadClientException: Unable to connect to Deluge, please check your settings ---> System.Net.WebException: The request timed out at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00059] in /build/mono/src/mono/mcs/class/System/System.Net/HttpWebRequest.cs:1033 at System.Net.HttpWebRequest.GetResponse () [0x0000e] in /build/mono/src/mono/mcs/class/System/System.Net/HttpWebRequest.cs:1045 at NzbDrone.Common.Http.Dispatchers.ManagedHttpDispatcher.GetResponse (NzbDrone.Common.Http.HttpRequest request, System.Net.CookieContainer cookies) [0x0012b] in C:\projects\radarr-usby1\src\NzbDrone.Common\Http\Dispatchers\ManagedHttpDispatcher.cs:74 at NzbDrone.Common.Http.Dispatchers.FallbackHttpDispatcher.GetResponse (NzbDrone.Common.Http.HttpRequest request, System.Net.CookieContainer cookies) [0x000cc] in C:\projects\radarr-usby1\src\NzbDrone.Common\Http\Dispatchers\FallbackHttpDispatcher.cs:58 at NzbDrone.Common.Http.HttpClient.ExecuteRequest (NzbDrone.Common.Http.HttpRequest request, System.Net.CookieContainer cookieContainer) [0x0007e] in C:\projects\radarr-usby1\src\NzbDrone.Common\Http\HttpClient.cs:114 at NzbDrone.Common.Http.HttpClient.Execute (NzbDrone.Common.Http.HttpRequest request) [0x00008] in C:\projects\radarr-usby1\src\NzbDrone.Common\Http\HttpClient.cs:50 at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.ExecuteRequest[TResult] (NzbDrone.Common.Http.JsonRpcRequestBuilder requestBuilder, System.String method, System.Object[] arguments) [0x0000e] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:213 --- End of inner exception stack trace --- at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.ExecuteRequest[TResult] (NzbDrone.Common.Http.JsonRpcRequestBuilder requestBuilder, System.String method, System.Object[] arguments) [0x0006f] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:234 at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.ProcessRequest[TResult] (NzbDrone.Core.Download.Clients.Deluge.DelugeSettings settings, System.String method, System.Object[] arguments) [0x00008] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:180 at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.SetLabel (System.String hash, System.String label, NzbDrone.Core.Download.Clients.Deluge.DelugeSettings settings) [0x00000] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:158 at NzbDrone.Core.Download.Clients.Deluge.Deluge.AddFromMagnetLink (NzbDrone.Core.Parser.Model.RemoteMovie remoteMovie, System.String hash, System.String magnetLink) [0x00025] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\Deluge\Deluge.cs:42 at NzbDrone.Core.Download.TorrentClientBase`1[TSettings].DownloadFromMagnetUrl (NzbDrone.Core.Parser.Model.RemoteMovie remoteMovie, System.String magnetUrl) [0x00048] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\TorrentClientBase.cs:214 at NzbDrone.Core.Download.TorrentClientBase`1[TSettings].Download (NzbDrone.Core.Parser.Model.RemoteMovie remoteMovie) [0x000f1] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\TorrentClientBase.cs:103 at NzbDrone.Core.Download.DownloadService.DownloadReport (NzbDrone.Core.Parser.Model.RemoteMovie remoteMovie, System.Boolean foceDownload) [0x000a3] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\DownloadService.cs:64 at NzbDrone.Core.Download.ProcessDownloadDecisions.ProcessDecisions (System.Collections.Generic.List`1[T] decisions) [0x00183] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\ProcessDownloadDecisions.cs:88

 

I googled your error and there is a guy saying it's related to deluge labels:

https://github.com/Radarr/Radarr/issues/2502

 

Are you sure your labels are identical (check for case) in radarr and deluge?

 

Anything in the deluge logs (appdata\binhex-delugevpn\deluged.log)?

Link to post
On 5/31/2018 at 12:15 AM, Gog said:

In your appdata\delugevpn folder, in core.conf, do you have something like this:

 

 "enabled_plugins": [
    "Label"
  ], 

 

with label.conf containing the definition for all your label parameters?

 

How are your permissions ?

I'm like this:


root@Tower:/mnt/cache/cache_only/appdata# ls -l
drwxrwxr-x 10 nobody users 4096 May 31 00:00 binhex-delugevpn/


root@Tower:/mnt/cache/cache_only/appdata/binhex-delugevpn# ls -l
-rw-rw-rw- 1 nobody users   2527 May 30 23:12 core.conf
-rw-rw-rw- 1 nobody users  11765 May 31 00:00 label.conf

 

3

 

Thanks for your response. I do have label.conf, but my core.conf does not contain "Label" under "enabled_plugins"

 

My permissions are:

root@Tower:/mnt/cache/cache_only/appdata# ls -l
drwxrwxr-x 1 nobody users 534 Jun 11 00:00 binhex-delugevpn/


root@Tower:/mnt/cache/cache_only/appdata/binhex-delugevpn# ls -l
-rw-rw-rw- 1 nobody users   2438 Jun 11 23:12 core.conf
-rw-rw-rw- 1 nobody users   2094 Jun 11 00:00 label.conf

Do I need to reset permissions somehow? I read that "Docker Safe New Perms" will not work on appdata. What command would I use?

 

Thanks again,  Richard

 

Link to post

Permissions look ok. Try to stop the container and edit core.conf with a unix-friendly editor like notepad++ add label to the plugin list, save the file and start the container

 

Quote

Do I need to reset permissions somehow? I read that "Docker Safe New Perms" will not work on appdata. What command would I use?
 
Thanks again,  Richard


 

Edited by Gog
messed up the quote in tapatalk
Link to post
On 6/8/2018 at 4:47 PM, bravos89 said:

 

Yes, the hardlinks option in sonarr/radarr should work for seeding with deluge and won't take double the space. I've had this setup running with sonarr/radarr and deluge for a few months with hardlinks for seeding.

 

Are you sure? All research I've done seems to indicate hardlinking can never work across drives. And multiple drives in a share (which is what UnRAID does) is going to have that problem. In looking at my downloads, I see two copies of every torrent downloaded. One in the "Downloads" share, and one in the "Media" share. Maybe symlinking would work with UnRAID? It definitely is copying on my end, when I have the setting set to 'hardlink instead of copy.'

Edited by Magic815
Link to post
On 6/11/2018 at 8:32 PM, Magic815 said:

 

Are you sure? All research I've done seems to indicate hardlinking can never work across drives. And multiple drives in a share (which is what UnRAID does) is going to have that problem. In looking at my downloads, I see two copies of every torrent downloaded. One in the "Downloads" share, and one in the "Media" share. Maybe symlinking would work with UnRAID? It definitely is copying on my end, when I have the setting set to 'hardlink instead of copy.'

 

I've actually been running this on my synology device. Am thinking about moving to unRaid with a new build shortly though and I think you should be able to hardlink within a user share (just not across user shares).

 

 

Link to post
On 6/5/2018 at 6:01 PM, Kaninm said:

I saw a few others report this issue and figured I'd mention I'm also having it. Deluge use to work when assigning it an IP address without issues. The last few weeks now the web UI refuses to connect. Works fine in Bridge mode, but almost all my containers have their own IP so that wont work. I dont expect this to get fixed anytime soon or ever, but I'm sure it affects a  number of people.

 

I'm having a similar issue. I changed the network of deluge to Custom: br0 from Bridge according to the manual of letsencrypt docker. I struggeled to get Deluge working, but somehow after an unRAID reboot I was able to connect and nginx reverse proxy worked perfect. This worked for about a week, but today I had to reboot the docker due to a change in VPN config and now I'm not able to access the web-ui anymore.

 

I have tried anything that I can think of to get it up and running again without changing back to Bridge:

Restarting Deluge docker (20 times +/-)

Stopping and starting Docker service

Starting Deluge with no other dockers running

Rebooting the router

Rebooting unRAID

Started deluge docker in bridge, which works perfectly.

Link to post

i have an issue when i log in to the web gui for the server i get a blank list and an error msg saying that the connection was lost to the server. i have 653+ seeds. in order to get it back i have to login to the unraid server and restart the delugeVPN server. and it does not last long before i get the msg again. what can i do to help track down the problem? 

Link to post
39 minutes ago, Nicon4454 said:

i have 653+ seeds

Do you have this many torrents seeding? Then that's probably your issue. Deluge does not handle many torrents well, you should try rtorrentvpn instead which are reported to handle many torrents much better. If your container is stored on a cache pool, this can also part of the issue. Try switching to a single cache drive instead or use an unassigned device to store this container. I've had this issue myself on a cache pool, when I went back to only a single cache drive the issue was solved.

Link to post
On 6/6/2018 at 3:14 AM, InVisibleGoD said:

 

 

I am using this container with an assigned IP address since I installed it a few months ago w/o any apparent issues...! 

 

 

 

What version of Unraid are you running and do you have the IP assigned to br0?

I've tried every torrent VPN docker on the app store and they all have the same issue with not being able to connect to webUI when VPN is enabled and they are given a static ip on br0. They work fine when vpn is disabled or they are set to the bridge interface. Very frustrating as, like you, mine were working fine until a few weeks ago.

Edited by Kaninm
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.