Jump to content
binhex

[Support] binhex - DelugeVPN

4864 posts in this topic Last Reply

Recommended Posts

Quote

Where it says "Download to:" needs to be set to /downloads if you docker run command is current.

Actually it should be /downloads/incomplete and /downloads/complete

Edited by strike

Share this post


Link to post
1 minute ago, strike said:

Actually it should be /downloads/incomplete and /downloads/complete

Well... I switched it to /downloads from your first response, and it's downloading stuff now without any errors so far, where is this directory defined? I have been trying to fix this on my own for a week now and it's driving me insane. I'm so confused, and I think I have gotten more confused googling! LOL

 

I have switched it to be /downloads/incomplete /downloads/complete. Seems to be working fine now... 

Share this post


Link to post
3 minutes ago, strike said:

Actually it should be /downloads/incomplete and /downloads/complete

True. What I posted would work, but it's not what he intended to do.

@BennyD, what strike posted goes in the first and second blank.

 

Share this post


Link to post
1 minute ago, jonathanm said:

True. What I posted would work, but it's not what he intended to do.

@BennyD, what strike posted goes in the first and second blank.

 

Yeah, I noticed what was wrong with your post after setting it, I fixed it right after. 

 

I'm still confused as to where this /downloads directory is being set.

Share this post


Link to post
1 minute ago, BennyD said:

where is this directory defined?

The docker config page. You told it to map /mnt/user/Downloads on the host to /downloads on the container.

Share this post


Link to post
3 minutes ago, jonathanm said:

The docker config page. You told it to map /mnt/user/Downloads on the host to /downloads on the container.

Aha! Thanks! I was being confused because under the field I have the /mnt/user/Downloads defined it says "/data".

 

Thank you everyone for all of your help! GREATLY APPRECIATED!

Sorry to be such a rookie! I'm trying, I really am! Googling and some of the docker settings confuse me, the fields are very descriptive. Hehehe

 

@strike Yeah, I understand how the mapping works, I was just confused because it seems like every docker image, the directory your mapping to is just "labeled" as /data instead of in deluge that /data should really say /downloads, that's why I was so lost.

Edited by BennyD

Share this post


Link to post
2 minutes ago, BennyD said:

Aha! Thanks! I was being confused because under the field I have the /mnt/user/Downloads defined it says "/data".

screenshot?

Share this post


Link to post
2 minutes ago, BennyD said:

Thanks! I was being confused because under the field I have the /mnt/user/Downloads defined it says "/data".

/data should have been the default predefined value in the docker template when you installed it. At least it used to be.

Share this post


Link to post
2 minutes ago, BennyD said:

deluge2.png.4b512386110636e746aa45e2d7db29bd.png

That's strange. Can you click the EDIT button on that path and screenshot what shows up?

Share this post


Link to post

What @wgstarks said. What you did was change the container path to /downloads but forgot to change the description so if still said /data

Edited by strike

Share this post


Link to post
15 minutes ago, jonathanm said:

That's strange. Can you click the EDIT button on that path and screenshot what shows up?

 

14 minutes ago, strike said:

What @wgstarks said. What you did was change the container path to /downloads but forgot to change the description so if still said /data

 

Yeah, you guys are correct. the description wasn't changed and it was totally screwing with me!

 

docker.png

Share this post


Link to post

Just remember if you're using some of @binhex other containers like radarr etc, you'll have to do the same change in the volume mappings that you did with deluge. All of @binhex containers use /data as default, so if you don't change the mappings you'll have issues.

Share this post


Link to post

This situation has brought to light something that I think needs to be fixed. @bonienl, can you please take a look at the last several posts? Something needs to be changed to clarify the situation, but I'm not sure how to best approach it.

Share this post


Link to post
1 hour ago, jonathanm said:

This situation has brought to light something that I think needs to be fixed. @bonienl, can you please take a look at the last several posts? Something needs to be changed to clarify the situation, but I'm not sure how to best approach it.

What's wrong.  The description is just that - a description of what the mapping is for.  If the template authors don't enter in a description in English, then it's on them, not up to unRaid.

Share this post


Link to post
5 minutes ago, BennyD said:

@strike

Yeah, I only use binhex containers. 

Would you mind if I PM'd you? 

Sure, go ahead 

Share this post


Link to post
1 minute ago, Squid said:

What's wrong.  The description is just that - a description of what the mapping is for.  If the template authors don't enter in a description in English, then it's on them, not up to unRaid.

Yes, but hiding the actual container mapping totally seems wrong to me. I know WHY the decision was made to hide it, but it seems like hiding it is causing at least as many issues as it solved. Maybe displaying it but still not allowing the edit without a button push? It's not like there is a lack of real estate on that screen. Maybe display like this:

Unraid Host /mnt/user/appdata/whatever = /preconfigured inside docker container

for path and port entries.

 

The description would still show below the text to the right side of the = and only the unraid host entry could be changed without pressing edit.

 

Basically I'm just wanting more description around those fields and exposing the container side for inspection but not for direct editing for path and port entries.

 

 

Share this post


Link to post
19 hours ago, strike said:

1. The Netherlands doesn't support port forwarding anymore, switch to another supported endpoint.

2. Check your credentials, the ones you put in are failing. Please use only 0-9,a-z,A-Z characters. From your log:

 

ok, I have checked my Credetials and I have the Following within it  Characters ,  Numbers,  and special characters.  is this the cause I am having issues ? 

Share this post


Link to post
2 hours ago, chris_netsmart said:

ok, I have checked my Credetials and I have the Following within it  Characters ,  Numbers,  and special characters.  is this the cause I am having issues ? 

Possibly. Easy enough to check. BTW, special characters add very little to password security. Total length is MUCH more important. In general, if you substitute 2 random alphabet letters for each special character you had before you will be gaining a significant amount of brute force resistance.

Share this post


Link to post

I will look into my password.  But you didn't say how it would be easy to test ?

 

Regarding the password would something like this do ?

 

Ex3mp1ePassw0rd

Share this post


Link to post
13 minutes ago, chris_netsmart said:

But you didn't say how it would be easy to test ?

Change the password on your PIA account and see if it works. Letters and numbers should work I think.

Share this post


Link to post
16 hours ago, wgstarks said:

Change the password on your PIA account and see if it works. Letters and numbers should work I think.

Good morning

 

I tried changing my password too only have numbers and Letters and is allow over 20 Characters.

I just fired up the Deluge-VPN and again I am getting the same error

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.