Jump to content
binhex

[Support] binhex - DelugeVPN

5341 posts in this topic Last Reply

Recommended Posts

@bally12345 two issues i can see from your screenshot:-

 

1. upload lmit of 5KB/s - this is WAY too low, remember torrent protocol uses tit-for-tat, you wont get high download rates without giving back, increase this to around 70% of your max upload rate for your line.

 

2. incoming port set to random - i cant remember which vpn provider you are with, but without a working incoming port your speeds are going to be very low, you need to sort this, each vpn provider is different, for PIA i set this up for you.

Share this post


Link to post
21 minutes ago, binhex said:
[mention=62199]bally12345[/mention] two issues i can see from your screenshot:-

 

1. upload lmit of 5KB/s - this is WAY too low, remember torrent protocol uses tit-for-tat, you wont get high download rates without giving back, increase this to around 70% of your max upload rate for your line.

 

2. incoming port set to random - i cant remember which vpn provider you are with, but without a working incoming port your speeds are going to be very low, you need to sort this, each vpn provider is different, for PIA i set this up for you.

1. The upload limit I changed from unlimited to 5 now too 300 just to test.

 

2. Unchecked randomize ports

 

Still slow

 

 

withoutPrivoxy.png

withPrivoxy.png

Edited by bally12345
Speedtest results

Share this post


Link to post
2 minutes ago, binhex said:

you may of unchecked randomize incoming port, BUT have you allocated it a working incoming port from your vpn provider? please be aware of this Q16.:-

 

https://forums.unraid.net/topic/44108-support-binhex-general/?do=findComment&comment=433612

 

 

I am using PIA (Switzerland) STRICT_PORT_FORWARD is set to yes so it should be automatic is that correct? Might just restart the docker

Share this post


Link to post
Stopping container: binhex-delugevpn
Successfully stopped container 'binhex-delugevpn'



Removing container: binhex-delugevpn
Successfully removed container 'binhex-delugevpn'



Command:
root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='binhex-delugevpn' --net='bridge' --privileged=true -e TZ="Europe/London" -e HOST_OS="Unraid" -e 'VPN_ENABLED'='yes' -e 'VPN_USER'='REMOVED' -e 'VPN_PASS'='REMOVED' -e 'VPN_PROV'='pia' -e 'VPN_OPTIONS'='' -e 'STRICT_PORT_FORWARD'='yes' -e 'ENABLE_PRIVOXY'='yes' -e 'LAN_NETWORK'='192.168.1.0/24' -e 'NAME_SERVERS'='209.222.18.222,37.235.1.174,1.1.1.1,8.8.8.8,209.222.18.218,37.235.1.177,1.0.0.1,8.8.4.4' -e 'DELUGE_DAEMON_LOG_LEVEL'='info' -e 'DELUGE_WEB_LOG_LEVEL'='info' -e 'DEBUG'='false' -e 'UMASK'='000' -e 'PUID'='99' -e 'PGID'='100' -p '8112:8112/tcp' -p '58846:58846/tcp' -p '58946:58946/tcp' -p '58946:58946/udp' -p '8118:8118/tcp' -v '/mnt/user/Downloads/Deluge/':'/data':'rw' -v '/mnt/user/appdata/binhex-delugevpn':'/config':'rw' 'binhex/arch-delugevpn' 
339eedae0d06cbfe5c913062d60d72f3ef619952cd81446f131138362ca6cb32

The command finished successfully!

 

Share this post


Link to post
I am using PIA (Switzerland) STRICT_PORT_FORWARD is set to yes so it should be automatic is that correct? Might just restart the docker
Yes that is automatic, you will need to restart in order for the incoming port to be configured

Sent from my EML-L29 using Tapatalk

Share this post


Link to post
Yes that is automatic, you will need to restart in order for the incoming port to be configured

Sent from my EML-L29 using Tapatalk

Yeh still no good, after restarting the docker was getting good speeds on speedtest on my VM but deluge was still slow. Might try another app and see what happens.



Sent from my SM-G930F using Tapatalk

Share this post


Link to post
22 minutes ago, bally12345 said:

Yeh still no good, after restarting the docker was getting good speeds on speedtest on my VM but deluge was still slow. Might try another app and see what happens.



Sent from my SM-G930F using Tapatalk
 

did you check to see if deluge did indeed have a dynamically allocated incoming port?

Share this post


Link to post
did you check to see if deluge did indeed have a dynamically allocated incoming port?
Sorry how do I do that? I just tried rutorrentvpn that didn't even start downloading, tried activ-tranmission with PIA

My normal orignal transmission downloaded unbuntu at 28MB/s without any VPN

Im wondering if its something in my router settings I need to do

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
9 minutes ago, bally12345 said:

Sorry how do I do that?

you go to the deluge ui and where you had it enabled for random port it should now show a set port number.

 

9 minutes ago, bally12345 said:

Im wondering if its something in my router settings I need to do

nope nothing to do with your router as per my link to faq q16 earlier, however it is possible your router cannot cope with encrypted traffic, comercial grade (esp isp routers) are notoriously underpowered.

Edited by binhex

Share this post


Link to post
nope nothing to do with your router as per my link to faq q16 earlier, however it is possible your router cannot cope with encrypted traffic, comercial grade (esp isp routers) are notoriously underpowered.
Asus router, I could just setup PIA on my router but I only want it for my a few dockers.



Sent from my SM-G930F using Tapatalk

Share this post


Link to post

Really simple check, disabled VPN from container settings, restarted and download at 45MB/s

enable VPN and hit 1MB/s


I deleted everything and started again, so pretty vanilla setup other than entering the PIA credentials and 3 files to the openvpn folder now using FRANCE

 

 

Screenshot 2019-02-25 15.43.23.png

Share this post


Link to post
9 minutes ago, bally12345 said:

Really simple check, disabled VPN from container settings, restarted and download at 45MB/s

enable VPN and hit 1MB/s


I deleted everything and started again, so pretty vanilla setup other than entering the PIA credentials and 3 files to the openvpn folder now using FRANCE

 

 

Screenshot 2019-02-25 15.43.23.png

screenshot for the incoming port please, obviously with vpn enabled

Edited by binhex

Share this post


Link to post
3 minutes ago, binhex said:

screenshot for the incoming port please, obviously with vpn enabled

Network interface is now showing as 0.0.0.0 is that correct?

Screenshot 2019-02-25 15.59.02.png

Share this post


Link to post
9 minutes ago, bally12345 said:

Network interface is now showing as 0.0.0.0 is that correct?

yep thats normal, looks like the incoming port is now set correctly, and you are still limited to 1MB/s ?, i see you have redone things so double check upload rate/download rate etc as per my earlier post:-

 

have a look at the link below for hints on how to fix this, Q6:-

 

https://forums.unraid.net/topic/44108-support-binhex-general/?tab=comments#comment-433613

Share this post


Link to post
9 minutes ago, binhex said:

yep thats normal, looks like the incoming port is now set correctly, and you are still limited to 1MB/s ?, i see you have redone things so double check upload rate/download rate etc as per my earlier post:-

 

have a look at the link below for hints on how to fix this, Q6:-

 

https://forums.unraid.net/topic/44108-support-binhex-general/?tab=comments#comment-433613

Still no joy even after reading everything in the post I get zero improvement,

 

***UPDATE*** 

Found the fix here

Installed itconfig Plugin and disabled enable_incoming_utp and enable_outgoing_utp 

 

Now getting 20MB/s via VPN!!!! Happy days!

 

Share this post


Link to post
6 minutes ago, bally12345 said:

Installed itconfig Plugin and disabled enable_incoming_utp and enable_outgoing_utp 

hmm ok new one on me, fyi i did a quick torrent download of the same torrent as you, ubuntu 18.10 desktop and hit 3MB/s no probs, which is not too bad for my connection, thats without the above tweak *shrug*, glad you got something that works for you, i will add this to the faq.

Share this post


Link to post
10 hours ago, binhex said:

@Rudder2 this is the issue now:-

 


2019-02-24 19:32:47,525 DEBG 'start-script' stdout output:
Sun Feb 24 19:32:47 2019 [vpn] Inactivity timeout (--ping-restart), restarting

so for some reason the tunnel is establishing BUT the built in ping functionality in openvpn is terminating as it cannot ping the other end of the tunnel, this then results in the tunnel being torn down and re-created. 

 

so the question is, why is this happening?, well my guess is out of date ovpn file, not sure where you have got this from but i would double check with the vpn provider that its up to date, if it is then try another endpoint, maybe the endpoint you are connecting to (dallas) is a bit flaky. 

 

if you want a hassle free experience then switch to PIA, it just works.

Weird, because when I ping an IP address in the tunnel I get packets.  I cannot ping web addresses as it can't resolve the DNS.  I think the problem is a DNS problem. 

 

Share this post


Link to post
7 hours ago, bally12345 said:

Installed itconfig Plugin and disabled enable_incoming_utp and enable_outgoing_utp 

 

Now getting 20MB/s via VPN!!!! Happy days!

This is great. My speeds weren't bad before, but now they have more than doubled. Thx.

Share this post


Link to post
15 hours ago, binhex said:

@Rudder2 this is the issue now:-

 


2019-02-24 19:32:47,525 DEBG 'start-script' stdout output:
Sun Feb 24 19:32:47 2019 [vpn] Inactivity timeout (--ping-restart), restarting

so for some reason the tunnel is establishing BUT the built in ping functionality in openvpn is terminating as it cannot ping the other end of the tunnel, this then results in the tunnel being torn down and re-created. 

 

so the question is, why is this happening?, well my guess is out of date ovpn file, not sure where you have got this from but i would double check with the vpn provider that its up to date, if it is then try another endpoint, maybe the endpoint you are connecting to (dallas) is a bit flaky. 

 

if you want a hassle free experience then switch to PIA, it just works.

I'm sorry for doubting you.  You are right!  The Dallas A02 exit node was broken!!  I changed it to the Atlanta-a01 exit node and It says I have a VPN IP and a Deluge IP but I still can't access the WebUI.  And this time when I try to go to the Proxy port it says "Invalid header received from client." instead of "This site can’t be reached ERR_CONNECTION_REFUSED"!  Things are getting better!  Here is my supervisord.log again. 

 

Hopefully it's the last time.  Your AWESOME!  Thank you for your help!

supervisord.log

Edited by Rudder2

Share this post


Link to post
10 hours ago, bally12345 said:

 disabled enable_incoming_utp and enable_outgoing_utp

How do you disable theses?  In ItConfig, there are three boxes on these lines.  The left-hand box is unticked. The boxes under the 'Setting' and 'Actual' columns will not change state.

Share this post


Link to post
1 minute ago, PeterB said:

How do you disable theses?  In ItConfig, there are three boxes on these lines.  The left-hand box is unticked. The boxes under the 'Setting' and 'Actual' columns will not change state.

 

If you check the first column, you can then uncheck the one in the middle.  I don't know if it actually is working.

Share this post


Link to post
1 minute ago, PeterB said:

How do you disable theses?  In ItConfig, there are three boxes on these lines.  The left-hand box is unticked. The boxes under the 'Setting' and 'Actual' columns will not change state.

Select the “Setting” box and the select “Apply”. Should change the “Actual”.

Share this post


Link to post
1 hour ago, Pducharme said:

 

If you check the first column, you can then uncheck the one in the middle.  I don't know if it actually is working.

Thanks, that did it!

Share this post


Link to post
8 hours ago, Rudder2 said:

Things are getting better!  Here is my supervisord.log again. 

ok so i agree, def progress, looks like the tunnel is established and isnt now dropping which is good. so the issue with not being able to access the web ui is normally due to one (or both) of the following issues:-

 

1. LAN_NETWORK not defined correctly - see Q4 in the following link to verify you have this defined correctly.

https://forums.unraid.net/topic/44108-support-binhex-general/?tab=comments#comment-433613

 

2. Using custom bridge - custom bridge is not currently supported and doesn't work correctly, you need to use the default bridge.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.