Jump to content
binhex

[Support] binhex - DelugeVPN

5627 posts in this topic Last Reply

Recommended Posts

Hi guys!

 

Trying to use VPN in deluge but keep getting this error when starting up the docker:  Unrecognized option or missing or extra parameter(s) in [CMD-LINE]:1: auth-user-pass (2.4.6)

 

Using Privateinternetaccess via switzerland

 

Read throught this topic but could not make any sense of it... Not using any special character in id or password. Followed SpaceinvaderOne guide. I´ll link the sipervisord.log file and maybe someone can help me :)

 

All best!

// Linus

supervisord.log

Share this post


Link to post
52 minutes ago, linusgrip said:

Hi guys!

 

Trying to use VPN in deluge but keep getting this error when starting up the docker:  Unrecognized option or missing or extra parameter(s) in [CMD-LINE]:1: auth-user-pass (2.4.6)

 

Using Privateinternetaccess via switzerland

 

Read throught this topic but could not make any sense of it... Not using any special character in id or password. Followed SpaceinvaderOne guide. I´ll link the sipervisord.log file and maybe someone can help me :)

 

All best!

// Linus

supervisord.log

this is not correct:-

 

2019-03-27 17:09:38.628346 [info] VPN_OPTIONS defined as 'swiss.privateinternetaccess.com'

VPN_OPTIONS is used to define advanced openvpn options NOT the endpoint, this is controlled via the ovpn file that you copied to /config/openvpn/ which at present looking at your logs is the netherlands, if you want port forwarding working then do not use the netherlands (no longer supports port forwarding).

Edited by binhex

Share this post


Link to post
14 hours ago, strike said:

 

Edit the auth file located in your delugevpn appdata dir. Add the user/pass on a new line in this format: 


username:password:10

restart the container and you should be able to connect

so then when I try to connect to it on the remote machine i enter no username at all and then 10 as the password?

Share this post


Link to post
7 minutes ago, binhex said:

this is not correct:-

 


2019-03-27 17:09:38.628346 [info] VPN_OPTIONS defined as 'swiss.privateinternetaccess.com'

VPN_OPTIONS is used to define advanced openvpn options NOT the endpoint, this is controlled via the ovpn file that you copied to /config/openvpn/ which at present looking at your logs is the netherlands, if you want port forwarding working then do not use the netherlands (no longer supports port forwarding).

Thank you! Saved my day :) 

Share this post


Link to post
2 hours ago, rbh00723 said:

so then when I try to connect to it on the remote machine i enter no username at all and then 10 as the password?

no, you enter the username and password you set in the auth file. Where "username" is your username and "password" is your password.

Share this post


Link to post

I'm having trouble with deluge deleting completed torrents. 

 

I have a simple setup downloading to data/incomplete then moving finished ones to data/complete. It seems when I get to the complete part it's deleting things instead of moving to complete. Then the torrent has a status of "No such file at this location".

 

Anyone else ever see this? I'm wondering if maybe another app is interfering or something.

 

Thanks

Share this post


Link to post
13 minutes ago, shaunvis said:

I'm having trouble with deluge deleting completed torrents. 

 

I have a simple setup downloading to data/incomplete then moving finished ones to data/complete. It seems when I get to the complete part it's deleting things instead of moving to complete. Then the torrent has a status of "No such file at this location".

 

Anyone else ever see this? I'm wondering if maybe another app is interfering or something.

 

Thanks

Sounds more like a mapping issue. Post your docker mappings, and your storage paths in the deluge config.

Share this post


Link to post
Just now, jonathanm said:

Sounds more like a mapping issue. Post your docker mappings, and your storage paths in the deluge config.

I'd agree but it's not every torrent. Some work fine. 

 

For example yesterday I grabbed 2 versions of the same movie. One theatrical, one Director's cut.

 

They both finished. One went to the completed folder, the other disappeared and said there was no file at location /complete/filename. 

 

I turned off the move to completed option and am trying again but I'm wondering what else could cause something like this. 

 

Share this post


Link to post

Super Newb question - Can i only have a vpn for deluge and nothing else on my unraid machine?

How much will a vpn affect speeds?

Share this post


Link to post
11 minutes ago, FrozenGamer said:

Super Newb question - Can i only have a vpn for deluge and nothing else on my unraid machine?

How much will a vpn affect speeds?

You really want to use VPN with torrents, but you don't have to.

 

As for speed, in my experience it's been horrible. I have a gigabit connection and best I've seen is 5MB or so through VPN in Deluge. 

Share this post


Link to post
1 minute ago, shaunvis said:

You really want to use VPN with torrents, but you don't have to.

Will the container isolate vpn to just deluge though?  I would hate to have all other internet traffic on unraid go through vpn.

Share this post


Link to post
11 minutes ago, FrozenGamer said:

Will the container isolate vpn to just deluge though?  I would hate to have all other internet traffic on unraid go through vpn.

Yes, all other traffic by default will still use your main connection.

 

You can route other traffic through this docker's VPN, so if anything else needs security use this docker as a proxy.  Typically a VPN will only allow so many concurrent connections on an account.  By routing all home VPN traffic through one docker, it counts as one connection.  See SpaceInmvaderOne's video for more.

Share this post


Link to post
52 minutes ago, FrozenGamer said:

Super Newb question - Can i only have a vpn for deluge and nothing else on my unraid machine?

How much will a vpn affect speeds?

As far as speeds go I have noticed very little reduction using the VPN. Slow torrents are slow whether they go through the VPN or not. I've been able to saturate my connection to the point I have to throttle Deluge during certain times of the day.

Share this post


Link to post
31 minutes ago, eb3k said:

As far as speeds go I have noticed very little reduction using the VPN. Slow torrents are slow whether they go through the VPN or not. I've been able to saturate my connection to the point I have to throttle Deluge during certain times of the day.

Thanks everyone for the answers.  eb3k - what vpn are you using? I assume it makes difference for speeds.

 

 

Share this post


Link to post
5 minutes ago, FrozenGamer said:

Thanks everyone for the answers.  eb3k - what vpn are you using? I assume it makes difference for speeds.

 

 

I'm using Private Internet Access. I use the Switzerland endpoint for port forwarding. I don't know my top DL speeds, but with several at once I have definitely reached saturation.

Share this post


Link to post
You really want to use VPN with torrents, but you don't have to.
 
As for speed, in my experience it's been horrible. I have a gigabit connection and best I've seen is 5MB or so through VPN in Deluge. 
Then you have a problem, I have heard people typically getting speeds around 50MB/s and possibly higher using pia.

Sent from my EML-L29 using Tapatalk

Share this post


Link to post
23 hours ago, binhex said:

Then you have a problem, I have heard people typically getting speeds around 50MB/s and possibly higher using pia.

Sent from my EML-L29 using Tapatalk
 

Which  server are you using? 

 

I use PIA and have tested a few. Switzerland seems the fastest but still only 5mb tops. 

Edited by shaunvis

Share this post


Link to post

Hello, I've been having some issues lately with DelugeVPN in my server. I have both DelugeVPN (privoxy disabled) and QbittorentVPN (privoxy enabled). I use NordVPN. I set them up the same day and they have been working fine until DelugeVPN started acting up. It keeps timing out as I see in the WebUI. Everything says 0 seeds/peers/connection. Username/pass is same in both Deluge and Qbit so its not a Auth issue. Deluge and Qbit use different servers in the ovpn/crt/key files. I changed the server in Deluge it worked for about a month and stopped a few days ago. I don't know why it keeps happening only in Deluge though. What info can I provide so you can help me? Thanks

Share this post


Link to post

Hello, I just update my deluge and now it doesnt work, it got broken. I'm nost usre how to fix it.

It starts up but it wont download anything. It also look like it still trying to boot. Would someone Please help me?

Here is the log.

ErrorWarningSystemArrayLogin



2019-03-30 15:58:55,949 DEBG 'start-script' stdout output:
Sat Mar 30 15:58:55 2019 auth-token received, disabling auth-nocache for the authentication token

2019-03-30 15:58:55,950 DEBG 'start-script' stdout output:
Sat Mar 30 15:58:55 2019 TUN/TAP device tun0 opened

2019-03-30 15:58:55,950 DEBG 'start-script' stdout output:
Sat Mar 30 15:58:55 2019 do_ifconfig, tt->did_ifconfig_ipv6_setup=0
Sat Mar 30 15:58:55 2019 /usr/bin/ip link set dev tun0 up mtu 1500

2019-03-30 15:58:55,953 DEBG 'start-script' stdout output:
Sat Mar 30 15:58:55 2019 /usr/bin/ip addr add dev tun0 local 10.2.10.10 peer 10.2.10.9

2019-03-30 15:58:55,955 DEBG 'start-script' stdout output:
Sat Mar 30 15:58:55 2019 /root/openvpnup.sh tun0 1500 1558 10.2.10.10 10.2.10.9 init

2019-03-30 15:58:55,965 DEBG 'start-script' stdout output:
Sat Mar 30 15:58:55 2019 Initialization Sequence Completed

2019-03-30 15:58:56,069 DEBG 'watchdog-script' stdout output:
[info] Deluge listening interface IP 0.0.0.0 and VPN provider IP 10.2.10.10 different, marking for reconfigure

2019-03-30 15:58:56,069 DEBG 'privoxy-script' stdout output:
[info] Configuring Privoxy...

2019-03-30 15:58:56,076 DEBG 'watchdog-script' stdout output:
[info] Deluge not running

2019-03-30 15:58:56,083 DEBG 'watchdog-script' stdout output:
[info] Deluge Web UI not running

2019-03-30 15:58:56,088 DEBG 'start-script' stdout output:
[info] Attempting to curl https://www.privateinternetaccess.com/vpninfo/servers?version=82...

2019-03-30 15:58:56,099 DEBG 'privoxy-script' stdout output:
[info] All checks complete, starting Privoxy...

2019-03-30 15:58:56,100 DEBG 'privoxy-script' stderr output:
2019-03-30 15:58:56.100 1504b96e1100 Info: Privoxy version 3.0.26
2019-03-30 15:58:56.100 1504b96e1100 Info: Program name: /usr/bin/privoxy

2019-03-30 15:58:56,396 DEBG 'start-script' stdout output:
[info] Successfully retrieved external IP address 172.98.67.35

2019-03-30 15:58:56,464 DEBG 'start-script' stdout output:
[info] Curl successful for https://www.privateinternetaccess.com/vpninfo/servers?version=82, response code 200

2019-03-30 15:58:56,546 DEBG 'start-script' stdout output:
[info] List of PIA endpoints that support port forwarding:-

2019-03-30 15:58:56,546 DEBG 'start-script' stdout output:
[info] ca-toronto.privateinternetaccess.com
[info] ca-montreal.privateinternetaccess.com
[info] ca-vancouver.privateinternetaccess.com
[info] de-berlin.privateinternetaccess.com
[info] de-frankfurt.privateinternetaccess.com
[info] sweden.privateinternetaccess.com
[info] swiss.privateinternetaccess.com
[info] france.privateinternetaccess.com
[info] czech.privateinternetaccess.com
[info] spain.privateinternetaccess.com
[info] ro.privateinternetaccess.com
[info] israel.privateinternetaccess.com

2019-03-30 15:58:56,557 DEBG 'start-script' stdout output:
[info] Attempting to curl http://209.222.18.222:2000/?client_id=5fad20a37ef6474a2f91611aef507dc0a350af29c0ff76e2efcc74eafbc6643b...

2019-03-30 15:58:57,397 DEBG 'start-script' stdout output:
[info] Curl successful for http://209.222.18.222:2000/?client_id=5fad20a37ef6474a2f91611aef507dc0a350af29c0ff76e2efcc74eafbc6643b, response code 200

2019-03-30 15:58:57,493 DEBG 'watchdog-script' stdout output:
[info] Deluge incoming port 6890 and VPN incoming port 22146 different, marking for reconfigure

2019-03-30 15:58:57,494 DEBG 'watchdog-script' stdout output:
[info] Attempting to start Deluge...
[info] Removing deluge pid file (if it exists)...

2019-03-30 15:58:57,675 DEBG 'watchdog-script' stdout output:
[info] Deluge listening interface currently defined as 0.0.0.0
[info] Deluge listening interface will be changed to 0.0.0.0
[info] Saving changes to Deluge config file /config/core.conf...

2019-03-30 15:58:57,896 DEBG 'watchdog-script' stdout output:
[info] Deluge process started
[info] Waiting for Deluge process to start listening on port 58846...

2019-03-30 16:00:19,267 WARN received SIGTERM indicating exit request
2019-03-30 16:00:19,268 DEBG killing privoxy-script (pid 151) with signal SIGTERM
2019-03-30 16:00:19,268 INFO waiting for start-script, watchdog-script, privoxy-script to die
2019-03-30 16:00:19,268 DEBG fd 17 closed, stopped monitoring <POutputDispatcher at 23302974950864 for <Subprocess at 23302974949352 with name privoxy-script in state STOPPING> (stdout)>
2019-03-30 16:00:19,269 DEBG fd 21 closed, stopped monitoring <POutputDispatcher at 23302974951152 for <Subprocess at 23302974949352 with name privoxy-script in state STOPPING> (stderr)>
2019-03-30 16:00:19,269 INFO stopped: privoxy-script (terminated by SIGTERM)
2019-03-30 16:00:19,269 DEBG received SIGCLD indicating a child quit
2019-03-30 16:00:19,269 DEBG killing watchdog-script (pid 150) with signal SIGTERM
2019-03-30 16:00:19,270 DEBG fd 16 closed, stopped monitoring <POutputDispatcher at 23302974950576 for <Subprocess at 23302974949640 with name watchdog-script in state STOPPING> (stderr)>
2019-03-30 16:00:19,270 DEBG fd 11 closed, stopped monitoring <POutputDispatcher at 23302974950288 for <Subprocess at 23302974949640 with name watchdog-script in state STOPPING> (stdout)>
2019-03-30 16:00:19,270 INFO stopped: watchdog-script (terminated by SIGTERM)
2019-03-30 16:00:19,270 DEBG received SIGCLD indicating a child quit
2019-03-30 16:00:19,270 DEBG killing start-script (pid 149) with signal SIGTERM
2019-03-30 16:00:19,271 DEBG fd 8 closed, stopped monitoring <POutputDispatcher at 23302974949712 for <Subprocess at 23302974949496 with name start-script in state STOPPING> (stdout)>
2019-03-30 16:00:19,271 DEBG fd 10 closed, stopped monitoring <POutputDispatcher at 23302974950000 for <Subprocess at 23302974949496 with name start-script in state STOPPING> (stderr)>
2019-03-30 16:00:19,271 INFO stopped: start-script (terminated by SIGTERM)
2019-03-30 16:00:19,271 DEBG received SIGCLD indicating a child quit
Created by...
___. .__ .__
\_ |__ |__| ____ | |__ ____ ___ ___
| __ \| |/ \| | \_/ __ \\ \/ /
| \_\ \ | | \ Y \ ___/ > <
|___ /__|___| /___| /\___ >__/\_ \
\/ \/ \/ \/ \/
https://hub.docker.com/u/binhex/

2019-03-30 16:03:25.720649 [info] Host is running unRAID
2019-03-30 16:03:25.750854 [info] System information Linux 4af33b83e174 4.14.49-unRAID #1 SMP Mon Jun 11 16:21:07 PDT 2018 x86_64 GNU/Linux
2019-03-30 16:03:25.788137 [info] PUID defined as '99'
2019-03-30 16:03:25.834642 [info] PGID defined as '100'
2019-03-30 16:03:25.916297 [info] UMASK defined as '000'
2019-03-30 16:03:25.952626 [info] Permissions already set for volume mappings
2019-03-30 16:03:25.998000 [info] DELUGE_DAEMON_LOG_LEVEL not defined,(via -e DELUGE_DAEMON_LOG_LEVEL), defaulting to 'info'
2019-03-30 16:03:26.033826 [info] DELUGE_WEB_LOG_LEVEL not defined,(via -e DELUGE_WEB_LOG_LEVEL), defaulting to 'info'
2019-03-30 16:03:26.068968 [info] VPN_ENABLED defined as 'yes'
2019-03-30 16:03:26.128143 [info] OpenVPN config file (ovpn extension) is located at /config/openvpn/Netherlands.ovpn
dos2unix: converting file /config/openvpn/Netherlands.ovpn to Unix format...
2019-03-30 16:03:26.193627 [info] VPN remote line defined as 'remote nl.privateinternetaccess.com 1198'
2019-03-30 16:03:26.229486 [info] VPN_REMOTE defined as 'nl.privateinternetaccess.com'
2019-03-30 16:03:26.264624 [info] VPN_PORT defined as '1198'
2019-03-30 16:03:26.307750 [info] VPN_PROTOCOL defined as 'udp'
2019-03-30 16:03:26.344735 [info] VPN_DEVICE_TYPE defined as 'tun0'
2019-03-30 16:03:26.377915 [info] VPN_PROV defined as 'pia'
2019-03-30 16:03:26.413241 [info] LAN_NETWORK defined as '10.0.0.0/24'
2019-03-30 16:03:26.449264 [info] NAME_SERVERS defined as '209.222.18.222,37.235.1.174,8.8.8.8,209.222.18.218,37.235.1.177,8.8.4.4'
2019-03-30 16:03:26.483984 [info] VPN_USER defined as 'p7'
2019-03-30 16:03:26.519129 [info] VPN_PASS defined as '90210'
2019-03-30 16:03:26.552178 [info] VPN_OPTIONS not defined (via -e VPN_OPTIONS)
2019-03-30 16:03:26.587060 [info] STRICT_PORT_FORWARD defined as 'yes'
2019-03-30 16:03:26.618852 [info] ENABLE_PRIVOXY defined as 'yes'
2019-03-30 16:03:26.654262 [info] Starting Supervisor...
2019-03-30 16:03:26,929 INFO Included extra file "/etc/supervisor/conf.d/delugevpn.conf" during parsing
2019-03-30 16:03:26,929 INFO Set uid to user 0 succeeded
2019-03-30 16:03:26,933 INFO supervisord started with pid 7
2019-03-30 16:03:27,936 INFO spawned: 'start-script' with pid 149
2019-03-30 16:03:27,938 INFO spawned: 'watchdog-script' with pid 150
2019-03-30 16:03:27,939 INFO spawned: 'privoxy-script' with pid 151
2019-03-30 16:03:27,939 INFO reaped unknown pid 8
2019-03-30 16:03:27,945 DEBG 'start-script' stdout output:
[info] VPN is enabled, beginning configuration of VPN

2019-03-30 16:03:27,945 INFO success: start-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2019-03-30 16:03:27,945 INFO success: watchdog-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2019-03-30 16:03:27,946 INFO success: privoxy-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2019-03-30 16:03:27,953 DEBG 'watchdog-script' stderr output:
dos2unix: converting file /config/core.conf to Unix format...

2019-03-30 16:03:27,965 DEBG 'start-script' stdout output:
[warn] Password contains characters which could cause authentication issues, please consider changing this if possible

2019-03-30 16:03:28,059 DEBG 'start-script' stdout output:
[info] Default route for container is 172.17.0.1

2019-03-30 16:03:28,067 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.222 to /etc/resolv.conf

2019-03-30 16:03:28,073 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.174 to /etc/resolv.conf

2019-03-30 16:03:28,077 DEBG 'start-script' stdout output:
[info] Adding 8.8.8.8 to /etc/resolv.conf

2019-03-30 16:03:28,084 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.218 to /etc/resolv.conf

2019-03-30 16:03:28,090 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.177 to /etc/resolv.conf

2019-03-30 16:03:28,096 DEBG 'start-script' stdout output:
[info] Adding 8.8.4.4 to /etc/resolv.conf

2019-03-30 16:03:28,206 DEBG 'start-script' stdout output:
[info] Docker network defined as 172.17.0.0/16

2019-03-30 16:03:28,213 DEBG 'start-script' stdout output:
[info] Adding 10.0.0.0/24 as route via docker eth0

2019-03-30 16:03:28,214 DEBG 'start-script' stdout output:
[info] ip route defined as follows...
--------------------

2019-03-30 16:03:28,216 DEBG 'start-script' stdout output:
default via 172.17.0.1 dev eth0
10.0.0.0/24 via 172.17.0.1 dev eth0
172.17.0.0/16 dev eth0 proto kernel scope link src 172.17.0.2

2019-03-30 16:03:28,216 DEBG 'start-script' stdout output:
--------------------

2019-03-30 16:03:28,222 DEBG 'start-script' stdout output:
iptable_mangle 16384 1
ip_tables 24576 3 iptable_mangle,iptable_filter,iptable_nat

2019-03-30 16:03:28,223 DEBG 'start-script' stdout output:
[info] iptable_mangle support detected, adding fwmark for tables

2019-03-30 16:03:28,417 DEBG 'start-script' stdout output:
[info] iptables defined as follows...
--------------------

2019-03-30 16:03:28,420 DEBG 'start-script' stdout output:
-P INPUT DROP
-P FORWARD ACCEPT
-P OUTPUT DROP
-A INPUT -i tun0 -j ACCEPT
-A INPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT
-A INPUT -i eth0 -p udp -m udp --sport 1198 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 8112 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --sport 8112 -j ACCEPT
-A INPUT -s 10.0.0.0/24 -i eth0 -p tcp -m tcp --dport 58846 -j ACCEPT
-A INPUT -s 10.0.0.0/24 -d 172.17.0.0/16 -i eth0 -p tcp -j ACCEPT
-A INPUT -p icmp -m icmp --icmp-type 0 -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A OUTPUT -o tun0 -j ACCEPT
-A OUTPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT
-A OUTPUT -o eth0 -p udp -m udp --dport 1198 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --dport 8112 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 8112 -j ACCEPT
-A OUTPUT -d 10.0.0.0/24 -o eth0 -p tcp -m tcp --sport 58846 -j ACCEPT
-A OUTPUT -s 172.17.0.0/16 -d 10.0.0.0/24 -o eth0 -p tcp -j ACCEPT
-A OUTPUT -p icmp -m icmp --icmp-type 8 -j ACCEPT
-A OUTPUT -o lo -j ACCEPT

2019-03-30 16:03:28,420 DEBG 'start-script' stdout output:
--------------------

2019-03-30 16:03:28,422 DEBG 'start-script' stdout output:
[info] Starting OpenVPN...

2019-03-30 16:03:28,475 DEBG 'start-script' stdout output:
Sat Mar 30 16:03:28 2019 WARNING: file 'credentials.conf' is group or others accessible
Sat Mar 30 16:03:28 2019 OpenVPN 2.4.6 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Apr 24 2018

2019-03-30 16:03:28,475 DEBG 'start-script' stdout output:
Sat Mar 30 16:03:28 2019 library versions: OpenSSL 1.1.1a 20 Nov 2018, LZO 2.10

2019-03-30 16:03:28,476 DEBG 'start-script' stdout output:
[info] OpenVPN started

2019-03-30 16:03:28,476 DEBG 'start-script' stdout output:
Sat Mar 30 16:03:28 2019 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

2019-03-30 16:03:28,477 DEBG 'start-script' stdout output:
Sat Mar 30 16:03:28 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]46.166.190.219:1198
Sat Mar 30 16:03:28 2019 UDP link local: (not bound)
Sat Mar 30 16:03:28 2019 UDP link remote: [AF_INET]46.166.190.219:1198

2019-03-30 16:03:28,927 DEBG 'start-script' stdout output:
Sat Mar 30 16:03:28 2019 [de6130aaccbd799fd05c50e178d01bd5] Peer Connection Initiated with [AF_INET]46.166.190.219:1198

2019-03-30 16:03:30,293 DEBG 'start-script' stdout output:
Sat Mar 30 16:03:30 2019 auth-token received, disabling auth-nocache for the authentication token

2019-03-30 16:03:30,293 DEBG 'start-script' stdout output:
Sat Mar 30 16:03:30 2019 TUN/TAP device tun0 opened

2019-03-30 16:03:30,293 DEBG 'start-script' stdout output:
Sat Mar 30 16:03:30 2019 do_ifconfig, tt->did_ifconfig_ipv6_setup=0
Sat Mar 30 16:03:30 2019 /usr/bin/ip link set dev tun0 up mtu 1500

2019-03-30 16:03:30,296 DEBG 'start-script' stdout output:
Sat Mar 30 16:03:30 2019 /usr/bin/ip addr add dev tun0 local 10.32.10.6 peer 10.32.10.5

,654 DEBG 'start-script' stdout output:
Sat Mar 30 16:23:08 2019 SIGINT[hard,] received, process exiting

2019-03-30 16:23:30,793 DEBG 'start-script' stdout output:
[warn] OpenVPN process terminated, restarting OpenVPN...

 

not sure if this part is in the posted log!


2019-03-30 18:31:07,023 DEBG 'start-script' stdout output:
[info] Curl successful for https://www.privateinternetaccess.com/vpninfo/servers?version=82, response code 200

2019-03-30 18:31:07,103 DEBG 'start-script' stdout output:
[warn] PIA endpoint 'nl.privateinternetaccess.com' is not in the list of endpoints that support port forwarding, DL/UL speeds maybe slow
[info] Please consider switching to one of the endpoints shown below

2019-03-30 18:31:07,103 DEBG 'start-script' stdout output:
[info] List of PIA endpoints that support port forwarding:-
[info] ca-toronto.privateinternetaccess.com
[info] ca-montreal.privateinternetaccess.com
[info] ca-vancouver.privateinternetaccess.com
[info] de-berlin.privateinternetaccess.com
[info] de-frankfurt.privateinternetaccess.com
[info] sweden.privateinternetaccess.com
[info] swiss.privateinternetaccess.com
[info] france.privateinternetaccess.com
[info] czech.privateinternetaccess.com
[info] spain.privateinternetaccess.com
[info] ro.privateinternetaccess.com
[info] israel.privateinternetaccess.com

2019-03-30 18:31:07,114 DEBG 'start-script' stdout output:
[info] Attempting to curl http://209.222.18.222:2000/?client_id=4c0079a3c8b77219f56d2b0ee70770a2301ba397ef3aab907654588370706880...

2019-03-30 18:31:07,228 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0
[info] 12 retries left
[info] Retrying in 10 secs...

2019-03-30 18:31:17,345 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0
[info] 11 retries left
[info] Retrying in 10 secs...

2019-03-30 18:31:27,462 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0
[info] 10 retries left
[info] Retrying in 10 secs...

2019-03-30 18:31:37,579 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0
[info] 9 retries left
[info] Retrying in 10 secs...

2019-03-30 18:31:47,694 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0
[info] 8 retries left
[info] Retrying in 10 secs...

2019-03-30 18:31:57,812 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0
[info] 7 retries left
[info] Retrying in 10 secs...

2019-03-30 18:32:07,928 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0
[info] 6 retries left
[info] Retrying in 10 secs...

2019-03-30 18:32:18,045 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0

2019-03-30 18:32:18,045 DEBG 'start-script' stdout output:
[info] 5 retries left
[info] Retrying in 10 secs...

2019-03-30 18:32:18,045 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0

2019-03-30 18:32:18,045 DEBG 'start-script' stdout output:
[info] 5 retries left
[info] Retrying in 10 secs...

2019-03-30 18:32:28,164 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0
[info] 4 retries left
[info] Retrying in 10 secs...

2019-03-30 18:32:28,164 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0
[info] 4 retries left
[info] Retrying in 10 secs...

2019-03-30 18:32:38,279 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0
[info] 3 retries left
[info] Retrying in 10 secs...

2019-03-30 18:32:48,394 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0
[info] 2 retries left
[info] Retrying in 10 secs...

2019-03-30 18:32:58,513 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0
[info] 1 retries left
[info] Retrying in 10 secs...

2019-03-30 18:33:08,628 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx, exhausted retries exiting script...

2019-03-30 18:33:08,629 DEBG 'start-script' stdout output:
[warn] PIA VPN port assignment API currently down, terminating OpenVPN process to force retry for incoming port...

2019-03-30 18:33:08,631 DEBG 'start-script' stdout output:
Sat Mar 30 18:33:08 2019 event_wait : Interrupted system call (code=4)

2019-03-30 18:33:08,640 DEBG 'start-script' stdout output:
Sat Mar 30 18:33:08 2019 /usr/bin/ip addr del dev tun0 local 10.4.10.6 peer 10.4.10.5

2019-03-30 18:33:08,652 DEBG 'st

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Edited by diehard2k9

Share this post


Link to post

@diehard2k9 see the second post in this thread for the answer.

Sent from my EML-L29 using Tapatalk

Share this post


Link to post

So i'm at a loss. I've spent the better part of 2 days investigating potential fixes. So let me start with a TL;DR before going too far.

  • Issue 1 (Original issue). Uploads are excessively slow, DL's are perfect. 
  • Issue 2 (After countless different fixes for issue 1). If i reboot my deluge it wont let me go into the UI unless i go and delete the Daemon port line from core config.

Trying to seed more, and in doing so i noticed my uploads are very slow. I get 250/10 (mbps) from comcast and run PIA. I've been using deluge without issue for 6 months but never paid attention to my upload speeds. I can easily get 100+mpbs download but nothing over 150k upload.

 

I reinstalled deluge, redoing the PIA settings found here, no issues. I tried both Toronto and Montreal (because of endpoint stuff) still ran the same as before. I followed a few guides online for settings in deluge as well as setting up itConfig.

 

At some point during this process something got messed up if/when i reboot deluge i cannot get back into the Gui until i got into core.conf and delete   "daemon_port": 58846,  line. After this i restart the container and it works fine.

 

*EDIT* Of note, the uploads run high at restart or after restarting a torrent. (150kbps) but then drop down to 1-2kbps.

 

Quote

{
  "file": 1, 
  "format": 1
}{
  "info_sent": 0.0, 
  "lsd": true, 
  "max_download_speed": 12000.0, 
  "send_info": false, 
  "natpmp": true, 
  "move_completed_path": "/data/completed/movies", 
  "peer_tos": "0x00", 
  "enc_in_policy": 1, 
  "queue_new_to_top": false, 
  "enc_out_policy": 1, 
  "ignore_limits_on_local_network": true, 
  "rate_limit_ip_overhead": false, 
  "daemon_port": 58846, 
  "torrentfiles_location": "/data/torrents", 
  "max_active_limit": 15, 
  "geoip_db_location": "/usr/share/GeoIP/GeoIP.dat", 
  "upnp": true, 
  "utpex": true, 
  "max_active_downloading": 10, 
  "max_active_seeding": 15, 
  "allow_remote": false, 
  "outgoing_ports": [
    39683, 
    39683
  ], 
  "enabled_plugins": [
    "Label", 
    "Blocklist", 
    "Extractor", 
    "ltConfig"
  ], 
  "max_half_open_connections": 20, 
  "download_location": "/data/incomplete", 
  "compact_allocation": false, 
  "max_upload_speed": 950.0, 
  "max_connections_global": 250, 
  "enc_prefer_rc4": true, 
  "random_port": false, 
  "cache_expiry": 60, 
  "max_upload_slots_per_torrent": 8, 
  "stop_seed_at_ratio": false, 
  "stop_seed_ratio": 2.0, 
  "max_download_speed_per_torrent": -1, 
  "prioritize_first_last_pieces": true, 
  "max_upload_speed_per_torrent": -1, 
  "auto_managed": true, 
  "enc_level": 2, 
  "copy_torrent_file": true, 
  "max_connections_per_second": 10, 
  "listen_ports": [
    46064, 
    46064
  ], 
  "del_copy_torrent_file": false, 
  "move_completed": true, 
  "autoadd_enable": false, 
  "proxies": {
    "peer": {
      "username": "", 
      "password": "", 
      "type": 0, 
      "hostname": "", 
      "port": 8080
    }, 
    "web_seed": {
      "username": "", 
      "password": "", 
      "type": 0, 
      "hostname": "", 
      "port": 8080
    }, 
    "tracker": {
      "username": "", 
      "password": "", 
      "type": 0, 
      "hostname": "", 
      "port": 8080
    }, 
    "dht": {
      "username": "", 
      "password": "", 
      "type": 0, 
      "hostname": "", 
      "port": 8080
    }
  }, 
  "dont_count_slow_torrents": false, 
  "add_paused": false, 
  "random_outgoing_ports": true, 
  "dht": true, 
  "new_release_check": false, 
  "max_connections_per_torrent": 120, 
  "seed_time_ratio_limit": 7.0, 
  "remove_seed_at_ratio": false, 
  "autoadd_location": "/data/watched", 
  "max_upload_slots_global": 20, 
  "seed_time_limit": 180, 
  "cache_size": 1024, 
  "share_ratio_limit": 2.0, 
  "plugins_location": "/config/plugins", 
  "listen_interface": "0.0.0.0"
}

 

Edited by Remamian

Share this post


Link to post
2 minutes ago, Remamian said:

So i'm at a loss. I've spent the better part of 2 days investigating potential fixes.

Why did you post this in 2 different threads? Crossposting like that is incredibly unproductive, on 2 points.

1. The two threads you posted in are for 2 DIFFERENT implementations. They are supported by different people. You need to only post in the actual area that applies.

2. Responses to you in the different areas aren't guaranteed to be read by others trying to help. It's incredibly frustrating to spend a significant period of time analyzing and composing a response, only to realize that someone else went through the exact same procedure in the other thread.

 

Please remove whichever post is in the thread that is wrong.

Share this post


Link to post
3 minutes ago, jonathanm said:

Why did you post this in 2 different threads? Crossposting like that is incredibly unproductive, on 2 points.

1. The two threads you posted in are for 2 DIFFERENT implementations. They are supported by different people. You need to only post in the actual area that applies.

2. Responses to you in the different areas aren't guaranteed to be read by others trying to help. It's incredibly frustrating to spend a significant period of time analyzing and composing a response, only to realize that someone else went through the exact same procedure in the other thread.

 

Please remove whichever post is in the thread that is wrong.

 

Already realized the  point you made and deleted the other. before you responded. I originally thought i was posting to Binhex but had already made the mistake. Thanks for looking out though!

Edited by Remamian
Clarification

Share this post


Link to post
22 minutes ago, Remamian said:

I originally thought i was posting to Binhex

You can always go directly to the correct support thread for any of your dockers by simply clicking on its icon and selecting Support.

Share this post


Link to post
41 minutes ago, trurl said:

You can always go directly to the correct support thread for any of your dockers by simply clicking on its icon and selecting Support.

Oh thank you! Thats fantastic to know! In this case it is for Binhex Deluge VPN so i do have the correct forum.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.