Jump to content
binhex

[Support] binhex - DelugeVPN

5786 posts in this topic Last Reply

Recommended Posts

My sonarr container cannot connect to my delugevpn container when vpn is enabled. I use pia.
When VPN_ENABLED is set to 'no', sonarr can connect to deluge without issues.

I also tried setting VPN_ENABLED set to 'yes' and STRICT_PORT_FORWARD set to 'no'. sonarr fails to connect to deluge in this case too.

I use fixed IPs for the docker containers.

 

Disclaimer: I have the same issue with qbittorrentvpn. It seems that deluge is more popular, hence I gave it a try too (and the cross posting). I will update both posts once I can figure this out.

Edited by Jenardo

Share this post


Link to post
On 4/5/2019 at 2:02 PM, Jenardo said:

My sonarr container cannot connect to my delugevpn container when vpn is enabled. I use pia.
When VPN_ENABLED is set to 'no', sonarr can connect to deluge without issues.

I also tried setting VPN_ENABLED set to 'yes' and STRICT_PORT_FORWARD set to 'no'. sonarr fails to connect to deluge in this case too.

I use fixed IPs for the docker containers.

 

Disclaimer: I have the same issue with qbittorrentvpn. It seems that deluge is more popular, hence I gave it a try too (and the cross posting). I will update both posts once I can figure this out.

I am seeing this as well. Is there a way to check the status of the proxy aside from the logs?

Share this post


Link to post

Anyone else having issues removing torrents and removing torrents and data? I'm unable to delete any with out the application crashing.


Error: 

The connection to the webserver has been lost!

 

Edit:

I was able to resolve this by fully deleting deluge and re-downloading it from the apps store

Edited by Payyn

Share this post


Link to post

Everything was working but then randomly I got the following error. I tried using the various OpenVPN config files provided by PIA on their website (UDP, IP, TCP, etc..). When I use the UDP files I get the error below:
 

2019-04-09 01:37:49,207 DEBG 'start-script' stdout output:,
Tue Apr  9 01:37:49 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:37:57,318 DEBG 'start-script' stdout output:,
Tue Apr  9 01:37:57 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:38:13,402 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:13 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:38:43,844 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:43 2019 [UNDEF] Inactivity timeout (--ping-restart), restarting,
,
2019-04-09 01:38:43,845 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:43 2019 SIGHUP[soft,ping-restart] received, process restarting,
,
2019-04-09 01:38:44,109 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:44 2019 WARNING: file 'credentials.conf' is group or others accessible,
Tue Apr  9 01:38:44 2019 OpenVPN 2.4.6 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Apr 24 2018,
Tue Apr  9 01:38:44 2019 library versions: OpenSSL 1.1.1a  20 Nov 2018, LZO 2.10,
,
2019-04-09 01:38:49,110 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:49 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]172.98.67.25:1198,
Tue Apr  9 01:38:49 2019 UDP link local: (not bound),
Tue Apr  9 01:38:49 2019 UDP link remote: [AF_INET]172.98.67.25:1198,
,
2019-04-09 01:38:49,110 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:49 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:38:51,134 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:51 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:38:55,181 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:55 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:39:03,805 DEBG 'start-script' stdout output:,
Tue Apr  9 01:39:03 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:39:20,046 DEBG 'start-script' stdout output:,
Tue Apr  9 01:39:20 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:39:49,276 DEBG 'start-script' stdout output:,
Tue Apr  9 01:39:49 2019 [UNDEF] Inactivity timeout (--ping-restart), restarting,
,
2019-04-09 01:39:49,280 DEBG 'start-script' stdout output:,
Tue Apr  9 01:39:49 2019 SIGHUP[soft,ping-restart] received, process restarting,
,
2019-04-09 01:39:49,337 DEBG 'start-script' stdout output:,
Tue Apr  9 01:39:49 2019 WARNING: file 'credentials.conf' is group or others accessible,
Tue Apr  9 01:39:49 2019 OpenVPN 2.4.6 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Apr 24 2018,
Tue Apr  9 01:39:49 2019 library versions: OpenSSL 1.1.1a  20 Nov 2018, LZO 2.10,
,
2019-04-09 01:39:54,337 DEBG 'start-script' stdout output:,
Tue Apr  9 01:39:54 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]172.98.67.46:1198,
Tue Apr  9 01:39:54 2019 UDP link local: (not bound),
Tue Apr  9 01:39:54 2019 UDP link remote: [AF_INET]172.98.67.46:1198,
,
2019-04-09 01:39:54,338 DEBG 'start-script' stdout output:,
Tue Apr  9 01:39:54 2019 write UDP: Operation not permitted (code=1),

 

My config file worked before, so I don't think that's the cause of an issue. 

Edited by emteedubs

Share this post


Link to post
6 hours ago, emteedubs said:

Everything was working but then randomly I got the following error. I tried using the various OpenVPN config files provided by PIA on their website (UDP, IP, TCP, etc..). When I use the UDP files I get the error below:
 


2019-04-09 01:37:49,207 DEBG 'start-script' stdout output:,
Tue Apr  9 01:37:49 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:37:57,318 DEBG 'start-script' stdout output:,
Tue Apr  9 01:37:57 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:38:13,402 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:13 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:38:43,844 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:43 2019 [UNDEF] Inactivity timeout (--ping-restart), restarting,
,
2019-04-09 01:38:43,845 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:43 2019 SIGHUP[soft,ping-restart] received, process restarting,
,
2019-04-09 01:38:44,109 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:44 2019 WARNING: file 'credentials.conf' is group or others accessible,
Tue Apr  9 01:38:44 2019 OpenVPN 2.4.6 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Apr 24 2018,
Tue Apr  9 01:38:44 2019 library versions: OpenSSL 1.1.1a  20 Nov 2018, LZO 2.10,
,
2019-04-09 01:38:49,110 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:49 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]172.98.67.25:1198,
Tue Apr  9 01:38:49 2019 UDP link local: (not bound),
Tue Apr  9 01:38:49 2019 UDP link remote: [AF_INET]172.98.67.25:1198,
,
2019-04-09 01:38:49,110 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:49 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:38:51,134 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:51 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:38:55,181 DEBG 'start-script' stdout output:,
Tue Apr  9 01:38:55 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:39:03,805 DEBG 'start-script' stdout output:,
Tue Apr  9 01:39:03 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:39:20,046 DEBG 'start-script' stdout output:,
Tue Apr  9 01:39:20 2019 write UDP: Operation not permitted (code=1),
,
2019-04-09 01:39:49,276 DEBG 'start-script' stdout output:,
Tue Apr  9 01:39:49 2019 [UNDEF] Inactivity timeout (--ping-restart), restarting,
,
2019-04-09 01:39:49,280 DEBG 'start-script' stdout output:,
Tue Apr  9 01:39:49 2019 SIGHUP[soft,ping-restart] received, process restarting,
,
2019-04-09 01:39:49,337 DEBG 'start-script' stdout output:,
Tue Apr  9 01:39:49 2019 WARNING: file 'credentials.conf' is group or others accessible,
Tue Apr  9 01:39:49 2019 OpenVPN 2.4.6 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Apr 24 2018,
Tue Apr  9 01:39:49 2019 library versions: OpenSSL 1.1.1a  20 Nov 2018, LZO 2.10,
,
2019-04-09 01:39:54,337 DEBG 'start-script' stdout output:,
Tue Apr  9 01:39:54 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]172.98.67.46:1198,
Tue Apr  9 01:39:54 2019 UDP link local: (not bound),
Tue Apr  9 01:39:54 2019 UDP link remote: [AF_INET]172.98.67.46:1198,
,
2019-04-09 01:39:54,338 DEBG 'start-script' stdout output:,
Tue Apr  9 01:39:54 2019 write UDP: Operation not permitted (code=1),

 

My config file worked before, so I don't think that's the cause of an issue. 

most probably firewall/router changes blocking outbound access to 1198, check firewall on host, hardware firewall and router, and check vlan as well if you have any setup.

Share this post


Link to post

I am trying a clean install, and I am getting this error. I have check and the port 58846 is not used in another docker. Any ideas? 

 

/usr/bin/docker: Error response from daemon: driver failed programming external connectivity on endpoint binhex-delugevpn (e36aed7be5b7ce9dc2dce4098c79fb65a479d4f9cc40e3f925977d8d07571430): Error starting userland proxy: listen tcp 0.0.0.0:58846: bind: address already in use.

I was running binhex-privoxy but I disabled that for the time being and getting the same error. 

 

 

EDIT: a reboot seems to have cleared it up. 

Edited by ice pube

Share this post


Link to post
On 12/17/2018 at 5:37 AM, kocane said:

The trouble is that I use a script in the end of Deluge downloads (nzbToMedia) and it connects to couchpotato and radarr on the host machine.  The only solution is to make everything be containerized?

 

Hey @kocane

 

I stumbled across your post in this forum after researching the same thing. I'm not sure if you ever found a solution, but I did. I implemented a workaround for @binhex's arch-qbittorrent container, but the same should apply for Deluge. I posted as it an issue on the github for that container, and you can read the solution here.

 

In brief, it's similar to the ADDITIONAL_PORTS method available in the arch-sabnzbdvpn container. The extra variable is parsed by the iptable.sh script and adds a new iptable rule which allows incoming and outgoing connections on the ports you specify on the LAN subnet. That last part is important - these newly permissive rules only allow connections to/from the ports you specify if they're on the local subnet, i.e. they're on your local network or your VLAN.

 

Feel free to reply here or PM me if you want any help.

 

As a disclaimer: I'm fairly certain this doesn't sabotage the iptables rules and create a leak. I did enough reading and I'm confident enough in my own competence, but of course I don't guarantee anything. I'm sure someone here will soon offer a strict warning on messing with the iptables rules, and they'd be correct - in the wrong hands the entire point of the VPN could be nullified, and it would happen silently.

 

If anyone actually looks at what I did and finds flaws, I'd REALLY appreciate the heads-up!

Share this post


Link to post

I am trying to get DelugeVPN running with Mullvad as a VPN host. I had the container running with PIA but my account expired and I was checking other options. I renamed the mullvad_us-ma.conf file from Mullvad to mullvad_us-ma.ovpn and edited the file to remove the lines:

 

tun-ipv6
up /etc/openvpn/update-resolv-conf
down /etc/openvpn/update-resolv-conf

 

 

I put all the files from them in my config directory and Mullvad just gives an ID (no pass) so I tried this value as VPN_USER and VPN_USER/VPN_PASS but I hang up at the end of starting the container with

"2019-04-09 20:37:31,798 DEBG 'start-script' stdout output:
[debug] Waiting for valid IP address from tunnel.."

 

Attached is my log file. Any suggestions?

 

 

supervisord.log

Share this post


Link to post
14 hours ago, binhex said:

most probably firewall/router changes blocking outbound access to 1198, check firewall on host, hardware firewall and router, and check vlan as well if you have any setup.

hmm, I don't have anything blocking outbound access that I'm aware of. My Ubuntu server (18.04) doesn't have ufw enabled. I don't have any VLANs set up. My router settings haven't been changed (and they shouldn't be blocking any outbound access either). It's odd how this happened all of a sudden. Could this be anything on the PIA front that may have changed? Any other potential culprits?

Share this post


Link to post
hmm, I don't have anything blocking outbound access that I'm aware of. My Ubuntu server (18.04) doesn't have ufw enabled. I don't have any VLANs set up. My router settings haven't been changed (and they shouldn't be blocking any outbound access either). It's odd how this happened all of a sudden. Could this be anything on the PIA front that may have changed? Any other potential culprits?
Try a different PIA endpoint it could be a problem at PIAs end

Sent from my EML-L29 using Tapatalk

Share this post


Link to post
On 4/5/2019 at 1:24 PM, Remamian said:

So i'm at a loss. I've spent the better part of 2 days investigating potential fixes. So let me start with a TL;DR before going too far.

  • Issue 1 (Original issue). Uploads are excessively slow, DL's are perfect. 
  • Issue 2 (After countless different fixes for issue 1). If i reboot my deluge it wont let me go into the UI unless i go and delete the Daemon port line from core config.

Trying to seed more, and in doing so i noticed my uploads are very slow. I get 250/10 (mbps) from comcast and run PIA. I've been using deluge without issue for 6 months but never paid attention to my upload speeds. I can easily get 100+mpbs download but nothing over 150k upload.

 

I reinstalled deluge, redoing the PIA settings found here, no issues. I tried both Toronto and Montreal (because of endpoint stuff) still ran the same as before. I followed a few guides online for settings in deluge as well as setting up itConfig.

 

At some point during this process something got messed up if/when i reboot deluge i cannot get back into the Gui until i got into core.conf and delete   "daemon_port": 58846,  line. After this i restart the container and it works fine.

 

*EDIT* Of note, the uploads run high at restart or after restarting a torrent. (150kbps) but then drop down to 1-2kbps.

 

 

Update it seems the Daemon port removal thing has taken care of itself, but still terrible uploading. Any help would be greatly appreciated.

Share this post


Link to post
15 minutes ago, chris_netsmart said:

Have you check the PIA speed connection, as i have discoveres tha my UK connection is running at 3mbs when i am connection.

Yes, thats one of the first things i looked at. I'm pulling 210/18 mbps on the 3 different ones i tried. Again i have no problem with download, getting 20-80mbps depending on what i'm downloading. Just uploading is 0-150kbps and while starts out strong drops down to 1-2kbps for any extended period of time.

 

Share this post


Link to post
21 hours ago, TaskMaster said:

I am trying to get DelugeVPN running with Mullvad as a VPN host. I had the container running with PIA but my account expired and I was checking other options. I renamed the mullvad_us-ma.conf file from Mullvad to mullvad_us-ma.ovpn and edited the file to remove the lines:

 

tun-ipv6
up /etc/openvpn/update-resolv-conf
down /etc/openvpn/update-resolv-conf

 

 

I put all the files from them in my config directory and Mullvad just gives an ID (no pass) so I tried this value as VPN_USER and VPN_USER/VPN_PASS but I hang up at the end of starting the container with

"2019-04-09 20:37:31,798 DEBG 'start-script' stdout output:
[debug] Waiting for valid IP address from tunnel.."

 

Attached is my log file. Any suggestions?

 

 

supervisord.log

Well I think using the account number as I am (ID/PASS) isn't successful. Since it was the initial Mullvad account signup it was good for 3 hours, but I still hang at the same point now (with that trial period expired) so I think I'm not getting authenticated. Unless someone sees something different from my log, that's my conclusion at this point. Maybe I can't use Mullvad.

Share this post


Link to post
14 hours ago, chris_netsmart said:

I don't upload. Only download as i use public sites.  Have you spoken to your upload site, aa they might be limiting the speed

 

Checked with them (IPTorrent) there is no throttling. I tested my connection by loading up my old utorrent and dropped one of the files in and its running smoothly at 4mbps upload, so its something either in the deluge client or unraid.

Share this post


Link to post
18 minutes ago, Remamian said:

 

Checked with them (IPTorrent) there is no throttling. I tested my connection by loading up my old utorrent and dropped one of the files in and its running smoothly at 4mbps upload, so its something either in the deluge client or unraid.

check all of the points in Q6 from the following link:-

https://forums.unraid.net/topic/44108-support-binhex-general/?tab=comments#comment-433613

 

Share this post


Link to post

I don't know what's going on. All of a sudden errors galore. Now there's another error. It reads like a permissions issue, but I checked the permissions and they're fine and match the UID and GID. The /config is binded to a NFS share on my Synology NAS. But again, it worked at one point and suddenly it stopped working. I tried mounting both NFS3 and 4, but the error still persists. Any help or thoughts would be much appreciated.

 

Edit: Problem solved. 


dos2unix: problems converting file /config/openvpn/CA Toronto.ovpn,
2019-04-12 00:52:39.257950 [info] VPN_ENABLED defined as 'yes',
2019-04-12 00:52:39.062116 [info] PUID defined as '1033',
2019-04-12 00:52:39.034095 [info] System information Linux 6ff0039b60b6 4.15.0-47-generic #50-Ubuntu SMP Wed Mar 13 10:44:52 UTC 2019 x86_64 GNU/Linux,
2019-04-12 00:52:39.091976 [info] PGID defined as '65541',
2019-04-12 00:52:39.140547 [info] UMASK defined as '000',
2019-04-12 00:52:39.168794 [info] Permissions already set for volume mappings,
2019-04-12 00:52:39.199245 [info] DELUGE_DAEMON_LOG_LEVEL defined as 'info',
2019-04-12 00:52:39.226604 [info] DELUGE_WEB_LOG_LEVEL defined as 'info',
2019-04-12 00:52:39.299952 [warn] Unable to chown/chmod /config/openvpn/, assuming SMB mountpoint,
2019-04-12 00:52:39.330785 [info] OpenVPN config file (ovpn extension) is located at /config/openvpn/CA Toronto.ovpn,
dos2unix: Failed to open temporary output file: Permission denied
dos2unix: problems converting file /config/openvpn/CA Toronto.ovpn

 

Edited by emteedubs

Share this post


Link to post
On 4/11/2019 at 7:48 AM, binhex said:

check all of the points in Q6 from the following link:-

https://forums.unraid.net/topic/44108-support-binhex-general/?tab=comments#comment-433613

 

I had already tried those, but i did again. No change. So i ended up uninstalling the container, removing all remnants of its data on my server and reinstalled it. Now i'm pulling in over 1mbps upload with the same settings as before. So i assume something got corrupted but its working well now. Thank you for your support!

Share this post


Link to post

anyone else all of a sudden have issues with radarr and sonarr using Privoxy? 

I can telnet to privoxy port from both containers but when its enabled in settings it cannot connect to any indexers.

nothing in logs that give info

Share this post


Link to post
On 4/10/2019 at 6:05 PM, TaskMaster said:

Well I think using the account number as I am (ID/PASS) isn't successful. Since it was the initial Mullvad account signup it was good for 3 hours, but I still hang at the same point now (with that trial period expired) so I think I'm not getting authenticated. Unless someone sees something different from my log, that's my conclusion at this point. Maybe I can't use Mullvad.

Is anyone successfully using Mullvad?

Share this post


Link to post
On 4/12/2019 at 9:25 PM, TaskMaster said:

Is anyone successfully using Mullvad?

i am

I use the string that comes inside the zip file downloaded from mullvad website. If you log in and then download the linux config file in the zip there will be userpass file. use that as both the username and password.

Share this post


Link to post
1 hour ago, nekromantik said:

i am

I use the string that comes inside the zip file downloaded from mullvad website. If you log in and then download the linux config file in the zip there will be userpass file. use that as both the username and password.

Can I ask what steps you took?

 

1) Downloading the config, what did you choose for port (default UDP, UDP 53, TCP 80 or TCP 443) and use IP address (YES, NO)?

2) Did you make any edits to the CONF file besides changing the extension to OVPN?

3) You used the info from the userpass file ending in m (like 7678445522299017m)  for both VPN_USER and VPN_PASS? Like VPN_USER=7678445522299017m and VPN_PASS=7678445522299017m

4) Did you use all the files from the downloaded zip in your CONFG directory?

5) Did you set VPN_PROV=custom?

6) Did you use the host address from the CONF/OVPN file for VPN_REMOTE?

 

 

Thanks for any other info - definitely appreciated!

Share this post


Link to post



Can I ask what steps you took?
 
1) Downloading the config, what did you choose for port (default UDP, UDP 53, TCP 80 or TCP 443) and use IP address (YES, NO)?
2) Did you make any edits to the CONF file besides changing the extension to OVPN?
3) You used the info from the userpass file ending in m (like 7678445522299017m)  for both VPN_USER and VPN_PASS? Like VPN_USER=7678445522299017m and VPN_PASS=7678445522299017m
4) Did you use all the files from the downloaded zip in your CONFG directory?
5) Did you set VPN_PROV=custom?
6) Did you use the host address from the CONF/OVPN file for VPN_REMOTE?
 
 
Thanks for any other info - definitely appreciated!


I used defaults for everything and no changes to file apart from changing extension.
Yes used string ending in m for both username and password.
Yes all files copied to container.
Yes VPN prov is custom.
Did not set VPN remote.

Sent from my Pixel 2 XL using Tapatalk

Share this post


Link to post

i am having issues getting the deluge VPN working in a docker container on my updated synology NAS.

 

here is the log file?

 

2019-04-15 00:15:34.050781 [info] System information Linux binhex-arch-delugevpn1 4.4.59+ #23824 SMP PREEMPT Tue Feb 12 16:52:55 CST 2019 x86_64 GNU/Linux
2019-04-15 00:15:34.119609 [info] PUID defined as '1026'
2019-04-15 00:15:34.189808 [info] PGID defined as '100'
2019-04-15 00:15:34.313660 [info] UMASK defined as '000'
2019-04-15 00:15:34.379194 [info] Permissions already set for volume mappings
2019-04-15 00:15:34.457719 [info] DELUGE_DAEMON_LOG_LEVEL defined as 'info'
2019-04-15 00:15:34.522246 [info] DELUGE_WEB_LOG_LEVEL defined as 'info'
2019-04-15 00:15:34.586472 [info] VPN_ENABLED defined as 'yes'
2019-04-15 00:15:34.657989 [info] OpenVPN config file (ovpn extension) is located at /config/openvpn/US West.ovpn
dos2unix: converting file /config/openvpn/US West.ovpn to Unix format...
2019-04-15 00:15:34.750327 [info] VPN remote line defined as 'remote us-west.privateinternetaccess.com 1198'
2019-04-15 00:15:34.813234 [info] VPN_REMOTE defined as 'us-west.privateinternetaccess.com'
2019-04-15 00:15:34.881986 [info] VPN_PORT defined as '1198'
2019-04-15 00:15:34.952050 [info] VPN_PROTOCOL defined as 'udp'
2019-04-15 00:15:35.016490 [info] VPN_DEVICE_TYPE defined as 'tun0'
2019-04-15 00:15:35.080469 [info] VPN_PROV defined as 'pia'
2019-04-15 00:15:35.143559 [info] LAN_NETWORK defined as '192.168.1.0/24'
2019-04-15 00:15:35.207209 [info] NAME_SERVERS defined as '68.94.156.8,68.94.157.8'
2019-04-15 00:15:35.274174 [info] VPN_USER defined as 'xxx'
2019-04-15 00:15:35.340382 [info] VPN_PASS defined as 'xxx'
2019-04-15 00:15:35.407141 [info] VPN_OPTIONS not defined (via -e VPN_OPTIONS)
2019-04-15 00:15:35.475068 [info] STRICT_PORT_FORWARD defined as 'yes'
2019-04-15 00:15:35.543713 [info] ENABLE_PRIVOXY defined as 'yes'
2019-04-15 00:15:35.616166 [info] Starting Supervisor...
2019-04-15 00:15:35,973 INFO Included extra file "/etc/supervisor/conf.d/delugevpn.conf" during parsing
2019-04-15 00:15:35,974 INFO Set uid to user 0 succeeded
2019-04-15 00:15:35,980 INFO supervisord started with pid 7
2019-04-15 00:15:36,982 INFO spawned: 'start-script' with pid 147
2019-04-15 00:15:36,985 INFO spawned: 'watchdog-script' with pid 148
2019-04-15 00:15:36,987 INFO spawned: 'privoxy-script' with pid 149
2019-04-15 00:15:36,987 INFO reaped unknown pid 8
2019-04-15 00:15:36,998 DEBG 'start-script' stdout output:
[info] VPN is enabled, beginning configuration of VPN

2019-04-15 00:15:36,998 INFO success: start-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2019-04-15 00:15:36,998 INFO success: watchdog-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2019-04-15 00:15:36,998 INFO success: privoxy-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2019-04-15 00:15:37,003 DEBG 'watchdog-script' stderr output:
dos2unix: 
2019-04-15 00:15:37,004 DEBG 'watchdog-script' stderr output:
converting file /config/core.conf to Unix format...

2019-04-15 00:15:37,027 DEBG 'start-script' stdout output:
[warn] Password contains characters which could cause authentication issues, please consider changing this if possible

2019-04-15 00:15:37,099 DEBG 'start-script' stdout output:
[info] Default route for container is 172.17.0.1

2019-04-15 00:15:37,106 DEBG 'start-script' stdout output:
[info] Adding 68.94.156.8 to /etc/resolv.conf

2019-04-15 00:15:37,112 DEBG 'start-script' stdout output:
[info] Adding 68.94.157.8 to /etc/resolv.conf

2019-04-15 00:15:37,207 DEBG 'start-script' stdout output:
[info] Docker network defined as    172.17.0.0/16

2019-04-15 00:15:37,213 DEBG 'start-script' stdout output:
[info] Adding 192.168.1.0/24 as route via docker eth0

2019-04-15 00:15:37,215 DEBG 'start-script' stdout output:
[info] ip route defined as follows...
--------------------

2019-04-15 00:15:37,217 DEBG 'start-script' stdout output:
default via 172.17.0.1 dev eth0 
172.17.0.0/16 dev eth0 proto kernel scope link src 172.17.0.2 
192.168.1.0/24 via 172.17.0.1 dev eth0 

2019-04-15 00:15:37,217 DEBG 'start-script' stdout output:
--------------------

2019-04-15 00:15:37,225 DEBG 'start-script' stdout output:
iptable_mangle          1656  0
ip_tables              14092  3 iptable_filter,iptable_mangle,iptable_nat
x_tables               16302  19 ip6table_filter,xt_ipvs,xt_iprange,xt_mark,xt_recent,ip_tables,xt_tcpudp,ipt_MASQUERADE,xt_limit,xt_state,xt_conntrack,xt_LOG,xt_nat,xt_multiport,iptable_filter,xt_REDIRECT,iptable_mangle,ip6_tables,xt_addrtype

2019-04-15 00:15:37,226 DEBG 'start-script' stdout output:
[info] iptable_mangle support detected, adding fwmark for tables

2019-04-15 00:15:37,310 DEBG 'start-script' stdout output:
[info] iptables defined as follows...
--------------------

2019-04-15 00:15:37,313 DEBG 'start-script' stdout output:
-P INPUT DROP
-P FORWARD ACCEPT
-P OUTPUT DROP
-A INPUT -i tun0 -j ACCEPT
-A INPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT
-A INPUT -i eth0 -p udp -m udp --sport 1198 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 8112 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --sport 8112 -j ACCEPT
-A INPUT -s 192.168.1.0/24 -i eth0 -p tcp -m tcp --dport 58846 -j ACCEPT
-A INPUT -s 192.168.1.0/24 -d 172.17.0.0/16 -i eth0 -p tcp -j ACCEPT
-A INPUT -p icmp -m icmp --icmp-type 0 -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A OUTPUT -o tun0 -j ACCEPT
-A OUTPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT
-A OUTPUT -o eth0 -p udp -m udp --dport 1198 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --dport 8112 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 8112 -j ACCEPT
-A OUTPUT -d 192.168.1.0/24 -o eth0 -p tcp -m tcp --sport 58846 -j ACCEPT
-A OUTPUT -s 172.17.0.0/16 -d 192.168.1.0/24 -o eth0 -p tcp -j ACCEPT
-A OUTPUT -p icmp -m icmp --icmp-type 8 -j ACCEPT
-A OUTPUT -o lo -j ACCEPT

2019-04-15 00:15:37,317 DEBG 'start-script' stdout output:
--------------------
[info] Starting OpenVPN...

2019-04-15 00:15:37,331 DEBG 'start-script' stdout output:
Mon Apr 15 00:15:37 2019 WARNING: file 'credentials.conf' is group or others accessible

2019-04-15 00:15:37,332 DEBG 'start-script' stdout output:
Mon Apr 15 00:15:37 2019 OpenVPN 2.4.6 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Apr 24 2018

2019-04-15 00:15:37,332 DEBG 'start-script' stdout output:
Mon Apr 15 00:15:37 2019 library versions: OpenSSL 1.1.1a  20 Nov 2018, LZO 2.10

2019-04-15 00:15:37,334 DEBG 'start-script' stdout output:
[info] OpenVPN started

2019-04-15 00:15:37,334 DEBG 'start-script' stdout output:
Mon Apr 15 00:15:37 2019 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

2019-04-15 00:15:37,335 DEBG 'start-script' stdout output:
Mon Apr 15 00:15:37 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]104.200.151.48:1198

2019-04-15 00:15:37,335 DEBG 'start-script' stdout output:
Mon Apr 15 00:15:37 2019 UDP link local: (not bound)

2019-04-15 00:15:37,336 DEBG 'start-script' stdout output:
Mon Apr 15 00:15:37 2019 UDP link remote: [AF_INET]104.200.151.48:1198

2019-04-15 00:15:37,502 DEBG 'start-script' stdout output:
Mon Apr 15 00:15:37 2019 [718d11436f8ced564f24769cfbe51f4e] Peer Connection Initiated with [AF_INET]104.200.151.48:1198

2019-04-15 00:15:38,673 DEBG 'start-script' stdout output:
Mon Apr 15 00:15:38 2019 auth-token received, disabling auth-nocache for the authentication token
Mon Apr 15 00:15:38 2019 TUN/TAP device tun0 opened
Mon Apr 15 00:15:38 2019 do_ifconfig, tt->did_ifconfig_ipv6_setup=0
Mon Apr 15 00:15:38 2019 /usr/bin/ip link set dev tun0 up mtu 1500

2019-04-15 00:15:38,678 DEBG 'start-script' stdout output:
Mon Apr 15 00:15:38 2019 /usr/bin/ip addr add dev tun0 local 10.21.10.6 peer 10.21.10.5

2019-04-15 00:15:38,681 DEBG 'start-script' stdout output:
Mon Apr 15 00:15:38 2019 /root/openvpnup.sh tun0 1500 1558 10.21.10.6 10.21.10.5 init

2019-04-15 00:15:38,742 DEBG 'start-script' stdout output:
Mon Apr 15 00:15:38 2019 Initialization Sequence Completed

2019-04-15 00:15:38,845 DEBG 'privoxy-script' stdout output:
[info] Configuring Privoxy...

2019-04-15 00:15:38,871 DEBG 'privoxy-script' stdout output:
[info] All checks complete, starting Privoxy...

2019-04-15 00:15:38,874 DEBG 'privoxy-script' stderr output:
2019-04-15 00:15:38.874 7f118ae15100 Info: Privoxy version 3.0.26

2019-04-15 00:15:38,875 DEBG 'privoxy-script' stderr output:
2019-04-15 00:15:38.875 7f118ae15100 Info: Program name: /usr/bin/privoxy

2019-04-15 00:15:38,884 DEBG 'watchdog-script' stdout output:
[info] Deluge listening interface IP 0.0.0.0 and VPN provider IP 10.21.10.6 different, marking for reconfigure

2019-04-15 00:15:38,891 DEBG 'watchdog-script' stdout output:
[info] Deluge not running

2019-04-15 00:15:38,898 DEBG 'start-script' stdout output:
[info] Attempting to curl https://www.privateinternetaccess.com/vpninfo/servers?version=82...

2019-04-15 00:15:38,907 DEBG 'watchdog-script' stdout output:
[info] Deluge Web UI not running

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.