[Support] binhex - DelugeVPN


8733 posts in this topic Last Reply

Recommended Posts

edit: solved it, had to downgrade on the tag "1.3.15_18_ge050905b2-1-04". sadly all my torrents are gone :/

 

original post:

 

Lately I have problems connecting to the daemon from my Deluge 1.3.15 installation on my Windows PC. Deluge Docker is running on another computer in the same network with unraid as OS. Connecting via the web interface is no problem.

 

I don't really have a big understanding how to fix this so some help would be appreciated.

 

grafik.png.c7ad9deb295d9ad8101496e697782a66.png

 

My appdata/binhex-delugevpn/auth file:

localclient: [...] :10
username:password:10
user:deluge:10

I try to connect to 10.0.0.2:58846 with user:user and password:deluge

 

The connection manager inside the webclient can connect to it:

grafik.png.1d3497cc4945ed34d932c4f3d6926a2b.png

 

The connection manager on my machine does not:

grafik.png.713c652970cc7a26b1132b9d2dda74f5.png

 

I think I set the ports for the docker correctly:

grafik.png.726998c567e2641baede8edd68b966b7.png

 

Cheers!

grafik.png

grafik.png

grafik.png

grafik.png

Edited by Henning
solved it
Link to post
  • Replies 8.7k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

OK guys, multi remote endpoint support is now in for this image please pull down the new image (this change will be rolled out to all my vpn images shortly).   What this means is that the im

There has been an issue raised on GitHub related to tracker announce request IP leakage under certain circumstances, after careful review of iptables i have tightened up the rules to prevent this. A n

I wanted to summarize how I got Mullvad working with DelugeVPN as I had to piece together several "solutions" from different comments in this thread and there was some incorrect info; likely old.

Posted Images

So now that I downgraded and the torrents are gone my next question would be:

Is it possible to restore it? I do not have a backup of the appdata folder but I found multiple archives in the appdata/binhex-delugevpn/archive folder which seems to hold backup of torrent states:

 

grafik.png.90cff42181754718859bf216c47d2c3a.png

 

Extracting them and overwriting the files in appdata/binhex-delugevpn/state did not work. Even rebuilding the image after it.

Did someone restored a backup sucessfully and are my files sufficient?

 

grafik.png

Edited by Henning
Link to post
2 hours ago, Henning said:

Lately I have problems connecting to the daemon from my Deluge 1.3.15 installation on my Windows PC. Deluge Docker is running on another computer in the same network with unraid as OS. Connecting via the web interface is no problem.

The real fix is running the 2.0 docker with the 2.0 windows front end. See here for some help. *(disclaimer. I don't use the windows client, I use linux desktop machines. The following information is what I obtained with 2 minutes of googling and reading)

https://forum.deluge-torrent.org/viewtopic.php?f=12&t=55404&start=20#p230175

Link to post

I'm adding a new 10TB UD drive to my existing 5TB UD drive that's full. New drive is currently in preclear, prepping for additional seeding space. What's best practice for adding additional storage space to Deluge without disturbing what's preexisting?

 

Edit: thinking this through further, if I simply change the Downloads folder to the new drive and changing nothing else I should be fine (i.e. continue to seed existing Linux distros from the existing full disk).. new disk isn't finished preclearing or I'd test...

Edited by BBLV
Link to post
8 hours ago, BBLV said:

I'm adding a new 10TB UD drive to my existing 5TB UD drive that's full. New drive is currently in preclear, prepping for additional seeding space. What's best practice for adding additional storage space to Deluge without disturbing what's preexisting?

 

Edit: thinking this through further, if I simply change the Downloads folder to the new drive and changing nothing else I should be fine (i.e. continue to seed existing Linux distros from the existing full disk).. new disk isn't finished preclearing or I'd test...

im not quite clear on your setup here, so are you replacing the 5TB UD (unassigned devices i guess this means) with your 10TB drive, or do you want to somehow combine the 10TB and the existing 5TB drive?.

 

if you simply want to swap the 5TB for the 10TB then its a fairly simple process, stop the container, rsync data from 5TB drive to 10TB drive, reconfigure docker container to target new 10TB drive, start container.

 

if you want to combine the two then this is a lot harder to do.

 

i have to ask the question, why is your drive so large?, wouldn't it be better to seed from your array if you want to seed for long periods of time?, any drive using UD is of course not protected from disk failure, but you of course know that i guess.

Edited by binhex
Link to post
8 hours ago, binhex said:

im not quite clear on your setup here, so are you replacing the 5TB UD (unassigned devices i guess this means) with your 10TB drive, or do you want to somehow combine the 10TB and the existing 5TB drive?.

 

if you simply want to swap the 5TB for the 10TB then its a fairly simple process, stop the container, rsync data from 5TB drive to 10TB drive, reconfigure docker container to target new 10TB drive, start container.

 

if you want to combine the two then this is a lot harder to do.

 

i have to ask the question, why is your drive so large?, wouldn't it be better to seed from your array if you want to seed for long periods of time?, any drive using UD is of course not protected from disk failure, but you of course know that i guess.

I wanted to keep the seeding going 24/7 and didn't want to constantly spin up the array drives, hence the usage of unassigned devices for Deluge. I don't want to replace the existing 5TB drive and don't necessarily want to combine the drives, just want to add additional storage space but continue to seed from both drives. My preclear should be done tomorrow on this new 10TB drive and I'll try my method mentioned above and comment back on how it works out.

Link to post
6 minutes ago, BBLV said:

wanted to keep the seeding going 24/7 and didn't want to constantly spin up the array drives

If you create a share for this on the array you can have both drives assigned and they will be the only ones that spin up (plus parity if you have it installed).

Link to post
19 minutes ago, wgstarks said:

If you create a share for this on the array you can have both drives assigned and they will be the only ones that spin up (plus parity if you have it installed).

Not a bad idea. Can't remember where I originally read that UD was the way to go, but your method makes a lot of sense.

Link to post

Tried to access delugevpn today and nothing gives following error message

 

An error occurred.

Sorry, the page you are looking for is currently unavailable.
Please try again later.

If you are the system administrator of this resource then you should check the error log for details.

 

Did a complete reinstall following spaceinvaders video to the letter and nothing!

 

any help?

Link to post
2 hours ago, erfly7 said:

Tried to access delugevpn today and nothing gives following error message

 

An error occurred.

Sorry, the page you are looking for is currently unavailable.
Please try again later.

If you are the system administrator of this resource then you should check the error log for details.

 

Did a complete reinstall following spaceinvaders video to the letter and nothing!

 

any help?

follow procedure in link below:-

https://github.com/binhex/documentation/blob/master/docker/faq/help.md

Link to post
5 minutes ago, erfly7 said:

ok not sure what I was doing think this is the correct one.

supervisord.odt 40.43 kB · 1 download

that is a succesful start, you sure the LAN_NETWORK is correct?, from your log:-

2019-08-22 01:16:24.885197 [info] LAN_NETWORK defined as '192.168.1.0/24'

see here for help Q4:- https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

Link to post

yes my router page is at 192.168.0.1

 

So I just copy

 

echo "# force iptable mangle module to load (required for *vpn dockers)" >> /boot/config/go echo "/sbin/modprobe iptable_mangle" >> /boot/config/go

 

into the terminal in Unraid?

Edited by erfly7
Link to post
On 8/21/2019 at 10:33 AM, BBLV said:

Not a bad idea. Can't remember where I originally read that UD was the way to go, but your method makes a lot of sense.

So changing my data target folder to the new drive killed my seeding from the old drive, as expected... Now I'm forced to copy the old 5TB drive's contents to the new 10TB drive and will worry about this again when this new drive is near full. By then maybe it will be time to buy a new 10TB drive to replace my current dual 6TB parity drives and move the Deluge data folder to its own share on the array.

Edited by BBLV
Link to post
On 8/22/2019 at 1:33 AM, BBLV said:

Not a bad idea. Can't remember where I originally read that UD was the way to go, but your method makes a lot of sense.

My solution is that torrents which are leeching are held, unprotected, in a folder on the cache drive (but a folder on UD would be just as good).  When the torrent finishes downloading,  deluge moves it to a folder on the protected array.  In this way, the parity drive is only involved during the nightly copy of newly completed downloads from cache.  If the cache drive were to fail, I would only lose currently downloading torrents, which could be easily restarted.  This has been working well for me over many years.

Link to post

I need some help to get this running. I followed spaceinvaders video but no dice. 

 

I have my own VPN that I run on my Router. Even if I disable the VPN in the options for binhex-delugevpn it still doesn't work. Even if I get the normal version of deluge with no VPN, the download will start then it drops down to 0 within 5 seconds. Any ideas?

 

i think it might be this that could be preventing the downloads from starting properly? (see image)

 

Untitled.png

 

 

 

*EDIT

 

Issue fixed. I got my paths wrong in Deluge settings. 

Edited by z0ki
Link to post
On 8/16/2019 at 10:38 PM, Henning said:

So now that I downgraded and the torrents are gone my next question would be:

Is it possible to restore it? I do not have a backup of the appdata folder but I found multiple archives in the appdata/binhex-delugevpn/archive folder which seems to hold backup of torrent states:

 

grafik.png.90cff42181754718859bf216c47d2c3a.png

 

Extracting them and overwriting the files in appdata/binhex-delugevpn/state did not work. Even rebuilding the image after it.

Did someone restored a backup sucessfully and are my files sufficient?

 

grafik.png

Someone able to answer this? Still havent touched deluge since than and am willing to have last try of restoring before starting the work of readding all the torrents manually.

Link to post

I am humbly seeking assistance in setting up the DelugeVPN docker container on a Synology DS918+ NAS system. I have followed the guide from here as best I could:

 

http://tomthegreat.com/2018/03/11/setting-up-deluge-with-vpn-on-synology-using-docker/

 

Unfortunately, I am unable to access the Deluge setup wizard after going through the process (Step 12). Looking at the supervisord.log file, it seems the problem is related to this:

 

DEBG 'start-script' stdout output:
ERROR: Cannot open TUN/TAP dev /dev/net/tun: No such device (errno=19)
Exiting due to fatal error

 

I have attached the logfile in it's entirety in the hopes of finding help in this matter. My computer skills are limited and thus I don't see a of way fixing this on my own.

 

Thank you for your consideration.

supervisord_namesremoved.log

Link to post

Hi,

 

I followed this tutorial to install DelugeVPN on my Synology Nas. It keeps crashing and I've found this error message in the logs:

[crit] VPN_PORT not found in /config/openvpn/XXXXXX-XXXX-XXXXX-XXXXXX-XXXXX_lu_openvpn.ovpn, exiting...

 

I'm using VPNUnlimited. Any idea what can I do to fix this?

Thanks for your work on this docker, by the way!

Link to post
37 minutes ago, Walhto said:

Hi,

 

I followed this tutorial to install DelugeVPN on my Synology Nas. It keeps crashing and I've found this error message in the logs:

[crit] VPN_PORT not found in /config/openvpn/XXXXXX-XXXX-XXXXX-XXXXXX-XXXXX_lu_openvpn.ovpn, exiting...

 

I'm using VPNUnlimited. Any idea what can I do to fix this?

Thanks for your work on this docker, by the way!

Did you download the vpn config fie from your vpn site and place it in that location?

Edited by Armed Ferret
Spelling error
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.