[Support] binhex - DelugeVPN


Recommended Posts

12 minutes ago, binhex said:

Shows "port is open". Does it mean it is correctly forwarded to my local Deluge, or it's just in a listening state by the VPN provider?

13 minutes ago, binhex said:

like what?

Host Port 3 and Host Port 4 both contain the parameters for "Container Port: 58946"

Container Variable: VPN_REMOTE and Container Variable: VPN_PORT - I cannot blank it out. I don't think it's needed for ovpn files.

 

Thank you!

 

Link to comment
2 minutes ago, Kir said:

Shows "port is open". Does it mean it is correctly forwarded to my local Deluge,

yes, that means its working correctly and deluge is listening on that port.

 

3 minutes ago, Kir said:

"Container Port: 58946"

yes you can delete this, its included in case people want to run it without vpn.

 

3 minutes ago, Kir said:

Container Variable: VPN_REMOTE and Container Variable: VPN_PORT

man you got an old template there!!, those env vars got removed about a year or more ago, feel free to delete.

Link to comment
1 minute ago, binhex said:

man you got an old template there!!, those env vars got removed about a year or more ago, feel free to delete.

So... what's the safe way to delete or reinstall with the new template? I do know it came from the times I started using Deluge long time go.

Link to comment
1 minute ago, Kir said:

So... what's the safe way to delete or reinstall with the new template? I do know it came from the times I started using Deluge long time go.

well you can delete the existing template you have on disk and then re-install using CA, then re-populate again with the same settings, you might wanna screenshot before you do this so you know what your working config looks like.

Link to comment
27 minutes ago, binhex said:

yes, that means its working correctly and deluge is listening on that port.

I still have a doubt that is how it works. After reinstalling with the new template, I got another public IP from my provider, but the old one still shows as open on the same port. Several addresses "around" the one I got also show up as open...

Link to comment

**EDIT**

I found the issue was that I mounted a share on the NAS for /Data which was outside of the Docker folder.  I could not see where I could set permissions for whatever "user" within this Docker container needed access to it, so I just created a new folder within the Docker folder on the NAS, and mounted the volume as /Data in the config.  It downloaded the file.

 

I then went and set the GROUP permissions for my original share to allow users to R/W, then went back and set the config of the docker container to mount my original folder that I was having issue with.  All is working now, and the files are being stored where I want them.

 

******************************************

 

New user here.

 

I followed the install guides I could find, as well as reviewed the FAQs here on this site to get this loaded onto my Synology 418play in a Docker container, and everything seems fine except that the torrents are not actually downloading.

 

Guides

https://hub.docker.com/r/binhex/arch-delugevpn/

http://tomthegreat.com/2018/03/11/setting-up-deluge-with-vpn-on-synology-using-docker/

 

I have verified that it is connected to PIA (using a server that supports port forwarding), and it is even grabbing the metadata for the torrent, but it doesn't actually download the file.

 

Any ideas?

 

Screenshot Overview

https://drive.google.com/open?id=1Ftp9TEGqi_OGC25Lb7E6lYZIHZeU36qK

 

Network Preferences

https://drive.google.com/open?id=1wREmaYMFWa1doYJEGX0m-wb8G-0UecA3

 

Supervisord File

https://drive.google.com/open?id=1VFkNiAesJ0xD49wKmmRkcCqhUSnPfvGa

 

 

Edited by Deluginal
Found the problem.
Link to comment

AutoRemovePlus-0.6.7 not working

 

Hey there, i've been trying on and off for ages to get AutoRemovePlus working, finally I've found this post https://forum.deluge-torrent.org/viewtopic.php?t=55529 that suggests that the container needs python3-future installed in order for this plugin to function, however I cannot figure out how to install this additional python package into the container - does anyone have any pointers on this please?

 

Thanks in advance & BR

Link to comment
9 hours ago, allFun said:

AutoRemovePlus-0.6.7 not working

 

Hey there, i've been trying on and off for ages to get AutoRemovePlus working, finally I've found this post https://forum.deluge-torrent.org/viewtopic.php?t=55529 that suggests that the container needs python3-future installed in order for this plugin to function, however I cannot figure out how to install this additional python package into the container - does anyone have any pointers on this please?

 

Thanks in advance & BR

IIRC, @binhex added that several months ago.

  • Like 1
Link to comment

I'm not sure what I'm doing wrong, but I'm having trouble getting this started..  I keep getting this error over and over.  if I create the /tmp/openvpn folder it seems to continue, I then also have to start the webui.  But when I stop or restart the docker it undoes/reset the tmp directory so the openvpn folder doesn't exist any more. I'm also not sure how to fix or correct the warning, but I'll so have read it not critical.  

 

Tue Mar 10 22:08:07 2020 WARNING: file 'credentials.conf' is group or others accessible
Options error: --status fails with '/tmp/openvpn/openvpn-status.log': No such file or directory (errno=2)
Options error: Please correct these errors.

Link to comment

has anyone else had any trouble seeding torrents using nordvpn with this container? i have no issues downloading, but for whatever reason my seeds will only go for kb/s for roughly a minute or less, if at all. i have all the original files sitting in completed download folder just fine. webui not reporting any errors. I do have upnp enabled in my apple router.

Edited by Cpt. Chaz
typo
Link to comment

Not sure what happened, it might have been when I uploaded UnRAID to 6.8.3, but my deluge will start up for a second, then will lose connection to the server.  Lots of errors in the log about "Unable to delete the otrrent file. No such file or directory" in /config/state/.  

 

I don't care about any of the torrents currently in there.  Is there a way to just start fresh with states/all active torrents, but maintain my plugins etc.?

Link to comment
On 2/4/2020 at 9:25 PM, binhex said:

i see you fixed your issue, fyi setting vpn_enabled to yes affects it by deploying iptables to strictly block incoming/outgoing traffic, thus preventing ip leakage at all times, if you set it to no then there are no iptables in place anymore, thats why a lot of people tend to have no issues when its set to no (issue is normally misconfiguration).

Sorry to bring this up again. So what's the go on setting up the remote control for DelugeVPN?

 

I've got DelugeVPN setup on my UnRaid server. I want to be able to control it through my Windows Deluge install on the same network. 

 

I am pretty noob in all of this so bare with me. 

 

Thanks. 

Link to comment
59 minutes ago, 87ghosts said:

 

I've got DelugeVPN setup on my UnRaid server. I want to be able to control it through my Windows Deluge install on the same network. 

To do this you would need to have the same version of Deluge in both machines. I don’t use Windows so I haven’t really kept up with development on windows version of Deluge but last time I checked there wasn’t a windows version of Deluge v2. You would need to install a Deluge v1 version of this docker to be able to connect from your windows machine.

 

Not sure what the advantages would be though. I think you should get the same functionality via the webUI.

Link to comment
1 hour ago, wgstarks said:

last time I checked there wasn’t a windows version of Deluge v2.

Still isn't a prebuilt one, theoretically there are instructions to roll your own, although like you, I don't windows for personal use, so no experience with following those directions.

1 hour ago, wgstarks said:

I think you should get the same functionality via the webUI.

It's not quite as convenient for manual use. Having a local client controlling the daemon on the server allows easier manual addition of magnet and torrent files. No advantage I can see if everything is already automated.

Link to comment
10 hours ago, jonathanm said:

It's not quite as convenient for manual use. Having a local client controlling the daemon on the server allows easier manual addition of magnet and torrent files. No advantage I can see if everything is already automated.

Precisely what I want from this haha. 

 

11 hours ago, wgstarks said:

To do this you would need to have the same version of Deluge in both machines.

Ah well that's a dead end then. Thanks anyway. 

 

Link to comment
2 hours ago, 87ghosts said:

Ah well that's a dead end then.

No, there are 2 options. Follow the linked directions on the deluge site to build an up to date windows client, or select an older container for unraid using a tag in the repository field of the container setup.

 

Either will require effort on your part, but all the needed information is readily available if you search.

Link to comment
10 minutes ago, jonathanm said:

No, there are 2 options. Follow the linked directions on the deluge site to build an up to date windows client, or select an older container for unraid using a tag in the repository field of the container setup.

 

Either will require effort on your part, but all the needed information is readily available if you search.

Thanks for the encouragement. I might use Transmission in the short term since I've got it's Remote GUI working. I'll figure out the up to date windows client option at my own pace. 

Link to comment
has anyone else had any trouble seeding torrents using nordvpn with this container? i have no issues downloading, but for whatever reason my seeds will only go for kb/s for roughly a minute or less, if at all. i have all the original files sitting in completed download folder just fine. webui not reporting any errors. I do have upnp enabled in my apple router.
No port forwarding on nordvpn will be your issue.

Sent from my CLT-L09 using Tapatalk

Link to comment

Hi guys. I'm using this container with Mullvad.

I do get - however - DNS leakage (according to https://am.i.mullvad.net/ and other online tools). At the moment I'm using a proxed profile of Firefox - DNS over HTTPS is *disabled*.

 

I've tried setting Mullvad public dns in Key 9 (Container Variable: NAME_SERVERS), but the only way not to get any leakage is to set that DNS in my windows machine.

 

Is anything wrong with my setup? I started having leakage with one of the latest update of the container (checked multiple times in the past but no leaks occured, and I haven't changed anything in my config).

 

Thanks!

Edited by melagodo
Link to comment

Hey everyone, 

 

I am hoping someone can help me out here with 2 issues I seem to be having. The first one is that after a while, could be a few days or a week or two Deluge will not download anything. The Torrents from Sonarr and Radarr will queue up but they will just sit there until I restart deluge. Once I restart it starts downloading with no issues. I am running deluge with PIA VPN. I don't have any speed issues like some people have mentioned but my torrents just won't download after a while. Is there a way to possibly setup a automatic restart of dockers in Unraid that I have not found? The 2nd issue I am having is I can't seem to be able to get torrents to remove themselves after they have been downloaded. I have auto remover installed but It doesn't seem to be doing anything. No matter what I do with the settings. The torrents will download then seed for a little bit then just pause and stay paused forever until I manually log in and remove all them. 

 

So if anyone has any insights on how to fix these issues that would be greatly appreciated. Thank you! 

 

Link to comment

SDomething happend with my container which i can't access from the browser or thin client. The logs shows

 

Quote

2020-03-15 10:43:57,441 DEBG 'start-script' stderr output:
Error: error sending query: Could not send or receive, because of network error

 

I haven't made any changes. Tried a few things and still same issue.

 

I'm currently using binhex/arch-delugevpn with PIA.

Link to comment

So I got delugevpn up and running, tested with a leak test and am able to manually download ubuntu via torrent just fine. When I try to pass torrents from radarr to deluge webui, they show up in the webui but just say error:connection timed out.

 

My VPN provider is cyberghost VPN. Any suggestions?

 

TIA

Link to comment
2 hours ago, mag1c said:

So I got delugevpn up and running, tested with a leak test and am able to manually download ubuntu via torrent just fine. When I try to pass torrents from radarr to deluge webui, they show up in the webui but just say error:connection timed out.

 

My VPN provider is cyberghost VPN. Any suggestions?

 

TIA

https://support.cyberghostvpn.com/hc/en-us/articles/213982169-Why-are-my-P2P-download-rates-so-low-

 

Quote

CyberGhost not allowing port-forwarding

 

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.