Jump to content
binhex

[Support] binhex - DelugeVPN

7144 posts in this topic Last Reply

Recommended Posts

 

On 5/12/2020 at 5:57 AM, hopsonhops said:

Theres a bug in 6.8.3 that causes all containers to constantly think they need to be updated, so I had rolled back to the previous version. Apparently 6.8.1 has this issue with routing container networks. Looks like I'm stuck with one issue or the other so I guess I'll just live with the false update notification issue.

Strange - I have the problem that I no longer have 'update' options showing on the Dashboard - I have to go to the Docker page in order to invoke the update.

Share this post


Link to post
Posted (edited)

Getting a VPN connection error on PIA so can't acess WebUI. I  Updated  Deluge Doccker and installed new Cert from PIA.  Tried several .ovpn configs from PIA for different servers but still same message.  What does this error mean?  Suggestions to fix welcomed.

 

2020-05-13 19:34:23,375 DEBG 'watchdog-script' stderr output:
terminate called after throwing an instance of 'std::bad_weak_ptr'
what(): bad_weak_ptr

 

Edited by PhiPhi
Insert Code tags

Share this post


Link to post
Posted (edited)

@binhex Setting -1 for upload slots in Global Network Bandwidth seems to kill the daemon instantly (without saving the setting) and completely corrupt the list of torrents I have added. I went from having over 500 torrents added to less than 3. Files are still on my drive but they are no longer in Deluge. Restarted the docker container twice too, doesn't make any difference.

 

I did this a second time after adding 100 torrents. Exact same thing.

 

Interestingly setting -1 works if there are no torrents active in Deluge.

 

-1 seemed to have been a valid setting before without throwing this error... no idea why it is for some settings but not this one. Is this a bug?

 

EDIT: Seem to also be having a problem. No matter what I specify as the download location, it won't make the folder.

 

Eg. if my "/data/" location is mapped to something like /tank/Downloads/Torrents where I have a subfolder for each tracker.

 

It seems Deluge will just dump everything there, even if I specify /data/Tracker1

 

for example as the download location when adding a torrent. I thought it was a permissions issue but when adding the torrent, having it start in "/tank/Downloads/Torrents" instead of e.g. "/tank/Downloads/Torrents/Tracker1" because the former is "/data/" I can still right click, "Move Download" to /tank/Downloads/Torrents/Tracker1 and it will work... It just won't start from there, and more annoyingly it won't cross-seed properly. I need to start the torrent in "/data/" add it in a paused state (which doesn't seem to work either) and then stop it immediately, change the download location via right click and move the already downloaded files back and then manually force recheck.

 

Is there any way to get this working normally?

Edited by plantsandbinary

Share this post


Link to post

Hello All, i am not able to access deluge Webui. I am using PIA VPN. I can able to access webui after turning of VPN. Can any one help me on this? . I tried different PIA VPN config but same issue

 

2020-05-13 20:51:41,935 DEBG 'watchdog-script' stdout output:
[info] Deluge key 'listen_interface' currently has an undefined value
[info] Deluge key 'listen_interface' will have a new value '10.82.10.6'
[info] Writing changes to Deluge config file '/config/core.conf'...

2020-05-13 20:51:42,280 DEBG 'watchdog-script' stdout output:
[info] Deluge key 'outgoing_interface' currently has an undefined value
[info] Deluge key 'outgoing_interface' will have a new value 'tun0'
[info] Writing changes to Deluge config file '/config/core.conf'...

2020-05-13 20:51:42,468 DEBG 'watchdog-script' stdout output:
[info] Deluge key 'default_daemon' currently has a value of '2764f3fde14944b381d5a620d1a3dc7f'
[info] Deluge key 'default_daemon' will have a new value '2764f3fde14944b381d5a620d1a3dc7f'
[info] Writing changes to Deluge config file '/config/web.conf'...

2020-05-13 20:51:42,767 DEBG 'watchdog-script' stdout output:
[info] Deluge process started
[info] Waiting for Deluge process to start listening on port 58846...

2020-05-13 20:51:42,979 DEBG 'watchdog-script' stdout output:
[info] Deluge process listening on port 58846

2020-05-13 20:51:45,024 DEBG 'watchdog-script' stdout output:
Setting "random_port" to: False
Configuration value successfully updated.

2020-05-13 20:51:47,125 DEBG 'watchdog-script' stdout output:
Setting "listen_ports" to: (21213, 21213)
Configuration value successfully updated.

2020-05-13 20:51:49,279 DEBG 'watchdog-script' stdout output:
[info] No torrents with state 'Error' found

2020-05-13 20:51:49,280 DEBG 'watchdog-script' stdout output:
[info] Starting Deluge Web UI...
[info] Deluge Web UI started

2020-05-13 20:51:49,286 DEBG 'watchdog-script' stdout output:
[info] Attempting to start Privoxy...

2020-05-13 20:51:50,298 DEBG 'watchdog-script' stdout output:
[info] Privoxy process started
[info] Waiting for Privoxy process to start listening on port 8118...

2020-05-13 20:51:50,305 DEBG 'watchdog-script' stdout output:
[info] Privoxy process listening on port 8118

2020-05-13 21:03:11,034 WARN received SIGTERM indicating exit request
2020-05-13 21:03:11,035 DEBG killing watchdog-script (pid 174) with signal SIGTERM
2020-05-13 21:03:11,035 INFO waiting for start-script, watchdog-script to die
2020-05-13 21:03:12,037 DEBG fd 11 closed, stopped monitoring <POutputDispatcher at 140687154367600 for <Subprocess at 140687154366928 with name watchdog-script in state STOPPING> (stdout)>
2020-05-13 21:03:12,037 DEBG fd 15 closed, stopped monitoring <POutputDispatcher at 140687153836960 for <Subprocess at 140687154366928 with name watchdog-script in state STOPPING> (stderr)>
2020-05-13 21:03:12,037 INFO stopped: watchdog-script (terminated by SIGTERM)
2020-05-13 21:03:12,038 DEBG received SIGCHLD indicating a child quit
2020-05-13 21:03:12,038 DEBG killing start-script (pid 173) with signal SIGTERM
2020-05-13 21:03:13,039 DEBG fd 8 closed, stopped monitoring <POutputDispatcher at 140687154229504 for <Subprocess at 140687154232144 with name start-script in state STOPPING> (stdout)>
2020-05-13 21:03:13,039 DEBG fd 10 closed, stopped monitoring <POutputDispatcher at 140687154366832 for <Subprocess at 140687154232144 with name start-script in state STOPPING> (stderr)>
2020-05-13 21:03:13,040 INFO stopped: start-script (terminated by SIGTERM)
2020-05-13 21:03:13,040 DEBG received SIGCHLD indicating a child quit
Created by...
___. .__ .__
\_ |__ |__| ____ | |__ ____ ___ ___
| __ \| |/ \| | \_/ __ \\ \/ /
| \_\ \ | | \ Y \ ___/ > <
|___ /__|___| /___| /\___ >__/\_ \
\/ \/ \/ \/ \/
https://hub.docker.com/u/binhex/

2020-05-13 21:03:15.753546 [info] System information Linux 47add084911d 4.19.107-Unraid #1 SMP Thu Mar 5 13:55:57 PST 2020 x86_64 GNU/Linux
2020-05-13 21:03:15.822867 [info] PUID defined as '99'
2020-05-13 21:03:15.855091 [info] PGID defined as '100'
2020-05-13 21:03:16.011914 [info] UMASK defined as '000'
2020-05-13 21:03:16.041761 [info] Permissions already set for volume mappings
2020-05-13 21:03:16.073119 [info] DELUGE_DAEMON_LOG_LEVEL defined as 'info'
2020-05-13 21:03:16.103154 [info] DELUGE_WEB_LOG_LEVEL defined as 'info'
2020-05-13 21:03:16.133524 [info] VPN_ENABLED defined as 'yes'
2020-05-13 21:03:16.171208 [info] OpenVPN config file (ovpn extension) is located at /config/openvpn/CA Montreal.ovpn
2020-05-13 21:03:16.228504 [info] VPN remote line defined as 'remote ca-montreal.privateinternetaccess.com 1198'
2020-05-13 21:03:16.259283 [info] VPN_REMOTE defined as 'ca-montreal.privateinternetaccess.com'
2020-05-13 21:03:16.288013 [info] VPN_PORT defined as '1198'
2020-05-13 21:03:16.323263 [info] VPN_PROTOCOL defined as 'udp'
2020-05-13 21:03:16.351491 [info] VPN_DEVICE_TYPE defined as 'tun0'
2020-05-13 21:03:16.381102 [info] VPN_PROV defined as 'pia'
2020-05-13 21:03:16.406479 [info] LAN_NETWORK defined as '192.168.1.0/24'
2020-05-13 21:03:16.432079 [info] NAME_SERVERS defined as '209.222.18.222,84.200.69.80,37.235.1.174,1.1.1.1,209.222.18.218,37.235.1.177,84.200.70.40,1.0.0.1'
2020-05-13 21:03:16.457634 [info] VPN_USER defined as ''
2020-05-13 21:03:16.483202 [info] VPN_PASS defined as ''
2020-05-13 21:03:16.509302 [info] VPN_OPTIONS not defined (via -e VPN_OPTIONS)
2020-05-13 21:03:16.534900 [info] STRICT_PORT_FORWARD defined as 'yes'
2020-05-13 21:03:16.561437 [info] ENABLE_PRIVOXY defined as 'yes'
2020-05-13 21:03:16.594030 [info] ADDITIONAL_PORTS not defined (via -e ADDITIONAL_PORTS), skipping allow for custom incoming ports
2020-05-13 21:03:16.628286 [info] Deleting files in /tmp (non recursive)...
2020-05-13 21:03:16.654112 [info] Starting Supervisor...
2020-05-13 21:03:16,818 INFO Included extra file "/etc/supervisor/conf.d/delugevpn.conf" during parsing
2020-05-13 21:03:16,818 INFO Set uid to user 0 succeeded
2020-05-13 21:03:16,820 INFO supervisord started with pid 7
2020-05-13 21:03:17,823 INFO spawned: 'start-script' with pid 167
2020-05-13 21:03:17,826 INFO spawned: 'watchdog-script' with pid 168
2020-05-13 21:03:17,826 INFO reaped unknown pid 8
2020-05-13 21:03:17,834 DEBG 'start-script' stdout output:
[info] VPN is enabled, beginning configuration of VPN

2020-05-13 21:03:17,835 INFO success: start-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2020-05-13 21:03:17,835 INFO success: watchdog-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2020-05-13 21:03:17,847 DEBG 'start-script' stdout output:
[warn] Password contains characters which could cause authentication issues, please consider changing this if possible

2020-05-13 21:03:17,898 DEBG 'start-script' stdout output:
[info] Default route for container is 172.17.0.1

2020-05-13 21:03:17,903 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.222 to /etc/resolv.conf

2020-05-13 21:03:17,905 DEBG 'start-script' stdout output:
[info] Adding 84.200.69.80 to /etc/resolv.conf

2020-05-13 21:03:17,910 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.174 to /etc/resolv.conf

2020-05-13 21:03:17,913 DEBG 'start-script' stdout output:
[info] Adding 1.1.1.1 to /etc/resolv.conf

2020-05-13 21:03:17,916 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.218 to /etc/resolv.conf

2020-05-13 21:03:17,921 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.177 to /etc/resolv.conf

2020-05-13 21:03:17,924 DEBG 'start-script' stdout output:
[info] Adding 84.200.70.40 to /etc/resolv.conf

2020-05-13 21:03:17,928 DEBG 'start-script' stdout output:
[info] Adding 1.0.0.1 to /etc/resolv.conf

2020-05-13 21:03:17,980 DEBG 'start-script' stdout output:
[info] Attempting to load iptable_mangle module...

2020-05-13 21:03:17,981 DEBG 'start-script' stderr output:
modprobe: FATAL: Module iptable_mangle not found in directory /lib/modules/4.19.107-Unraid

2020-05-13 21:03:17,981 DEBG 'start-script' stdout output:
[warn] Unable to load iptable_mangle module using modprobe, trying insmod...

2020-05-13 21:03:17,982 DEBG 'start-script' stderr output:
insmod: ERROR: could not load module /lib/modules/iptable_mangle.ko: No such file or directory

2020-05-13 21:03:17,982 DEBG 'start-script' stdout output:
[warn] Unable to load iptable_mangle module, you will not be able to connect to the applications Web UI or Privoxy outside of your LAN
[info] unRAID/Ubuntu users: Please attempt to load the module by executing the following on your host: '/sbin/modprobe iptable_mangle'
[info] Synology users: Please attempt to load the module by executing the following on your host: 'insmod /lib/modules/iptable_mangle.ko'

2020-05-13 21:03:18,003 DEBG 'start-script' stdout output:
[info] Docker network defined as 172.17.0.0/16

2020-05-13 21:03:18,007 DEBG 'start-script' stdout output:
[info] Adding 192.168.1.0/24 as route via docker eth0

2020-05-13 21:03:18,008 DEBG 'start-script' stdout output:
[info] ip route defined as follows...
--------------------

2020-05-13 21:03:18,009 DEBG 'start-script' stdout output:
default via 172.17.0.1 dev eth0
172.17.0.0/16 dev eth0 proto kernel scope link src 172.17.0.4
192.168.1.0/24 via 172.17.0.1 dev eth0

2020-05-13 21:03:18,009 DEBG 'start-script' stdout output:
--------------------

2020-05-13 21:03:18,063 DEBG 'start-script' stdout output:
[info] iptables defined as follows...
--------------------

2020-05-13 21:03:18,065 DEBG 'start-script' stdout output:
-P INPUT DROP
-P FORWARD DROP
-P OUTPUT DROP
-A INPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT
-A INPUT -i eth0 -p udp -m udp --sport 1198 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 8112 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --sport 8112 -j ACCEPT
-A INPUT -s 192.168.1.0/24 -i eth0 -p tcp -m tcp --dport 58846 -j ACCEPT
-A INPUT -s 192.168.1.0/24 -d 172.17.0.0/16 -i eth0 -p tcp -j ACCEPT
-A INPUT -p icmp -m icmp --icmp-type 0 -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -i tun0 -j ACCEPT
-A OUTPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT
-A OUTPUT -o eth0 -p udp -m udp --dport 1198 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --dport 8112 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 8112 -j ACCEPT
-A OUTPUT -d 192.168.1.0/24 -o eth0 -p tcp -m tcp --sport 58846 -j ACCEPT
-A OUTPUT -s 172.17.0.0/16 -d 192.168.1.0/24 -o eth0 -p tcp -j ACCEPT
-A OUTPUT -p icmp -m icmp --icmp-type 8 -j ACCEPT
-A OUTPUT -o lo -j ACCEPT
-A OUTPUT -o tun0 -j ACCEPT

2020-05-13 21:03:18,066 DEBG 'start-script' stdout output:
--------------------

2020-05-13 21:03:18,068 DEBG 'start-script' stdout output:
[info] Starting OpenVPN...

2020-05-13 21:03:18,075 DEBG 'start-script' stdout output:
Wed May 13 21:03:18 2020 WARNING: file 'credentials.conf' is group or others accessible
Wed May 13 21:03:18 2020 OpenVPN 2.4.8 [git:makepkg/3976acda9bf10b5e+] x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Jan 3 2020
Wed May 13 21:03:18 2020 library versions: OpenSSL 1.1.1f 31 Mar 2020, LZO 2.10

2020-05-13 21:03:18,076 DEBG 'start-script' stdout output:
[info] OpenVPN started

2020-05-13 21:03:18,077 DEBG 'start-script' stdout output:
Wed May 13 21:03:18 2020 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

2020-05-13 21:03:18,078 DEBG 'start-script' stdout output:
Wed May 13 21:03:18 2020 TCP/UDP: Preserving recently used remote address: [AF_INET]
Wed May 13 21:03:18 2020 UDP link local: (not bound)
Wed May 13 21:03:18 2020 UDP link remote: [AF_INET]

2020-05-13 21:03:18,250 DEBG 'start-script' stdout output:
Wed May 13 21:03:18 2020 [c3288ea57944d8030ec4fc9939569fb7] Peer Connection Initiated with [AF_INET]

2020-05-13 21:03:19,373 DEBG 'start-script' stdout output:
Wed May 13 21:03:19 2020 TUN/TAP device tun0 opened
Wed May 13 21:03:19 2020 /usr/bin/ip link set dev tun0 up mtu 1500

2020-05-13 21:03:19,375 DEBG 'start-script' stdout output:
Wed May 13 21:03:19 2020 /usr/bin/ip addr add dev tun0 local 10.48.10.10 peer 10.48.10.9

2020-05-13 21:03:19,377 DEBG 'start-script' stdout output:
Wed May 13 21:03:19 2020 /root/openvpnup.sh tun0 1500 1558 10.48.10.10 10.48.10.9 init

2020-05-13 21:03:19,386 DEBG 'start-script' stdout output:
Wed May 13 21:03:19 2020 Initialization Sequence Completed

2020-05-13 21:03:19,508 DEBG 'start-script' stdout output:
[info] Port forwarding is enabled
[info] Checking endpoint 'ca-montreal.privateinternetaccess.com' is port forward enabled...

2020-05-13 21:03:19,513 DEBG 'start-script' stdout output:
[info] Attempting to curl https://www.privateinternetaccess.com/vpninfo/servers?version=82...

2020-05-13 21:03:19,920 DEBG 'start-script' stdout output:
[info] Curl successful for https://www.privateinternetaccess.com/vpninfo/servers?version=82, response code 200

2020-05-13 21:03:19,987 DEBG 'start-script' stdout output:
[info] PIA endpoint 'ca-montreal.privateinternetaccess.com' is in the list of endpoints that support port forwarding

2020-05-13 21:03:19,988 DEBG 'start-script' stdout output:
[info] List of PIA endpoints that support port forwarding:-
[info] ca-toronto.privateinternetaccess.com
[info] ca-montreal.privateinternetaccess.com
[info] ca-vancouver.privateinternetaccess.com
[info] de-berlin.privateinternetaccess.com
[info] de-frankfurt.privateinternetaccess.com
[info] sweden.privateinternetaccess.com
[info] swiss.privateinternetaccess.com
[info] france.privateinternetaccess.com
[info] czech.privateinternetaccess.com
[info] spain.privateinternetaccess.com
[info] ro.privateinternetaccess.com
[info] israel.privateinternetaccess.com
[info] Attempting to get dynamically assigned port...

2020-05-13 21:03:19,995 DEBG 'start-script' stdout output:
[info] Attempting to curl http://209.222.18.222:2000/?client_id=7d24f8ae5b6dd5a5f8f8380f005bc3333099c58a3ef84c010aadc6cdb3eb87d7...

2020-05-13 21:03:20,479 DEBG 'start-script' stdout output:
[info] Curl successful for http://209.222.18.222:2000/?client_id=7d24f8ae5b6dd5a5f8f8380f005bc3333099c58a3ef84c010aadc6cdb3eb87d7, response code 200

2020-05-13 21:03:20,515 DEBG 'start-script' stdout output:
[info] Successfully assigned incoming port 24433

2020-05-13 21:03:20,515 DEBG 'start-script' stdout output:
[info] Checking we can resolve name 'www.google.com' to address...

2020-05-13 21:03:20,698 DEBG 'start-script' stdout output:
[info] DNS operational, we can resolve name 'www.google.com' to address ''

2020-05-13 21:03:20,700 DEBG 'start-script' stdout output:
[info] Attempting to get external IP using Name Server 'ns1.google.com'...

2020-05-13 21:03:20,927 DEBG 'start-script' stdout output:
[info] Successfully retrieved external IP address 

2020-05-13 21:03:20,994 DEBG 'watchdog-script' stdout output:
[info] Deluge listening interface IP 0.0.0.0 and VPN provider IP 10.48.10.10 different, marking for reconfigure

2020-05-13 21:03:21,004 DEBG 'watchdog-script' stdout output:
[info] Deluge not running

2020-05-13 21:03:21,012 DEBG 'watchdog-script' stdout output:
[info] Deluge Web UI not running

2020-05-13 21:03:21,022 DEBG 'watchdog-script' stdout output:
[info] Privoxy not running

2020-05-13 21:03:21,022 DEBG 'watchdog-script' stdout output:
[info] Deluge incoming port 6890 and VPN incoming port 24433 different, marking for reconfigure
[info] Attempting to start Deluge...
[info] Removing deluge pid file (if it exists)...

2020-05-13 21:03:21,345 DEBG 'watchdog-script' stdout output:
[info] Deluge key 'listen_interface' currently has a value of '10.82.10.6'
[info] Deluge key 'listen_interface' will have a new value '10.48.10.10'
[info] Writing changes to Deluge config file '/config/core.conf'...

2020-05-13 21:03:21,528 DEBG 'watchdog-script' stdout output:
[info] Deluge key 'outgoing_interface' currently has a value of 'tun0'
[info] Deluge key 'outgoing_interface' will have a new value 'tun0'
[info] Writing changes to Deluge config file '/config/core.conf'...

2020-05-13 21:03:21,691 DEBG 'watchdog-script' stdout output:
[info] Deluge key 'default_daemon' currently has a value of '2764f3fde14944b381d5a620d1a3dc7f'
[info] Deluge key 'default_daemon' will have a new value '2764f3fde14944b381d5a620d1a3dc7f'
[info] Writing changes to Deluge config file '/config/web.conf'...

2020-05-13 21:03:21,976 DEBG 'watchdog-script' stdout output:
[info] Deluge process started
[info] Waiting for Deluge process to start listening on port 58846...

2020-05-13 21:03:22,191 DEBG 'watchdog-script' stdout output:
[info] Deluge process listening on port 58846

2020-05-13 21:03:24,219 DEBG 'watchdog-script' stdout output:
Setting "random_port" to: False
Configuration value successfully updated.

2020-05-13 21:03:26,320 DEBG 'watchdog-script' stdout output:
Setting "listen_ports" to: (24433, 24433)
Configuration value successfully updated.

2020-05-13 21:03:28,472 DEBG 'watchdog-script' stdout output:
[info] No torrents with state 'Error' found

2020-05-13 21:03:28,473 DEBG 'watchdog-script' stdout output:
[info] Starting Deluge Web UI...

2020-05-13 21:03:28,473 DEBG 'watchdog-script' stdout output:
[info] Deluge Web UI started

2020-05-13 21:03:28,480 DEBG 'watchdog-script' stdout output:
[info] Attempting to start Privoxy...

2020-05-13 21:03:29,492 DEBG 'watchdog-script' stdout output:
[info] Privoxy process started
[info] Waiting for Privoxy process to start listening on port 8118...

2020-05-13 21:03:29,497 DEBG 'watchdog-script' stdout output:
[info] Privoxy process listening on port 8118

 

Share this post


Link to post
8 minutes ago, surenther said:

Hello All, i am not able to access deluge Webui. I am using PIA VPN. I can able to access webui after turning of VPN. Can any one help me on this? . I tried different PIA VPN config but same issue

The same thing happens to me and I am using PIA.  I have seen no errors in the logs, and I am able to access PIA via my phone with the same endpoint.  It seems to resolve itself after a while, which I'm not really sure what side the error is on PIA or my network.  Something says PIA if it is resolving itself without any changes on my side.

 

I thought of opening a support case with PIA but I cannot replicate the error on any other device, which again seems to point to my setup.  Since there are no errors in my logs I'm not sure what they would have to go on either.

Share this post


Link to post
On 5/12/2020 at 8:28 AM, STABILO-BOSS said:

Hi Binhex,


I haven't been on my server for a while, but just went on to use Deluge, however it wont launch for me, was wondering if you could help? :)

 

My logs I see the below when I go to start the programme:

 


020-05-12 08:19:18,163 DEBG 'start-script' stdout output:
Tue May 12 08:19:18 2020 SIGHUP[soft,tls-error] received, process restarting

When a go to start deluge it just doesn't load for me.

So it turns out, my vpn server was no longer valid. I guess NORD updated their server list. I simply downloaded a new openvpn file, replaced the old 1 in appdata and everything is working again :)

Share this post


Link to post
Posted (edited)

Has anyone got this working with the thin client? aka the version you download to windows/unbuntu etc. and then connect to on your unraid server? I've tried everything but it shows the server offline all the time...

 

To the guys above me having problems with PIA. Use a different VPN provider or at the very least redownload your .conf files, place them in the opvn folder and use custom with your username and pass in the container config page. It works that way also.

 

EDIT: You know what, forget this. I give up. This thing won't cross seed and now after rebooting it's errored about 200+ of my torrents and deleted and is now redownloading them. This is is ruining business. I'm going back to ruTorrent.

Edited by plantsandbinary

Share this post


Link to post
1 hour ago, plantsandbinary said:

 

To the guys above me having problems with PIA. Use a different VPN provider or at the very least redownload your .conf files, place them in the opvn folder and use custom with your username and pass in the container config page. It works that way also.

 

Setting the custom option instead of PIA worked for me.  I'd already updated the .conf files.  Thank you!

Share this post


Link to post
Posted (edited)

Untitled.jpg

1 hour ago, PhiPhi said:

Setting the custom option instead of PIA worked for me.  I'd already updated the .conf files.  Thank you!

I tried setting up the same still not working. Am i missing anything ?

 

Edited by surenther

Share this post


Link to post
11 minutes ago, surenther said:

I tried setting up the same still not working. Am i missing anything ?

your previous log shows a successful start, so i suspect the issue is either misconfiguration of lan_network, or vlan blocking, hardware firewall blocking, adblocker on browser, or host firewall (if not unraid).

 

if you are not sure how to work out the lan_network then see Q4 in the following link:-

https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

 

Share this post


Link to post
23 minutes ago, binhex said:

your previous log shows a successful start, so i suspect the issue is either misconfiguration of lan_network, or vlan blocking, hardware firewall blocking, adblocker on browser, or host firewall (if not unraid).

 

if you are not sure how to work out the lan_network then see Q4 in the following link:-

https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

 

 

Thanks. You're correct my Unraid server is in 192.168.1.x subnet and i am trying to access through 192.168.2.x subnet. Let me check my pfsense firewall rule.

 

 

Share this post


Link to post

Hi, 

 

Good day to everyone, I have two questions(problems) regarding Deluge on Unraid. Any suggestions will be really appreciated.

 

My first problem started to appear after I tried to move a downloaded torrent to a different folder within the WebUI but I forgot about the uppercase and so deluge created a new folder with the same name. Even after I merged the folders "music" and "Music" there seems to be a consistent problem.

 

Whenever I restart or "stop and start" deluge I can access Webui but it shows an empty UI, no torrents can be seen. Although I found a workaround it is really inconvenient to redo it eachtime. If I go to AppData - binhex delugevpn and delete the safe_state_check file and restart the WebUI it recreates the file and all my torrents reappear in the WebUI. Does anyone know how to fix this problem for good?

 

The second problem can be also related to the first I'm not sure as I am a newbie but for example, after 3-4 days of constant seeding of the torrents delugevpn seems to lost connection to some of the tracker specific torrents. This also can be overcome after a restart of the container which also means that I have to delete the safe_state_check file and repeat the process for torrents to reappear. So if anyone has advice for any of the problems it will be really appreciated.

 

Regards,

 

 

Share this post


Link to post
Posted (edited)

Does anyone have some optimal settings for deluge for speed?  

 

These are my settings but the speeds are very slow :

 

 

image.png.69daa94ece000a00f62a53327af8a8cf.png

Edited by Armed Ferret
adding screenshot

Share this post


Link to post

Is there any way to stick to stable versions of the client? 

 

I'm connecting to a tracker that appears to be rejecting me because I'm using 2.0.4.dev23 on this.  I'm inquiring as to whether I'm correct on this from the tracker's forums.

 

I'm currently transitioning from my laptop which is on 2.0.3 and is working just fine with said tracker.

Share this post


Link to post

Anybody else seeing this in their log output every 30 minutes? This started happening a few days ago.

 

2020-05-17 09:37:28,402 DEBG 'watchdog-script' stdout output:
[warn] Incoming port site 'https://portchecker.co/check' failed to web scrape, marking as failed

 

Share this post


Link to post
1 hour ago, bmfrosty said:

Is there any way to stick to stable versions of the client? 

You can tag a specific version. See the github/dockerhub readmes linked in the first post.

Share this post


Link to post
Posted (edited)
7 hours ago, wgstarks said:

You can tag a specific version. See the github/dockerhub readmes linked in the first post.

So far, I'm either looking right past it, or it isn't there.  Do you have a specific link?

 

That took me an embarrassingly long time to find.

Edited by bmfrosty

Share this post


Link to post
19 minutes ago, bmfrosty said:

So far, I'm either looking right past it, or it isn't there.  Do you have a specific link?

 

That took me an embarrassingly long time to find.

The versions tab on the dockerhub page lists all the versions that are available.

Share this post


Link to post
On 5/17/2020 at 5:18 PM, Dase said:

Anybody else seeing this in their log output every 30 minutes? This started happening a few days ago.

 


2020-05-17 09:37:28,402 DEBG 'watchdog-script' stdout output:
[warn] Incoming port site 'https://portchecker.co/check' failed to web scrape, marking as failed

 

fixed, the website used to check open port had changed.

Share this post


Link to post
Posted (edited)

Having an issue with the privoxy side of things.   It's worked for a good while using both PIA and Mullvad (newest), and I've made no major changes I can think of recently to cause any problems.  But I am unable to use the proxy now for some reason.   I have re-uploaded the mullvad config files.  I am able to get into the Deluge webUI, so I know it's created a tunnel (or thinks it has), and yet I can not proxy through it via web browser,  or Jackett (which is how I found out it was failing).  I've attached the most recent reboot log.  Below are my settings with VPN ID's hidden.  Let me know any thought into the issue and how I might resolve it.

 

Thanks!

 

image.png.9eb04bcd09455ede16cd21a04fd0427b.png

Edited by Malo
Issue resolved, files removed

Share this post


Link to post
3 hours ago, Malo said:

I've attached the most recent reboot log.  Below are my settings with VPN ID's hidden.  Let me know any thought into the issue and how I might resolve it.

can you please attach the privoxy config file, its located at /config/privoxy/config

Share this post


Link to post

If I have two cache drives, does anyone know if I can install the dockers on one and use deluge to download and seed off of the other one?  I think having all the dockers and deluge torrenting all off one drive is causing some issues.  I'd like to separate them.

 

Is this possible?

Share this post


Link to post
35 minutes ago, DigitalDivide said:

If I have two cache drives, does anyone know if I can install the dockers on one and use deluge to download and seed off of the other one?  I think having all the dockers and deluge torrenting all off one drive is causing some issues.  I'd like to separate them.

 

Is this possible?

Not yet.  Two options....

1. Set up one of the drives as an Unassigned Device and move your dockers over there.  When repointing the dockers you'll need to set R/W Slave in the path options for everything that points to an Unassigned Device.  I used to have my setup like this,  Or,

2. Wait for the next version of Unraid to be released (when it's ready).  Supports multiple cache pools for this purpose

 

Share this post


Link to post
1 hour ago, DigitalDivide said:

If I have two cache drives, does anyone know if I can install the dockers on one and use deluge to download and seed off of the other one?  I think having all the dockers and deluge torrenting all off one drive is causing some issues.  I'd like to separate them.

 

Is this possible?

I have my dockers, and their data, on an unassigned drive.  I download my torrents (leeching), initially, directly onto a cache-only share.  Once the download finishes, and the torrent starts seeding, the torrent is automatically moved to a normal parity -protected share on array disks.  I then do some processing, manually, using MKVToolNix, to place the manipulated movie file on to my Movies share.  When I've completed that, I use deluge to move the torrent onto a another share on array disks.  In this way, I can martial my torrents and know which ones I've created a movie file from. Duluge only ever writes torrents to the cache drive, without use of the parity drives.  Once the torrent file is no longer being updated, it is moved to a parity-protected share for greater protection.

Share this post


Link to post

I want to separate the dockers from the download data.  I have the dockers on the cache drive and the tv shows that I watch and delete are all sitting on my unassigned drive.  Right now I don't have to touch anything.  I have Sonarr passing the tv shows I want to deluge (jackett) is involved.  When deluge downloads the file it moves it to completed folder and sonarr picks it up and moves it to my unassigned drive that I use for just watching tv shows.  Emby on my nvidia shield sees the new episode or show and I just start watching. Deluge continues seeding the files unti the ratio is reached.  I will eventually go into deluge and remove the data I no longer want sitting there.  Other than that I don't do anything, it all works flawlessy.  

 

From what I'm reading from your post and above it, the docker and deluge files have to be on the same drive unless I'm misunderstanding

 

I'm wondering if I can pop in another unassigned device and have deluge download the files to that and seed from that...??

 

Right now I have in deluge

Downloads go to /data/downloads

Completed go to /data/completed

 

Can I just put in /mnt/disks/unassigndisk/media/tv for the downloads?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.