[Support] binhex - DelugeVPN


Recommended Posts

On 9/21/2020 at 7:43 AM, binhex said:

OK guys, multi remote endpoint support is now in for this image please pull down the new image

Thanks, binhex for this release. I'm now able to connect to CA servers

 

Question about this image, and others... Is there a possibility to log on my favorites torrent site when the docker start ?

Presently, I'm going in console to manually log with a curl command. Is they're a way to automate it ?

Link to comment
On 1/21/2016 at 12:06 PM, binhex said:

PIA Users only - Next-Gen OpenVPN testing.

 

I have now finished up coding provisional support for PIA Next-Gen OpenVPN with working port forwarding, at the moment its not tagged as latest as i wanted some testers, if you fancy testing the new image then please read on:-

 

To test you need to do the following:-

1. Download next-gen ovpn config file - Click on the following link and then click on 'View OpenVPN Configurations' , please download a ovpn file for next-gen:- https://www.privateinternetaccess.com/pages/download#

2. Extract the zip and copy one of the ovpn files and all the other certs etc to /config/openvpn/, ensuring you either rename or delete the old current-gen network ovpn file.

3. Now 'edit' the container and append to the 'Repository'  the value ':test' which is the test tagged image then click 'Apply' at the bottom.

4. Restart/start the container and monitor the supervisord.log file.

 

IMPORTANT - Please note i have noticed that PIA will not permit a reallocation of an incoming port for around 15-20 minutes, so please be patient if you restart the container and previously had a port you will see lots of retries - this is out of my control sadly.

Running through this now, I love being a guinea pig

Link to comment
On 9/24/2020 at 5:25 PM, binhex said:

PIA Users - Fancy being a guinea pig for Next-Gen OpenVPN support?, if so read here:-

https://forums.unraid.net/topic/44109-support-binhex-delugevpn/?do=findComment&comment=433617

 

Guinea Pig on the loose!

 

I am getting an error when it is trying to retrieve a token from PIA. "parse error: Invalid numeric literal at line 4, column 0", and it is unable to get the payload from PIA (bottom of the log). It then goes into a loop re-connecting to PIA and trying again.

 

here is a partial log file where I am seeing this:

 

2020-09-24 18:38:17,655 DEBG 'start-script' stdout output:
[debug] VPN remote configuration options as follows...
[debug] VPN remote server is defined as 'ca-toronto.privacy.network'
[debug] VPN remote port is defined as '1198'
[debug] VPN remote protocol is defined as 'udp'
[debug] VPN remote ip is defined as '66.115.142.228 66.115.142.239 66.115.142.203 66.115.142.249 66.115.142.232'

2020-09-24 18:38:17,655 DEBG 'start-script' stdout output:
[debug] OpenVPN command line:- /usr/bin/openvpn --reneg-sec 0 --mute-replay-warnings --auth-nocache --setenv VPN_PROV 'pia' --setenv DEBUG 'true' --setenv VPN_DEVICE_TYPE 'tun0' --setenv VPN_ENABLED 'yes' --setenv vpn_remote_server 'ca-toronto.privacy.network' --setenv APPLICATION 'deluge' --script-security 2 --writepid /root/openvpn.pid --remap-usr1 SIGHUP --log-append /dev/stdout --pull-filter ignore 'up' --pull-filter ignore 'down' --pull-filter ignore 'route-ipv6' --pull-filter ignore 'ifconfig-ipv6' --pull-filter ignore 'tun-ipv6' --pull-filter ignore 'dhcp-option DNS6' --pull-filter ignore 'persist-tun' --pull-filter ignore 'reneg-sec' --up /root/openvpnup.sh --up-delay --up-restart --keepalive 10 60 --setenv STRICT_PORT_FORWARD 'yes' --setenv VPN_USER 'xxxxxxxx' --setenv VPN_PASS 'xxxxxxxx' --disable-occ --auth-user-pass credentials.conf --cd /config/openvpn --config '/config/openvpn/CA Toronto.ovpn' --remote 66.115.142.228 1198 udp --remote 66.115.142.239 1198 udp --remote 66.115.142.203 1198 udp --remote 66.115.142.249 1198 udp --remote 66.115.142.232 1198 udp --remote-random
[info] Starting OpenVPN (non daemonised)...

2020-09-24 18:38:17,661 DEBG 'start-script' stdout output:
Thu Sep 24 18:38:17 2020 WARNING: file 'credentials.conf' is group or others accessible
Thu Sep 24 18:38:17 2020 OpenVPN 2.4.9 [git:makepkg/9b0dafca6c50b8bb+] x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Apr 20 2020

2020-09-24 18:38:17,661 DEBG 'start-script' stdout output:
Thu Sep 24 18:38:17 2020 library versions: OpenSSL 1.1.1g  21 Apr 2020, LZO 2.10

2020-09-24 18:38:17,661 DEBG 'start-script' stdout output:
Thu Sep 24 18:38:17 2020 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

2020-09-24 18:38:17,662 DEBG 'start-script' stdout output:
Thu Sep 24 18:38:17 2020 CRL: loaded 1 CRLs from file [[INLINE]]

2020-09-24 18:38:17,662 DEBG 'start-script' stdout output:
Thu Sep 24 18:38:17 2020 TCP/UDP: Preserving recently used remote address: [AF_INET]66.115.142.203:1198
Thu Sep 24 18:38:17 2020 UDP link local: (not bound)
Thu Sep 24 18:38:17 2020 UDP link remote: [AF_INET]66.115.142.203:1198

2020-09-24 18:38:17,916 DEBG 'start-script' stdout output:
Thu Sep 24 18:38:17 2020 [toronto407] Peer Connection Initiated with [AF_INET]66.115.142.203:1198

2020-09-24 18:38:19,196 DEBG 'start-script' stdout output:
Thu Sep 24 18:38:19 2020 TUN/TAP device tun0 opened
Thu Sep 24 18:38:19 2020 /usr/bin/ip link set dev tun0 up mtu 1500

2020-09-24 18:38:19,197 DEBG 'start-script' stdout output:
Thu Sep 24 18:38:19 2020 /usr/bin/ip addr add dev tun0 10.9.112.3/24 broadcast 10.9.112.255

2020-09-24 18:38:19,198 DEBG 'start-script' stdout output:
Thu Sep 24 18:38:19 2020 /root/openvpnup.sh tun0 1500 1558 10.9.112.3 255.255.255.0 init

2020-09-24 18:38:19,202 DEBG 'start-script' stdout output:
[debug] Waiting for valid local and gateway IP addresses from tunnel...

2020-09-24 18:38:19,203 DEBG 'start-script' stdout output:
Thu Sep 24 18:38:19 2020 Initialization Sequence Completed

2020-09-24 18:38:21,231 DEBG 'start-script' stdout output:
[debug] Valid local IP address from tunnel acquired '10.9.112.3'
[debug] Valid gateway IP address from tunnel acquired '10.9.112.1'

2020-09-24 18:38:21,231 DEBG 'start-script' stdout output:
[debug] Checking we can resolve name 'www.google.com' to address...

2020-09-24 18:38:21,392 DEBG 'start-script' stdout output:
[debug] DNS operational, we can resolve name 'www.google.com' to address '172.217.23.132'

2020-09-24 18:38:21,392 DEBG 'start-script' stdout output:
[info] Attempting to get external IP using Name Server 'ns1.google.com'...

2020-09-24 18:38:21,741 DEBG 'start-script' stdout output:
[info] Successfully retrieved external IP address 66.115.142.203

2020-09-24 18:38:21,742 DEBG 'start-script' stdout output:
[info] Port forwarding is enabled
[info] Checking endpoint 'ca-toronto.privacy.network' is port forward enabled...

2020-09-24 18:38:27,954 DEBG 'start-script' stdout output:
parse error: Invalid numeric literal at line 4, column 0

2020-09-24 18:38:27,956 DEBG 'start-script' stdout output:
[info] PIA endpoint 'ca-toronto.privacy.network' is in the list of endpoints that support port forwarding

2020-09-24 18:38:27,956 DEBG 'start-script' stdout output:
[info] List of PIA endpoints that support port forwarding:-

2020-09-24 18:38:27,957 DEBG 'start-script' stdout output:
[info] al.privacy.network
[info] ad.privacy.network
[info] austria.privacy.network
[info] brussels.privacy.network
[info] ba.privacy.network
[info] sofia.privacy.network
[info] czech.privacy.network
[info] denmark.privacy.network
[info] ee.privacy.network
[info] fi.privacy.network
[info] france.privacy.network
[info] de-frankfurt.privacy.network
[info] de-berlin.privacy.network
[info] gr.privacy.network
[info] hungary.privacy.network
[info] is.privacy.network
[info] ireland.privacy.network
[info] man.privacy.network
[info] italy.privacy.network
[info] lv.privacy.network

2020-09-24 18:38:27,957 DEBG 'start-script' stdout output:
[info] liechtenstein.privacy.network
[info] lt.privacy.network
[info] lu.privacy.network
[info] mk.privacy.network
[info] malta.privacy.network
[info] md.privacy.network
[info] monaco.privacy.network
[info] montenegro.privacy.network
[info] nl-amsterdam.privacy.network
[info] no.privacy.network
[info] poland.privacy.network
[info] pt.privacy.network
[info] ro.privacy.network
[info] rs.privacy.network
[info] sk.privacy.network
[info] spain.privacy.network
[info] sweden.privacy.network
[info] swiss.privacy.network
[info] ua.privacy.network
[info] uk-manchester.privacy.network
[info] uk-london.privacy.network
[info] uk-southampton.privacy.network
[info] bahamas.privacy.network
[info] ca-vancouver.privacy.network
[info] ca-ontario.privacy.network
[info] ca-montreal.privacy.network
[info] ca-toronto.privacy.network
[info] greenland.privacy.network
[info] mexico.privacy.network

2020-09-24 18:38:27,957 DEBG 'start-script' stdout output:
[info] panama.privacy.network
[info] ar.privacy.network
[info] br.privacy.network
[info] venezuela.privacy.network
[info] yerevan.privacy.network
[info] cambodia.privacy.network
[info] cyprus.privacy.network
[info] georgia.privacy.network
[info] hk.privacy.network
[info] in.privacy.network
[info] iran.privacy.network
[info] israel.privacy.network
[info] japan.privacy.network
[info] kazakhstan.privacy.network
[info] philippines.privacy.network
[info] qatar.privacy.network
[info] saudiarabia.privacy.network
[info] sg.privacy.network
[info] srilanka.privacy.network
[info] taiwan.privacy.network
[info] tr.privacy.network
[info] ae.privacy.network
[info] vietnam.privacy.network
[info] aus-perth.privacy.network
[info] au-sydney.privacy.network
[info] aus-melbourne.privacy.network
[info] nz.privacy.network
[info] dz.privacy.network

2020-09-24 18:38:27,957 DEBG 'start-script' stdout output:
[info] egypt.privacy.network
[info] morocco.privacy.network
[info] nigeria.privacy.network
[info] za.privacy.network

2020-09-24 18:38:27,957 DEBG 'start-script' stdout output:
[debug] Waiting for valid local and gateway IP addresses from tunnel...

2020-09-24 18:38:29,985 DEBG 'start-script' stdout output:
[debug] Valid local IP address from tunnel acquired '10.9.112.3'
[debug] Valid gateway IP address from tunnel acquired '10.9.112.1'

2020-09-24 18:38:36,007 DEBG 'start-script' stdout output:
parse error: Invalid numeric literal at line 4, column 0

2020-09-24 18:38:36,509 DEBG 'start-script' stdout output:
[warn] Unable to successfully download PIA json payload from URL 'https://10.9.112.1:19999/getSignature?token=8gm84jFIIDNCf5dGOMau_4pmRONktjf4Xt1WKFD1yB_N8wqWBuxOOOMIhxQUjv2+g+H9UbwoM2Q3HFX8nttSCKrRt7xM2TcWxr6aShK1dNTKhzdrSmeQ0XHsb0E='
[info] 12 retries left
[info] Retrying in 10 secs...


 

Edited by jonathanm
redact creds
Link to comment
30 minutes ago, MisterOrange said:

I am getting an error when it is trying to retrieve a token from PIA. "parse error: Invalid numeric literal at line 4, column 0", and it is unable to get the payload from PIA (bottom of the log). It then goes into a loop re-connecting to PIA and trying again.

I was getting the same, but left it for a few minutes and it came good on it's own.

 

Getting great speeds finally from an endpoint on my own continent (au-sydney)! :)

 

@binhex do you need anything specific from us guinea pigs?

Edited by Jorgen
Link to comment
2 hours ago, Jorgen said:

I was getting the same, but left it for a few minutes and it came good on it's own.

 

Getting great speeds finally from an endpoint on my own continent (au-sydney)! :)

 

@binhex do you need anything specific from us guinea pigs?

This eventually worked for me as well...sort of. Deluge came up correctly and the UI was working, however I am unable to connect to Deluge from Sonarr whenever the VPN was enable. Works fine with it disabled. Experimenting with settings now, but it takes forever to try each one since it is taking 10-15 minutes for it to eventually connect to PIA correctly.

Link to comment

Hello,

I posted about my Deluge issues elsewhere, and did not get the answer I was looking for so I will try this thread.

I have binhex-delugevpn installed, and it works like a charm when the "VPN_ENABLED" option is disabled.

 

However! when I do enable VPN_ENABLED option on startup, the deluge docker never starts up. I get log errors reminiscent of the below (and attached).

image.png.53c154d7fd4bd7879b157fa8a21781de.png

What Is the reason that I am seeing IPv6 references in the log?

 

I have PIA ovpn files in the ovpn appdata folder as required. I think I have in there the "next gen" option.

 

Like I said earlier, when the VPN_ENABLED option is set to NO, everything works, the docker starts, and I'm able to get into the GUI.

There is no point to use deluge to download torrents unless I am connected to a VPN.

 

Any and all help is very appreciated.

 

Thank you!

-Eli

Deluge_Log_09242020.pdf

Edited by UnBeastRaid
Link to comment
Very happy with the next-gen testing. Had to throttle the download bandwidth in deluge because downloading an Ubuntu ISO maxed out my internet connection!
I too am seeing speeds on next gen that I never achieved on current gen, very close to line speeds for me.

Sent from my CLT-L09 using Tapatalk

Link to comment
1 minute ago, chris_netsmart said:

Reading back through the posts. And before u go ahead and do this.  Is it as easyer as.

 

Download the new opvn files.

Unzip and choose you endpoint

And copy over the endpoint and cerf.

 

If so then i will try it later once i get home. And post the results

 

Remember and change the 'Repository' part to show':test:, too:
image.png.c3bafbe2345d82435b97f901e9cd4a30.png

 

I'm struggling to get connected. Tried Berlin for the last 90mins or so (let it cycle for about 30mins, stopped, gave it 20mins or so before another attempt) & about to try another endpoint, so will update when I've tried that.
 

Link to comment

Connected now, after a bunch of retries, to Frankfurt. 

 

Seemed to have a few logs of this; am I right in thinking this is when PIA aren't permitting a reallocation?

[warn] Unable to successfully download PIA json to generate token from URL 'https://212.102.57.65/authv3/generateToken'
[info] 2 retries left
[info] Retrying in 10 secs...

 

This is the one I seen most, not sure what it is, or refers to, but most people seem to be seeing it:

2020-09-25 10:07:16,021 DEBG 'start-script' stdout output:
parse error: Invalid numeric literal at line 4, column 0

 

Tested using an Ubuntu image download... and I'm still getting only around 600-800Kib/s in download speed. Cannot for the life of me figure out why I'm not getting any faster than that. Same image, connected with PIA Windows app (same location endpoint on nextgen) on gaming rig is getting ~12-13Mb/s 😧

Link to comment
5 minutes ago, xxDeadbolt said:

Connected now, after a bunch of retries, to Frankfurt. 

 

Seemed to have a few logs of this; am I right in thinking this is when PIA aren't permitting a reallocation?


[warn] Unable to successfully download PIA json to generate token from URL 'https://212.102.57.65/authv3/generateToken'
[info] 2 retries left
[info] Retrying in 10 secs...

 

This is the one I seen most, not sure what it is, or refers to, but most people seem to be seeing it:


2020-09-25 10:07:16,021 DEBG 'start-script' stdout output:
parse error: Invalid numeric literal at line 4, column 0

 

Tested using an Ubuntu image download... and I'm still getting only around 600-800Kib/s in download speed. Cannot for the life of me figure out why I'm not getting any faster than that. Same image, connected with PIA Windows app (same location endpoint on nextgen) on gaming rig is getting ~12-13Mb/s 😧

I’m seeing slow performance as well, but I suspect it’s on the PIA side. Strangely, binhex’s rTorrent VPN docker using Mullvad without forwarding working I can get 82-85MB/sec on my gigabit connection, but the same torrent with next gen in DelugeVPN won’t get above 22-24MB/sec and that’s using the high performance options with the ItConfig plugin. 

Link to comment
10 minutes ago, xxDeadbolt said:

This is the one I seen most, not sure what it is, or refers to, but most people seem to be seeing it:


2020-09-25 10:07:16,021 DEBG 'start-script' stdout output:
parse error: Invalid numeric literal at line 4, column 0

this can be safely ignored, i am aware of it and will try to silence it in the future, it is purely the json parser tool 'jq' bitching cos it found content that it couldnt parse, this is due to pia being a bit shit and lobbing some crappy hash or some such at the bottom of the json.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.