[Support] binhex - DelugeVPN


8664 posts in this topic Last Reply

Recommended Posts

2 hours ago, CBPXXIV said:

I've finally given up.  I realized I was on an old version that I had pulled for some reason so I'm now on the latest I can't for the life of me get the next gen PIA endpoints to work with strict port forwarding enabled.  Looking at the log it says the endpoint I'm trying to connected to doesn't support port forwarding but it should and I looks like the ones in the log are the legacy addresses? Hopefully someone can see whatever silly error I'm making.  I also noticed the the auto remove plug-in is not longer there, that's disappointing.  Or did I mess that up too?  Removing strict port forward I'm able to get the gui no issue, any help would be appreciated.

 

Thanks

-cb

supervisord 120202.log 35.21 kB · 2 downloads

you are either still specifying a specific tagged release or the 'latest' image you have on disk is out of date, solutions for both:-

 

1. tagged release - go to unraid web ui/docker/left click and select edit for the container/go to 'Repository:' field and remove everything including the colon from the Repository field. e.g.:-

binhex/arch-delugevpn:test

becomes

binhex/arch-delugevpn

2. out of date image - go to unraid web ui/docker/click on 'check for updates' at the bottom, and then select 'update all' - wait for it to finish then check the logs again to confirm its working. 

Link to post
  • Replies 8.7k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

There has been an issue raised on GitHub related to tracker announce request IP leakage under certain circumstances, after careful review of iptables i have tightened up the rules to prevent this. A n

OK guys, multi remote endpoint support is now in for this image please pull down the new image (this change will be rolled out to all my vpn images shortly).   What this means is that the im

I wanted to summarize how I got Mullvad working with DelugeVPN as I had to piece together several "solutions" from different comments in this thread and there was some incorrect info; likely old.

Posted Images

4 hours ago, binhex said:

you are either still specifying a specific tagged release or the 'latest' image you have on disk is out of date, solutions for both:-

 

1. tagged release - go to unraid web ui/docker/left click and select edit for the container/go to 'Repository:' field and remove everything including the colon from the Repository field. e.g.:-


binhex/arch-delugevpn:test

becomes

binhex/arch-delugevpn

2. out of date image - go to unraid web ui/docker/click on 'check for updates' at the bottom, and then select 'update all' - wait for it to finish then check the logs again to confirm its working. 

 

The Repository field was already set to that.  Did the check for updates and there was one available.  That did the trick, now I feel amazingly stupid for not checking that lol.  That for the help, now to try and figure out how to get auto remove installed again.  It disappeared and doesn't seem to want to install again

Link to post
1 hour ago, binhex said:

The egg file is in the plugins folder, it was working before I updated deluge.  I downloaded a fresh copy and a previous version and tried both (not at the same time obviously), it's not showing in the plugins settings.  Tried both AutoRemovePlus-0.6.1-py2.7 and AutoRemovePlus-0.6.1-py2.6, should be the correct versions for Deluge 2.x+.  Concerning Q4, That file will not open with notepad++ even with the container stopped, however this is not the issue I' m having but I figured I would take a look.

Screenshot 2020-12-02 121958.png

Screenshot 2020-12-02 122652.png

Link to post
46 minutes ago, CBPXXIV said:

Tried both AutoRemovePlus-0.6.1-py2.7 and AutoRemovePlus-0.6.1-py2.6, should be the correct versions for Deluge 2.x+. 

The current updated version of the plugin is 0.6.6. Different branch.

https://github.com/springjools/deluge-autoremoveplus/releases/tag/0.6.6

 

I've also noticed that trying to open core.conf and some of the other appdata files results in permissions errors.

Link to post
31 minutes ago, wgstarks said:

The support thread for the plugin is here if you want to follow the changes made to it.

Thanks, I grabbed the egg and was able to edit the conf file.  box just unchecks itself when I try to turn it on in the gui.  At least I have a place to start at now

Link to post
6 hours ago, wgstarks said:

Not all plugins are compatible with the webUI (I’m not sure about this one). You may have to configure it via GTK.

I know the version I mentioned before was, the 6.1 one.  Not sure if the the branch 6.6 you linked is.  I had it working before I upgraded to use the next gen servers.  Odd.  I'm probably  missing something silly again like not clicking update as binhex suggested earlier.  At the very least its showing in the settings now, I'll have to fiddle around with it and browse some more threads.  Fingers crossed. 

 

EDIT:

FYI, there is a newer version of the auto remove plus that seems to be functioning properly

https://forum.deluge-torrent.org/viewtopic.php?f=9&t=55733&p=232150&hilit=autoremove#p232150

 

Edited by CBPXXIV
new information
Link to post

I was using NordVPN for awhile since I already had an account with them, but just switched to PIA. When I try to start Deluge using PIA instead, it just hangs. if VPN_ENABLED is set to false, it's fine. When I start the container with VPN_ENABLED, the web UI just says "refused to connect," and if I try to view logs from the Docker page of Unraid that also hangs. I can connect to the container with no issues, and the deluged.log doesn't seem to show anything spooky. I've got the cert files and a .ovpn endpoint in the openvpn folder, and I've verified that the username + password are correct. I have also updated to the most recent image. Any ideas of what else could be causing the hang?

 

EDIT: Nevermind, found AUTH_FAILED issues. Will try to fix then loop back if I still have issues.

Edited by Liam_Galt
Link to post
20 minutes ago, Liam_Galt said:

EDIT: Nevermind, found AUTH_FAILED issues. Will try to fix then loop back if I still have issues.

Be sure you are using the user name/password that you use to login to the PIA website. User name should start with a p.

Link to post
Just now, wgstarks said:

Be sure you are using the user name/password that you use to login to the PIA website. User name should start with a p.

Yeah, it's the correct username/password. I've triple-checked, and typed it in manually multiple times, but still no luck.

Link to post
6 minutes ago, Liam_Galt said:

Yeah, it's the correct username/password. I've triple-checked, and typed it in manually multiple times, but still no luck.

Couple of folk have had this, but if your password is more than 99 chars, I think, it has issues - if it is, try changing it to something smaller

Link to post
5 hours ago, binhex said:

This is unfortunately where I started in the first place:

 

Quote

[Cause] Your subscription has run out [Solution] double check this on the vpn providers website.

Subscribed yesterday, verified that it works with PIA Chrome extension.

Quote

[Cause] You have not typed in your username (VPN_USER value) and/or password (VPN_PASS value) correctly [Solution] do not copy and paste, type it in manually to prevent whitespace issues.

These are correct.

Quote

[Cause] You are using the wrong credentials [Solution] ensure the credentials are for openvpn/wireguard, NOT proxy servers etc. [PIA users] Do NOT use the generated PPTP/L2TP/Socks Username and Password, this is not the correct credentials, you need to specify the web login credentials (username will be of the format Pxxxxxx) for VPN_USER and VPN_PASS.

I am using the p****** username, and the password. They work in other PIA clients.

Quote

[Cause] Your password contains a character which may cause issues [Solution] please ensure it only contains letters a-z (upper case or lower case) and numbers 0-9.

It is only alphanumeric. I've tried changing a few times, still no luck.

Quote

[Cause] Your password is too long [Solution] Certain VPN providers (such as PIA) may limit the password length, please try shortening the password for your account. [PIA users] The maximum length for account passwords has changed with next-gen network, please ensure your password is 99 characters or less.

The password is only 16 characters.

Quote

[Cause] Out of date openvpn config file (ovpn extension) [Solution] ensure you download the latest ovpn file from your vpn provider.

I downloaded them yesterday.

Quote

[Cause] The vpn provider you have signed up with is having authentication issues [Solution] try another endpoint, failing that contact the vpn provider and explain you are having authentication issues when using native openvpn/wireguard clients with AUTH_FAILED shown.

Again, other PIA clients work.

 

I've tried using both Wireguard and OpenVPN but to no avail, still AUTH_FAILED.

Link to post
3 minutes ago, Liam_Galt said:

Here's what I've got. Thanks for taking a look.

supervisord.log 823.62 kB · 1 download

from your log i see the following cipher set in your ovpn file (located in /config/openvpn/):-

cipher aes-128-cbc

can you try removing that line and replacing it with:-

cipher aes-256-gcm
ncp-disable

 

Link to post
11 minutes ago, binhex said:

from your log i see the following cipher set in your ovpn file (located in /config/openvpn/):-


cipher aes-128-cbc

can you try removing that line and replacing it with:-


cipher aes-256-gcm
ncp-disable

 

Still AUTH_FAILURE, but with deprecated option warnings:
2020-12-03 10:11:47 DEPRECATED OPTION: --cipher set to 'aes-256-gcm' but missing in --data-ciphers (AES-256-GCM:AES-128-GCM). Future OpenVPN version will ignore --cipher for cipher negotiations. Add 'aes-256-gcm' to --data-ciphers or change --cipher 'aes-256-gcm' to --data-ciphers-fallback 'aes-256-gcm' to silence this warning.

Link to post
11 minutes ago, Liam_Galt said:

Still AUTH_FAILURE, but with deprecated option warnings:

the deprecation warnings can be ignored, ok dude im afraid i got to the end of my list of known issues for auth_failure :-(.

 

the only thing left is to contact pia and see what they can see from their side.

Edited by binhex
Link to post
1 hour ago, binhex said:

the deprecation warnings can be ignored, ok dude im afraid i got to the end of my list of known issues for auth_failure :-(.

 

the only thing left is to contact pia and see what they can see from their side.

Support told me to ask on reddit :'D

I'll loop back here if I figure it out in case someone encounters a similar issue in the future.

Link to post
On 10/25/2020 at 12:14 PM, eastpanther95 said:

PIA user here, moving to nextgen servers, removed old container and image. Pulled using command:

 

docker create --name deluge --restart=always --privileged=true -p 8112:8112 -p 8118:8118 -p 58846:58846 -p 58946:58946 -v H:\Deluge\Data:/data -v H:\Deluge\config:/config -v /etc/localtime:/etc/localtime:ro -e VPN_ENABLED=yes -e VPN_CLIENT=wireguard -e VPN_USER=XXXXXXX -e VPN_PASS=XXXXXXX -e VPN_PROV=pia -e STRICT_PORT_FORWARD=yes -e ENABLE_PRIVOXY=yes -e LAN_NETWORK=10.0.0.0/24 -e NAME_SERVERS=84.200.69.80,37.235.1.174,1.1.1.1,37.235.1.177,84.200.70.40,1.0.0.1 -e DELUGE_DAEMON_LOG_LEVEL=info -e DELUGE_WEB_LOG_LEVEL=info -e DEBUG=false -e UMASK=000 -e PUID=0 -e PGID=0 binhex/arch-delugevpn

 

 

VPN fails to start, supervisord shows the issue bringing up the interface. Not sure what the resolution is. Any help?


2020-10-25 17:05:49,384 DEBG 'start-script' stderr output:
[#] ip link add wg0 type wireguard
2020-10-25 17:05:49,389 DEBG 'start-script' stderr output:
RTNETLINK answers: Operation not supported
2020-10-25 17:05:49,402 DEBG 'start-script' stderr output:
Unable to access interface: Protocol not supported
2020-10-25 17:05:49,404 DEBG 'start-script' stderr output:
[#] ip link delete dev wg0
2020-10-25 17:05:49,422 DEBG 'start-script' stdout output:
[warn] WireGuard interface failed to come 'up', exit code is '1'

 

 

Bumping this back up not sure if any of you have similar issues

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.