[Support] binhex - DelugeVPN


Recommended Posts

35 minutes ago, cpthook said:


Hello..  Started to receive a network error this morning and wanted to see if I was the only one.  GUI no longer connects after working nonstop for a few years.  Has anything changed?  I tried a few different PIA DNS servers but no success.

 

Thanks for any help

 

 

____________________________________________________________________________________________________

 

 

Created by...
___. .__ .__
\_ |__ |__| ____ | |__ ____ ___ ___
| __ \| |/ \| | \_/ __ \\ \/ /
| \_\ \ | | \ Y \ ___/ > <
|___ /__|___| /___| /\___ >__/\_ \
\/ \/ \/ \/ \/
https://hub.docker.com/u/binhex/

2021-11-05 05:07:02.735709 [info] Host is running unRAID
2021-11-05 05:07:02.754610 [info] System information Linux 3be0b24c9ad8 5.10.28-Unraid #1 SMP Wed Apr 7 08:23:18 PDT 2021 x86_64 GNU/Linux
2021-11-05 05:07:02.777898 [info] OS_ARCH defined as 'x86-64'
2021-11-05 05:07:02.800370 [info] PUID defined as '99'
2021-11-05 05:07:02.838791 [info] PGID defined as '100'
2021-11-05 05:07:02.891200 [info] UMASK defined as '000'
2021-11-05 05:07:02.911622 [info] Permissions already set for volume mappings
2021-11-05 05:07:02.944129 [info] Deleting files in /tmp (non recursive)...
2021-11-05 05:07:02.968962 [info] VPN_ENABLED defined as 'yes'
2021-11-05 05:07:02.989930 [info] VPN_CLIENT defined as 'openvpn'
2021-11-05 05:07:03.010404 [info] VPN_PROV defined as 'pia'
2021-11-05 05:07:03.158229 [info] OpenVPN config file (ovpn extension) is located at /config/openvpn/Czech Republic.ovpn
2021-11-05 05:07:03.199427 [info] VPN remote server(s) defined as 'czech.privacy.network,'
2021-11-05 05:07:03.216710 [info] VPN remote port(s) defined as '1198,'
2021-11-05 05:07:03.233887 [info] VPN remote protcol(s) defined as 'udp,'
2021-11-05 05:07:03.254197 [info] VPN_DEVICE_TYPE defined as 'tun0'
2021-11-05 05:07:03.274290 [info] VPN_OPTIONS not defined (via -e VPN_OPTIONS)
2021-11-05 05:07:03.296416 [info] LAN_NETWORK defined as '192.168.1.0/24'
2021-11-05 05:07:03.317205 [info] NAME_SERVERS defined as '10.0.0.242,10.0.0.243'
2021-11-05 05:07:03.337587 [info] VPN_USER defined as '*****'
2021-11-05 05:07:03.358686 [info] VPN_PASS defined as '*******'
2021-11-05 05:07:03.379035 [info] STRICT_PORT_FORWARD defined as 'yes'
2021-11-05 05:07:03.399482 [info] ENABLE_PRIVOXY defined as 'yes'
2021-11-05 05:07:03.423988 [info] VPN_INPUT_PORTS not defined (via -e VPN_INPUT_PORTS), skipping allow for custom incoming ports
2021-11-05 05:07:03.443900 [info] VPN_OUTPUT_PORTS not defined (via -e VPN_OUTPUT_PORTS), skipping allow for custom outgoing ports
2021-11-05 05:07:03.466204 [info] DELUGE_DAEMON_LOG_LEVEL defined as 'info'
2021-11-05 05:07:03.486555 [info] DELUGE_WEB_LOG_LEVEL defined as 'info'
2021-11-05 05:07:03.507682 [info] Starting Supervisor...
2021-11-05 05:07:03,777 INFO Included extra file "/etc/supervisor/conf.d/delugevpn.conf" during parsing
2021-11-05 05:07:03,777 INFO Set uid to user 0 succeeded
2021-11-05 05:07:03,781 INFO supervisord started with pid 7
2021-11-05 05:07:04,783 INFO spawned: 'shutdown-script' with pid 189
2021-11-05 05:07:04,784 INFO spawned: 'start-script' with pid 190
2021-11-05 05:07:04,785 INFO spawned: 'watchdog-script' with pid 191
2021-11-05 05:07:04,785 INFO reaped unknown pid 8 (exit status 0)
2021-11-05 05:07:04,788 DEBG 'start-script' stdout output:
[info] VPN is enabled, beginning configuration of VPN

2021-11-05 05:07:04,788 INFO success: shutdown-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-11-05 05:07:04,788 INFO success: start-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-11-05 05:07:04,789 INFO success: watchdog-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-11-05 05:07:04,826 DEBG 'start-script' stdout output:
[info] Adding 10.0.0.242 to /etc/resolv.conf

2021-11-05 05:07:04,828 DEBG 'start-script' stdout output:
[info] Adding 10.0.0.243 to /etc/resolv.conf

2021-11-05 05:07:34,864 DEBG 'start-script' stderr output:
Error: error sending query: Could not send or receive, because of network error


2021-11-05 05:08:09,898 DEBG 'start-script' stderr output:
Error: error sending query: Could not send or receive, because of network error


 

 

24 minutes ago, binhex said:

this looks like a networking issue on your end, check your server can perform dns resolution, also check name servers 10.0.0.242,10.0.0.243 are operational.

Mine started doing the exact same thing yesterday... Haven't changed a thing other then restoring a previous docker backup

 

Link to comment
13 minutes ago, cpthook said:

with the SabNZBD_VPN container just fine. 

i would suspect if you rebooted the sabnzbdvpn container it would be in the same state - i.e. unable to resolve, try changing NAME_SERVERS value to the defaults:-

209.222.18.222,84.200.69.80,37.235.1.174,1.1.1.1,209.222.18.218,37.235.1.177,84.200.70.40,1.0.0.1

 

Link to comment
5 minutes ago, binhex said:

i would suspect if you rebooted the sabnzbdvpn container it would be in the same state - i.e. unable to resolve, try changing NAME_SERVERS value to the defaults:-

209.222.18.222,84.200.69.80,37.235.1.174,1.1.1.1,209.222.18.218,37.235.1.177,84.200.70.40,1.0.0.1

 

 

Thanks... :)  you are correct.  I actually just did what you suggested on my own after looking at my SAB settings again.  Looking at logs, Deluge skipped over a few name server before it chose Default route for container is 172.17.0.1.  I did not have backup name servers with my previous Deluge setup.

 

[info] VPN is enabled, beginning configuration of VPN

2021-11-05 08:16:14,201 INFO success: shutdown-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-11-05 08:16:14,201 INFO success: start-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-11-05 08:16:14,201 INFO success: watchdog-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-11-05 08:16:14,236 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.222 to /etc/resolv.conf

2021-11-05 08:16:14,238 DEBG 'start-script' stdout output:
[info] Adding 84.200.69.80 to /etc/resolv.conf

2021-11-05 08:16:14,241 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.174 to /etc/resolv.conf

2021-11-05 08:16:14,244 DEBG 'start-script' stdout output:
[info] Adding 1.1.1.1 to /etc/resolv.conf

2021-11-05 08:16:14,246 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.218 to /etc/resolv.conf

2021-11-05 08:16:14,250 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.177 to /etc/resolv.conf

2021-11-05 08:16:14,253 DEBG 'start-script' stdout output:
[info] Adding 84.200.70.40 to /etc/resolv.conf

2021-11-05 08:16:14,256 DEBG 'start-script' stdout output:
[info] Adding 1.0.0.1 to /etc/resolv.conf

2021-11-05 08:16:59,501 DEBG 'start-script' stdout output:
[info] Default route for container is 172.17.0.1

2021-11-05 08:16:59,511 DEBG 'start-script' stdout output:
[info] Docker network defined as 172.17.0.0/16

2021-11-05 08:16:59,514 DEBG 'start-script' stdout output:
[info] Adding 192.168.1.0/24 as route via docker eth0

2021-11-05 08:16:59,515 DEBG 'start-script' stdout output:
[info] ip route defined as follows...

 

Link to comment
2 hours ago, mrMTB said:

Any thoughts on what might have changed?

nothing has changed in the image, it was last built months ago, so its either vpn issue or you have changed something on your lan, possible causes:-

 

    wrong lan_network - check q4:- https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md 
    out of date openvpn/wireguard config file - download new one from vpn provider
    browser blocking - adblock or similar?
    host blocking - firewall installed?
    vlan blocking - check
    pihole/pfsense/opnsense/router blocking - changed config recently?

Link to comment

I upgrade unRaid to the latest RC2 release and since then delugeVPN is not working as before. I used to have both, login for different external IP and set the Proxy from within the WebUI. This gave me great download speed. Now, if I have the Proxy enabled, no download is happening. Everything is seeded though so it is weird to say the least...

Link to comment

Did PIA change it's port forwarded servers again? I'm getting all KB speeds this morning. My supervisord.log only shows; 
[info] qatar.privacy.network
[info] saudiarabia.privacy.network
[info] sg.privacy.network
[info] srilanka.privacy.network
[info] taiwan.privacy.network
[info] tr.privacy.network
[info] ae.privacy.network
[info] vietnam.privacy.network
[info] aus-melbourne.privacy.network
[info] au-sydney.privacy.network
[info] aus-perth.privacy.network
[info] nz.privacy.network
[info] dz.privacy.network
[info] egypt.privacy.network
[info] morocco.privacy.network
[info] nigeria.privacy.network
[info] za.privacy.network

None of which I currently have configured. 

Link to comment
3 minutes ago, sol said:

Did PIA change it's port forwarded servers again? I'm getting all KB speeds this morning. My supervisord.log only shows; 
[info] qatar.privacy.network
[info] saudiarabia.privacy.network
[info] sg.privacy.network
[info] srilanka.privacy.network
[info] taiwan.privacy.network
[info] tr.privacy.network
[info] ae.privacy.network
[info] vietnam.privacy.network
[info] aus-melbourne.privacy.network
[info] au-sydney.privacy.network
[info] aus-perth.privacy.network
[info] nz.privacy.network
[info] dz.privacy.network
[info] egypt.privacy.network
[info] morocco.privacy.network
[info] nigeria.privacy.network
[info] za.privacy.network

None of which I currently have configured. 

just restarted my container and i dont see the same, ive got the normal listing:-

2021-11-08 16:15:03,371 DEBG 'start-script' stdout output:
[info] PIA endpoint 'nl-amsterdam.privacy.network' is in the list of endpoints that support port forwarding

2021-11-08 16:15:03,372 DEBG 'start-script' stdout output:
[info] List of PIA endpoints that support port forwarding:-

2021-11-08 16:15:03,372 DEBG 'start-script' stdout output:
[info] al.privacy.network

2021-11-08 16:15:03,372 DEBG 'start-script' stdout output:
[info] ad.privacy.network
[info] austria.privacy.network
[info] brussels.privacy.network
[info] ba.privacy.network
[info] sofia.privacy.network
[info] zagreb.privacy.network
[info] czech.privacy.network
[info] denmark.privacy.network
[info] denmark-2.privacy.network
[info] ee.privacy.network
[info] fi.privacy.network

2021-11-08 16:15:03,372 DEBG 'start-script' stdout output:
[info] fi-2.privacy.network
[info] france.privacy.network
[info] de-berlin.privacy.network
[info] de-frankfurt.privacy.network
[info] gr.privacy.network
[info] hungary.privacy.network
[info] is.privacy.network
[info] ireland.privacy.network
[info] man.privacy.network
[info] italy.privacy.network
[info] italy-2.privacy.network
[info] lv.privacy.network
[info] liechtenstein.privacy.network
[info] lt.privacy.network
[info] lu.privacy.network

2021-11-08 16:15:03,373 DEBG 'start-script' stdout output:
[info] mk.privacy.network
[info] malta.privacy.network
[info] md.privacy.network
[info] monaco.privacy.network
[info] montenegro.privacy.network
[info] nl-amsterdam.privacy.network
[info] no.privacy.network
[info] poland.privacy.network
[info] pt.privacy.network
[info] ro.privacy.network
[info] rs.privacy.network

2021-11-08 16:15:03,373 DEBG 'start-script' stdout output:
[info] sk.privacy.network
[info] spain.privacy.network
[info] sweden.privacy.network
[info] sweden-2.privacy.network
[info] swiss.privacy.network
[info] ua.privacy.network
[info] uk-london.privacy.network
[info] uk-southampton.privacy.network
[info] uk-manchester.privacy.network
[info] uk-2.privacy.network
[info] bahamas.privacy.network
[info] ca-toronto.privacy.network

2021-11-08 16:15:03,373 DEBG 'start-script' stdout output:
[info] ca-montreal.privacy.network
[info] ca-vancouver.privacy.network
[info] ca-ontario.privacy.network
[info] greenland.privacy.network
[info] mexico.privacy.network
[info] panama.privacy.network
[info] ar.privacy.network
[info] br.privacy.network
[info] venezuela.privacy.network
[info] yerevan.privacy.network
[info] bangladesh.privacy.network
[info] cambodia.privacy.network
[info] china.privacy.network

2021-11-08 16:15:03,373 DEBG 'start-script' stdout output:
[info] cyprus.privacy.network
[info] georgia.privacy.network
[info] hk.privacy.network
[info] in.privacy.network
[info] israel.privacy.network
[info] japan.privacy.network
[info] japan-2.privacy.network
[info] kazakhstan.privacy.network
[info] macau.privacy.network
[info] mongolia.privacy.network
[info] philippines.privacy.network
[info] qatar.privacy.network
[info] saudiarabia.privacy.network

2021-11-08 16:15:03,373 DEBG 'start-script' stdout output:
[info] sg.privacy.network
[info] srilanka.privacy.network
[info] taiwan.privacy.network
[info] tr.privacy.network
[info] ae.privacy.network
[info] vietnam.privacy.network
[info] au-sydney.privacy.network
[info] aus-melbourne.privacy.network
[info] aus-perth.privacy.network
[info] nz.privacy.network

2021-11-08 16:15:03,373 DEBG 'start-script' stdout output:
[info] dz.privacy.network
[info] egypt.privacy.network
[info] morocco.privacy.network
[info] nigeria.privacy.network
[info] za.privacy.network

 

Link to comment
11 minutes ago, binhex said:

just restarted my container and i dont see the same, ive got the normal listing:-

2021-11-08 16:15:03,371 DEBG 'start-script' stdout output:
[info] PIA endpoint 'nl-amsterdam.privacy.network' is in the list of endpoints that support port forwarding

2021-11-08 16:15:03,372 DEBG 'start-script' stdout output:
[info] List of PIA endpoints that support port forwarding:-

2021-11-08 16:15:03,372 DEBG 'start-script' stdout output:
[info] al.privacy.network

2021-11-08 16:15:03,372 DEBG 'start-script' stdout output:
[info] ad.privacy.network
[info] austria.privacy.network
[info] brussels.privacy.network
[info] ba.privacy.network
[info] sofia.privacy.network
[info] zagreb.privacy.network
[info] czech.privacy.network
[info] denmark.privacy.network
[info] denmark-2.privacy.network
[info] ee.privacy.network
[info] fi.privacy.network

2021-11-08 16:15:03,372 DEBG 'start-script' stdout output:
[info] fi-2.privacy.network
[info] france.privacy.network
[info] de-berlin.privacy.network
[info] de-frankfurt.privacy.network
[info] gr.privacy.network
[info] hungary.privacy.network
[info] is.privacy.network
[info] ireland.privacy.network
[info] man.privacy.network
[info] italy.privacy.network
[info] italy-2.privacy.network
[info] lv.privacy.network
[info] liechtenstein.privacy.network
[info] lt.privacy.network
[info] lu.privacy.network

2021-11-08 16:15:03,373 DEBG 'start-script' stdout output:
[info] mk.privacy.network
[info] malta.privacy.network
[info] md.privacy.network
[info] monaco.privacy.network
[info] montenegro.privacy.network
[info] nl-amsterdam.privacy.network
[info] no.privacy.network
[info] poland.privacy.network
[info] pt.privacy.network
[info] ro.privacy.network
[info] rs.privacy.network

2021-11-08 16:15:03,373 DEBG 'start-script' stdout output:
[info] sk.privacy.network
[info] spain.privacy.network
[info] sweden.privacy.network
[info] sweden-2.privacy.network
[info] swiss.privacy.network
[info] ua.privacy.network
[info] uk-london.privacy.network
[info] uk-southampton.privacy.network
[info] uk-manchester.privacy.network
[info] uk-2.privacy.network
[info] bahamas.privacy.network
[info] ca-toronto.privacy.network

2021-11-08 16:15:03,373 DEBG 'start-script' stdout output:
[info] ca-montreal.privacy.network
[info] ca-vancouver.privacy.network
[info] ca-ontario.privacy.network
[info] greenland.privacy.network
[info] mexico.privacy.network
[info] panama.privacy.network
[info] ar.privacy.network
[info] br.privacy.network
[info] venezuela.privacy.network
[info] yerevan.privacy.network
[info] bangladesh.privacy.network
[info] cambodia.privacy.network
[info] china.privacy.network

2021-11-08 16:15:03,373 DEBG 'start-script' stdout output:
[info] cyprus.privacy.network
[info] georgia.privacy.network
[info] hk.privacy.network
[info] in.privacy.network
[info] israel.privacy.network
[info] japan.privacy.network
[info] japan-2.privacy.network
[info] kazakhstan.privacy.network
[info] macau.privacy.network
[info] mongolia.privacy.network
[info] philippines.privacy.network
[info] qatar.privacy.network
[info] saudiarabia.privacy.network

2021-11-08 16:15:03,373 DEBG 'start-script' stdout output:
[info] sg.privacy.network
[info] srilanka.privacy.network
[info] taiwan.privacy.network
[info] tr.privacy.network
[info] ae.privacy.network
[info] vietnam.privacy.network
[info] au-sydney.privacy.network
[info] aus-melbourne.privacy.network
[info] aus-perth.privacy.network
[info] nz.privacy.network

2021-11-08 16:15:03,373 DEBG 'start-script' stdout output:
[info] dz.privacy.network
[info] egypt.privacy.network
[info] morocco.privacy.network
[info] nigeria.privacy.network
[info] za.privacy.network

 

I restarted mine and got these interesting results; 

2021-11-08 10:24:18,692 DEBG 'start-script' stdout output:
[warn] PIA VPN info API currently down, skipping endpoint port forward check

2021-11-08 10:24:50,767 DEBG 'start-script' stdout output:
[warn] Unable to successfully download PIA json to generate token from URL 'https://privateinternetaccess.com/gtoken/generateToken'
[info] 12 retries left
[info] Retrying in 10 secs...

Link to comment
27 minutes ago, binhex said:

😞 i can only assume this is the case then, nothing to do but wait until its working again.

Looks like it is some kind of issue with ca-montreal. 
Changed to ca-ontario and speeds and logs look normal. 

 

Thanks for your kind attention. It gives me the confidence to dive in and tinker. 

Edited by sol
  • Like 1
Link to comment

Hi! I have just set up the DelugeVPN docker on unraid with pia, wireguard and privoxy. I got the Web-UI and sonarr working but i cannot access it through the daemon from the client on my PC, does anyone have any tips on this ?

I have added a user in the auth file on deluge.

image.png.87ea3c18f9cf9321ece413e2e67c0186.pngimage.png.a32a60256e1d33c7ae665083db61c9bf.pngimage.png.2c828426133de2820653eb368a84520c.pngimage.png.15d169962439813a775243d6376cdc3d.png

Link to comment

Hey Guys,

 

I am wondering if I can help. I am suffering servere slow upload on torrents using Deluge w/AirVPN (20KiBs-60KiBs). I am using an unlimited traffic server with Hetzner as the provider, I get 900Mbs up/down using ookla speed test cli, only 300Mbs up/down inside the container with AirVPN (I can live with this). I have set up a remote port on AirVPN using UDP and have set that port as the incoming port on deluge. I have installed the ltConfig plugin and set it to high performance. I have 30 seeding torrents and yet right now there is only 3 active with 20KiBs-60KiBs upload. Any idea what I might be missing?

image.thumb.png.07202f5988d848f5e2d28cd103788d76.png

As you can see the ratio on some of those torrents like 15 seeders to 42 peers, surely I should be seeding? It even shows a bunch of active peers e.g. 1 (38) but I provide no upload.

If I click a torrent with no upload and an active peer and look at peers sometimes it will show one with downloading 0%.

Should the port on the peers address match my incoming port? Right now it doesn't, I don't know if that is an issue.

image.png.c23d1b6ee36ac536dd5e7704c86080e4.png

 

Here is my docker-compose file (using nginx, can provide the nginx conf if needed).

version: '3.4'
services:
  deluge:
    image: binhex/arch-delugevpn
    container_name: deluge
    restart: unless-stopped
    cap_add:
      - NET_ADMIN
    environment:
      - VPN_ENABLED=yes
      - VPN_PROV=airvpn
      - VPN_CLIENT=openvpn
      - ENABLE_PRIVOXY=yes
      - LAN_NETWORK=192.168.1.0/24
      - NAME_SERVERS=209.222.18.222,84.200.69.80,37.235.1.174,1.1.1.1,209.222.18.218,37.235.1.177,84.200.70.40,1.0.0.1
      - DELUGE_DAEMON_LOG_LEVEL=info
      - DELUGE_WEB_LOG_LEVEL=info
      - DEBUG=false
      - VPN_INPUT_PORTS=1234
      - VPN_OUTPUT_PORTS=5678
      - UMASK=000
      - PUID=1000
      - PGID=1000
    volumes:
      - /etc/localtime:/etc/localtime:ro
      - ./deluge-config:/config
      - /media/gdrive:/data
      - /home/x/seeding:/seeding
    ports:
      - 8112:8112
      - 8118:8118
      - 58846:58846
      - 58946:58946       
    networks:
      - app-network

  webserver:
    image: nginx:mainline-alpine
    container_name: webserver
    restart: unless-stopped
    ports:
      - "80:80"
      - "443:443"
    volumes:
      - web-root:/var/www/html
      - ./nginx-conf:/etc/nginx/conf.d
      - certbot-etc:/etc/letsencrypt
      - certbot-var:/var/lib/letsencrypt
      - dhparam:/etc/ssl/certs
    depends_on:
      - stash
      - deluge
    networks:
      - app-network

  certbot:
    image: certbot/certbot
    container_name: certbot
    volumes:
      - certbot-etc:/etc/letsencrypt
      - certbot-var:/var/lib/letsencrypt
      - web-root:/var/www/html
    depends_on:
      - webserver
    command: certonly --webroot --webroot-path=/var/www/html --email x --agree-tos --no-eff-email --force-renewal -d x

volumes:
  certbot-etc:
  certbot-var:
  web-root:
    driver: local
    driver_opts:
      type: none
      device: /home/x/stash-config/views/
      o: bind
  dhparam:
    driver: local
    driver_opts:
      type: none
      device: /home/x/stash-config/dhparam/
      o: bind

networks:
  app-network:
    driver: bridge

 

I am at my wits end, does anyone have any clue?

Link to comment

@binhex First thanks for all the support, you are such an amazing and Vital piece of this community and I cant tell you how amazing it is that most everything always just WORKS

 

I have been having issues with all my unraid servers recently, I have three and all are running DelugeVPN with the same PIA account and target Endpoint

 

Here is a pastebin of the logs from my primary host, I've already done some troubleshooting myself, nuked the container and app data folders and reinstalled fresh with no success

https://pastebin.com/sHvssb5C

 

I will note that with this fresh install I'm not able to reconfigure the label plugin and stuff but with the previous install all my other *arr apps were working fine, still downloading and importing media and I could view status in the apps but I couldnt view the Deluge Web UI

 

I've tried to access from multiple OS's and Hosts, different browsers and stuff

144440027_DelugeWebUIdown-Vivaldi.thumb.png.a788e6e39533ea37689bf191af706557.png

Link to comment

I have what I think is an odd issue.  I'm using binhex-delugevpn and anytime I restart it or reboot unraid, I can't connect to my VPN (Torguard with wireguard).  Now... if I edit it and change anything, meaning change port 8118 to 8118 so I get the apply option instead of just done, it works without a problem when it applies.   Has anyone else experienced this or know where I should look?  Let me know what logs or settings I can provide to help troubleshoot this.  TIA

Link to comment
3 hours ago, Blindkitty38 said:

I have been having issues with all my unraid servers recently, I have three and all are running DelugeVPN with the same PIA account and target Endpoint

ok lets start with the most common issue, lan network, from your log:-

LAN_NETWORK defined as '192.168.1.0/24'

can you check this, Q4:- https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

Link to comment
3 hours ago, RichJacot said:

I have what I think is an odd issue.  I'm using binhex-delugevpn and anytime I restart it or reboot unraid, I can't connect to my VPN (Torguard with wireguard).  Now... if I edit it and change anything, meaning change port 8118 to 8118 so I get the apply option instead of just done, it works without a problem when it applies.   Has anyone else experienced this or know where I should look?  Let me know what logs or settings I can provide to help troubleshoot this.  TIA

you really need to have DEBUG turned on (set to true) when the issue happens and then post the /config/supervisord.log file for me to analyse exactly what the cause is.

Link to comment
30 minutes ago, binhex said:

ok lets start with the most common issue, lan network, from your log:-

LAN_NETWORK defined as '192.168.1.0/24'

can you check this, Q4:- https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

Yes. '192.168.1.0/24'

 

Where can I find the debug setting?  I looked through the docker settings but didn't see it.

 

I'm about to leave town so I'll need to get back to this early next week.  I should be able to recreate it at will by restarting the docker.

 

Thank you!

Link to comment
21 hours ago, Blindkitty38 said:

Yes I am on the same subnet, Its a very basic network configuration for the time being

 

I noticed you blacked out the IP in the photo from your original post. If it is a private IP, you don't have to black it out. What is the address you are trying to reach Deluge at? Do you have any VPNs or multiple network cards on the system you are trying to access Deluge on?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.