[Support] binhex - DelugeVPN


Recommended Posts

On 10/8/2022 at 6:28 PM, Kevin McTague said:

[debug] Having issues resolving name 'www.google.com'

looks like name resolution issues.

On 10/8/2022 at 6:28 PM, Kevin McTague said:

2022-10-08 12:54:48.145331 [info] NAME_SERVERS defined as '217.114.38.10,217.114.38.42,217.114.38.194,23.105.174.4'

the above is what you currently have defined, try the defaults instead:-

 

NAME_SERVERS=84.200.69.80,37.235.1.174,1.1.1.1,37.235.1.177,84.200.70.40,1.0.0.1

 

Link to comment
5 hours ago, ChristianMoley said:

Hey, I can no longer access Deluge vpn's webui. I didn't touch anything before it stopped working, so I am very confused. In the config, my lan network setting is correct, my vpn username and password are correct as well. For sanity sake, I redownloaded the openvpn files (using Mullvad vpn) and it still is not working.

 

Again, it was working for a while until it just wasn't. I'm very confused and don't know what to do. The Deluge vpn container is up to date and so is Unraid (v6.11.1).

delugevpn log.txt 3.93 kB · 0 downloads

no problem shown in the snippet of the log, what is the ip of the machine running the web browser and what is the value of LAN_NETWORK?

Link to comment
39 minutes ago, binhex said:

looks like name resolution issues.

the above is what you currently have defined, try the defaults instead:-

 

NAME_SERVERS=84.200.69.80,37.235.1.174,1.1.1.1,37.235.1.177,84.200.70.40,1.0.0.1

 

@binhex. Thank you for the response. The defaults are for PIA, I use NordVPN,  Any recommendations?

Link to comment
2 hours ago, binhex said:

 

Thanks. Self-help fail. My apologies.

 

These all seem to be "permanent" failure modes, i.e. they'll prevent the connection from ever establishing. In my case, it will eventually connect and everything runs just fine, so those don't seem to be applicable.

 

Am I misinterpreting what I'm reading or is there some other possible error raising it's head?

Link to comment
1 hour ago, FreeMan said:

 

Thanks. Self-help fail. My apologies.

 

These all seem to be "permanent" failure modes, i.e. they'll prevent the connection from ever establishing. In my case, it will eventually connect and everything runs just fine, so those don't seem to be applicable.

 

Am I misinterpreting what I'm reading or is there some other possible error raising it's head?

if the issue is intermittent then i suspect the vpn endpoint you are attempting to connect to is having a bad day :-), try another endpoint and/or contact your vpn provider and tell them connectivity to that endpoint is intermittently failing.

Link to comment

Hello,

 

as a newby to docker and vpn use and after a moot 45 minute chat session with their so called support i have 

a very odd question for all you unraid / *.nix wizards : how can one translate my VPN providers ovpn files to use it with delugevpn ?

 

example :

 

**************************** start ******************************** 

client
remote nl2.jumptoserver.com 4443
proto udp
dev tun
auth-user-pass
tls-client
resolv-retry infinite
remote-random
nobind
tun-mtu 1500
tun-mtu-extra 32
mssfix 1450
persist-key
persist-tun
ping 15
ping-restart 0
ping-timer-rem
reneg-sec 0
comp-lzo
cipher AES-256-CBC
auth SHA256
<ca>
-----BEGIN CERTIFICATE-----
MIIFQjCCAyqgAwIBAgIIUfxepT+rr8owDQYJKoZIhvcNAQEMBQAwPzELMAkGA1UE
BhMCS1kxEzARBgNVBAoTCkZhc3Rlc3RWUE4xGzAZBgNVBAMTEkZhc3Rlc3RWUE4g
Um9vdCBDQTAeFw0xNzA5MTYwMDAxNDZaFw0yNzA5MTQwMDAxNDZaMD8xCzAJBgNV
BAYTAktZMRMwEQYDVQQKEwpGYXN0ZXN0VlBOMRswGQYDVQQDExJGYXN0ZXN0VlBO
IFJvb3QgQ0EwggIiMA0GCSqGSIb3DQEBAQUAA4ICDwAwggIKAoICAQC1Xj+WfPTo
zFynFqc+c3CVrggIllaXEl5bY5VgFynXkqCTM6lSrfC4pNjGXUbqWe6RnGJbM4/6
kUn+lQDjFSQV1rzP2eDS8+r5+X2WXh4AoeNRUWhvSG+HiHD/B2EFK+Nd5BRSdUjp
KWAtsCmT2bBt7nT0jN1OdeNrLJeyF8siAqv/oQzKznF9aIe/N01b2M8ZOFTzoXi2
fZAckgGWui8NB/lzkVIJqSkAPRL8qiJLuRCPVOX1PFD8vV//R8/QumtfbcYBMo6v
Ck2HmWdrh5OQHPxb3KJtbtG+Z1j8x6HGEAe17djYepBiRMyCEQvYgfD6tvFylc4I
quhqE9yaP60PJod5TxpWnRQ6HIGSeBm+S+rYSMalTZ8+pUqOOA+IQCYpfpx6EKIJ
L/VsW2C7cXdvudxDhXPI5lR/QidCb9Ohq3WkfxXaYwzrngdg2avmNqId9R4KESuM
9GoHW0dszfyBCh5wYfeaffMElfDam3B92NUwyhZwtIiv623WVXY9PPz+EDjSJsIA
u2Vi1vdJyA4nD4k9Lwmx/1zTc/UaYVLsiBqL2WdfvFTeoWoV+dNxQXSEPhB8gwi8
x4O4lZW0cwVy/6fa8KMY8gZbcbSTr7U5bRERfW8l+jY+mYKQ/M/ccgpxaHiw1/+4
LWfbJQ7VhJJrTyN0C36FQzY1URkSXg+53wIDAQABo0IwQDAPBgNVHRMBAf8EBTAD
AQH/MA4GA1UdDwEB/wQEAwIBBjAdBgNVHQ4EFgQUmVEL4x6xdCqiqu2OBLs27EA8
xGYwDQYJKoZIhvcNAQEMBQADggIBABCpITvO1+R4T9v2+onHiFxU5JjtCZ0zkXqR
CMp/Z0UIYbeo1p07pZCPAUjBfGPCkAaR++OiG9sysALdJf8Y6HQKcyuAcWUqQnaI
hoZ2JcAP7EKq7uCqsMhcYZD/j3O/3RPtSW5UOx6ItDU+Ua0t9Edho9whNw0VQXmo
1JjYoP3FzPjuKoDWTSO1q5eYlZfwcTcs55O2shNkFafPg/6cCm5j6v9nyHrM3sk4
LjkrBPUXVx2m/aoz219t8O9Ha9/CdMKXsPO/8gTUzpgnzSgPnGnBmi5xr1nspVN8
X4E2f3D+DKqBim3YgslD68NcuFQvJ0/BxZzWVbrr+QXoyzaiCgXuogpIDc2bB6oR
XqFnHNz36d4QJmJdWdSaijiS/peQ6EOPgOZ1GuObLWlDCBZLNeQ+N6QaiJxVO4XU
j/s22i1IRtwdz84TRHrbWiIpEymsqmb/Ep5r4xV5d6+791axclfOTH7tQrY/SbPt
TJI4OEgNekI8YfadQifpelF82MsFFEZuaQn0lj+fvLGtE/zKh3OdLTxRc5TAgBB+
0T81+JQosygNr2aFFG0hxar1eyw/gLeG8H+7Ie50pyPvXO4OgB6Key8rSExpilQX
lvAT1qX0qS3/K1i/9QkSE9ftIPT6vtwLV2sVQzfyanI4IZgWC6ryhvNLsRn0NFnQ
clor0+aq
-----END CERTIFICATE-----
</ca>
key-direction 1
<tls-auth>
-----BEGIN OpenVPN Static key V1-----
697fe793b32cb5091d30f2326d5d124a
9412e93d0a44ef7361395d76528fcbfc
82c3859dccea70a93cfa8fae409709bf
f75f844cf5ff0c237f426d0c20969233
db0e706edb6bdf195ec3dc11b3f76bc8
07a77e74662d9a800c8cd1144ebb67b7
f0d3f1281d1baf522bfe03b7c3f963b1
364fc0769400e413b61ca7b43ab19fac
9e0f77e41efd4bda7fd77b1de2d7d785
5cbbe3e620cecceac72c21a825b243e6
51f44d90e290e09c3ad650de8fca99c8
58bc7caad584bc69b11e5c9fd9381c69
c505ec487a65912c672d83ed0113b5a7
4ddfbd3ab33b3683cec593557520a72c
4d6cce46111f56f3396cc3ce7183edce
553c68ea0796cf6c4375fad00aaa2a42
-----END OpenVPN Static key V1-----
</tls-auth>

**************************** end *********************************

 

I watched space invaders videos - where he just put 3 files to the deluge config directory ....

Can the *.cert and *.pem file be created  from the above file - are there changes to be made etc.

 

cheers and thx upfront

Link to comment
Hello,
 
as a newby to docker and vpn use and after a moot 45 minute chat session with their so called support i have 
a very odd question for all you unraid / *.nix wizards : how can one translate my VPN providers ovpn files to use it with delugevpn ?
 
example :
 
**************************** start ******************************** 
client
remote nl2.jumptoserver.com 4443
proto udp
dev tun
auth-user-pass
tls-client
resolv-retry infinite
remote-random
nobind
tun-mtu 1500
tun-mtu-extra 32
mssfix 1450
persist-key
persist-tun
ping 15
ping-restart 0
ping-timer-rem
reneg-sec 0
comp-lzo
cipher AES-256-CBC
auth SHA256

-----BEGIN CERTIFICATE-----
MIIFQjCCAyqgAwIBAgIIUfxepT+rr8owDQYJKoZIhvcNAQEMBQAwPzELMAkGA1UE
BhMCS1kxEzARBgNVBAoTCkZhc3Rlc3RWUE4xGzAZBgNVBAMTEkZhc3Rlc3RWUE4g
Um9vdCBDQTAeFw0xNzA5MTYwMDAxNDZaFw0yNzA5MTQwMDAxNDZaMD8xCzAJBgNV
BAYTAktZMRMwEQYDVQQKEwpGYXN0ZXN0VlBOMRswGQYDVQQDExJGYXN0ZXN0VlBO
IFJvb3QgQ0EwggIiMA0GCSqGSIb3DQEBAQUAA4ICDwAwggIKAoICAQC1Xj+WfPTo
zFynFqc+c3CVrggIllaXEl5bY5VgFynXkqCTM6lSrfC4pNjGXUbqWe6RnGJbM4/6
kUn+lQDjFSQV1rzP2eDS8+r5+X2WXh4AoeNRUWhvSG+HiHD/B2EFK+Nd5BRSdUjp
KWAtsCmT2bBt7nT0jN1OdeNrLJeyF8siAqv/oQzKznF9aIe/N01b2M8ZOFTzoXi2
fZAckgGWui8NB/lzkVIJqSkAPRL8qiJLuRCPVOX1PFD8vV//R8/QumtfbcYBMo6v
Ck2HmWdrh5OQHPxb3KJtbtG+Z1j8x6HGEAe17djYepBiRMyCEQvYgfD6tvFylc4I
quhqE9yaP60PJod5TxpWnRQ6HIGSeBm+S+rYSMalTZ8+pUqOOA+IQCYpfpx6EKIJ
L/VsW2C7cXdvudxDhXPI5lR/QidCb9Ohq3WkfxXaYwzrngdg2avmNqId9R4KESuM
9GoHW0dszfyBCh5wYfeaffMElfDam3B92NUwyhZwtIiv623WVXY9PPz+EDjSJsIA
u2Vi1vdJyA4nD4k9Lwmx/1zTc/UaYVLsiBqL2WdfvFTeoWoV+dNxQXSEPhB8gwi8
x4O4lZW0cwVy/6fa8KMY8gZbcbSTr7U5bRERfW8l+jY+mYKQ/M/ccgpxaHiw1/+4
LWfbJQ7VhJJrTyN0C36FQzY1URkSXg+53wIDAQABo0IwQDAPBgNVHRMBAf8EBTAD
AQH/MA4GA1UdDwEB/wQEAwIBBjAdBgNVHQ4EFgQUmVEL4x6xdCqiqu2OBLs27EA8
xGYwDQYJKoZIhvcNAQEMBQADggIBABCpITvO1+R4T9v2+onHiFxU5JjtCZ0zkXqR
CMp/Z0UIYbeo1p07pZCPAUjBfGPCkAaR++OiG9sysALdJf8Y6HQKcyuAcWUqQnaI
hoZ2JcAP7EKq7uCqsMhcYZD/j3O/3RPtSW5UOx6ItDU+Ua0t9Edho9whNw0VQXmo
1JjYoP3FzPjuKoDWTSO1q5eYlZfwcTcs55O2shNkFafPg/6cCm5j6v9nyHrM3sk4
LjkrBPUXVx2m/aoz219t8O9Ha9/CdMKXsPO/8gTUzpgnzSgPnGnBmi5xr1nspVN8
X4E2f3D+DKqBim3YgslD68NcuFQvJ0/BxZzWVbrr+QXoyzaiCgXuogpIDc2bB6oR
XqFnHNz36d4QJmJdWdSaijiS/peQ6EOPgOZ1GuObLWlDCBZLNeQ+N6QaiJxVO4XU
j/s22i1IRtwdz84TRHrbWiIpEymsqmb/Ep5r4xV5d6+791axclfOTH7tQrY/SbPt
TJI4OEgNekI8YfadQifpelF82MsFFEZuaQn0lj+fvLGtE/zKh3OdLTxRc5TAgBB+
0T81+JQosygNr2aFFG0hxar1eyw/gLeG8H+7Ie50pyPvXO4OgB6Key8rSExpilQX
lvAT1qX0qS3/K1i/9QkSE9ftIPT6vtwLV2sVQzfyanI4IZgWC6ryhvNLsRn0NFnQ
clor0+aq
-----END CERTIFICATE-----

key-direction 1

-----BEGIN OpenVPN Static key V1-----
697fe793b32cb5091d30f2326d5d124a
9412e93d0a44ef7361395d76528fcbfc
82c3859dccea70a93cfa8fae409709bf
f75f844cf5ff0c237f426d0c20969233
db0e706edb6bdf195ec3dc11b3f76bc8
07a77e74662d9a800c8cd1144ebb67b7
f0d3f1281d1baf522bfe03b7c3f963b1
364fc0769400e413b61ca7b43ab19fac
9e0f77e41efd4bda7fd77b1de2d7d785
5cbbe3e620cecceac72c21a825b243e6
51f44d90e290e09c3ad650de8fca99c8
58bc7caad584bc69b11e5c9fd9381c69
c505ec487a65912c672d83ed0113b5a7
4ddfbd3ab33b3683cec593557520a72c
4d6cce46111f56f3396cc3ce7183edce
553c68ea0796cf6c4375fad00aaa2a42
-----END OpenVPN Static key V1-----

**************************** end *********************************
 
I watched space invaders videos - where he just put 3 files to the deluge config directory ....
Can the *.cert and *.pem file be created  from the above file - are there changes to be made etc.
 
cheers and thx upfront
You do not need to translate the file, it looks like the cert is inline so just drop this file into /config/openvpn/ and hopefully the magic will happen, check the log file /config/supervisord.log to track progress

Sent from my 22021211RG using Tapatalk

  • Confused 1
Link to comment

Hello,

 

Perhaps I am not remembering correctly, but I thought I could access the Deluge webUI outside my LAN when I first set this up (I cannot currently at least) - is the VPN setup to run 'split-tunnel' so the Deluge daemon runs under the VPN but the Deluge webUI runs without the VPN...?  Or are all services in the docker container running under the VPN?

 

I couldn't find any mention of split tunnel in the guides / FAQs so that makes me think that everything is running under the VPN - any solutions to access the webUI when not on the LAN?

 

Thanks!

Edited by arrrghhh
Link to comment
4 hours ago, binhex said:

You do not need to translate the file, it looks like the cert is inline so just drop this file into /config/openvpn/ and hopefully the magic will happen, check the log file /config/supervisord.log to track progress

Sent from my 22021211RG using Tapatalk
 

Hello Mr. Binhex,

 

thx for the very fast response 8) ....

 

now i am really confused - copied the file, and edited the deluge settings from within the gui.

starting the docker seems to work but starting the the gui brings up the notorious error msg

 

website cannot be reached (sorry ger->eng) , check firwall and proxy settings

 

ERR_CONNECTION_REFUSED

 

can i delete the supervisord.log file without breaking delugevpn - just asking because it is allready 200 KiB in size and i dont wanna post such a monster here in the forum .....

Link to comment

EDIT: The issue im having isn't with binhex-delugevpn, its unraid itself. My 6.11.x issue

 

I've had this happen to me a few times since upgrading to 6.11.x

 

binhex-delugevpn will just stop working/responding completely. If I try to stop or restart the container I get "execution error" from unraid. I've even tried rebooting the docker service itself and it still doesn't fix the issue. Only thing I've found that works is rebooting the machine entirely.

 

Any Idea what could be causing this? Here is my log.

 

Edited by ShadyDeth
Link to comment

Is anyone else having an issue where you can manually recheck finished files and the files are found to be incomplete?  I have had to recheck/downloads up to 3 times in a row at times.  I have seen the percent done go from 100% to 80% on some files.  I'm seeing very noticeable glitches in video files downloaded through deluge.  UnRaid isn't reporting any issues with my array/fs.  It started around a month ago, seemed to get better, but is now worse for me.

Link to comment

Like an earlier poster, I found today that I can't access the delugevpn webUI - it just times out. Nothing has been changed at this end at all, so it's a mystery. Docker seems to start and stop fine, according to the logs, but no other apps are able to access deluge.

 

UPDATE: following a tip from @Tomahawk51 below, I checked VPN settings and also local IP address, reset them all - and deluge is working again. So that's all good then! Problem solved.

Edited by jonathanljs
Link to comment
17 hours ago, jonathanljs said:

Like an earlier poster, I found today that I can't access the delugevpn webUI - it just times out. Nothing has been changed at this end at all, so it's a mystery. Docker seems to start and stop fine, according to the logs, but no other apps are able to access deluge. 

I'm having the same experience.  It's on my list to check the VPN Endpoints with a regular client.  Will report back if that is OK (indicating maybe something else is going on?).

 

UPDATE: The problem was with my VPN.  Setting to a new endpoint in the config file resolved my issue.

Edited by Tomahawk51
  • Like 1
Link to comment
On 10/14/2022 at 9:54 AM, Tomahawk51 said:

I'm having the same experience.  It's on my list to check the VPN Endpoints with a regular client.  Will report back if that is OK (indicating maybe something else is going on?).

 

UPDATE: The problem was with my VPN.  Setting to a new endpoint in the config file resolved my issue.

Are you having issues accessing the webUI for Deluge on your local network or from the internet?  I can access the Deluge webUI from my LAN, but from other locations I am not able to access the Deluge webUI - other services I have running are accessible from remote locations, so I'm wondering if the VPN is not setup to be 'split-tunnel' - that is, VPN tunnel for the Deluge daemon, and no VPN tunnel for the Deluge webUI...

Link to comment
On 10/13/2022 at 10:45 AM, bobobeastie said:

Is anyone else having an issue where you can manually recheck finished files and the files are found to be incomplete?  I have had to recheck/downloads up to 3 times in a row at times.  I have seen the percent done go from 100% to 80% on some files.  I'm seeing very noticeable glitches in video files downloaded through deluge.  UnRaid isn't reporting any issues with my array/fs.  It started around a month ago, seemed to get better, but is now worse for me.

I had that somewhat regularly when I was running uTorrent on my Win desktop machine, especially when the machine was rebooted by Windows updates. I've not noticed it using Deluge.

Link to comment
20 hours ago, arrrghhh said:

  I can access the Deluge webUI from my LAN, but from other locations I am not able to access the Deluge webUI - other services I have running are accessible from remote locations,

Please see Q4 on https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

 

Specifically the very last bit.

Quote

If you need to be able to access the Web UI from multiple networks then please use a comma to separate values, e.g.:-

 

Link to comment
5 hours ago, JonathanM said:

Please see Q4 on https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

 

Specifically the very last bit.

Apologies but this does not apply to me - this is if I had multiple subnets on my LAN.  I can access Deluge webUI from my LAN just fine.  It's only accessing the Deluge webUI from the internet or WAN that I have problems.

 

I've asked about if the VPN is setup as a 'split-tunnel' - seems it is not?  Where the Deluge daemon is run through the VPN and the Deluge webUI is run outside of the VPN so the webUI can be accessed like any other service running on the server - using the same public IP as the server itself.

Link to comment

I cannot get WireGuard working with PIA.  I have followed the FAQ and never had trouble getting anything else to work with this docker.  The one line in the FAQ that puzzles me a bit is this one:

 

Quote

1. Change Docker parameter from --cap-add=NET_ADMIN to --privileged=true (WireGuard requires privileged permissions).

 

I don't have anything in the docker that says "--cap-add=NET_ADMIN".  I have this, but I am not sure this is what the FAQ refers to:

 

image.png.46705cc77da149c9c373564de3fc123e.png

 

This is the only think I think it can be because I have followed the rest to the letter.  

 

image.png.44056aa4f877c569978e055e83165ce4.png 

 

This is all that is in my wg0.conf file.  

 


[Interface]
Address = 10.24.146.122
PrivateKey = kGZ/uf0H5v7drJOsaCNPxo+hERNkfIh7cyUcDpNQdGg=
PostUp = '/root/wireguardup.sh'
PostDown = '/root/wireguarddown.sh'

[Peer]
PublicKey = OOy/RLnU33EAXZkQWfTrOA7CgmK88HUjgPm2Ky5pKFw=
AllowedIPs = 0.0.0.0/0
Endpoint = nl-amsterdam.privacy.network 1337

 

There is no list of endpoints in my supervisord.log.  Here is the supervisord.log.  It seems to be telling me it can't resolve nl-amsterdam.privacy.network 1337.

 

Created by...
___.   .__       .__
\_ |__ |__| ____ |  |__   ____ ___  ___
 | __ \|  |/    \|  |  \_/ __ \\  \/  /
 | \_\ \  |   |  \   Y  \  ___/ >    <
 |___  /__|___|  /___|  /\___  >__/\_ \
     \/        \/     \/     \/      \/
   https://hub.docker.com/u/binhex/

2022-10-19 00:03:32.359749 [info] Host is running unRAID
2022-10-19 00:03:32.376784 [info] System information Linux b997ff38d197 5.19.14-Unraid #1 SMP PREEMPT_DYNAMIC Thu Oct 6 09:15:00 PDT 2022 x86_64 GNU/Linux
2022-10-19 00:03:32.397742 [info] OS_ARCH defined as 'x86-64'
2022-10-19 00:03:32.417220 [info] PUID defined as '99'
2022-10-19 00:03:32.548834 [info] PGID defined as '100'
2022-10-19 00:03:32.757009 [info] UMASK defined as '000'
2022-10-19 00:03:32.780403 [info] Permissions already set for '/config'
2022-10-19 00:03:32.813122 [info] Deleting files in /tmp (non recursive)...
2022-10-19 00:03:32.834943 [info] VPN_ENABLED defined as 'yes'
2022-10-19 00:03:32.852974 [info] VPN_CLIENT defined as 'wireguard'
2022-10-19 00:03:32.870207 [info] VPN_PROV defined as 'pia'
2022-10-19 00:03:33.173614 [info] WireGuard config file (conf extension) is located at /config/wireguard/wg0.conf
2022-10-19 00:03:33.200710 [info] VPN_REMOTE_SERVER defined as 'nl-amsterdam.privacy.network 1337'
2022-10-19 00:03:33.243004 [info] VPN_REMOTE_PORT defined as '1337'
2022-10-19 00:03:33.258570 [info] VPN_DEVICE_TYPE defined as 'wg0'
2022-10-19 00:03:33.274097 [info] VPN_REMOTE_PROTOCOL defined as 'udp'
2022-10-19 00:03:33.291612 [info] LAN_NETWORK defined as '192.168.1.0/24'
2022-10-19 00:03:33.309441 [info] NAME_SERVERS defined as '1.1.1.1,1.0.0.1'
2022-10-19 00:03:33.326958 [info] VPN_USER defined as 'xxxxxxxxxx'
2022-10-19 00:03:33.344674 [info] VPN_PASS defined as 'xxxxxxxxxx'
2022-10-19 00:03:33.362778 [info] STRICT_PORT_FORWARD defined as 'yes'
2022-10-19 00:03:33.380827 [info] ENABLE_PRIVOXY defined as 'no'
2022-10-19 00:03:33.400403 [info] VPN_INPUT_PORTS not defined (via -e VPN_INPUT_PORTS), skipping allow for custom incoming ports
2022-10-19 00:03:33.419120 [info] VPN_OUTPUT_PORTS not defined (via -e VPN_OUTPUT_PORTS), skipping allow for custom outgoing ports
2022-10-19 00:03:33.436771 [info] DELUGE_DAEMON_LOG_LEVEL not defined,(via -e DELUGE_DAEMON_LOG_LEVEL), defaulting to 'info'
2022-10-19 00:03:33.454386 [info] DELUGE_WEB_LOG_LEVEL not defined,(via -e DELUGE_WEB_LOG_LEVEL), defaulting to 'info'
2022-10-19 00:03:33.473525 [info] Starting Supervisor...
2022-10-19 00:03:33,725 INFO Included extra file "/etc/supervisor/conf.d/delugevpn.conf" during parsing
2022-10-19 00:03:33,725 INFO Set uid to user 0 succeeded
2022-10-19 00:03:33,728 INFO supervisord started with pid 7
2022-10-19 00:03:34,731 INFO spawned: 'start-script' with pid 168
2022-10-19 00:03:34,733 INFO spawned: 'watchdog-script' with pid 169
2022-10-19 00:03:34,733 INFO reaped unknown pid 8 (exit status 0)
2022-10-19 00:03:34,742 DEBG 'start-script' stdout output:
[info] VPN is enabled, beginning configuration of VPN

2022-10-19 00:03:34,742 INFO success: start-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2022-10-19 00:03:34,742 INFO success: watchdog-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2022-10-19 00:03:34,747 DEBG 'start-script' stdout output:
[info] Adding 1.1.1.1 to /etc/resolv.conf

2022-10-19 00:03:34,751 DEBG 'start-script' stdout output:
[info] Adding 1.0.0.1 to /etc/resolv.conf

2022-10-19 00:04:30,124 DEBG 'start-script' stdout output:
[crit] 'nl-amsterdam.privacy.network 1337' cannot be resolved, possible DNS issues, exiting...

2022-10-19 00:04:30,124 DEBG fd 8 closed, stopped monitoring <POutputDispatcher at 23200439382896 for <Subprocess at 23200439382800 with name start-script in state RUNNING> (stdout)>
2022-10-19 00:04:30,125 DEBG fd 10 closed, stopped monitoring <POutputDispatcher at 23200438224880 for <Subprocess at 23200439382800 with name start-script in state RUNNING> (stderr)>
2022-10-19 00:04:30,125 INFO exited: start-script (exit status 1; not expected)
2022-10-19 00:04:30,125 DEBG received SIGCHLD indicating a child quit

 

Thanks for any help!

craigr

 

Edited by craigr
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.