[Support] binhex - SABnzbd


380 posts in this topic Last Reply

Recommended Posts

2017-06-24 02:28:15,864 ERROR: Cannot change permissions of /mnt/tv_shows/show/_UNPACK_show S01E01 1080p WEBRip x264-STRiFE/sample-show.s01e01.1080p.webrip.x264-strife.par2
2017-06-24 02:28:15,862 ERROR: Cannot change permissions of /mnt/tv_shows/show/_UNPACK_show S01E01 1080p WEBRip x264-STRiFE/sample-show.s01e01.1080p.webrip.x264-strife.mkv
2017-06-24 02:28:15,861 ERROR: Cannot change permissions of /mnt/tv_shows/show/_UNPACK_show S01E01 1080p WEBRip x264-STRiFE/show.s01e01.1080p.webrip.x264-strife.srr
2017-06-24 02:28:15,860 ERROR: Cannot change permissions of /mnt/tv_shows/show/_UNPACK_show S01E01 1080p WEBRip x264-STRiFE/show.s01e01.1080p.webrip.x264-strife.sfv
2017-06-24 02:28:15,859 ERROR: Cannot change permissions of /mnt/tv_shows/show/_UNPACK_show S01E01 1080p WEBRip x264-STRiFE/show.s01e01.1080p.webrip.x264-strife.nfo
2017-06-24 02:28:15,859 ERROR: Cannot change permissions of /mnt/tv_shows/show/_UNPACK_show S01E01 1080p WEBRip x264-STRiFE/show.s01e01.1080p.webrip.x264-strife.mkv
2017-06-24 02:28:15,857 ERROR:

Cannot change permissions of /mnt/tv_shows/show/_UNPACK_show S01E01 1080p WEBRip x264-STRiFE

 

 

 

Just started happening tonight out of nowhere.  All shows download, none are written to their respective folders, and the error log for SAB fills with this.

Link to post
  • Replies 379
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I too updated the sabnzbd container today and now i cannot access it. Appears to be same as WonkoTheSane.   2017-05-24 19:40:34,503 DEBG 'sabnzbd' stderr output: 2017-05-24 19:40:34,503::ERRO

brawny had the answer in another thread that helped me. put simply, check  Local IPv4 address, under status and interface options (the wrench) in sabnzbd and make sure that they are the sam

Overview: Support for Docker image arch-sabnzbd in the binhex repo. Application: SABnzbd - http://sabnzbd.org/ Docker Hub: https://hub.docker.com/r/binhex/arch-sabnzbd/ GitHub: https://

Posted Images

  • 2 weeks later...

the SABNZB docker page showed update ready and I updated, now I cant reach SABNZB anymore. It seems to be running though, I get a green arrow.

 

log shows:

 

2017-07-05 22:41:30,122 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,122::ERROR::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE Shutting down due to error in start listener:
Traceback (most recent call last):
File "/opt/sabnzbd/cherrypy/process/wspbus.py", line 245, in start
self.publish('start')
File "/opt/sabnzbd/cherrypy/process/wspbus.py", line 225, in publish
raise exc
ChannelFailures: SSLError(336245134, u'[SSL: CA_MD_TOO_WEAK] ca md too weak (_ssl.c:2699)')


2017-07-05 22:41:30,122 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,122::INFO::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE Bus STOPPING

2017-07-05 22:41:30,124 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,124::INFO::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE HTTP Server cherrypy._cpwsgi_server.CPWSGIServer(('0.0.0.0', 8080)) shut down

2017-07-05 22:41:30,124 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,124::INFO::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE HTTP Server None already shut down

2017-07-05 22:41:30,124 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,124::INFO::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE Stopped thread '_TimeoutMonitor'.

2017-07-05 22:41:30,124 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,124::INFO::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE Bus STOPPED

2017-07-05 22:41:30,124 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,124::INFO::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE Bus EXITING

2017-07-05 22:41:30,125 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,124::INFO::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE Bus EXITED

2017-07-05 22:41:30,127 DEBG fd 8 closed, stopped monitoring <POutputDispatcher at 47811641720128 for <Subprocess at 47811562678896 with name sabnzbd in state STARTING> (stdout)>
2017-07-05 22:41:30,127 DEBG fd 10 closed, stopped monitoring <POutputDispatcher at 47811642369376 for <Subprocess at 47811562678896 with name sabnzbd in state STARTING> (stderr)>
2017-07-05 22:41:30,127 INFO exited: sabnzbd (exit status 70; not expected)
2017-07-05 22:41:30,127 DEBG received SIGCLD indicating a child quit
2017-07-05 22:41:31,129 INFO gave up: sabnzbd entered FATAL state, too many start retries too quickly

Edited by dikkiedirk
Link to post
the SABNZB docker page showed update ready and I updated, now I cant reach SABNZB anymore. It seems to be running though, I get a green arrow.
 
log shows:
 
2017-07-05 22:41:30,122 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,122::ERROR::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE Shutting down due to error in start listener:
Traceback (most recent call last):
File "/opt/sabnzbd/cherrypy/process/wspbus.py", line 245, in start
self.publish('start')
File "/opt/sabnzbd/cherrypy/process/wspbus.py", line 225, in publish
raise exc
ChannelFailures: SSLError(336245134, u'[sSL: CA_MD_TOO_WEAK] ca md too weak (_ssl.c:2699)')


2017-07-05 22:41:30,122 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,122::INFO::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE Bus STOPPING

2017-07-05 22:41:30,124 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,124::INFO::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE HTTP Server cherrypy._cpwsgi_server.CPWSGIServer(('0.0.0.0', 8080)) shut down

2017-07-05 22:41:30,124 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,124::INFO::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE HTTP Server None already shut down

2017-07-05 22:41:30,124 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,124::INFO::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE Stopped thread '_TimeoutMonitor'.

2017-07-05 22:41:30,124 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,124::INFO::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE Bus STOPPED

2017-07-05 22:41:30,124 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,124::INFO::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE Bus EXITING

2017-07-05 22:41:30,125 DEBG 'sabnzbd' stderr output:
2017-07-05 22:41:30,124::INFO::[_cplogging:219] [05/Jul/2017:22:41:30] ENGINE Bus EXITED

2017-07-05 22:41:30,127 DEBG fd 8 closed, stopped monitoring (stdout)>
2017-07-05 22:41:30,127 DEBG fd 10 closed, stopped monitoring (stderr)>
2017-07-05 22:41:30,127 INFO exited: sabnzbd (exit status 70; not expected)
2017-07-05 22:41:30,127 DEBG received SIGCLD indicating a child quit
2017-07-05 22:41:31,129 INFO gave up: sabnzbd entered FATAL state, too many start retries too quickly


Discussed several times in this thread, see here

https://forums.lime-technology.com/index.php?/topic/44118-[support]-binhex---SABnzbd#entry564738


Sent from my SM-G935F using Tapatalk

Link to post
Just now, dikkiedirk said:

that link doesn't seem correct. it points me to a beging page

 

 

sorry android tapatalk app is crap at sharing links, try this:-

 

 

Link to post
7 minutes ago, dikkiedirk said:

thanks, seems ok now. what was the cause? does it need to generate they key and cert or are they corrupt?

 

old certs are no longer strong enough, thus deleting them causes sabnzbd o generate newer certs that work with the latest version of openssl

Link to post

I have seen this error in SABNzbd - doesn't seem to be stopping SAB from downloading:

 

-------------------------------------

[09/Jul/2017:15:47:31] ENGINE Error in HTTPServer.tick
Traceback (most recent call last):
  File "/opt/sabnzbd/cherrypy/wsgiserver/__init__.py", line 2024, in start
    self.tick()
  File "/opt/sabnzbd/cherrypy/wsgiserver/__init__.py", line 2091, in tick
    s, ssl_env = self.ssl_adapter.wrap(s)
  File "/opt/sabnzbd/cherrypy/wsgiserver/ssl_builtin.py", line 67, in wrap
    server_side=True)
  File "/usr/lib/python2.7/ssl.py", line 363, in wrap_socket
    _context=self)
  File "/usr/lib/python2.7/ssl.py", line 611, in __init__
    self.do_handshake()
  File "/usr/lib/python2.7/ssl.py", line 840, in do_handshake
    self._sslobj.do_handshake()
error: [Errno 0] Error

--------------------------------------------

I see the SSL references in the error, I presume it is the same cert errors discudded in previous posts?

 

Brian

 

Link to post
8 hours ago, tucansam said:

I've had the exact same error for weeks.

 

There are two issues with SABnzbd:-

 

!. SABnzbd wont start - this is due to the certs being too weak, delete cert and key, and restart to re-generate.

2. SABnzbd shows a error message in the web ui (cosmetic as far as i know) - this is known bug, see here https://github.com/sabnzbd/sabnzbd/issues/853

 

Both of these issues is detailed in the FAQ (linked in my sig).

Link to post

I am still seeing tons of duplicate downloads, same/different directory names. etc.  This has been going on since I moved from a standalone sab/sickbeard machine to a docker (sab and sonarr).

 

I don't know if this is a sab or sonarr problem, and I have exhausted all methods I know for troubleshooting.  I am tempted to scrap the docker and go back to a separate machine.

 

Initially my old file server (also unraid) still housed all of my media, and my current (docker-enabled) unraid server was running plex to serve it up from the old server.  As of yesterday I have migrated all media to the new server, and now docker/sab/sonarr/plex/media all lives on one system.

 

I began to do my weekly cleanup of my media stash, consolidating directories with similar names, removing duplicate episodes (there are always tons), etc.

 

Specifically, here is one case, but it is essentially what happens with all shows:

 

- Browse a show folder, finding "tv_shows/Show (2015)", "tv_shows/Show 2015", and "tv_shows/Show".  Cuss loudly, beat keyboard.  Go into Sonarr and confirm that "tv_shows/Show (2015)" is the correct folder.  Look in all three folders and find lots of duplicate episodes, some with very different file names, some with simply ".1.mkv", ".2.mkv", ".3.mkv" appended to the filename (exact same file, exact same author, exact same file size).  Cuss and pound keyboard some more.

 

- Delete dupes, move all media to the correct "tv_shows/Show (2015)" folder, delete now empty dupe directories.

 

- Wonder endlessly why sonarr is not downloading missing episodes, go in and confirm the show is "monitored" and do automatic search for all missing episodes.

 

- Happily watch sab start to queue all missing episodes, leave it unattended for a while.

 

- Come back, look at show folder, find "tv_shows/Show (2015)", "tv_shows/Show 2015", and "tv_shows/Show" again.  And duplicate episodes.  Again.

 

- Cuss and pound keyboard.

 

- Post in this thread for help.

 

I have no idea, like I said, if this is sonarr or sab causing all this nonsense, and when folks as me "is sab handling renaming" or something along those lines, I have no idea.  I copied the settings from my old (standalone server) sab settings because they worked.  Sickbeard worked perfectly with all this, and I used it in a docker for a while, and never had this issue, until I switched to sonarr, because development on sb stopped and Sickrage wasn't any better.

 

But every time I post in the sonarr docker container support thread, people's responses seem to indicate this is a sab issue.  But this all started with sonarr, so I'm not so sure.

 

If this belongs in the sonarr thread instead, forgive me and I'll move it.

 

In the meantime, if anyone has any ideas, I'm all ears.

 

Oh one more thing... I unchecked the "download propers" checkbox in sonarr, yet I still get huge 1080p files downloaded for shows where 720 or 1080p episodes already exist, just with smaller file sizes.  In fact, I have a whole stack of DVDs and Blurays for 80s TV shows that I copied up to the server using MakeMKV, full awesome uncompressed copies, and now I have 100% duplicates that were downloaded (yet sonarr saw all the original episodes from the discs before deciding to download duplicates).  I am slowly going through them one by one to check them as "unmonitored" hoping this will help.  As is stands now I have nearly a terabyte of duplicate episodes, and I only made it to the "N's" in show titles.....

 

I also have a ton of files with names like "lk1j28fajiw3jlkjaskldjf09ajwpasjd09fj.mkv" which I know is obfuscated, and I still have no idea what that is or what is means, or what show and episode it is, etc.  Most of the time when I watch one, it turns out its a dupe of something I already have.

 

This is complete insanity and after months of this I'm at my wit's end.  At this point the time I am spending trying to maintain my media library by hand is worth more than spending some money and building a separate server to start from scratch and return to my non-docker days.  I'm not blaming unraid, there is obviously a config problem somewhere.

Link to post

Config issue with sonarr, sab, or docker, or combination.  Suggest posting the active Docker template files for sab and sonarr as well as the config.xml files for sab and sonarr (mask the api keys in the config files before posting or send via PM).

Edited by unevent
Link to post
11 minutes ago, unevent said:

Config issue with sonarr, sab, or docker, or combination.  Suggest posting the active Docker template files for sab and sonarr as well as the config.xml files for sab and sonarr (mask the api keys in the config files before posting or send via PM).

 

 

I'm sorry, but I don't know what any of that stuff is.

 

There is a "config.xml" in my sonarr directory, but its only got a few lines.  There is none in my sab directory, unless you mean the sab.ini file

 

For Docker templates, is that just a screen shot of the config options when I click "Edit" on the icons under the docker tab?

 

Sorry for my ignorance.

Link to post
3 hours ago, binhex said:

 

There are two issues with SABnzbd:-

 

!. SABnzbd wont start - this is due to the certs being too weak, delete cert and key, and restart to re-generate.

2. SABnzbd shows a error message in the web ui (cosmetic as far as i know) - this is known bug, see here https://github.com/sabnzbd/sabnzbd/issues/853

 

Both of these issues is detailed in the FAQ (linked in my sig).

Thanks, Binhex. I will consider this closed as it doesn't seem to interfere withthe operation of SAB.

Link to post
42 minutes ago, tucansam said:

Hopefully I'm on the right track with this.  These are the "my-APPNAME.xml" files for sab and sonarr from /boot/config/plugins/dockerMan/templates-user

 

And the config.xml from sonarr and .ini from sab

 

 

 

sonarr.config.xml

sab.config.xml

config.xml.from.sonarr.txt

sabnzbd.ini

 

Not near my server, but looks like sonarr stores the config in the database.  Will need pics of renamer config page, sab config page (downloader), and a pic of the edit screen for any tv show in sonarr.  Mask any api keys.

Link to post

I see a few things going on; Sab is renaming and dumping to '/mnt/tv_shows' (/mnt/user/tv_shows) and sonarr may be doing the same, but will need the screen pics from sonarr to verify.  The dockers have a few map issues that should be corrected, below.

 

Sonarr Docker:

  1. Update the mapping for '/downloads' for sonarr docker (host path 4) to include the 'slave' option since it is a path on a disk handled by unassigned devices.  Edit the sonarr docker and find your '/downloads' map, edit and change the mode from 'rw' to 'rw,slave'.
  2. Update the mapping for '/tv' for sonarr docker (host path 3) to not include the 'slave' option since it is a path to the array.  Not sure if it matters, others will need to clarify the slave option being used for array maps.  Edit the sonarr docker and find your '/tv' map, edit and change the mode from 'rw,slave' to 'rw'.
  3. Update the mapping for '/config' for sonarr docker (appdata config path) to include the 'slave' option since it is a path on a disk handled by unassigned devices.  Edit the sonarr docker and find your '/config' map, edit and change the mode from 'rw' to 'rw,slave'.

Sabnzbd Docker:

  1. Depending on which we find out is doing the renaming, the map for '/mnt/user/tv_shows' (/mnt/tv_shows) may need to be removed or if kept the 'rw,slave' mode changed to just 'rw'.
  2. Update the mapping for '/downloads' for sab docker (host path 2) to change the default from '/mnt/cache/appdate/data' to '/downloads' since it could be confusing.
  3. Update the mapping for '/config' for sab docker (appdata config path) to include the 'slave' option since it is a path on a disk handled by unassigned devices.  Edit the sab docker and find your '/config' map, edit and change the mode from 'rw' to 'rw,slave'.

Once I see the pics from sonarr we should be able to figure out the renamer and double file/folder issue.

 

Edited by unevent
Link to post

THANK YOU guys, I appreciate it.  I will make the changes mentioned above and see what you have to say about my config.  Pics attached.

 

 

sonarr4.jpg

 

 

sonarr3.jpg

 

 

sonarr2.jpg

 

 

sonarr1.jpg

 

 

sab3.jpg

 

 

sab2.jpg

 

 

sab1.jpg

 

 

Edited by tucansam
Link to post

Looks like sab is doing sorting and copying to your tv_show array share and sonarr is also processing the downloads.  My suggestion would be to disable sab's sorting and double-dumping to the user share and let sonarr handle all the post processing (renaming and copying the final product to the tv_show user share).  To configure this, follow the steps below:

 

Sabnzbd:

  • Go to sab's GUI and click 'config' on top menu followed by 'categories'.  For the 'tv' category, change the 'Folder/Path' to just 'tv_shows' (change from '/mnt/tv_shows' to just 'tv_shows').  Save changes.
    • This path is relative to '/downloads/complete' within sab so when a download is complete sab will dump what it downloaded to '/downloads/complete/tv_shows'.  From there we will configure sonarr to grab what is in that folder, rename and then dump it to your tv_show array share completing the post processing.
  • While in sab's config GUI, click 'sorting' on top row.  Disable (uncheck) 'Enable TV Sorting'.  Save changes.

Sabnzbd Docker:

  • Remove host path '/mnt/tv_shows' (/mnt/user/tv_shows) from the mapping.

Sonarr:

  • In sonarr's GUI, click 'settings'.  Click 'Media Management'.  Enable (Yes) 'Rename Episodes'.
    • Configure the renaming how you like.  If need an example, I do the following:  include series title: no, Include episiode title: no, Include quality: yes, Replace spaces: yes, separator: 'period', numbering style: S01E05, season folder format: Season {season:00}, multi-episode style: extend, single episode example: The.Series.Title.2010.S01E01.Episode.Title.1.HDTV-720p, multi-episode example: The.Series.Title.2010.S01E01-02-03.Episode.Title.HDTV-720p
  • While still in sonarr's 'settings', click 'Download Client'.  Click 'sab' and verify the 'Category' is set to 'tv' (so that is matches the category in sab).  edit: Also verify the API key for sab is correct here.

The only thing left is to verify the path within sonarr for your tv show final location.  Your Docker template shows host path 2 being configured as '/tv' and is pointed to your array share for tv_shows.  Verify the 'Path' for your tv shows in sonarr has '/tv' in their path.  Using stargate tv show as example, Path: '/tv/stargate'.  This maps to your array as '/mnt/user/tv_shows/stargate" due to the Docker mapping '/tv' to /mnt/user/tv_shows'.  If that is confusing, post a pic of the tv show config page (click the wrench icon top-right on a tv show).  Only interested in the 'Path'.

Edited by unevent
Link to post

I'm getting this after every restart of unRAID in my SABnzbd container...

 

Quote

[13/Jul/2017:22:46:03] ENGINE Error in HTTPServer.tick
Traceback (most recent call last):
  File "/opt/sabnzbd/cherrypy/wsgiserver/__init__.py", line 2024, in start
    self.tick()
  File "/opt/sabnzbd/cherrypy/wsgiserver/__init__.py", line 2091, in tick
    s, ssl_env = self.ssl_adapter.wrap(s)
  File "/opt/sabnzbd/cherrypy/wsgiserver/ssl_builtin.py", line 67, in wrap
    server_side=True)
  File "/usr/lib/python2.7/ssl.py", line 363, in wrap_socket
    _context=self)
  File "/usr/lib/python2.7/ssl.py", line 611, in __init__
    self.do_handshake()
  File "/usr/lib/python2.7/ssl.py", line 840, in do_handshake
    self._sslobj.do_handshake()
error: [Errno 0] Error

 

I see mention of other errors, and a pointer to the FAQ for an answer, but i can't find anything, and I just want to be sure everything is fine, and if there's anything I should do to resolve this particular issue?

Link to post

i still can't connect to my sabnzbd, i think i need to regenerate the certs however the links in the posts above aren't showing up for me.

 

can a kind individual link to the relevant thread for me please as i've had a non working sab install on my server now for weeks:-/

Link to post
On 14/07/2017 at 1:40 PM, JustinChase said:

I'm getting this after every restart of unRAID in my SABnzbd container...

 

 

I see mention of other errors, and a pointer to the FAQ for an answer, but i can't find anything, and I just want to be sure everything is fine, and if there's anything I should do to resolve this particular issue?

 

cosmetic, its a known bug with sabnzbd and openssl 1.1.x 

Link to post
3 hours ago, ThEgOg said:

i still can't connect to my sabnzbd, i think i need to regenerate the certs however the links in the posts above aren't showing up for me.

 

can a kind individual link to the relevant thread for me please as i've had a non working sab install on my server now for weeks:-/

 

taken from my faq:-

 

The above error indicates that the currently used certificate and key are too weak and thus must be replaced with a stronger cert/key. If your using the self-signed certificate that comes with SABnzbd then you can simply stop the Docker container, and then delete the files /config/admin/server.key and /config/admin/server.cert then start the container again to force the regeneration of compliant certs.

Link to post
  • 3 weeks later...

Thanks in advance, I love all your work! Having a strange issue, seems like I lost my style sheets and all of the sites icons are large and can't be navigated. I have removed the docker with and without the image then reinstalled to no avail. Running Unraid 6.3.5. I attached a sample of the home page. There's some (error=430) for @news.eweka.nl besides that the only error in the log is: 

 

2017-08-07 17:51:54,047::INFO::[_cplogging:219] [07/Aug/2017:17:51:54] ENGINE Bus STARTING
2017-08-07 17:51:54,051::INFO::[_cplogging:219] [07/Aug/2017:17:51:54] ENGINE Started monitor thread '_TimeoutMonitor'.
2017-08-07 17:51:54,288::INFO::[_cplogging:219] [07/Aug/2017:17:51:54] ENGINE Serving on https://0.0.0.0:8090
2017-08-07 17:51:54,296::ERROR::[_cplogging:219] [07/Aug/2017:17:51:54] ENGINE Error in HTTPServer.tick
Traceback (most recent call last):
  File "/opt/sabnzbd/cherrypy/wsgiserver/__init__.py", line 2024, in start
    self.tick()
  File "/opt/sabnzbd/cherrypy/wsgiserver/__init__.py", line 2091, in tick
    s, ssl_env = self.ssl_adapter.wrap(s)
  File "/opt/sabnzbd/cherrypy/wsgiserver/ssl_builtin.py", line 67, in wrap
    server_side=True)
  File "/usr/lib/python2.7/ssl.py", line 363, in wrap_socket
    _context=self)
  File "/usr/lib/python2.7/ssl.py", line 611, in __init__
    self.do_handshake()
  File "/usr/lib/python2.7/ssl.py", line 840, in do_handshake
    self._sslobj.do_handshake()
error: [Errno 0] Error
 

I've attached some images to show the errors I'm having. 

 

Any advice is appreciated. 

 

Thanks!

 

 

1.JPG

2.JPG

3.JPG

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.