Jump to content
binhex

[Support] binhex - SABnzbdVPN

643 posts in this topic Last Reply

Recommended Posts

Thx for the good explanation of it  and for you great work

Share this post


Link to post

I was working just fine for the the better part of a week when I first set things up in early January and then all of the sudden I can't get past 200KB/s download shortly after I updated to the latest image. 

I was containerizing my VM stack and still had my old VM powered off.  Turned that on and it goes straight to maxing out over PIA.

So, both clients on at the same time, Container does 200KB/s max while VM can saturate my line.

I've done everything I can possibly think of at this point and no idea why my speed suddenly crashed.  I've turned off all other containers on the host, rebooted, I cannot find a correlation.  I did try disabling the VPN and still extremely slow speeds. 

Any ideas?  I looked at the last commit, and I get it, real basic change, but I'm going to roll back just to test it out.

Edited by Maverick0984

Share this post


Link to post

So, rolling back did nothing, same issue.  Going back to my dedicated VM still good.  Decided to spin up a new VM, install a fresh Docker-CE and move it over.  Ran fine in the new location.

 

This means my Synology DS-1817+ just isn't powerful enough which is unfortunate.  It was working previously when it was the only container running and as I loaded up a handful more, performance began to degrade and I just didn't notice as it isn't downloading 24/7.

 

Just wanted to close the loop on this for anyone paying attention.

Share this post


Link to post

What is the proper way to run both deluge and sabnzbd over vpn?

 

I currently have binhex-delugevpn up and running perfectly, but trying to also add binhex-sabnzbdvpn generates config errors. Are you only supposed to use one docker with VPN/privoxy enabled, and somehow point the other one at it?

 

/usr/bin/docker: Error response from daemon: driver failed programming external connectivity on endpoint binhex-sabnzbdvpn (14648aaad0ff3ea953484e7db4f8b22e6a8cbf9eee1c1e32e2abf2dece4a9aab): Bind for 0.0.0.0:8118 failed: port is already allocated.

 

Edited by torch2k

Share this post


Link to post
4 hours ago, torch2k said:

Are you only supposed to use one docker with VPN/privoxy enabled,

Privoxy is a separate piece, you only need it enabled in one or the other, not both. VPN should be enabled in both. Privoxy is used to route http requests through the existing VPN tunnel, by specifying the IP and port in the http proxy settings of whatever browser or search agent you wish to send through the VPN tunnel.

Share this post


Link to post
20 minutes ago, rguinn said:

Is it posable to build NordVPN in to this? 

I run it with Nord VPN just fine. Use custom VPN provider from drop down 

Share this post


Link to post
3 minutes ago, brianbrifri said:

I run it with Nord VPN just fine. Use custom VPN provider from drop down 

Thank you can you tell me is it just your user and password info? did you put anything in the VPN_OPTIONS field 

Share this post


Link to post

Resolved, "iptable_mangle module" was not present on host....but I don't know, how it was working for like a month and then decided to stop working.....anyway great docker, love it, 11/10 :)

 

For the other: I did the following:
on Q2 I scrolled to "Q2. I can't seem to access the webui from outside my LAN, why is this?" and did the descriped steps.

 

echo "# force iptable mangle module to load (required for *vpn dockers)" >> /boot/config/go
echo "/sbin/modprobe iptable_mangle" >> /boot/config/go 

and reboot

 

Original Post:

 

 

Hey,

 

TL;DR: No access to SabNZBD interface when VPN dockersetting is set to "yes", but VPN works.

 

I have the following problem: 2 days or so agao everything worked fine and I could easily access the Webinterface ob sabnzdb, but since today in the morning, I can't access it anymore. I've done some troubleshooting and think it has something to do with my VPN settings, because if i disable the VPN in the Docker settings in Unraid, I can access it, but when I re-enable it, no response from SabNZBD. But the weirdes thing is, when the VPN is activated and I can't reach the Webinterface, the API still works and Radarr/Sonarr etc can send NZB to SabNZBD and it will even download them. Sooooo I'm not sure where the Problem is. 

The only thing I changed since yesterday is adding a new NIC to the system and I'm trying to get Link aggreation to work....but I don't now, if it's related, cause when the VPN settings ist set to "no", I can access the Webinterface.
 

Thanks

 

Edit: I've looked into the Debug log and found out, that SabNZBD itself is not starting.....but I think, thats a false alarm, cause the weirdes thing is, that Sonarr and Radarr still can communicate via the API with Sab.....but the webinterface is not loading

 

Edit 2: Ahh, RTFM....i know....and now I've read the FAQ for VPN=yes and no GUI......the Problem is, that when I use the network br0, then everything works (the VPN also(Sab is reporting the VPN IP)), but not in brige mode....but I will dig further in it

 

Edit 3: Sooo I installed OpenVPN on my personal machine and loaded the exakt same copy from the Sab Folder and the credentails.conf into the config folder of openVPN, startet the connection and connected correctly (myip.is showed the VPN IP). So I think the VPN isn't the problem. I also removed the 2nd NIC (thought this was the issue), but no GUI. I don't how to fix this problem. From one to another day it doesn't work anymore.

 

Edit 4: Yeah, still the same Problem. I've found out, that the VPN is not the Problem, cause I enterd the folllowing in the console and get the VPN IP adress:

curl https://ipinfo.io/ip

I don't know the problem, maybe a broken IPTable? Still looking for a solution.

 

LOG: unimportant!

2019-02-09 18:41:40,798 DEBG 'watchdog-script' stdout output:
[info] Attempting to start SABnzbd...

[...]

2019-02-09 18:41:42,320 DEBG 'watchdog-script' stdout output:
[debug] Waiting for SABnzbd process to start...

2019-02-09 18:41:43,324 DEBG 'watchdog-script' stdout output:
[debug] Waiting for SABnzbd process to start...

2019-02-09 18:41:44,327 DEBG 'watchdog-script' stdout output:
[debug] Waiting for SABnzbd process to start...

[...]

2019-02-09 18:42:11,428 DEBG 'watchdog-script' stdout output:
[warn] Wait for SABnzbd process to start aborted
[info] Waiting for SABnzbd process to start listening on port 8080...

 

Edited by tobix
I didn't RTFM; Still not working after reading, resolved

Share this post


Link to post

I'm sorry for what is probably a newb question, however is it normal for only .py files to show up in the post-processing folder? .sh files won't work?

Share this post


Link to post

Greetings community, I have configured the sabnzbdvpn and have configured privoxy for sickchill. I cannot, however access anything on http://sickchill.github.io/ through the privoxy. I have a feeling it is blocking it, I am trying to access a json file as well as a text file and keep getting blocked. It works when not going through the privoxy.


I am fairly new to all of this but does anybody know how to configure the privoxy (and which file/lines to add in configs) to allow this traffic?

 

Thank you in advance for any assistance you can provide.

-Fizz

Share this post


Link to post

Apologies if this is the wrong thread , but a support link in CA sent me here.

 

Just found binhex-privoxyvpn in CA, and from what I can tell it's fairly new.  Is it the "VPN" part of the other binhex containers (ie, binhex-delugevpn without the deluge)?  If so, this might come in handy - I've raised before that I've wanted to stop a container, but couldn't because VPN traffic was going through it.

 

If so, I'm guessing deluge/rtorrent can be set to use a proxy and have VPN turned off?

 

Share this post


Link to post
1 hour ago, Cessquill said:

Apologies if this is the wrong thread , but a support link in CA sent me here.

 

Just found binhex-privoxyvpn in CA, and from what I can tell it's fairly new.  Is it the "VPN" part of the other binhex containers (ie, binhex-delugevpn without the deluge)?  If so, this might come in handy - I've raised before that I've wanted to stop a container, but couldn't because VPN traffic was going through it.

 

If so, I'm guessing deluge/rtorrent can be set to use a proxy and have VPN turned off?

 

Wrong thread, but I haven't seen the correct thread get created yet, so this will do.

 

AFAIK, yes this is just the VPN/privoxy piece without the download client, be it nzb or torrent.

 

I don't think torrent clients can be tunnelled through a http proxy, which is what privoxy is.

 

What you can do, is install this as your privoxy gateway, so you can stop your vpn enabled downloader without disturbing the proxy. However, this means that your vpn account will have another constant connection. I don't know the limits on the various VPN providers.

Share this post


Link to post
18 minutes ago, jonathanm said:

What you can do, is install this as your privoxy gateway, so you can stop your vpn enabled downloader without disturbing the proxy. However, this means that your vpn account will have another constant connection. I don't know the limits on the various VPN providers.

Thanks - that's what I was thinking.  PIA has a 5 connection limit, so it's not the end of the world using 2 or 3 of those on Unraid.  Would rather use as few as possible though.

 

(the support link in CA currently points to here - assuming a new topic will be created and linked in due course)

Share this post


Link to post
53 minutes ago, Cessquill said:

(the support link in CA currently points to here - assuming a new topic will be created and linked in due course)

created, and of course jonathanm is spot on for usage.

  • Upvote 1

Share this post


Link to post

Binhex-

I am having an issue with two containers using binhex-sabnzbdvpn privoxy with PIA. For what ever reason binhex-deluge and binhex-hydra seem to ignore proxy settings. Currently I have Radarr, Sonarr, Jackett and even some PC's utilizing SAB's privoxy. Today, I received a warning from my ISP about torrent traffic. It turns out even with Deluge and Hydra having same proxy setup as everything else, they connect to the internet even when sabnzbdvpn is off. In fact even with SAB running they do not seem to use PIA VPN. No other dockers or PC's can do this. No SAB = no internet. Any thoughts? Today I tried the new binhex-privoxy docker, same result. Thank you in advance for all your hard work!

Share this post


Link to post
10 minutes ago, spacebender said:

For what ever reason binhex-deluge and binhex-hydra seem to ignore proxy settings.

do not use privoxy to attempt to secure torrent traffic it is not designed to do this, if you want to prevent letters from your ISP then you have to run these as individual application WITH the vpn running for each app, if you want to see what prioxy IS designed to be used for then see Q3 from the following link:-

 

https://forums.unraid.net/topic/44108-support-binhex-general/?tab=comments#comment-433613

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now