[Support] binhex - SABnzbdVPN

Recommended Posts

Hi Guys,

I sent this to Nordvpn, but I was curious if anyone else had speed issues with SABnzbVPN or their vpn in general.


Ryzen 8 core 16 thread cpu. 
32 gigs of ram. 

My internet is fibre 360mbs down and 30mbs up.


My router is an Asus Ac-5300 Tri-Band. I'm using the latest version of Merlin Firmware on it My internet provider is cogeco. I'm about an hour from Toronto where a lot of these vpn providers have servers, or so they say.


I have openvpn set up on the router with Nordvpn, so that it connects to the server's individual ips that I want on my vpn. The problem is I can only achieve 5mbs of download speed.  I'm using SABnzbVPN.  I was thinking of connecting to the vpn directly in SAB, not sure if it would make a difference.  I know Nordvpn doesn't support portforwarding.  FYI:  Had the same speed issues with PIA


I know about using the closes servers, switching between UPD and TCP, trying different servers. Using p2p, which made it worse  I have tried everything. I know it depends on the speed of your internet. I don't expect great speeds, but 5mbs? With the equipment I'm using it's not that bad...LOL I have read about a number of people getting 20 to 50mbs on smaller internet packages and equipment. I have done speed tests on my internet and it is functioning properly. 


I'm thinking it is being blocked somewhere. Is it possible that the ports 1194 /443  are being blocked by my isp? My router has the default firewall wall button on.   Anybody got any ideas? Maybe change ports on SAB,  Usenet. Pretty much out ideas. Might just have to accept the fact that this is the way it is, or try another VPN.  Not so sure that will make a difference.



This might help someone else.  This is the response from Nordvpn.  I get the impression he didn't read much of my email...LOL


The downside to OpenVPN is that in its current architecture, it is not scalable. It runs as a monolithic process and cannot run multi-threaded.

This means that if you have a beefy processor with 8 cores and each of the core has 8 threads, OpenVPN will use only a single thread in one of the available cores.

Regarding routers - they do not have powerful CPUs, thus encrypting and decrypting OpenVPN traffic is a real challenge for them. For that reason, the speed can drop by a large amount.

You could try increasing your speed by connecting to a few different servers (preferably to the ones in yours or neighbouring country), changing between TCP and UDP, enabling QoS and changing Upload and Download to 100Mbps, disabling SPI Firewall and NAT Acceleration (if your router has one). You could also try looking for the most optimal MTU value on your router which could be in the range from 1300 to 1500.

If these changes do not help and you are getting better speeds while connected to the same servers with our software on your computer, then, unfortunately, your router's hardware cannot encrypt the internet traffic fast enough and this is the reason for speed drop. In this case, there is nothing that I can suggest you, unfortunately.

Edited by Badboy
Link to comment

hi im sorry if this was said before but i cant seem to see it but i can make the non vpn container no probs but when i made the vpn one and i put in my Pia user name and pass it wont start all default wont work i turn off vpn and it works if some one can show me a screen shot to follow or a vid it would be much appreciated

Link to comment

I just set this container up over the weekend. I was able to connect it to ProtonVPN without issue and have tested download by manually dropping a .nzb file into my watched folder and it was able to max out my speed. My question is, how can I configure things properly so that I can push from an indexer to the sabnzbd API? I have set this up successfully in the past with port forwarding on my router. I tried it for this sab installation on the off chance that it would work, but have been unable to push using my home IP address. Has anyone successfully enabled push for sabnzbd using this container?


EDIT: I've also discovered that I cannot send alerts to my SMTP server, which is on the same layer 2 network as my UNraid server. So it would seem I am missing something when it comes to the networking within this container. Are there some parameters I should be using for specific traffic that I do not want tunneled?

Edited by knalbone
Link to comment
9 hours ago, brianbrifri said:

Mine works with VPN now too....no shaggy what's going on here either.

if the docker image hasnt changed (it hasnt) then it can only be external factors in play, your firewall, your ISP, your VPN provider or your usenet provider, any of these could potentially cause a block.

Link to comment
1 hour ago, charlieny100 said:

Yesterday I got a notification that my SabVPN docker was automatically updated. Could that have something to do with why it started to work for some?

in a word, no, tha change was a simple env var check enhancement, im 100% sure its not related.

Link to comment
26 minutes ago, tola5 said:

Hi if I use your rtorrentvpn and have  and use Privoxy with it are there a way too use that and not login 2 time with the vpn cant find  poxy settings on sabnzbd but perhaps im look the wrong please 

i think what you are asking is, can you share the vpn connection from rtorrent with sabnzbd, if thats the question then the answer is no, if on the other hand you are asking if you can use a single instance of privoxy for multiple applications then the answer is yes.

Link to comment
6 minutes ago, binhex said:

i think what you are asking is, can you share the vpn connection from rtorrent with sabnzbd, if thats the question then the answer is no, if on the other hand you are asking if you can use a single instance of privoxy for multiple applications then the answer is yes.

yes that was the first one but do I total misunderstand what privaxy do ?  do it not make application send data through a other docker vpn ? 

Link to comment
30 minutes ago, tola5 said:

 do it not make application send data through a other docker vpn ? 

yes, and thus my reply below:-


31 minutes ago, tola5 said:

if on the other hand you are asking if you can use a single instance of privoxy for multiple applications then the answer is yes.

whether sabnzbd supports proxy i dont know, this image (as in sabnzbdvpn) was built with the idea that you use the built in vpn client, NOT to use a proxy connections from another container, having said that if sabnzbd does support proxy (i dont know if it does) then you should be able to configure sabnzbd to use privoxy from another container.


Obviously this comes with the risk that if the proxy server goes down (as in your turn off the other container) then sabnzbd COULD leak ip info if it does not respect the proxy connection being set and bypasses proxy when unavailable (totally untested by me).


If you are using a decent VPN provider then you will be able to have multiple connections in any case (PIA allows 5 concurrent connections), thus it shouldnt really be a problem.

Link to comment

I was working just fine for the the better part of a week when I first set things up in early January and then all of the sudden I can't get past 200KB/s download shortly after I updated to the latest image. 

I was containerizing my VM stack and still had my old VM powered off.  Turned that on and it goes straight to maxing out over PIA.

So, both clients on at the same time, Container does 200KB/s max while VM can saturate my line.

I've done everything I can possibly think of at this point and no idea why my speed suddenly crashed.  I've turned off all other containers on the host, rebooted, I cannot find a correlation.  I did try disabling the VPN and still extremely slow speeds. 

Any ideas?  I looked at the last commit, and I get it, real basic change, but I'm going to roll back just to test it out.

Edited by Maverick0984
Link to comment

So, rolling back did nothing, same issue.  Going back to my dedicated VM still good.  Decided to spin up a new VM, install a fresh Docker-CE and move it over.  Ran fine in the new location.


This means my Synology DS-1817+ just isn't powerful enough which is unfortunate.  It was working previously when it was the only container running and as I loaded up a handful more, performance began to degrade and I just didn't notice as it isn't downloading 24/7.


Just wanted to close the loop on this for anyone paying attention.

Link to comment

What is the proper way to run both deluge and sabnzbd over vpn?


I currently have binhex-delugevpn up and running perfectly, but trying to also add binhex-sabnzbdvpn generates config errors. Are you only supposed to use one docker with VPN/privoxy enabled, and somehow point the other one at it?


/usr/bin/docker: Error response from daemon: driver failed programming external connectivity on endpoint binhex-sabnzbdvpn (14648aaad0ff3ea953484e7db4f8b22e6a8cbf9eee1c1e32e2abf2dece4a9aab): Bind for failed: port is already allocated.


Edited by torch2k
Link to comment
4 hours ago, torch2k said:

Are you only supposed to use one docker with VPN/privoxy enabled,

Privoxy is a separate piece, you only need it enabled in one or the other, not both. VPN should be enabled in both. Privoxy is used to route http requests through the existing VPN tunnel, by specifying the IP and port in the http proxy settings of whatever browser or search agent you wish to send through the VPN tunnel.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.