Jump to content
binhex

[Support] binhex - SABnzbdVPN

885 posts in this topic Last Reply

Recommended Posts

Hello,

 

I hope someone can give me a hint of what is going on here. Attached the log file.

The WebUI isn't accessible anymore. 

 

I already tried to revert to the version 2.3.9-1-01.

log.log

Share this post


Link to post
8 hours ago, darkreeper said:

Hello,

 

I hope someone can give me a hint of what is going on here. Attached the log file.

The WebUI isn't accessible anymore. 

 

I already tried to revert to the version 2.3.9-1-01.

log.log 63.65 kB · 1 download

im not sure who your vpn provider is but for some bizarre reason they are using self signed certificates?!, not good!, until your vpn provider can supply you with certificates from a known CA you wont be able to connect:-

 

Sat Jul 13 04:41:55 2019 VERIFY ERROR: depth=1, error=self signed certificate in certificate chain: CN=TG-VPN-CA
Sat Jul 13 04:41:55 2019 OpenSSL: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed
Sat Jul 13 04:41:55 2019 TLS_ERROR: BIO read tls_read_plaintext error
Sat Jul 13 04:41:55 2019 TLS Error: TLS object -> incoming plaintext read error
Sat Jul 13 04:41:55 2019 TLS Error: TLS handshake failed

2019-07-13 04:41:55,291 DEBG 'start-script' stdout output:
Sat Jul 13 04:41:55 2019 Fatal TLS error (check_tls_errors_co), restarting
Sat Jul 13 04:41:55 2019 SIGHUP[soft,tls-error] received, process restarting

 

Edited by binhex

Share this post


Link to post

This is strange. It worked well before. I will test a different server from the VPN provider. It is TorGuard btw.

Gesendet von meinem MI 8 mit Tapatalk

Share this post


Link to post

Alright. You were totally right. The VPN provider has changed its certificates to fully support IPv6.

I have readded them and it is working now.

Share this post


Link to post

Hi,

I am using purevpn, this docker was working fine for a month or so. but for last 2 weeks i have been getting solid "connection reset" when its trying to connect to openvpn. I have rebuilt docker image, tried older ones, made sure my userid/password are ok. But no joy so far:

 

Created by...
___. .__ .__
\_ |__ |__| ____ | |__ ____ ___ ___
| __ \| |/ \| | \_/ __ \\ \/ /
| \_\ \ | | \ Y \ ___/ > <
|___ /__|___| /___| /\___ >__/\_ \
\/ \/ \/ \/ \/
https://hub.docker.com/u/binhex/

2019-07-28 10:36:00.536516 [info] System information Linux 83bfff2fd624 4.19.56-Unraid #1 SMP Tue Jun 25 10:19:34 PDT 2019 x86_64 GNU/Linux
2019-07-28 10:36:00.557148 [info] PUID defined as '99'
2019-07-28 10:36:00.717512 [info] PGID defined as '100'
2019-07-28 10:36:00.934463 [info] UMASK defined as '000'
2019-07-28 10:36:00.953517 [info] Permissions already set for volume mappings
2019-07-28 10:36:00.975940 [info] VPN_ENABLED defined as 'yes'
2019-07-28 10:36:01.000140 [info] OpenVPN config file (ovpn extension) is located at /config/openvpn/nl2-ovpn-tcp-tcp.ovpn
dos2unix: converting file /config/openvpn/nl2-ovpn-tcp-tcp.ovpn to Unix format...
2019-07-28 10:36:01.031151 [info] VPN remote line defined as 'remote nl2-ovpn-tcp.pointtoserver.com 80'
2019-07-28 10:36:01.051488 [info] VPN_REMOTE defined as 'nl2-ovpn-tcp.pointtoserver.com'
2019-07-28 10:36:01.070964 [info] VPN_PORT defined as '80'
2019-07-28 10:36:01.093260 [info] VPN_PROTOCOL defined as 'tcp-client'
2019-07-28 10:36:01.112867 [info] VPN_DEVICE_TYPE defined as 'tun0'
2019-07-28 10:36:01.132197 [info] VPN_PROV defined as 'custom'
2019-07-28 10:36:01.151465 [info] LAN_NETWORK defined as '10.2.1.0/24'
2019-07-28 10:36:01.170595 [info] ADDITIONAL_PORTS defined as '8081'
2019-07-28 10:36:01.190308 [info] NAME_SERVERS defined as '209.222.18.222,84.200.69.80,37.235.1.174,1.1.1.1,209.222.18.218,37.235.1.177,84.200.70.40,1.0.0.1'
2019-07-28 10:36:01.210152 [info] VPN_USER defined as 'purevpn0nnnnnnn'
2019-07-28 10:36:01.229564 [info] VPN_PASS defined as '########'
2019-07-28 10:36:01.248862 [info] VPN_OPTIONS not defined (via -e VPN_OPTIONS)
2019-07-28 10:36:01.268388 [info] ENABLE_PRIVOXY defined as 'yes'
2019-07-28 10:36:01.296143 [info] Starting Supervisor...
2019-07-28 10:36:01,437 INFO Included extra file "/etc/supervisor/conf.d/sabnzbdvpn.conf" during parsing
2019-07-28 10:36:01,437 INFO Set uid to user 0 succeeded
2019-07-28 10:36:01,439 INFO supervisord started with pid 6
2019-07-28 10:36:02,441 INFO spawned: 'start-script' with pid 142
2019-07-28 10:36:02,442 INFO spawned: 'watchdog-script' with pid 143
2019-07-28 10:36:02,442 INFO reaped unknown pid 7
2019-07-28 10:36:02,446 DEBG 'start-script' stdout output:
[info] VPN is enabled, beginning configuration of VPN

2019-07-28 10:36:02,446 INFO success: start-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2019-07-28 10:36:02,446 INFO success: watchdog-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2019-07-28 10:36:02,487 DEBG 'start-script' stdout output:
[info] Default route for container is 172.17.0.1

2019-07-28 10:36:02,490 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.222 to /etc/resolv.conf

2019-07-28 10:36:02,492 DEBG 'start-script' stdout output:
[info] Adding 84.200.69.80 to /etc/resolv.conf

2019-07-28 10:36:02,495 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.174 to /etc/resolv.conf

2019-07-28 10:36:02,497 DEBG 'start-script' stdout output:
[info] Adding 1.1.1.1 to /etc/resolv.conf

2019-07-28 10:36:02,499 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.218 to /etc/resolv.conf

2019-07-28 10:36:02,502 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.177 to /etc/resolv.conf

2019-07-28 10:36:02,504 DEBG 'start-script' stdout output:
[info] Adding 84.200.70.40 to /etc/resolv.conf

2019-07-28 10:36:02,507 DEBG 'start-script' stdout output:
[info] Adding 1.0.0.1 to /etc/resolv.conf

2019-07-28 10:36:02,835 DEBG 'start-script' stdout output:
[info] Attempting to load tun kernel module...

2019-07-28 10:36:02,836 DEBG 'start-script' stderr output:
modprobe: FATAL: Module tun not found in directory /lib/modules/4.19.56-Unraid

2019-07-28 10:36:02,836 DEBG 'start-script' stdout output:
[warn] Unable to load tun kernel module using modprobe, trying insmod...

2019-07-28 10:36:02,836 DEBG 'start-script' stderr output:
insmod: ERROR: could not load module /lib/modules/tun.ko: No such file or directory

2019-07-28 10:36:02,837 DEBG 'start-script' stdout output:
[warn] Unable to load tun kernel module, assuming its dynamically loaded

2019-07-28 10:36:02,840 DEBG 'start-script' stdout output:
[info] Attempting to load iptable_mangle module...

2019-07-28 10:36:02,841 DEBG 'start-script' stderr output:
modprobe: FATAL: Module iptable_mangle not found in directory /lib/modules/4.19.56-Unraid

2019-07-28 10:36:02,841 DEBG 'start-script' stdout output:
[warn] Unable to load iptable_mangle module using modprobe, trying insmod...

2019-07-28 10:36:02,842 DEBG 'start-script' stderr output:
insmod: ERROR: could not load module /lib/modules/iptable_mangle.ko: No such file or directory

2019-07-28 10:36:02,842 DEBG 'start-script' stdout output:
[warn] Unable to load iptable_mangle module, you will not be able to connect to the applications Web UI or Privoxy outside of your LAN
[info] unRAID/Ubuntu users: Please attempt to load the module by executing the following on your host: '/sbin/modprobe iptable_mangle'
[info] Synology users: Please attempt to load the module by executing the following on your host: 'insmod /lib/modules/iptable_mangle.ko'

2019-07-28 10:36:02,854 DEBG 'start-script' stdout output:
[info] Docker network defined as 172.17.0.0/16

2019-07-28 10:36:02,857 DEBG 'start-script' stdout output:
[info] Adding 10.2.1.0/24 as route via docker eth0

2019-07-28 10:36:02,857 DEBG 'start-script' stdout output:
[info] ip route defined as follows...
--------------------

2019-07-28 10:36:02,858 DEBG 'start-script' stdout output:
default via 172.17.0.1 dev eth0
10.2.1.0/24 via 172.17.0.1 dev eth0
172.17.0.0/16 dev eth0 proto kernel scope link src 172.17.0.3

2019-07-28 10:36:02,858 DEBG 'start-script' stdout output:
--------------------

2019-07-28 10:36:02,873 DEBG 'start-script' stdout output:
[info] Adding additional incoming port 8081 for eth0

2019-07-28 10:36:02,893 DEBG 'start-script' stdout output:
[info] Adding additional outgoing port 8081 for eth0

2019-07-28 10:36:02,901 DEBG 'start-script' stdout output:
[info] iptables defined as follows...
--------------------

2019-07-28 10:36:02,902 DEBG 'start-script' stdout output:
-P INPUT DROP
-P FORWARD DROP
-P OUTPUT DROP
-A INPUT -i tun0 -j ACCEPT
-A INPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --sport 80 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 8080 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --sport 8080 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 8090 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --sport 8090 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 8081 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --sport 8081 -j ACCEPT
-A INPUT -s 10.2.1.0/24 -d 172.17.0.0/16 -i eth0 -p tcp -j ACCEPT
-A INPUT -p icmp -m icmp --icmp-type 0 -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A OUTPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --dport 80 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --dport 8080 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 8080 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --dport 8090 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 8090 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --dport 8081 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 8081 -j ACCEPT
-A OUTPUT -s 172.17.0.0/16 -d 10.2.1.0/24 -o eth0 -p tcp -j ACCEPT
-A OUTPUT -p icmp -m icmp --icmp-type 8 -j ACCEPT
-A OUTPUT -o lo -j ACCEPT
-A OUTPUT -o tun0 -j ACCEPT

2019-07-28 10:36:02,902 DEBG 'start-script' stdout output:
--------------------

2019-07-28 10:36:02,902 DEBG 'start-script' stdout output:
[info] Starting OpenVPN...

2019-07-28 10:36:02,919 DEBG 'start-script' stdout output:
Sun Jul 28 10:36:02 2019 WARNING: file 'credentials.conf' is group or others accessible
Sun Jul 28 10:36:02 2019 OpenVPN 2.4.7 [git:makepkg/2b8aec62d5db2c17+] x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Feb 19 2019
Sun Jul 28 10:36:02 2019 library versions: OpenSSL 1.1.1c 28 May 2019, LZO 2.10

2019-07-28 10:36:02,919 DEBG 'start-script' stdout output:
Sun Jul 28 10:36:02 2019 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

2019-07-28 10:36:02,919 DEBG 'start-script' stdout output:
[info] OpenVPN started

2019-07-28 10:36:02,920 DEBG 'start-script' stdout output:
Sun Jul 28 10:36:02 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]43.226.228.4:80

2019-07-28 10:36:02,920 DEBG 'start-script' stdout output:
Sun Jul 28 10:36:02 2019 Attempting to establish TCP connection with [AF_INET]43.226.228.4:80 [nonblock]

2019-07-28 10:36:04,920 DEBG 'start-script' stdout output:
Sun Jul 28 10:36:04 2019 TCP connection established with [AF_INET]43.226.228.4:80
Sun Jul 28 10:36:04 2019 TCP_CLIENT link local: (not bound)
Sun Jul 28 10:36:04 2019 TCP_CLIENT link remote: [AF_INET]43.226.228.4:80

2019-07-28 10:36:13,595 DEBG 'start-script' stdout output:
Sun Jul 28 10:36:13 2019 Connection reset, restarting [-1]

2019-07-28 10:36:13,595 DEBG 'start-script' stdout output:
Sun Jul 28 10:36:13 2019 SIGHUP[soft,connection-reset] received, process restarting

Any suggestions?

Edited by daver898

Share this post


Link to post

Hello,

 

I just recently change my ISP from Xfinity to Verizon FIOS.

After I cut over to the new ISP and now I am unable to get my PIA VPN started.

I tried changing the opvn file to TCP or IP but it didn't work.

Once I start the container it starts to loop with the following message,

 

019-08-06 20:50:20,166 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:50:50,305 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:51:20,446 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:51:50,584 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:52:20,725 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:52:50,862 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:53:21,004 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:53:51,144 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:54:21,282 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:54:51,429 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:55:21,577 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:55:51,722 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:56:21,862 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:56:52,002 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:57:22,142 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:57:52,280 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:58:22,419 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:58:52,558 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:59:22,696 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:59:52,834 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:00:22,973 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:00:53,112 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:01:23,251 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:01:53,390 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:02:23,528 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:02:53,668 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:03:23,807 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:03:53,947 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:04:24,085 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:04:54,224 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:05:24,362 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:05:54,500 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:06:24,639 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:06:54,780 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:07:24,916 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:07:55,054 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:08:25,192 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:08:55,331 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:09:25,468 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:09:55,607 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:10:25,745 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:10:55,884 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:11:26,022 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:11:56,161 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:12:26,301 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:12:56,440 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:13:26,577 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:13:56,714 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:14:26,852 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:14:56,991 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:15:27,129 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:15:57,266 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:16:27,406 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:16:57,545 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:17:27,684 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:17:57,822 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:18:27,960 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:18:58,098 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:19:28,236 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:19:58,376 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:20:28,514 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:20:58,652 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:21:28,791 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:21:58,928 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:22:29,067 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:22:59,205 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:23:29,343 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:23:59,482 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:24:29,621 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:24:59,758 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:25:29,898 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:26:00,036 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:26:30,173 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:27:00,312 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:27:30,450 DEBG 'watchdog-script' stdout output:
172.217.10.100
 

If someone can please help me get the proper configuration done so I can get this working.

Share this post


Link to post
7 hours ago, BF90X said:

Hello,

 

I just recently change my ISP from Xfinity to Verizon FIOS.

After I cut over to the new ISP and now I am unable to get my PIA VPN started.

I tried changing the opvn file to TCP or IP but it didn't work.

Once I start the container it starts to loop with the following message,

 

019-08-06 20:50:20,166 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:50:50,305 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:51:20,446 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:51:50,584 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:52:20,725 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:52:50,862 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:53:21,004 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:53:51,144 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:54:21,282 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:54:51,429 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:55:21,577 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:55:51,722 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:56:21,862 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:56:52,002 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:57:22,142 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:57:52,280 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:58:22,419 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:58:52,558 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:59:22,696 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 20:59:52,834 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:00:22,973 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:00:53,112 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:01:23,251 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:01:53,390 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:02:23,528 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:02:53,668 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:03:23,807 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:03:53,947 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:04:24,085 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:04:54,224 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:05:24,362 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:05:54,500 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:06:24,639 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:06:54,780 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:07:24,916 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:07:55,054 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:08:25,192 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:08:55,331 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:09:25,468 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:09:55,607 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:10:25,745 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:10:55,884 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:11:26,022 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:11:56,161 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:12:26,301 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:12:56,440 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:13:26,577 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:13:56,714 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:14:26,852 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:14:56,991 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:15:27,129 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:15:57,266 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:16:27,406 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:16:57,545 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:17:27,684 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:17:57,822 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:18:27,960 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:18:58,098 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:19:28,236 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:19:58,376 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:20:28,514 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:20:58,652 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:21:28,791 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:21:58,928 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:22:29,067 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:22:59,205 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:23:29,343 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:23:59,482 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:24:29,621 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:24:59,758 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:25:29,898 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:26:00,036 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:26:30,173 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:27:00,312 DEBG 'watchdog-script' stdout output:
172.217.10.100

2019-08-06 21:27:30,450 DEBG 'watchdog-script' stdout output:
172.217.10.100
 

If someone can please help me get the proper configuration done so I can get this working.

i will need a full debug log to help, please follow the procedure linked below:-

https://github.com/binhex/documentation/blob/master/docker/faq/help.md

Share this post


Link to post
12 hours ago, binhex said:

i will need a full debug log to help, please follow the procedure linked below:-

https://github.com/binhex/documentation/blob/master/docker/faq/help.md

 

12 hours ago, binhex said:

i will need a full debug log to help, please follow the procedure linked below:-

https://github.com/binhex/documentation/blob/master/docker/faq/help.md

I followed the steps from the link.

After reviewing it, it seems that VPN connects but the container page doesn't load when it is active.

When I turn off VPN, I am able to access the container page and it loads properly.

Thanks for your help.

supervisord.log

Edited by BF90X

Share this post


Link to post
16 hours ago, BF90X said:

I followed the steps from the link.

After reviewing it, it seems that VPN connects but the container page doesn't load when it is active.

When I turn off VPN, I am able to access the container page and it loads properly.

Thanks for your help.

Assuming you didn't change any networking settings from default, that sounds like your VPN server doesn't support port-forwarding.

Share this post


Link to post
52 minutes ago, testdasi said:

Assuming you didn't change any networking settings from default, that sounds like your VPN server doesn't support port-forwarding.

this doesn't come into play as we are talking about a usenet client here not torrents, all code to determine the incoming port is disabled for this image.

 

17 hours ago, BF90X said:

When I turn off VPN, I am able to access the container page and it loads properly.

your log is clean, showing no issues, so i can only assume that your new ISP (and thus new router perhaps?) is issuing leases on a different network range, can you confirm the ip address of your unraid server is in the range 192.168.1.0/24

Share this post


Link to post
28 minutes ago, binhex said:

this doesn't come into play as we are talking about a usenet client here not torrents, all code to determine the incoming port is disabled for this image.

I understand your point but I can reliably reproduce this with my VPN (PIA) by simply switching to a non-port-forwarding server. I would lose access to the interface within 10 secs or so after docker start but I can tell the docker is still running based on network stats. Maybe something peculiar about my network / ISP.

Share this post


Link to post
5 hours ago, binhex said:

this doesn't come into play as we are talking about a usenet client here not torrents, all code to determine the incoming port is disabled for this image.

 

your log is clean, showing no issues, so i can only assume that your new ISP (and thus new router perhaps?) is issuing leases on a different network range, can you confirm the ip address of your unraid server is in the range 192.168.1.0/24

Thanks for your response.

That is correct, my unraid server is in the ip address range 192.168.1.0/24

My VPN provider is PIA and I didn't experience issues before the ISP change.

My router is also the same, I am using Pfsense which was getting the hand off from the modem before and now it's getting the hand off from the FIOS circuit.

I haven't experience any issues with other docker containers.

Share this post


Link to post
22 hours ago, testdasi said:

I understand your point but I can reliably reproduce this with my VPN (PIA) by simply switching to a non-port-forwarding server. I would lose access to the interface within 10 secs or so after docker start but I can tell the docker is still running based on network stats. Maybe something peculiar about my network / ISP.

hmm then i would double check your ovpn and certs, as this should not happen - just tested it with uk-london (no pf) with this image and no problems.

Share this post


Link to post
On 8/8/2019 at 11:42 AM, binhex said:

this doesn't come into play as we are talking about a usenet client here not torrents, all code to determine the incoming port is disabled for this image.

 

your log is clean, showing no issues, so i can only assume that your new ISP (and thus new router perhaps?) is issuing leases on a different network range, can you confirm the ip address of your unraid server is in the range 192.168.1.0/24

Was there an update recently?

It seems to be working properly again and I haven't changed anything.

Share this post


Link to post
9 minutes ago, BF90X said:

Was there an update recently?

It seems to be working properly again and I haven't changed anything.

last update was july 10th.

Share this post


Link to post

Summary: Fetching NZB from URL works only with internal docker container IP, not with real host IP

 

Description:

 

Some content management application M only send references to NZBs to the downloader as an URL so that the NZB must be fetched by the downloader itself.

 

Imagine that the NZB URL points to NZBhydra2 as meta indexer X running in a docker container A on the same host H where SABnzb is also running in a docker container B. As a result M (running in docker container C on H) wants SABnzb in B to fetch the NZB from X in A.

The containers A, B, C run in their vanilla setting as downloaded (Bridge mode), just the pathes were set properly.

Container A is the linuxserver container with NZBhydra2.

Container B is the binhex container with SABnzbd, OpenVPN and Privoxy.

 

Observation: Depending on how X (NZBhydra2) is referenced in the URL, SABnzbd will be able to fetch the NZB or it will time out, and this can be verify using curl in the container terminal session

What works:

(1) internal IP of container A running NZBhydra / curl 172.17.0.x:5076 works

 

What does not work

(2) external IP of container A running NZBhydra, i.e. real IP of host H / curl "local IP":5076 -> connection refused

(3) local DNS name of H / curl "local dns name":5076 -> Could not resolve host

 

Thoughts:

 

(1) should NOT work, since this IP may change and applications external to the container should always use the real IP address or DNS name of H, could be that OpenVPN treats the container-internal IPs as on the same network and not to be forwarded through the VPN tunnel?

(2) should actually work, could this have to do with OpenVPN, sending traffic for IP of H through the VPN tunnel and nothing answering there? Why would it consider its won hosts real IP address to be on the internet and not on the own end of the tunnel?

(3) reason: if using the binhex SABnzbd-VPN container, within the container local DNS names cannot be resolved because all DNS traffic is sent to the DNS server on the other end of the VPN tunnel

 

My questions (decreasing priority):

-How can I make (3) work? probably some proper setting for OpenVPN for name resolution? which?

-Why does (2) not work and how can I make (2) work?

-Why does (1) work and how can I prevent container-external processes to access container-internal IPs?

 

Thank you for your tme and effort!

 

Edited by b0m541
additional details

Share this post


Link to post

Sabnzbvpn is no longer loading for me. It stops at the following:

dos2unix: converting file /config/openvpn/Switzerland.ovpn to Unix format...

 

Share this post


Link to post

Need help. I am new to unraid and want to setup my vpn info but lost on how. I am using vyprvpn service.

I have

VPN_ENABLED = yes

VPN_USER = ***** (My VPN login Name)

VPN_PASS = ***** (My VPN login Pass)

VPN_PROV = custom (Since its not PIA or AirVPN)

VPN_OPTIONS = blank

 

I have put my ovpn file into the openvpn folder it created.

 

But when I try and connect to the GUI it never works, but if I disable the VPN it does. how can/ where can I pull a log.

Edited by almulder

Share this post


Link to post
Need help. I am new to unraid and want to setup my vpn info but lost on how. I am using vyprvpn service.
I have
VPN_ENABLED = yes
VPN_USER = ***** (My VPN login Name)
VPN_PASS = ***** (My VPN login Pass)
VPN_PROV = custom (Since its not PIA or AirVPN)
VPN_OPTIONS = blank
 
I have put my ovpn file into the openvpn folder it created.
 
But when I try and connect to the GUI it never works, but if I disable the VPN it does. how can/ where can I pull a log.
Follow the guide here:-
https://github.com/binhex/documentation/blob/master/docker/guides/vpn.md

Sent from my CLT-L09 using Tapatalk

Share this post


Link to post

Could not make it work, so I decided to just sign up to PIA and use it since it seems more geared toward that, and now it works. Thanks.

Share this post


Link to post

First, as always Binhex, thank you for doing this for us!

 

I've been beating my head against the wall. So any help would be greatly appreciated.

The moment i disable the VPN, it starts working... but then again... no VPN :(

I have swapped my network to a full unifi network, but that shouldnt be the cause : 

I am able to connect to the VPN but unable to load up the GUI for sabnzb. Attached is my debug enabled log : 

 

https://pastebin.com/i9JrSE5Y

Edited by denellum

Share this post


Link to post
24 minutes ago, denellum said:

First, as always Binhex, thank you for doing this for us!

 

I've been beating my head against the wall. So any help would be greatly appreciated.

The moment i disable the VPN, it starts working... but then again... no VPN :(

I have swapped my network to a full unifi network, but that shouldnt be the cause : 

I am able to connect to the VPN but unable to load up the GUI for sabnzb. Attached is my debug enabled log : 

 

https://pastebin.com/i9JrSE5Y

nothing obviously wrong there, you sure this is correct?:-

 

2019-10-11 10:20:04.904522 [info] LAN_NETWORK defined as '10.10.40.0/24'

 

what is your servers ip address and subnet mask?

Share this post


Link to post
3 minutes ago, binhex said:

nothing obviously wrong there, you sure this is correct?:-

 

2019-10-11 10:20:04.904522 [info] LAN_NETWORK defined as '10.10.40.0/24'

 

what is your servers ip address and subnet mask?

Yes sir, i have my network well segmented :)

The server is 10.10.40.40/24

Share this post


Link to post
3 minutes ago, denellum said:

Yes sir, i have my network well segmented :)

The server is 10.10.40.40/24

and the pc you are attempting to connect to the web ui, is that also on 10.10.40.0/24?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.