[Support] binhex - SABnzbdVPN


Recommended Posts

Hi, about when the new version came out SABnzbd seems to have stopped working. Now its probably something obvious, but nothing seems wrong when I look though the config and the logs. 

 

Sonarr / Radarr etc all work fine as does testing connections to providers from within SAB. Any ideas?

 


Created by...
___. .__ .__
\_ |__ |__| ____ | |__ ____ ___ ___
| __ \| |/ \| | \_/ __ \\ \/ /
| \_\ \ | | \ Y \ ___/ > <
|___ /__|___| /___| /\___ >__/\_ \
\/ \/ \/ \/ \/
https://hub.docker.com/u/binhex/

2021-03-01 18:02:13.872311 [info] System information Linux 73a08c34798d 4.19.107-Unraid #1 SMP Sun Mar 8 14:34:03 CDT 2020 x86_64 GNU/Linux
2021-03-01 18:02:13.892462 [info] OS_ARCH defined as 'x86-64'
2021-03-01 18:02:13.911421 [info] PUID defined as '99'
2021-03-01 18:02:13.970760 [info] PGID defined as '100'
2021-03-01 18:02:14.061308 [info] UMASK defined as '000'
2021-03-01 18:02:14.078498 [info] Permissions already set for volume mappings
2021-03-01 18:02:14.100600 [info] Deleting files in /tmp (non recursive)...
2021-03-01 18:02:14.123907 [info] VPN_ENABLED defined as 'yes'
2021-03-01 18:02:14.142979 [warn] VPN_CLIENT not defined (via -e VPN_CLIENT), defaulting to 'openvpn'
2021-03-01 18:02:14.161050 [info] VPN_PROV defined as 'airvpn'
2021-03-01 18:02:14.184420 [info] OpenVPN config file (ovpn extension) is located at /config/openvpn/AirVPN_Europe_UDP-443.ovpn
2021-03-01 18:02:14.225932 [info] VPN remote server(s) defined as 'europe.vpn.airdns.org,'
2021-03-01 18:02:14.242115 [info] VPN remote port(s) defined as '443,'
2021-03-01 18:02:14.258494 [info] VPN remote protcol(s) defined as 'udp,'
2021-03-01 18:02:14.278899 [info] VPN_DEVICE_TYPE defined as 'tun0'
2021-03-01 18:02:14.298075 [info] VPN_OPTIONS not defined (via -e VPN_OPTIONS)
2021-03-01 18:02:14.315910 [info] LAN_NETWORK defined as '192.168.100.0/24'
2021-03-01 18:02:14.333265 [info] NAME_SERVERS defined as '209.222.18.222,84.200.69.80,37.235.1.174,1.1.1.1,209.222.18.218,37.235.1.177,84.200.70.40,1.0.0.1'
2021-03-01 18:02:14.351240 [info] ENABLE_PRIVOXY defined as 'yes'
2021-03-01 18:02:14.369217 [info] ADDITIONAL_PORTS defined as '8989,9897,5076,7878,8686,5299'
2021-03-01 18:02:14.394946 [info] Starting Supervisor...
2021-03-01 18:02:14,529 INFO Included extra file "/etc/supervisor/conf.d/sabnzbdvpn.conf" during parsing
2021-03-01 18:02:14,529 INFO Set uid to user 0 succeeded
2021-03-01 18:02:14,531 INFO supervisord started with pid 6
2021-03-01 18:02:15,533 INFO spawned: 'shutdown-script' with pid 151
2021-03-01 18:02:15,534 INFO spawned: 'start-script' with pid 152
2021-03-01 18:02:15,535 INFO spawned: 'watchdog-script' with pid 153
2021-03-01 18:02:15,535 INFO reaped unknown pid 7 (exit status 0)
2021-03-01 18:02:15,539 DEBG 'start-script' stdout output:
[info] VPN is enabled, beginning configuration of VPN

2021-03-01 18:02:15,539 INFO success: shutdown-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-03-01 18:02:15,539 INFO success: start-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-03-01 18:02:15,539 INFO success: watchdog-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-03-01 18:02:15,596 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.222 to /etc/resolv.conf

2021-03-01 18:02:15,599 DEBG 'start-script' stdout output:
[info] Adding 84.200.69.80 to /etc/resolv.conf

2021-03-01 18:02:15,602 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.174 to /etc/resolv.conf

2021-03-01 18:02:15,605 DEBG 'start-script' stdout output:
[info] Adding 1.1.1.1 to /etc/resolv.conf

2021-03-01 18:02:15,608 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.218 to /etc/resolv.conf

2021-03-01 18:02:15,612 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.177 to /etc/resolv.conf

2021-03-01 18:02:15,614 DEBG 'start-script' stdout output:
[info] Adding 84.200.70.40 to /etc/resolv.conf

2021-03-01 18:02:15,618 DEBG 'start-script' stdout output:
[info] Adding 1.0.0.1 to /etc/resolv.conf

2021-03-01 18:02:18,512 DEBG 'start-script' stdout output:
[info] Default route for container is 172.17.0.1

2021-03-01 18:02:18,523 DEBG 'start-script' stdout output:
[info] Docker network defined as 172.17.0.0/16

2021-03-01 18:02:18,525 DEBG 'start-script' stdout output:
[info] Adding 192.168.100.0/24 as route via docker eth0

2021-03-01 18:02:18,526 DEBG 'start-script' stdout output:
[info] ip route defined as follows...

2021-03-01 18:02:18,526 DEBG 'start-script' stdout output:
--------------------

2021-03-01 18:02:18,526 DEBG 'start-script' stdout output:
default via 172.17.0.1 dev eth0
172.17.0.0/16 dev eth0 proto kernel scope link src 172.17.0.12
192.168.100.0/24 via 172.17.0.1 dev eth0

2021-03-01 18:02:18,526 DEBG 'start-script' stdout output:
broadcast 127.0.0.0 dev lo table local proto kernel scope link src 127.0.0.1
local 127.0.0.0/8 dev lo table local proto kernel scope host src 127.0.0.1
local 127.0.0.1 dev lo table local proto kernel scope host src 127.0.0.1
broadcast 127.255.255.255 dev lo table local proto kernel scope link src 127.0.0.1
broadcast 172.17.0.0 dev eth0 table local proto kernel scope link src 172.17.0.12
local 172.17.0.12 dev eth0 table local proto kernel scope host src 172.17.0.12
broadcast 172.17.255.255 dev eth0 table local proto kernel scope link src 172.17.0.12

2021-03-01 18:02:18,526 DEBG 'start-script' stdout output:
--------------------

2021-03-01 18:02:18,529 DEBG 'start-script' stdout output:
iptable_mangle 16384 2
ip_tables 24576 5 iptable_filter,iptable_nat,iptable_mangle

2021-03-01 18:02:18,529 DEBG 'start-script' stdout output:
[info] iptable_mangle support detected, adding fwmark for tables

2021-03-01 18:02:18,611 DEBG 'start-script' stdout output:
[info] iptables defined as follows...
--------------------

2021-03-01 18:02:18,613 DEBG 'start-script' stdout output:
-P INPUT DROP
-P FORWARD DROP
-P OUTPUT DROP
-A INPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT
-A INPUT -s 213.152.161.137/32 -i eth0 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 8080 -j ACCEPT
-A INPUT -i eth0 -p udp -m udp --dport 8080 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 8090 -j ACCEPT
-A INPUT -i eth0 -p udp -m udp --dport 8090 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 8989 -j ACCEPT
-A INPUT -i eth0 -p udp -m udp --dport 8989 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 9897 -j ACCEPT
-A INPUT -i eth0 -p udp -m udp --dport 9897 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 5076 -j ACCEPT
-A INPUT -i eth0 -p udp -m udp --dport 5076 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 7878 -j ACCEPT
-A INPUT -i eth0 -p udp -m udp --dport 7878 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 8686 -j ACCEPT
-A INPUT -i eth0 -p udp -m udp --dport 8686 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 5299 -j ACCEPT
-A INPUT -i eth0 -p udp -m udp --dport 5299 -j ACCEPT
-A INPUT -s 192.168.100.0/24 -i eth0 -p tcp -m tcp --dport 8118 -j ACCEPT
-A INPUT -p icmp -m icmp --icmp-type 0 -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -i tun0 -j ACCEPT
-A OUTPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT
-A OUTPUT -d 213.152.161.137/32 -o eth0 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 8080 -j ACCEPT
-A OUTPUT -o eth0 -p udp -m udp --sport 8080 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 8090 -j ACCEPT
-A OUTPUT -o eth0 -p udp -m udp --sport 8090 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 8989 -j ACCEPT
-A OUTPUT -o eth0 -p udp -m udp --sport 8989 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 9897 -j ACCEPT
-A OUTPUT -o eth0 -p udp -m udp --sport 9897 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 5076 -j ACCEPT
-A OUTPUT -o eth0 -p udp -m udp --sport 5076 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 7878 -j ACCEPT
-A OUTPUT -o eth0 -p udp -m udp --sport 7878 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 8686 -j ACCEPT
-A OUTPUT -o eth0 -p udp -m udp --sport 8686 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 5299 -j ACCEPT
-A OUTPUT -o eth0 -p udp -m udp --sport 5299 -j ACCEPT
-A OUTPUT -d 192.168.100.0/24 -o eth0 -p tcp -m tcp --sport 8118 -j ACCEPT
-A OUTPUT -p icmp -m icmp --icmp-type 8 -j ACCEPT
-A OUTPUT -o lo -j ACCEPT
-A OUTPUT -o tun0 -j ACCEPT

2021-03-01 18:02:18,613 DEBG 'start-script' stdout output:
--------------------

2021-03-01 18:02:18,614 DEBG 'start-script' stdout output:
[info] Starting OpenVPN (non daemonised)...

2021-03-01 18:02:18,633 DEBG 'start-script' stdout output:
2021-03-01 18:02:18 DEPRECATED OPTION: --cipher set to 'AES-256-CBC' but missing in --data-ciphers (AES-256-GCM:AES-128-GCM). Future OpenVPN version will ignore --cipher for cipher negotiations. Add 'AES-256-CBC' to --data-ciphers or change --cipher 'AES-256-CBC' to --data-ciphers-fallback 'AES-256-CBC' to silence this warning.


2021-03-01 18:02:18,633 DEBG 'start-script' stdout output:
2021-03-01 18:02:18 WARNING: file 'credentials.conf' is group or others accessible

2021-03-01 18:02:18 OpenVPN 2.5.1 [git:makepkg/f186691b32e68362+] x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Feb 24 2021
2021-03-01 18:02:18 library versions: OpenSSL 1.1.1j 16 Feb 2021, LZO 2.10

2021-03-01 18:02:18,634 DEBG 'start-script' stdout output:
2021-03-01 18:02:18 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

2021-03-01 18:02:18,634 DEBG 'start-script' stdout output:
2021-03-01 18:02:18 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
2021-03-01 18:02:18 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication

2021-03-01 18:02:18,634 DEBG 'start-script' stdout output:
2021-03-01 18:02:18 TCP/UDP: Preserving recently used remote address: [AF_INET]213.152.161.137:443
2021-03-01 18:02:18 Socket Buffers: R=[212992->212992] S=[212992->212992]
2021-03-01 18:02:18 UDP link local: (not bound)
2021-03-01 18:02:18 UDP link remote: [AF_INET]213.152.161.137:443

2021-03-01 18:02:18,651 DEBG 'start-script' stdout output:
2021-03-01 18:02:18 TLS: Initial packet from [AF_INET]213.152.161.137:443, sid=da75fdc4 19433f2d

2021-03-01 18:02:18,651 DEBG 'start-script' stdout output:
2021-03-01 18:02:18 net_route_v4_best_gw query: dst 0.0.0.0
2021-03-01 18:02:18 net_route_v4_best_gw result: via 172.17.0.1 dev eth0

2021-03-01 18:02:18,679 DEBG 'start-script' stdout output:
2021-03-01 18:02:18 VERIFY OK: depth=1, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=airvpn.org CA, emailAddress=info@airvpn.org

2021-03-01 18:02:18,679 DEBG 'start-script' stdout output:
2021-03-01 18:02:18 VERIFY KU OK
2021-03-01 18:02:18 Validating certificate extended key usage
2021-03-01 18:02:18 ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
2021-03-01 18:02:18 VERIFY EKU OK
2021-03-01 18:02:18 VERIFY OK: depth=0, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=Talitha, emailAddress=info@airvpn.org

2021-03-01 18:02:18,703 DEBG 'start-script' stdout output:
2021-03-01 18:02:18 Control Channel: TLSv1.3, cipher TLSv1.3 TLS_CHACHA20_POLY1305_SHA256, 4096 bit RSA
2021-03-01 18:02:18 [Talitha] Peer Connection Initiated with [AF_INET]213.152.161.137:443

2021-03-01 18:02:18,852 DEBG 'start-script' stdout output:
2021-03-01 18:02:18 PUSH: Received control message: 'PUSH_REPLY,comp-lzo no,redirect-gateway ipv6 def1 bypass-dhcp,dhcp-option DNS 10.31.4.1,dhcp-option DNS6 fde6:7a:7d20:1b04::1,tun-ipv6,route-gateway 10.31.4.1,topology subnet,ping 10,ping-restart 60,ifconfig-ipv6 fde6:7a:7d20:1b04::1027/64 fde6:7a:7d20:1b04::1,ifconfig 10.31.4.41 255.255.255.0,peer-id 5,cipher AES-256-GCM'

2021-03-01 18:02:18,852 DEBG 'start-script' stdout output:
2021-03-01 18:02:18 Pushed option removed by filter: 'dhcp-option DNS6 fde6:7a:7d20:1b04::1'
2021-03-01 18:02:18 Pushed option removed by filter: 'tun-ipv6'
2021-03-01 18:02:18 Pushed option removed by filter: 'ifconfig-ipv6 fde6:7a:7d20:1b04::1027/64 fde6:7a:7d20:1b04::1'
2021-03-01 18:02:18 OPTIONS IMPORT: timers and/or timeouts modified
2021-03-01 18:02:18 OPTIONS IMPORT: compression parms modified
2021-03-01 18:02:18 OPTIONS IMPORT: --ifconfig/up options modified
2021-03-01 18:02:18 OPTIONS IMPORT: route options modified
2021-03-01 18:02:18 OPTIONS IMPORT: route-related options modified
2021-03-01 18:02:18 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
2021-03-01 18:02:18 OPTIONS IMPORT: peer-id set
2021-03-01 18:02:18 OPTIONS IMPORT: adjusting link_mtu to 1625
2021-03-01 18:02:18 OPTIONS IMPORT: data channel crypto options modified
2021-03-01 18:02:18 Data Channel: using negotiated cipher 'AES-256-GCM'
2021-03-01 18:02:18 Outgoing Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
2021-03-01 18:02:18 Incoming Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
2021-03-01 18:02:18 net_route_v4_best_gw query: dst 0.0.0.0
2021-03-01 18:02:18 net_route_v4_best_gw result: via 172.17.0.1 dev eth0
2021-03-01 18:02:18 ROUTE_GATEWAY 172.17.0.1/255.255.0.0 IFACE=eth0 HWADDR=02:42:ac:11:00:0c

2021-03-01 18:02:18,852 DEBG 'start-script' stdout output:
2021-03-01 18:02:18 GDG6: remote_host_ipv6=n/a
2021-03-01 18:02:18 net_route_v6_best_gw query: dst ::
2021-03-01 18:02:18 sitnl_send: rtnl: generic error (-101): Network is unreachable

2021-03-01 18:02:18 ROUTE6: default_gateway=UNDEF

2021-03-01 18:02:18,852 DEBG 'start-script' stdout output:
2021-03-01 18:02:18 TUN/TAP device tun0 opened
2021-03-01 18:02:18 net_iface_mtu_set: mtu 1500 for tun0
2021-03-01 18:02:18 net_iface_up: set tun0 up
2021-03-01 18:02:18 net_addr_v4_add: 10.31.4.41/24 dev tun0
2021-03-01 18:02:18 /root/openvpnup.sh tun0 1500 1553 10.31.4.41 255.255.255.0 init

2021-03-01 18:02:23,896 DEBG 'start-script' stdout output:
2021-03-01 18:02:23 net_route_v4_add: 213.152.161.137/32 via 172.17.0.1 dev [NULL] table 0 metric -1

2021-03-01 18:02:23,897 DEBG 'start-script' stdout output:
2021-03-01 18:02:23 net_route_v4_add: 0.0.0.0/1 via 10.31.4.1 dev [NULL] table 0 metric -1
2021-03-01 18:02:23 net_route_v4_add: 128.0.0.0/1 via 10.31.4.1 dev [NULL] table 0 metric -1
2021-03-01 18:02:23 WARNING: OpenVPN was configured to add an IPv6 route. However, no IPv6 has been configured for tun0, therefore the route installation may fail or may not work as expected.

2021-03-01 18:02:23 add_route_ipv6(::/3 -> :: metric -1) dev tun0
2021-03-01 18:02:23 net_route_v6_add: ::/3 via :: dev tun0 table 0 metric -1
2021-03-01 18:02:23 sitnl_send: rtnl: generic error (-13): Permission denied

2021-03-01 18:02:23 ERROR: Linux IPv6 route can't be added

2021-03-01 18:02:23 add_route_ipv6(2000::/4 -> :: metric -1) dev tun0
2021-03-01 18:02:23 net_route_v6_add: 2000::/4 via :: dev tun0 table 0 metric -1
2021-03-01 18:02:23 sitnl_send: rtnl: generic error (-13): Permission denied

2021-03-01 18:02:23 ERROR: Linux IPv6 route can't be added

2021-03-01 18:02:23 add_route_ipv6(3000::/4 -> :: metric -1) dev tun0
2021-03-01 18:02:23 net_route_v6_add: 3000::/4 via :: dev tun0 table 0 metric -1
2021-03-01 18:02:23 sitnl_send: rtnl: generic error (-13): Permission denied

2021-03-01 18:02:23 ERROR: Linux IPv6 route can't be added

2021-03-01 18:02:23 add_route_ipv6(fc00::/7 -> :: metric -1) dev tun0
2021-03-01 18:02:23 net_route_v6_add: fc00::/7 via :: dev tun0 table 0 metric -1
2021-03-01 18:02:23 sitnl_send: rtnl: generic error (-13): Permission denied

2021-03-01 18:02:23 ERROR: Linux IPv6 route can't be added

2021-03-01 18:02:23 Initialization Sequence Completed

2021-03-01 18:02:24,898 DEBG 'start-script' stdout output:
[info] Application does not require external IP address, skipping external IP address detection

2021-03-01 18:02:24,902 DEBG 'start-script' stdout output:
[info] Application does not require port forwarding or VPN provider is != pia, skipping incoming port assignment

2021-03-01 18:02:24,980 DEBG 'watchdog-script' stdout output:
[info] SABnzbd not running

2021-03-01 18:02:24,984 DEBG 'watchdog-script' stdout output:
[info] Privoxy not running

2021-03-01 18:02:24,984 DEBG 'watchdog-script' stdout output:
[info] Attempting to start SABnzbd...

2021-03-01 18:02:25,584 DEBG 'watchdog-script' stdout output:
[info] SABnzbd process started
[info] Waiting for SABnzbd process to start listening on port 8080...

2021-03-01 18:02:25,692 DEBG 'watchdog-script' stdout output:
[info] SABnzbd process is listening on port 8080

2021-03-01 18:02:25,693 DEBG 'watchdog-script' stdout output:
[info] Attempting to start Privoxy...

2021-03-01 18:02:26,699 DEBG 'watchdog-script' stdout output:
[info] Privoxy process started
[info] Waiting for Privoxy process to start listening on port 8118...

2021-03-01 18:02:26,702 DEBG 'watchdog-script' stdout output:
[info] Privoxy process listening on port 8118

 

Screenshot 2021-03-01 at 18.03.48.png

Screenshot 2021-03-01 at 18.04.09.png

Screenshot 2021-03-01 at 18.04.37.png

Link to comment

What are people doing when running multiple instances of a docker?

 

I have 2 Radarrs. One for 4k, to automatically keep the library separate. But the only way I could get it running through Privoxy was to run Radarr through SABNZ and Radarr-4k through Deluge. 

 

After fixing this up as per Q24 to Q26 in the FAQ. All is working except the Radarr going through SABNZ can't see Deluge and the Radarr-4k going through Deluge can't see SABNZ.

 

The reason they were setup going through different Privoxys was even when I assign a different port number for Radarr-4k, it still didn't want to load. Maybe I need to go back and revisit that?

 

image.png.0914d22ed976f0ff6b7667da7013a36b.png

image.png.722ff5fd23f887f0f23d5722444026ad.png

 

But on my Docker page it looks like this;

image.png.765c1f8d8407d5f232d8f88706214a51.png

I'm not sure why port mapping still says 7878 and not 17878 as I have set in the docker and in Radarr-4k.

 

Hopefully others who have multiple docker instances too can help.

Clearly I'm not doing something properly.

Cheers

Link to comment

So I fixed my Sab problem. Something got corrupted in the upgrade which meant the downloader was continually crashing. Deleted the image, removed the container etc and re downloaded and without changing any settings it seems to be working as intended. 
 

On a separate note, it’s is possible to change the proxy port on the VPN container from  8118 to say 8119? Is it as simple and just changing the mapping when editing the container?

Link to comment
2 minutes ago, stridemat said:

it’s is possible to change the proxy port on the VPN container from  8118 to say 8119?

yes simple enough, the golden rule is ONLY change the host side though, never change the container port as its hard set, but the host port can be whatever you want, as long as its not already in use.

Link to comment
33 minutes ago, binhex said:

yes simple enough, the golden rule is ONLY change the host side though, never change the container port as its hard set, but the host port can be whatever you want, as long as its not already in use.

Thanks. I think I may also have ballsed that up. 
 

The container port is greyed out. It reads 8119  when the value it should be is 8118. I guess it a case of recreating the entry again then removing this one? 

13457273-E171-46DA-AD4D-1A99AD48B564.png

Link to comment
1 minute ago, stridemat said:

The container port is greyed out. It reads 8119  when the value it should be is 8118. I guess it a case of recreating the entry again then removing this one? 

yep delete the stuffed up port, add port and re-define it with the correct port numbers

Link to comment

Hi, I have the following problem since the last two updates of the container.

The script NzbtoMedia shows me after the download an error message:

[ERROR]::SERVER: Server failed to respond at http://server-ip:8081
[ERROR]::SICKBEARD: Server did not respond. Exiting

The required port 8081 was entered under ADDITIONAL_PORTS when creating the container.

The Sickchill container is not routed through the SabnzbdVPN container.

If you need more log files, I will be glad to send them to you.

I hope someone can help me to solve my problem.

 

UPDATE:  I have exchanged the server ip against the docker ip and now everything works again.

Edited by king79
Link to comment

Hi All

 

Anyone else has issues with sabnzbdvpn? Both Radarr and Sonarr are reporting they can't connect. Checking the sabnzbdvpn log file, nothing is jumping out at me, all seems fine. I even forced a re-download of sabnzbdvpn with the same result. It worked on Sunday but stopped working yesterday.

Edited by IrishBiker
speeling
Link to comment
20 minutes ago, IrishBiker said:

Hi All

 

Anyone else has issues with sabnzbdvpn? Both Radarr and Sonarr are reporting they can't connect. Checking the sabnzbdvpn log file, nothing is jumping out at me, all seems fine. I even forced a re-download of sabnzbdvpn with the same result. It worked on Sunday but stopped working yesterday.

 

Sonarr reports the following:

 

HTTP Error - Res: [GET] http://not.telling.you:8080/api?mode=queue&start=0&limit=0&apikey=(removed)&output=json: 503.ServiceUnavailable

 

however running

 

http://not.telling.you:8080/api?mode=get_config&apikey=_specialkey_&output=json

 

displays the usual json enteriesjson.png.09a2a8b998dc3f4894448610e5247e47.png

Link to comment
49 minutes ago, IrishBiker said:

Hi All

 

Anyone else has issues with sabnzbdvpn? Both Radarr and Sonarr are reporting they can't connect. Checking the sabnzbdvpn log file, nothing is jumping out at me, all seems fine. I even forced a re-download of sabnzbdvpn with the same result. It worked on Sunday but stopped working yesterday.

i ended up following another post in here about this and excluded my local server address in the General settings of both Radarr and Sonarr. Once i did that i was able to talk to SAB from Radarr and Sonarr

  • Thanks 1
Link to comment
40 minutes ago, 08deanr said:

i ended up following another post in here about this and excluded my local server address in the General settings of both Radarr and Sonarr. Once i did that i was able to talk to SAB from Radarr and Sonarr

I added my local server to the "Addresses for the proxy to ignore" but made no difference. Also my "Bypass Proxy for Local Addresses" was already enabled.

 

UPDATE, I take it back, its seems to be working, its a case of WTF???

Edited by IrishBiker
WTF???
Link to comment
4 hours ago, 08deanr said:

i ended up following another post in here about this and excluded my local server address in the General settings of both Radarr and Sonarr. Once i did that i was able to talk to SAB from Radarr and Sonarr

Can you give a link to the post that has the solution.  I have the same problem and am getting nowhere.

Link to comment

Ok, one last thing. Is there something special I need to do to make radarr/sonarr to talk to binhex-delugevpn, when radarr/sonarr are going through binhex-sabnzbdvpn?

 

I keep getting;

 

image.png.863c34ec632ec927caf332fa8330d717.png

 

Other then that, all containers are running and I can connect to them all. All indexers are working.

Just can't connected to Deluge in radarr/sonarr.

 

Edit: And connecting to SABNZ is all good too.

 

Edit2: I guess I could download the normal Deluge docker and route that through SABNZ. Then I could just use localhost like I did for Sonarr/Radarr connecting to SABNZ.

 

Edit3: I tried various combos for Host; Server IP, localhost. But oddly putting in the Docker IP works;

image.png.0f5cb436d17392d8f5514441d1186061.png

Edited by cappapp
Link to comment

Hello binhex!,

 

I don't believe in free free tech support, so I sent you a donation for a few coffees. 

Here's my problem. 

 

binhex-sabnzbdvpn version: 3.2.0 [7be9281]

 

I previously installed your sabvpn docker a few days ago and everything went fine and my PIA vpn was staying connected.  While fiddling with privoxy (unsuccessfully), I reinstalled the docker a few times, following the normal procedure (remove docker> delete template> delete binhex-sabnzbdvpn folder in appdata).  The problem now is that the "Public IPv4 address" and "Nameserver / DNS Lookup" (in the status view) are randomly giving me "Connection failed!".  They do this independently and together at times when refreshing the status.  My download speed goes from 32MB/s down to almost zero then back up.  Any help would be appreciated!

 

I can add my logs.  Just not sure which ones to add

 

Here's the only thing that stuck out at me, but this might be normal.  Thanks

 

UPDATE: The issue seems to have resolved itself. Status has been stable for around 5 hours. I'm assuming it was either a finicky DNS or an issue with PIA. 

 

 

2021-03-02 22:11:59,062 DEBG 'start-script' stdout output:
[info] Application does not require external IP address, skipping external IP address detection

2021-03-02 22:11:59,063 DEBG 'start-script' stdout output:
[info] Application does not require port forwarding or VPN provider is != pia, skipping incoming port assignment

2021-03-02 22:11:59,062 DEBG 'start-script' stdout output:
[info] Application does not require external IP address, skipping external IP address detection

2021-03-02 22:11:59,063 DEBG 'start-script' stdout output:
[info] Application does not require port forwarding or VPN provider is != pia, skipping incoming port assignment

 

 

Edited by cjohnson46
Link to comment

Get the following every time I start SABnzbdvpn with wireguard. Container will start up with no internet access.

 

2021-03-03 18:39:49,441 DEBG 'start-script' stderr output:
[#] ip link add wg0 type wireguard

2021-03-03 18:39:49,444 DEBG 'start-script' stderr output:
[#] wg setconf wg0 /dev/fd/63

2021-03-03 18:39:49,469 DEBG 'start-script' stderr output:
[#] ip -4 address add 10.41.151.89 dev wg0

2021-03-03 18:39:49,479 DEBG 'start-script' stderr output:
[#] ip link set mtu 8920 up dev wg0

2021-03-03 18:39:49,500 DEBG 'start-script' stderr output:
[#] ip -4 route add 10.0.0.0/8 dev wg0

2021-03-03 18:39:49,501 DEBG 'start-script' stderr output:
[#] '/root/wireguardup.sh'

2021-03-03 18:40:45,435 DEBG 'watchdog-script' stdout output:
[info] DNS failure, creating file '/tmp/dnsfailure' to indicate failure...

2021-03-03 18:40:45,435 DEBG 'watchdog-script' stdout output:
[info] DNS failure, creating file '/tmp/dnsfailure' to indicate failure...

2021-03-03 18:40:45,604 DEBG 'start-script' stdout output:
[info] DNS failure, creating file '/tmp/dnsfailure' to indicate failure...

2021-03-03 18:40:45,606 DEBG 'start-script' stdout output:
[info] Application does not require external IP address, skipping external IP address detection

2021-03-03 18:40:45,608 DEBG 'start-script' stdout output:
[info] Application does not require port forwarding or VPN provider is != pia, skipping incoming port assignment

2021-03-03 18:40:45,609 DEBG 'start-script' stdout output:
[info] WireGuard interface 'up'

 Any help would be appreciated.

  • Like 1
Link to comment

There is a bug in the parsing of the nslookup for the vpn server remote IP. If the DNS response contains IP addresses of the root dns servers in addition to the A records for the vpn server, then the root server IPs will also be added as remote vpn server IPs and tried to connect to using openvpn. This is clearly not desirable.

 

Link to comment
On 3/2/2021 at 6:50 PM, JoeUnraidUser said:

Can you give a link to the post that has the solution.  I have the same problem and am getting nowhere.

I think they are referring to the same thing that I did and it got it back up and running for me. Go to radarr/sonarr settings > general > proxy and add your server IP into the "Ignored Addresses" section. Radarr and sonarr IPs indicate they are no longer routing through sab vpn though. However, I think that activity is still being funneled through vpn for activity outside the network. Would love for someone with a better understanding to clarify.

Edited by redpill85
Link to comment
There is a bug in the parsing of the nslookup for the vpn server remote IP. If the DNS response contains IP addresses of the root dns servers in addition to the A records for the vpn server, then the root server IPs will also be added as remote vpn server IPs and tried to connect to using openvpn. This is clearly not desirable.
 
I would love to see a log demonstrating this bug as I'm not aware of it, please attach the log if you can.

Sent from my CLT-L09 using Tapatalk

Link to comment

so when i have a custom IP in BR0 with VPN enabled i cannot access the GUI. if i disable the VPN, i am able to access the GUI. if i use bridge mode i can access the gui but i now have a need to change it to a unique IP address. i've also tried the below commands but it made no change. any advice? whatcha need from me?

 

 

echo "# force iptable mangle module to load (required for *vpn dockers)" >> /boot/config/go echo "/sbin/modprobe iptable_mangle" >> /boot/config/go  and reboot

Link to comment

hi.

 

Can someone provide what the settings should be in the binhex-sabnzbdvpn docker container in Unraid when using Nord VPN as the vpn provider?

 

I have tried a few different things and can't seem to get it to work.

 

Anyone done this before?

 

Your help is much appreciated.

Link to comment

Well, I thought this was fixed, but it seems to keep happening over and over.  Any ideas would be great!

 

VVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVV

 

Hello binhex!,

 

I don't believe in free free tech support, so I sent you a donation for a few coffees. 

Here's my problem. 

 

binhex-sabnzbdvpn version: 3.2.0 [7be9281]

 

I previously installed you sabvpn docker a few days ago and everything went fine and my PIA vpn was staying connected.  While fiddling with privoxy (unsuccessfully), I reinstalled the docker a few times, following the normal procedure (remove docker> delete template> delete binhex-sabnzbdvpn folder in appdata).  The problem now is that the "Public IPv4 address" and "Nameserver / DNS Lookup" (in the status view) are randomly giving me "Connection failed!".  They do this independently and together at times when refreshing the status.  My download speed goes from 32MB/s down to almost zero then back up.  Any help would be appreciated!

 

I can add my logs.  Just not sure which ones to add

 

Here's the only thing that stuck out at me, but this might be normal.  Thanks

 

2021-03-02 22:11:59,062 DEBG 'start-script' stdout output:
[info] Application does not require external IP address, skipping external IP address detection

2021-03-02 22:11:59,063 DEBG 'start-script' stdout output:
[info] Application does not require port forwarding or VPN provider is != pia, skipping incoming port assignment

2021-03-02 22:11:59,062 DEBG 'start-script' stdout output:
[info] Application does not require external IP address, skipping external IP address detection

2021-03-02 22:11:59,063 DEBG 'start-script' stdout output:
[info] Application does not require port forwarding or VPN provider is != pia, skipping incoming port assignment

 

1971301829_saberrors.png.7d4b16b3c3d49ffae463da1ed4c2cb45.png

 

Edited by cjohnson46
Added SAB Errors
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.