Jump to content
binhex

[Support] binhex - Plex

169 posts in this topic Last Reply

Recommended Posts

15 hours ago, JohnnyBlaze99 said:

Hey TomSerious...if you are still monitoring this thread... here is what i did to get it to work...

 

made sure in the container, that the AppData Config path, pointed to the /mnt/cache/appdata/binhex-plex. That seemed to resolve the issue for me..

 

Hey Johnny!

 

Thank you so much, that fixed it for me too!!

 

I already gave up on that topic and was using plex server on a VM xD

Share this post


Link to post

Just installed Binhex plex instance and have managed to get it up and running using the basic mounts but i'm really confused over how i add further containers. Is anyone able to explain or screenshot their docker image showing how their folders are mapped to the host? Might just make things easier to understand. Cheers ...

 

Sent from my LG-D855 using Tapatalk

 

 

 

Share this post


Link to post
32 minutes ago, superloopy1 said:

Just installed Binhex plex instance and have managed to get it up and running using the basic mounts but i'm really confused over how i add further containers. Is anyone able to explain or screenshot their docker image showing how their folders are mapped to the host? Might just make things easier to understand. Cheers ...

 

Sent from my LG-D855 using Tapatalk

 

 

 

 

I don't know if I'm a good example to follow.  Someone may-well pop up and tell me I have something incorrectly configured, BUT the setup shown, works smoothly for my docker trio- PLEX, Sonarr & NZBGet under 6.35.  The trick (for me) was to use dockers from the same author- makes life much simpler.

 

Dockers.png

Edited by johnny121b

Share this post


Link to post
 
I don't know if I'm a good example to follow.  Someone may-well pop up and tell me I have something incorrectly configured, BUT the setup shown, works smoothly for my docker trio- PLEX, Sonarr & NZBGet under 6.35.  The trick (for me) was to use dockers from the same author- makes life much simpler.
 
Dockers.thumb.png.6b173985e8b1d0b8aec3a67fef6252dc.png
Thanks for that.

How do you map the individual folders ie movies, tv, etc or dont you separate your media? I have the initial mappings working ok but obviously need to add more containers. How do oeople have additional folders mapped?

Sent from my LG-D855 using Tapatalk

Share this post


Link to post

My movies are largely in a single folder in my 'movie' share.  Some of the more important titles merit their own subdirectory (for special features mostly), but 99% of them are tossed into the movie share.  My TV shows are in my 'tv' share, but each series [does] have its own subdirectory.  I don't do season folders.  For me, that just added too much to the path length in the occasional series.  (Windows doesn't handle path lengths over 255-characters) 

 

When PLEX does its scanning, it doesn't care whether the movie is in \movie or in \movie\Raiders of the Lost Ark. 

Share this post


Link to post
My movies are largely in a single folder in my 'movie' share.  Some of the more important titles merit their own subdirectory (for special features mostly), but 99% of them are tossed into the movie share.  My TV shows are in my 'tv' share, but each series [does] have its own subdirectory.  I don't do season folders.  For me, that just added too much to the path length in the occasional series.  (Windows doesn't handle path lengths over 255-characters) 
 
When PLEX does its scanning, it doesn't care whether the movie is in \movie or in \movie\Raiders of the Lost Ark. 
Thanks. How is your tv folder mapped to its unraid directory? Have you added a second path to the docker image, which by default only comes with /media. Its these 'extra' paths that i cant seem to get right. Think i'll give emby another go.

Sent from my LG-D855 using Tapatalk

Share this post


Link to post
1 hour ago, superloopy1 said:

Thanks. How is your tv folder mapped to its unraid directory? Have you added a second path to the docker image, which by default only comes with /media. Its these 'extra' paths that i cant seem to get right. Think i'll give emby another go.

Sent from my LG-D855 using Tapatalk
 

I'll take some screenshots later today.  I'm about to head to work.  I understand your frustration.  The added layer of abstraction when dealing with dockers absolutely drove me crazy.. so-much-so, that when I finally got it running, I squirreled away screenshots of everything- because despite the fact that I had it running, I still didn't fully UNDERSTAND why it worked..so I knew I couldn't fix it when it broke.  (unfortunately for you, I'm not sure where those screenshots are at-the-moment, because it's been so long ago.) 

 

What are you working with besides PLEX?  NZBGet/Sabnzbd/? Sonarr/Sickbeard/?

Share this post


Link to post
2 hours ago, johnny121b said:

I'll take some screenshots later today.  I'm about to head to work.  I understand your frustration.  The added layer of abstraction when dealing with dockers absolutely drove me crazy.. so-much-so, that when I finally got it running, I squirreled away screenshots of everything- because despite the fact that I had it running, I still didn't fully UNDERSTAND why it worked..so I knew I couldn't fix it when it broke.  (unfortunately for you, I'm not sure where those screenshots are at-the-moment, because it's been so long ago.) 

 

What are you working with besides PLEX?  NZBGet/Sabnzbd/? Sonarr/Sickbeard/?

 

ok so the gnarly bit you need to wrap your heads around (this goes out to all newbie's not just you johnny121b :-) ) is that the location you set for downloads for your usenet and/or torrent clients MUST be consistent for ALL docker containers, so for instance assuming two containers (there could and probably will be more than two in reality), a downloader (sabnzbdvpn) and a metadata downloader (sonarr), here are some scenario's:-

 

BROKEN EXAMPLE 1.
 

sabnzbdvpn

/mnt/cache/appdata/data/completed is mapped to /data

 

sonarr

/mnt/cache/appdata/data is mapped to /data

 

Why is this broken? because although the container path (/data) is the same for both containers, the host path does NOT match

 

BROKEN EXAMPLE 2.
 

sabnzbdvpn

/mnt/cache/appdata/data/Completed is mapped to /data

 

sonarr

/mnt/cache/appdata/data/completed is mapped to /data

 

Why is this broken? because although the container path (/data) is the same for both containers, the host path does NOT match (linux is CaSe sensitive).

 

BROKEN EXAMPLE 3.
 

sabnzbdvpn

/mnt/cache/appdata/data/completed is mapped to /data

 

sonarr

/mnt/cache/appdata/data/completed is mapped to /downloads

 

Why is this broken? because although the host path is now ok, the container paths do NOT match.

 

WORKING EXAMPLE 1.
 

sabnzbdvpn

/mnt/cache/appdata/data/completed is mapped to /data

 

sonarr

/mnt/cache/appdata/data/completed is mapped to /data

 

Why is this working? because BOTH the container path (/data) and the host path (/mnt/cache/appdata/data/completed) EXACTLY match.

 

IMPORTANT - application configuration
 

Lastly keep in mind that when you configure sabnzbdvpn and sonarr (in this example) the paths again must match, so if you configure sabnzbdvpn to download to /data/usenet/ then you MUST also configure sonarr to use the same path, you CANNOT configure sonarr to use /data, this again would cause a mismatch of path, even if you have set the container path and the host path to be the same (as in the working example above).

 

I hope this helps somebody.

Edited by binhex

Share this post


Link to post
14 hours ago, johnny121b said:

I'll take some screenshots later today.  I'm about to head to work.  I understand your frustration.  The added layer of abstraction when dealing with dockers absolutely drove me crazy.. so-much-so, that when I finally got it running, I squirreled away screenshots of everything- because despite the fact that I had it running, I still didn't fully UNDERSTAND why it worked..so I knew I couldn't fix it when it broke.  (unfortunately for you, I'm not sure where those screenshots are at-the-moment, because it's been so long ago.) 

 

What are you working with besides PLEX?  NZBGet/Sabnzbd/? Sonarr/Sickbeard/?

 

At my age, my head doesn't wrap around abstraction as well as it once did.  Hard to believe I could once write code in assembly.  Adding to BinHex's response, here's a shot of an example show in Sonarr.  If you're like me, you're overthinking the paths.  Even now, i look at BinHex's reply, and I struggle with the logic in USING abstract paths- IF everything has to be the same anyways.  I -SO- want to specify absolutes....complete absolutes...from every application.  But times change, and we all have to adapt.  I blurred out some details on the page, but I think you'll get the idea. (I was once scolded for including too much detail, but now I only record public domain shows.)

 

The second shot, is the path configuration for NZBGet.  Its paths are unchanged from the docker defaults.  Not sure if this all helps, but hopefully it might.

 

Sonarr PROGRAM EXAMPLE2.png

NZBGet PATHS.png

Share this post


Link to post

I started experiencing some freezing on the docker after upgrading to 6.5.  I had to restart the docker twice in 2 days.  Anyone else having this issue?

Share this post


Link to post

i grabbed the latest update, and now the cache drive that i had before working, is not, and causes the docker to crash. Tried mounting transcode to both cache, and now as you can see to an unassigned SSD, with same results.

 

2018-03-23 19:15:03,633 DEBG 'plexmediaserver' stderr output:
terminate called after throwing an instance of 'std::runtime_error'
what(): Codecs: Initialize: 'boost::filesystem::temp_directory_path: Not a directory: "/mnt/disks/Crucial_CT512MX100SSD1_14340D0B2B0E/transcode"'

2018-03-23 19:15:03,636 DEBG 'plexmediaserver' stderr output:
****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Plex Media Server/Crash Reports/1.12.1.4885-1046ba85f/PLEX MEDIA SERVER/23cba4c2-6e78-f9ca-256f48f4-0f7f637c.dmp

2018-03-23 19:15:03,640 DEBG fd 8 closed, stopped monitoring <POutputDispatcher at 22500921630160 for <Subprocess at 22500912017920 with name plexmediaserver in state STARTING> (stdout)>
2018-03-23 19:15:03,640 DEBG fd 10 closed, stopped monitoring <POutputDispatcher at 22500912169328 for <Subprocess at 22500912017920 with name plexmediaserver in state STARTING> (stderr)>
2018-03-23 19:15:03,640 INFO exited: plexmediaserver (terminated by SIGABRT; not expected)
2018-03-23 19:15:03,640 DEBG received SIGCLD indicating a child quit
2018-03-23 19:15:06,646 INFO spawned: 'plexmediaserver' with pid 72
2018-03-23 19:15:06,658 DEBG 'plexmediaserver' stderr output:
mkdir: cannot create directory ‘/mnt/disks’: Permission denied

2018-03-23 19:15:06,868 DEBG 'plexmediaserver' stderr output:
terminate called after throwing an instance of 'std::runtime_error'
what(): Codecs: Initialize: 'boost::filesystem::temp_directory_path: Not a directory: "/mnt/disks/Crucial_CT512MX100SSD1_14340D0B2B0E/transcode"'

2018-03-23 19:15:06,872 DEBG 'plexmediaserver' stderr output:
****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Plex Media Server/Crash Reports/1.12.1.4885-1046ba85f/PLEX MEDIA SERVER/2d68e878-8b3a-56ce-2051c774-35ff8e62.dmp

2018-03-23 19:15:06,875 DEBG fd 8 closed, stopped monitoring <POutputDispatcher at 22500912169328 for <Subprocess at 22500912017920 with name plexmediaserver in state STARTING> (stdout)>
2018-03-23 19:15:06,875 DEBG fd 10 closed, stopped monitoring <POutputDispatcher at 22500921629872 for <Subprocess at 22500912017920 with name plexmediaserver in state STARTING> (stderr)>
2018-03-23 19:15:06,876 INFO exited: plexmediaserver (terminated by SIGABRT; not expected)
2018-03-23 19:15:06,876 DEBG received SIGCLD indicating a child quit
2018-03-23 19:15:06,876 INFO gave up: plexmediaserver entered FATAL state, too many start retries too quickly

Share this post


Link to post
5 minutes ago, JohnnyBlaze99 said:

Not a directory: "/mnt/disks/Crucial_CT512MX100SSD1_14340D0B2B0E/transcode"'

Are you mapping /mnt to /mnt in the template?

Share this post


Link to post

Admittedly I don't use Plex, but the way that I see it is that you've got an environment variable (TRANS_DIR) with a setting of /mnt/disks/.....

 

Plex returns an error  saying that /mnt/disks/... doesn't exist.  Because it doesn't as far as the container is concerned.  The only paths you've mapped are /config mapped to /mnt/cache/appdata/... and /media mapped to /mnt/user/Multimedia

 

Doesn't matter about the variable setting or not.  Plex can only see folders on the host if you have them mapped.  Adding another path of /mnt mapped to /mnt should get rid of that error (assuming you typed in the path correctly in the environment variable)

Edited by Squid

Share this post


Link to post
44 minutes ago, JohnnyBlaze99 said:

Not a directory: "/mnt/disks/Crucial_CT512MX100SSD1_14340D0B2B0E/transcode"'

Shouldn't it be "/mnt/cache/transcode" ?

 

If your "/config" is mapped to "/mnt/cache/appdata/binhex-plex", then your 'TRANS-DIR' should be mapped to "/config/transcode" and this will point to this real folder "/mnt/cache/appdata/binhex-plex/transcode"

 

edit the line "/mnt/disks/Crucial_CT512MX100SSD1_14340D0B2B0E/transcode"' to "/config/transcode" and restart your plex docker.

Edited by SoAvenger
better answer

Share this post


Link to post
30 minutes ago, SoAvenger said:

Shouldn't it be "/mnt/cache/transcode" ?

 

If your "/config" is mapped to "/mnt/cache/appdata/binhex-plex", then your 'TRANS-DIR' should be mapped to "/config/transcode" and this will point to this real folder "/mnt/cache/appdata/binhex-plex/transcode"

 

edit the line "/mnt/disks/Crucial_CT512MX100SSD1_14340D0B2B0E/transcode"' to "/config/transcode" and restart your plex docker.

 

This worked. not sure what changed between the updates that caused this, but /config/transcode corrected the issue. Wondering where it will point though now? Will it still use the cache drive as a transcode, by using /mnt/cache/appdata/binhex-plex/transcode ?

 

Share this post


Link to post

think of it as a simple math problem

 

if "/config" equals (=)  "/mnt/cache/appdata/binhex-plex" then

"/config/transcode" equals (=) " "/mnt/cache/appdata/binhex-plex/transcode"

 

Hope that helps

Share this post


Link to post
1 hour ago, JohnnyBlaze99 said:

Wondering where it will point though now? Will it still use the cache drive as a transcode, by using /mnt/cache/appdata/binhex-plex/transcode ?

Computer systems are very fast but not able to take intuitive leaps (aka they are stupid but exactingly logical). You have to tell it exactly what you want it to do or it will do nothing. A path such as "/mnt/cache/appdata/binhex-plex/transcode" is really step by step instructions for it to follow. If you tell a computer to open the folder "/transcode" it will say 'error no such file or directory' because you didn't tell it where to look for the folder "/transcode". You have to tell it where to look and in this case:

 

  1. /mnt  (this is the location that unraid keeps its hard drives)
  2. /cache  (this is a hard drive (aka location, your ssd) and in your case specifically Crucial_CT512MX100SSD1_14340D0B2B0E)
  3. /appdata  (folder (aka location on your ssd) that Docker uses to store your Docker apps)
  4. /binhex-plex  (folder (aka location on your ssd) that contains your plex server app)
  5. /transcode  (folder (aka location on your ssd) that plex app uses to transcode files)

These instructions are also called a 'Directory Tree' and if you Google search Directory Tree you may find better or more in depth explanations that may be useful. Hope this helps.

Edited by SoAvenger

Share this post


Link to post

Just did the latest binhex plex update and log keeps saying its crashed... can't load web GUI at all...

 

Quote


Created by...
___. .__ .__
\_ |__ |__| ____ | |__ ____ ___ ___
| __ \| |/ \| | \_/ __ \\ \/ /
| \_\ \ | | \ Y \ ___/ > <
|___ /__|___| /___| /\___ >__/\_ \
\/ \/ \/ \/ \/
https://hub.docker.com/u/binhex/

2018-03-24 18:03:02.970498 [info] Host is running unRAID
2018-03-24 18:03:03.000991 [info] System information Linux homeserver 4.14.13-unRAID #1 SMP PREEMPT Wed Jan 10 10:27:09 PST 2018 x86_64 GNU/Linux
2018-03-24 18:03:03.041420 [info] PUID defined as '99'
2018-03-24 18:03:03.081478 [info] PGID defined as '100'
2018-03-24 18:03:03.134130 [warn] UMASK not defined (via -e UMASK), defaulting to '000'
2018-03-24 18:03:03.169650 [info] Permissions already set for volume mappings
2018-03-24 18:03:03.209592 [info] TRANS_DIR defined as '/mnt/cache/transcode'
2018-03-24 18:03:03.345077 [info] Starting Supervisor...
2018-03-24 18:03:03,556 CRIT Set uid to user 0
2018-03-24 18:03:03,556 INFO Included extra file "/etc/supervisor/conf.d/plexmediaserver.conf" during parsing
2018-03-24 18:03:03,561 INFO supervisord started with pid 7
2018-03-24 18:03:04,564 INFO spawned: 'plexmediaserver' with pid 48
2018-03-24 18:03:04,564 INFO reaped unknown pid 8
2018-03-24 18:03:04,577 DEBG 'plexmediaserver' stderr output:
mkdir: cannot create directory ‘/mnt/cache’: Permission denied

2018-03-24 18:03:04,859 DEBG 'plexmediaserver' stderr output:
terminate called after throwing an instance of 'std::runtime_error'
what(): Codecs: Initialize: 'boost::filesystem::temp_directory_path: Not a directory: "/mnt/cache/transcode"'

2018-03-24 18:03:04,863 DEBG 'plexmediaserver' stderr output:
****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Plex Media Server/Crash Reports/1.12.1.4885-1046ba85f/PLEX MEDIA SERVER/78c2e854-0d4c-4ca7-205809c3-0b3dbb36.dmp

2018-03-24 18:03:04,870 DEBG fd 8 closed, stopped monitoring <POutputDispatcher at 23182019266968 for <Subprocess at 23182019265024 with name plexmediaserver in state STARTING> (stdout)>
2018-03-24 18:03:04,870 DEBG fd 10 closed, stopped monitoring <POutputDispatcher at 23182028958752 for <Subprocess at 23182019265024 with name plexmediaserver in state STARTING> (stderr)>
2018-03-24 18:03:04,871 INFO exited: plexmediaserver (terminated by SIGABRT; not expected)
2018-03-24 18:03:04,871 DEBG received SIGCLD indicating a child quit
2018-03-24 18:03:05,874 INFO spawned: 'plexmediaserver' with pid 56
2018-03-24 18:03:05,888 DEBG 'plexmediaserver' stderr output:
mkdir: cannot create directory ‘/mnt/cache’: Permission denied

2018-03-24 18:03:06,040 DEBG 'plexmediaserver' stderr output:
terminate called after throwing an instance of 'std::runtime_error'
what(): Codecs: Initialize: 'boost::filesystem::temp_directory_path: Not a directory: "/mnt/cache/transcode"'

2018-03-24 18:03:06,044 DEBG 'plexmediaserver' stderr output:
****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Plex Media Server/Crash Reports/1.12.1.4885-1046ba85f/PLEX MEDIA SERVER/14762052-d4f9-67bb-723c40b2-3a641631.dmp

2018-03-24 18:03:06,053 DEBG fd 8 closed, stopped monitoring <POutputDispatcher at 23182019416432 for <Subprocess at 23182019265024 with name plexmediaserver in state STARTING> (stdout)>
2018-03-24 18:03:06,053 DEBG fd 10 closed, stopped monitoring <POutputDispatcher at 23182028959184 for <Subprocess at 23182019265024 with name plexmediaserver in state STARTING> (stderr)>
2018-03-24 18:03:06,053 INFO exited: plexmediaserver (terminated by SIGABRT; not expected)
2018-03-24 18:03:06,053 DEBG received SIGCLD indicating a child quit
2018-03-24 18:03:08,058 INFO spawned: 'plexmediaserver' with pid 64
2018-03-24 18:03:08,072 DEBG 'plexmediaserver' stderr output:
mkdir: cannot create directory ‘/mnt/cache’: Permission denied

2018-03-24 18:03:08,239 DEBG 'plexmediaserver' stderr output:
terminate called after throwing an instance of 'std::runtime_error'
what(): Codecs: Initialize: 'boost::filesystem::temp_directory_path: Not a directory: "/mnt/cache/transcode"'

2018-03-24 18:03:08,244 DEBG 'plexmediaserver' stderr output:
****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Plex Media Server/Crash Reports/1.12.1.4885-1046ba85f/PLEX MEDIA SERVER/307fac64-ffe4-bd6a-04868da4-2a08b745.dmp

2018-03-24 18:03:08,252 DEBG fd 8 closed, stopped monitoring <POutputDispatcher at 23182028959184 for <Subprocess at 23182019265024 with name plexmediaserver in state STARTING> (stdout)>
2018-03-24 18:03:08,252 DEBG fd 10 closed, stopped monitoring <POutputDispatcher at 23182019416432 for <Subprocess at 23182019265024 with name plexmediaserver in state STARTING> (stderr)>
2018-03-24 18:03:08,252 INFO exited: plexmediaserver (terminated by SIGABRT; not expected)
2018-03-24 18:03:08,252 DEBG received SIGCLD indicating a child quit
2018-03-24 18:03:11,258 INFO spawned: 'plexmediaserver' with pid 72
2018-03-24 18:03:11,271 DEBG 'plexmediaserver' stderr output:
mkdir: cannot create directory ‘/mnt/cache’: Permission denied

2018-03-24 18:03:11,423 DEBG 'plexmediaserver' stderr output:
terminate called after throwing an instance of 'std::runtime_error'
what(): Codecs: Initialize: 'boost::filesystem::temp_directory_path: Not a directory: "/mnt/cache/transcode"'

2018-03-24 18:03:11,428 DEBG 'plexmediaserver' stderr output:
****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Plex Media Server/Crash Reports/1.12.1.4885-1046ba85f/PLEX MEDIA SERVER/39c3b0d3-8f3e-e654-3f064f07-50118dc6.dmp

2018-03-24 18:03:11,435 DEBG fd 8 closed, stopped monitoring <POutputDispatcher at 23182019416432 for <Subprocess at 23182019265024 with name plexmediaserver in state STARTING> (stdout)>
2018-03-24 18:03:11,435 DEBG fd 10 closed, stopped monitoring <POutputDispatcher at 23182028958896 for <Subprocess at 23182019265024 with name plexmediaserver in state STARTING> (stderr)>
2018-03-24 18:03:11,435 INFO exited: plexmediaserver (terminated by SIGABRT; not expected)
2018-03-24 18:03:11,435 DEBG received SIGCLD indicating a child quit
2018-03-24 18:03:11,435 INFO gave up: plexmediaserver entered FATAL state, too many start retries too quickly

 

Share this post


Link to post

Ok so i read through the previous post properly and followed the directions and it worked... sorry guys should learn to read first...

Share this post


Link to post

My client updated last night and It's also crashing :(

 

Tried force upgrading, removing and re--installing. No dice.

 

Created by...
___.   .__       .__
\_ |__ |__| ____ |  |__   ____ ___  ___
 | __ \|  |/    \|  |  \_/ __ \\  \/  /
 | \_\ \  |   |  \   Y  \  ___/ >    <
 |___  /__|___|  /___|  /\___  >__/\_ \
     \/        \/     \/     \/      \/
   https://hub.docker.com/u/binhex/

2018-03-24 06:15:31.953278 [info] Host is running unRAID
2018-03-24 06:15:31.985530 [info] System information Linux 43c0de99563d 4.14.4-unRAID #1 SMP PREEMPT Wed Dec 13 12:42:33 PST 2017 x86_64 GNU/Linux
2018-03-24 06:15:32.029707 [info] PUID defined as '99'
2018-03-24 06:15:32.072343 [info] PGID defined as '100'
2018-03-24 06:15:32.156222 [info] UMASK defined as '000'
2018-03-24 06:15:32.199255 [info] Permissions already set for volume mappings
2018-03-24 06:15:32.241750 [info] TRANS_DIR defined as '/mnt/user/transcode'
2018-03-24 06:15:32.334238 [info] Starting Supervisor...
2018-03-24 06:15:32,493 CRIT Set uid to user 0
2018-03-24 06:15:32,493 INFO Included extra file "/etc/supervisor/conf.d/plexmediaserver.conf" during parsing
2018-03-24 06:15:32,496 INFO supervisord started with pid 7
2018-03-24 06:15:33,500 INFO spawned: 'plexmediaserver' with pid 48
2018-03-24 06:15:33,500 INFO reaped unknown pid 8
2018-03-24 06:15:33,513 DEBG 'plexmediaserver' stderr output:
mkdir: cannot create directory ‘/mnt/user’: Permission denied

2018-03-24 06:15:33,702 DEBG 'plexmediaserver' stderr output:
terminate called after throwing an instance of 'std::runtime_error'
  what():  Codecs: Initialize: 'boost::filesystem::temp_directory_path: Not a directory: "/mnt/user/transcode"'

2018-03-24 06:15:33,707 DEBG 'plexmediaserver' stderr output:
****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Plex Media Server/Crash Reports/1.12.1.4885-1046ba85f/PLEX MEDIA SERVER/1a2e15ce-53dd-217c-25894a64-17bbae38.dmp

2018-03-24 06:15:33,711 DEBG fd 8 closed, stopped monitoring <POutputDispatcher at 22582005164440 for <Subprocess at 22582005162496 with name plexmediaserver in state STARTING> (stdout)>
2018-03-24 06:15:33,711 DEBG fd 10 closed, stopped monitoring <POutputDispatcher at 22582014774304 for <Subprocess at 22582005162496 with name plexmediaserver in state STARTING> (stderr)>
2018-03-24 06:15:33,711 INFO exited: plexmediaserver (terminated by SIGABRT; not expected)
2018-03-24 06:15:33,711 DEBG received SIGCLD indicating a child quit
2018-03-24 06:15:34,715 INFO spawned: 'plexmediaserver' with pid 56
2018-03-24 06:15:34,729 DEBG 'plexmediaserver' stderr output:
mkdir: cannot create directory ‘/mnt/user’: Permission denied

2018-03-24 06:15:34,921 DEBG 'plexmediaserver' stderr output:
terminate called after throwing an instance of 'std::runtime_error'
  what():  Codecs: Initialize: 'boost::filesystem::temp_directory_path: Not a directory: "/mnt/user/transcode"'

2018-03-24 06:15:34,925 DEBG 'plexmediaserver' stderr output:
****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Plex Media Server/Crash Reports/1.12.1.4885-1046ba85f/PLEX MEDIA SERVER/07f975c9-5182-bb5f-0e6e6904-4f08be45.dmp

 

Edited by Aleas

Share this post


Link to post
1 hour ago, Aleas said:

filesystem::temp_directory_path: Not a directory: "/mnt/user/transcode"'

do you have a cache drive?

do you have a user share called "transcode"?

what do you have set as your "Container Path: /config"?

 

Share this post


Link to post

yes something changed with the recent update.  I get permission errors when transcoding to ram now.

 

Am using /tmp in settings for transcode path.  Sorry i cant post logs ATM not at home.

 

Current settings have worked fine for a year or more.

 

 

Edited by Viperkc

Share this post


Link to post
Just now, Viperkc said:

yes something changed with the recent update.  I get permission errors when transcoding to ram now.

 

Am using /tmp in settings for transcode path.  Sorry i cant post logs ATM not at home.

 

 

try "/config/tmp"

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now