Jump to content
binhex

[Support] binhex - Plex Pass

435 posts in this topic Last Reply

Recommended Posts

10 minutes ago, SoAvenger said:

Unfortunately, under settings - docker, there is a path for 'default appdata storage location' that cannot be left blank and cannot be overridden by the individuale dockers

Yes, you can change the individual docker appdata path to whatever you want for that container.

 

Edit the /config container path and enter whatever you wish.  In the screenshot below I called the appdata for the 2nd instance PLEXHDHRPREM as if it were the docker appdata for the instance that will have the HDHomeRun Premium EPG.

 

image.thumb.png.e7b22ae4cb78beb7d5b48b8db6e8cfa5.png

Edited by Hoopster
  • Like 1

Share this post


Link to post
45 minutes ago, Hoopster said:

Yes, you can change the individual docker appdata path to whatever you want for that container.

 

Edit the /config container path and enter whatever you wish.  In the screenshot below I called the appdata for the 2nd instance PLEXHDHRPREM as if it were the docker appdata for the instance that will have the HDHomeRun Premium EPG.

 

image.thumb.png.e7b22ae4cb78beb7d5b48b8db6e8cfa5.png

I stand corrected sir. Thank you for your powers of persuasion and all your help. I installed four different dockers and all of them shared config data because they were all the same except for the address in the web page. I gave up. Your last post inspired me to try one more time and it WORKED!

 

Thank you very much!

screen119.jpg

Share this post


Link to post
12 minutes ago, SoAvenger said:

I installed four different dockers and all of them shared config data because they were all the same

Yes, all dockers will default to an appdata path based on the default specified on the docker setting page.  Since every docker you tried was the same application (although a different distribution), they likely had the same default path.  Now you know that you can edit anything you want in any docker config.

 

I am glad you got it working. 👍

Share this post


Link to post

I wanted to know with current version of this docker how would I setup my transcoding for RAM?   

 

I have the old mapping Container Path = /transcode and Host Path = /tmp

 

Now I see this Key 1 TRANS_DIR = /config/transcode

 

Do I need to change anything?  Also how can I verify if is really using RAM?  Sorry but I am still learning.

Share this post


Link to post
7 minutes ago, rmilyard said:

I wanted to know with current version of this docker how would I setup my transcoding for RAM?   

 

I have the old mapping Container Path = /transcode and Host Path = /tmp

 

Now I see this Key 1 TRANS_DIR = /config/transcode

 

Do I need to change anything?  Also how can I verify if is really using RAM?  Sorry but I am still learning.

Just go into plex the app and set to "TRANS_DIR"

Share this post


Link to post

I have plex, with transcode set to "TRANS_Dir" which is suppose to be ram.

 

However I show 6 GB of transcode sitting inside my appdata. I am have issues with docker filling up now.

 

Any ideas how to get this to stop? I show the transcode folder with some new files of like today.

Share this post


Link to post
9 minutes ago, scubieman said:

I have plex, with transcode set to "TRANS_Dir" which is suppose to be ram.

 

However I show 6 GB of transcode sitting inside my appdata. I am have issues with docker filling up now.

 

Any ideas how to get this to stop? I show the transcode folder with some new files of like today.

this is not correct, you do not need to set anything in plex, you just need to define an additional volume and then target that as your value for the TRANS_DIR env var, see following link scroll down to Plex FAQ:-

 

 

Share this post


Link to post
13 minutes ago, binhex said:

this is not correct, you do not need to set anything in plex, you just need to define an additional volume and then target that as your value for the TRANS_DIR env var, see following link scroll down to Plex FAQ:-

 

 

Thanks!  I believe I have it working now!

Share this post


Link to post
2 minutes ago, rmilyard said:

Thanks!  I believe I have it working now!

For transcode did you set to /tmp?

Share this post


Link to post
2 minutes ago, scubieman said:

For transcode did you set to /tmp?

TRANS_DIR = /transcode

 

Then made

 

Container Path = /transcode 

Host Path = /tmp

 

  • Like 1

Share this post


Link to post
1 minute ago, rmilyard said:

TRANS_DIR = /transcode

 

Then made

 

Container Path = /transcode 

Host Path = /tmp

 

This look ok?

 

image.png.d0821dba0b0978ae5da760e64266018b.pngimage.thumb.png.85366145931cf425ceb8c63b56767311.png

Share this post


Link to post

Help 

 

I am getting the following error when I attempt to install the lastest version of BINHEXPlexpass. 

 

Error: failed to register layer: ApplyLayer exit status 1 stdout: stderr: write /usr/bin/v4l2-ctl: no space left on device

 

Plexpass is on my cache drive and it has over 200 GB free. I have over 2500 movies and equal # of Albums. 

Share this post


Link to post
15 hours ago, scubieman said:

What does your folders look like? 

 

image.thumb.png.9ea37099641a05c5999cf2178baccc8f.png

image.thumb.png.61825cab6a528690085554ac5114468c.png

 

Here are my folders please help me to configure correctly

 

Rich

 

Share this post


Link to post
21 hours ago, richgnoe said:

exit status 1 stdout: stderr: write /usr/bin/v4l2-ctl: no space left on device

this wont be the space on your cache drive, it will be the space available on the docker image, you most probably have a badly configured container that is writing large downloads inside the container and thus causing the docker image to run out of space, or possibly log files from a badly designed docker container.

 

your best bet is to try and identify what is causing the issue, re-configure it to stop it happening and then delete and re-create the docker image, then restore all your docker apps, i think from memory CA backup and restore plugin does this automagically - right @Squid ?

 

 

Share this post


Link to post
6 hours ago, binhex said:

your best bet is to try and identify what is causing the issue, re-configure it to stop it happening and then delete and re-create the docker image, then restore all your docker apps, i think from memory CA backup and restore plugin does this automagically - right @Squid ?

You don't need to restore via App Data Backup/Restore.   That's only needed if the cache drive dies or is replaced.

 

The Apps tab has a "Previous Apps" section on the hamburger icon.  Then you can check off all of the appropriate applications and it'll be back up and running like nothing happened in a matter of minutes.

  • Like 1

Share this post


Link to post

Hey guys, so I will be installing this for the first time on my unraid (used to run plex on mac mini). I have an i3-8400 coming this weekend that supports hardware transcoding. Is there anything that I need to add to the docker template to enable hardware transcoding? I read a post about something having to be added but that was for the linuxserver.io build, not sure if anything needs to be done for binhex?

Share this post


Link to post

Anyone? I installed my new CPU, mobo and RAM, unraid booted well.

 

I just installed the plex app docker, but when I click WebUI it keeps saying "site can't be reached" and won't load. 

Also within docker when I click "show docker allocations" There is a "???" next to the port number. I don't see any place to assign a port number either to 32400...

 

Guys help I think something is going on. I am attaching the log file here. Seems to be some kind of error I don't know why. 

 

Downloads is a share I created that is on "cache only" that is an SSD and I created a folder on that share called "transcode" for plex transcoding

 

What did I do wrong? Help please

 

supervisord.log

Screen Shot 2018-12-21 at 5.45.58 PM.png

Edited by maxse

Share this post


Link to post

Wouldn't be a bad idea to post your diagnostics

2018-12-21 17:45:00,067 DEBG 'plexmediaserver' stderr output:
mkdir: cannot create directory ‘/mnt/user’: Permission denied

 

Share this post


Link to post

Hei @binhex, great work as always :)

Any chance of having this container use some proxy for outgoing communication? I am using privoxy from your delugevpn and it works great, however in my country some subtitle providers are being blocked, so I would like Plex to use privoxy when fetching movies/songs metadata from the internet.

I read online that plex would use host configuration, thus there is no such config from plex itself, so perhaps you can do some docker magic here? :)

Thanks again for great containers and as usually, buying you a beer!

Share this post


Link to post
On 1/4/2019 at 2:15 PM, dakipro said:

Hei @binhex, great work as always :)

Any chance of having this container use some proxy for outgoing communication? I am using privoxy from your delugevpn and it works great, however in my country some subtitle providers are being blocked, so I would like Plex to use privoxy when fetching movies/songs metadata from the internet.

I read online that plex would use host configuration, thus there is no such config from plex itself, so perhaps you can do some docker magic here? :)

Thanks again for great containers and as usually, buying you a beer!

so if plex picks up host config then you should simply set the proxy by issuing the following commands inside the container, if it works then i can look at allowing users to define this via env var.

 export http_proxy=http://<ip address of your unraid server>:<port number for privoxy>/
 export https_proxy=https://<ip address of your unraid server>:<port number for privoxy>/

 

Share this post


Link to post

Hi does anyone know the best practice method of running the commands needed to enable hardware transcoding? At the moment if I restart my Unraid box for any reason I have to ssh into it and run:

modprobe i915
chmod -R 777 /dev/dri

Which is not difficult but I'd like to automate it none the less.

Share this post


Link to post
18 minutes ago, dgwharrison said:

Hi does anyone know the best practice method of running the commands needed to enable hardware transcoding? At the moment if I restart my Unraid box for any reason I have to ssh into it and run:


modprobe i915
chmod -R 777 /dev/dri

Which is not difficult but I'd like to automate it none the less.

Do you not have those commands in your go file?  They get executed on reboot if they are in your go file as has been mentioned on several threads related to enabling Plex hardware transcoding.

Share this post


Link to post

Hi @binhex Thanks for the plexpass unraid docker container. Really appreciate your work on all the other repos as well.

However, I was going to customize my plex - chromecast.xml for obvious reasons of audio and video passthrough and such and couldn't find that anyhow.

 

Could you please let us know the path to that folder.

Typically it is /usr/lib/plexmediaserver/Resources/Profiles/Chromecast.xml in standard ubuntu linux installs or at

/mnt/HD/HD_a2/Nas_Prog/plexmediaserver/binaries/Resources/Profiles/Chromecast.xml on WD NAS PR4100 or such devices.

 

Your help would be highly appreciated as always.

 

Cheers!

Edited by Shomil Saini
Edited for correct Path of NAS

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now