Jump to content
binhex

[Support] binhex - Plex Pass

945 posts in this topic Last Reply

Recommended Posts

  image.thumb.png.d58aa3683a653a1f7bd0c696c2b76539.pngimage.png.6ec170b1c915f8783acd6dcfe11799d0.png

This is what the structure looks like as it is now. I am thinking that PlexPass is set up to find the media files under the "media" folder in the second screen.

Can I re-order this?

 

Share this post


Link to post
7 hours ago, lockrob2000 said:

Can someone point me in the right direction? Or tell me if it is possible at this point to re-order the shares so that all my media is seen under "Media"?

How Plex "sees" your media through the docker file system has little to do with how you order the shares in the array.  It all has to do with the volume mappings you specify in the docker container.

 

A volume mapping is just a way of mapping the physical file structure of the shares on the unRAID array to the docker container file system.

 

I use a different Plex docker container but the concept is the same.

 

Much like your system, I have separate shares for each media type (Movies, Pictures, TVShows, etc.)

 

image.png.3100b8db264afeca82611aca9c7d308c.png

 

There is no Media folder in unRAID and the content shares are not subfolders of any other folder (Top level folders are shares in unRAID).  Some do organize their media under a single share called 'Media' with subfolders for content type.

 

In the Plex docker, I chose to preserve the direct share mapping to a container path specific to content type, so I did this (created a volume mapping for each content type):

 

image.thumb.png.c083aabb213f7ba140678f81d3ea2ba5.png

 

I could have opted to just make a /media (container path) mapping to /mnt/user/ (host path) and called it good.  In that scenario, for each content type, I would then browse to /media/{share name} in the Plex server when creating Libraries for each content type; e.g. /media/Movies to select the content type for a Movies Library.

 

However, in the way I currently have my volume mappings defined, for a Movies Library I browse directly to /movies as seen below:

 

image.png.e0a070bfe3374b1f75da34e5d6f91d19.png

 

The volume mapping I created in the docker container config is the same as saying 'when I select the folder /movies as a LIbrary folder in Plex, tell Plex to look for content in /mnt/user/Movies on the unRAID array."

 

When specifying a folder for the Library in Plex, the folder structure you see in the screenshot above has no relation to the way the folders/shares are actually organized on your unRAID array.  You have mapped a host file system folder (unRAID) to a container file system (Plex) folder via the volume mappings you created in the docker container config and you merely need to select the appropriate container path in Plex.

 

The /media folder you see in Plex may or may not have anything to do with unRAID shares/content depending on how you created volume mappings.

Edited by Hoopster

Share this post


Link to post

OK, that's what I thought and I was putting my paths in as the same as you show.

What I am unsure about is this

image.thumb.png.5e618193c7692deb8da13a41202562d2.png

 

This path "Host Path 2" has a container path of "media" pre-populated. This is something I don't have and I am not sure I can remove it.

Also, when I point to the files I have set up for my various media, I get a response stating that the disc are not mounted, and yet I know that they are (I can get to the media using other players).

It may have something with this not being set - and I am not sure where this parameter gets set.

image.png.df8d13b1c149452323507c72f412e08b.png

Sorry, if this is too much, but it was working fine just a bit ago.

Share this post


Link to post
On 3/9/2019 at 10:30 PM, BBLV said:

Mine's been spotty since 6.6.7. Some pull, some don't. Not sure what's broken and not sophisticated enough to even begin looking.

Just a thought check your agents are stills selected and in the order you set them I found my had reset I guess to default during an update go to settings and drill down to to general section and click on agents select the ones you like and drag them to the the order of your choosing

Share this post


Link to post
18 hours ago, lockrob2000 said:

This path "Host Path 2" has a container path of "media" pre-populated. This is something I don't have and I am not sure I can remove it.

You can edit and modify that mapping in any way your wish, you can remove it and create another or, you can use it as is.

 

On 3/17/2019 at 5:46 PM, lockrob2000 said:

  image.thumb.png.d58aa3683a653a1f7bd0c696c2b76539.pngimage.png.6ec170b1c915f8783acd6dcfe11799d0.png

This is what the structure looks like as it is now. I am thinking that PlexPass is set up to find the media files under the "media" folder in the second screen. 

Can I re-order this?

 

The way you have things mapped now with /media mapped to /mnt/user should work.  For a movies Library you would select the media folder you have circled in the first screen and then Movies in the second screen.  For photos it would be /media/Photos and so one for the other media types.

 

The media folder in the second screenshot probably has nothing to do with your Plex media on your unRAID array and if you select it, nothing will show up in Plex.

 

18 hours ago, lockrob2000 said:

It may have something with this not being set - and I am not sure where this parameter gets set.

image.png.df8d13b1c149452323507c72f412e08b.png

Sorry, if this is too much, but it was working fine just a bit ago.

I am not sure why it shows no port mapping for the binhex-plexpass container.  I use a different container so, I am not sure what they should be.  You could check the container support page and perhaps it will show you what the default port mappings should be.

Edited by Hoopster

Share this post


Link to post

Well, I got it to work again, but I had to (well, not sure if I HAD to but I did...) roll back to an earlier version and edited that one entry, and the paths work now.

You had better believe that I will be screenshot-ing (is that a word?) the set up for future reference. 

Thanks for all the help!

Share this post


Link to post
17 hours ago, Hoopster said:

I am not sure why it shows no port mapping for the binhex-plexpass container. 

fyi - the reason there are no ports defined is because this container is designed to run in host mode, thus no ports required.

Share this post


Link to post

Good to know, thanks.

On an unrelated note, do you know if using Plex in Docker puts Plex into a "double NAT" situation?

thanks-

Share this post


Link to post
7 minutes ago, lockrob2000 said:

Good to know, thanks.

On an unrelated note, do you know if using Plex in Docker puts Plex into a "double NAT" situation?

thanks-

as this container uses host mode and not bridge there is no NATing going on, so no.

Share this post


Link to post

Hello binhex,

 

Thank you for this plexpass docker.

I noticed the other day the plex has an update "A Plex Media Server update is available for the server SJOERD Tower! 1.15.2.793 Download now.

 

Do I need to update it from within the docker or do we need to wait till you made a new docker ?

 

Regards

Share this post


Link to post
1 hour ago, sjoerd said:

I noticed the other day the plex has an update "A Plex Media Server update is available for the server SJOERD Tower! 1.15.2.793 Download now.

Do I need to update it from within the docker or do we need to wait till you made a new docker ?

You need to wait for Binhex to release an update.

 

Unless you have a version label specified in your docker, e.g. binhex/arch-plexpass:1.14.1.5488-1-01 - then you need to change the tag to latest to get updates.

Share this post


Link to post
You need to wait for Binhex to release an update.

 

Unless you have a version label specified in your docker, e.g. binhex/arch-plexpass:1.14.1.5488-1-01 - then you need to change the tag to latest to get updates.

And just to add to that, updates are done automatically via script, so as soon as it's available it will get built

 

Sent from my EML-L29 using Tapatalk

 

 

 

Share this post


Link to post

My plex docker container has a memory leak and I'm not sure how to fix it. When I restart the docker container it barely uses any memory however it slowly increases and doesn't stop, after 1 or 2 days it's using 5-6GB of RAM. I've tried to delete my docker img and recreate it downloading a fresh docker container for binhex-plex-pass. I would prefer not to start from scratch as I have quite a number of users on my server. Is there anything I can do to figure out what is causing this?

Share this post


Link to post
7 minutes ago, bobokun said:

My plex docker container has a memory leak and I'm not sure how to fix it. When I restart the docker container it barely uses any memory however it slowly increases and doesn't stop, after 1 or 2 days it's using 5-6GB of RAM. I've tried to delete my docker img and recreate it downloading a fresh docker container for binhex-plex-pass. I would prefer not to start from scratch as I have quite a number of users on my server. Is there anything I can do to figure out what is causing this?

Plex is causing this. Roll back to a stable version.

Quote

you will need to go back to this tag "1.14.1.5488-1-01", if you dont know how to do that then check Q12 in the following link:-

 

https://forums.unraid.net/topic/44108-support-binhex-general/?tab=comments#comment-433612

 

Share this post


Link to post
On 3/25/2019 at 8:09 PM, binhex said:

And just to add to that, updates are done automatically via script, so as soon as it's available it will get built

 

Sent from my EML-L29 using Tapatalk

 

 

 

 

Hi,

 

Sorry for my late reply;

So I just need to wait a bit then I guess 🙂

Share this post


Link to post

I'm a bit puzzled

I installed your version from the CA

image.png.b105423b7265ffb4242bf1ed86c2c8cc.png

And when I start the webui the webui tells me 1.15.2.793 is available. The download now link let me download plexmediaserver-1.15.2.793-782228f99.x86_64.rpm from download.plex.tv but I got a feeling that not a docker.

 

And what do u mean with "updates are done automatically via script". Can I check I those scripts actually fire (logs and suchs)

 

 

Edited by sjoerd

Share this post


Link to post
2 minutes ago, sjoerd said:

And when I start the webui the webui tells me 1.15.2.793 is available.

that is out of date actually, 1.15.3.835 is now the latest version of plex pass, and as you can see if you click on the link in my last post this version has been built and is now tagged as latest, if you go to unraid web ui/docker tab and then click on the 'check for updates' button you will see a new version is available for download, then simply click on the 'update all' button or update plex pass only, thats all you need to do, you cannot install rpm's directly.

 

 

Share this post


Link to post

Yes I did click - check for updates. They are spinning for about 10 min now. Oh wait - I reloaded the page with dockers and now I see they can be updated.

 

It seems 3 out of 4 dockers could be updated. I wonder why I had to check manually using the "check for updates" button and why they kept spinning for so long (until i refreshed the page).

Share this post


Link to post
1 minute ago, sjoerd said:

I wonder why I had to check manually using the "check for updates" button

because its not automatic, not everybody wants automatic updates so the default is not to, if you want automatic updates then you need to install the plugin called "CA auto update applications" and configure it to do the updates.

 

2 minutes ago, sjoerd said:

and why they kept spinning for so long (until i refreshed the page).

no idea on this, slow internet connection would be my guess, typically takes about 30 secs for me.

Share this post


Link to post

Hey Binhex - thanks so much for your work. I use 6 of your dockers regularly and they are fantastic! I'm hoping you can help me with an issue I'm having with the Plexpass docker...I'm pretty much an unRAID/Docker novice (just built my first set up a few weeks ago) so I imagine it's a pretty simple thing.

 

I set up the docker via CA, changed the settings for media and transcode directories, and can't get anything to launch. I see that it says it doesn't have access to mnt/user (which doesn't make sense to me, I gave it access), and mnt/user/Transcode also definitely exists. Any ideas?

Log for: binhex-plexpass.pdf

Share this post


Link to post
12 hours ago, zbron said:

I set up the docker via CA, changed the settings for media and transcode directories, and can't get anything to launch. I see that it says it doesn't have access to mnt/user (which doesn't make sense to me, I gave it access), and mnt/user/Transcode also definitely exists. Any ideas?

this sounds like you maybe struggling with the concept of volume mappings with docker containers, have a read Q4 to Q7. from the following link:-

https://forums.unraid.net/topic/44108-support-binhex-general/?tab=comments#comment-433612

 

to debug your issue a bit further can you left click the plex icon and select edit, then choose "advanced view" from the top right and then screenshot the whole thing and post the screenshots here, its most likely a volume mapping not defined correctly.

Share this post


Link to post
35 minutes ago, binhex said:

this sounds like you maybe struggling with the concept of volume mappings with docker containers, have a read Q4 to Q7. from the following link:-

https://forums.unraid.net/topic/44108-support-binhex-general/?tab=comments#comment-433612

 

to debug your issue a bit further can you left click the plex icon and select edit, then choose "advanced view" from the top right and then screenshot the whole thing and post the screenshots here, its most likely a volume mapping not defined correctly.

Thanks so much for replying back - I just read over the attached link (thanks for providing the resource), and can't figure out exactly how I've messed with the volume mapping up. Below I've attached screenshots of everything I see in the advanced view.

1.thumb.png.7f960d79e38ea202e02d7b58deaaed46.png2.thumb.png.59bb3c2fd40bbe083d3fc078a2fc5f60.png3.png.80f0e956167061737ec88cf5fb450b29.png

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.