[Support] binhex - Plex Pass


Recommended Posts

Question, not really an issue with the plex server docker. (right now i'm using the default one, not sure what the difference is between binhex and the regular one), but just a quick question.  Is there a way to make it so when someone logs into their plex client to not see other users?

 

See attached.

 

And Binhex, I really do love your dockers (im new to this and you make it easy)!!

Screen Shot 2021-09-02 at 9.26.03 AM.png

Link to comment
  • 4 weeks later...

Is anyone having issues with version 1.24.3.5033-1-01 ?? I updated last Tuesday and been having trouble ever since.

 

Example of issues:

1. Users getting excessive buffering when they are able to connect.  and local connections failing at times in the middle of a program (Direct Play) 

2. Transcodes failing midway thru a program and "Server not available".  (Thought this was a remote/bandwidth issue but speed test, and port forwarding working fine).  Rebooted everything twice and checked connection. And yes, using Nvidia HW.

3. Status Dashboard page "Now Playing" not showing everything playing. remote or local.  Also seen double entries from same source.

4. Tautulli unable to connect to Plex Server and in other times, showing no activity even though several shows are running.

5. Several settings pages not displaying at times. restart docker and pages come back but only for a short time.

 

Other than these types of entries in the log file, there isn't much information there:
DEBG 'plexmediaserver' stdout output:
Critical: libusb_init failed

 

My last step was to downgrade to 1.24.2.5000-1-01.  Not sure if this helping yet but I can access the setting pages now and Tautulli is connecting and updating correctly.  I will wait for 24 hours to signal an all clear however.

 

Any assistance would be appreciated. 

 

Profile:

CPU: Intel® Core™ i7-8700 CPU @ 3.20GHz

Mem: 64Gb

Unraid version: 6.9.2

NVidia driver: 470.74

NVIDIA Quadro P2000

 

Edited by Rudeboy42
Link to comment

@binhex is there a bug in this version that would break it if your using a GPU and the Nvida Drivers. Seems since the last update the docker wont start if i have a GPU added in the code. I get SERVER ERROR when trying to start. 

 

I added the GPU to another docker and it works fine so though i check in 

Link to comment
1 minute ago, furian said:

is this version working with the 11th gen cpu? cause the linuxserver version still shows artifact during transcoding of 2160p content...

 

damn i wish plex would just make it a priority...

At the end of the day both this image and LSIO are running the same app just packaged differently, so i doubt it will work any better for this image.

Link to comment
11 hours ago, rguinn said:

@binhex is there a bug in this version that would break it if your using a GPU and the Nvida Drivers. Seems since the last update the docker wont start if i have a GPU added in the code. I get SERVER ERROR when trying to start. 

 

I added the GPU to another docker and it works fine so though i check in 

no probs for me, just pulled down latest, im doing gpu passthrough for a P2000, maybe its a driver issue, try rolling back the version of the driver (im not running latest driver).

  • Thanks 1
Link to comment
1 hour ago, binhex said:

no probs for me, just pulled down latest, im doing gpu passthrough for a P2000, maybe its a driver issue, try rolling back the version of the driver (im not running latest driver).

@binhex Thanks I was on a old and updated to the new version so it must be a issues on my end ill may blow out he docker and trying again. its working with Emby so now i hunt for the problem - As Always thanks for the reply

Edited by rguinn
Link to comment
4 hours ago, rguinn said:

@binhex Thanks I was on a old and updated to the new version so it must be a issues on my end ill may blow out he docker and trying again. its working with Emby so now i hunt for the problem - As Always thanks for the reply

Weird I just got a docker update and its now working with GPU again so woohoo for me hope my docker server is not showing signs of issues

Link to comment
On 1/7/2019 at 1:19 PM, binhex said:

so if plex picks up host config then you should simply set the proxy by issuing the following commands inside the container, if it works then i can look at allowing users to define this via env var.

 export http_proxy=http://<ip address of your unraid server>:<port number for privoxy>/
 export https_proxy=https://<ip address of your unraid server>:<port number for privoxy>/

 

 

Hey @binhex, it took almost 2 years till someone tested that but I can report it works. Added env vars for http_proxy and https_proxy manually, maybe empty defaults for those could be added to make others aware of that functionality.

 

FYI why I needed to use this: I have trouble tunneling plex through a VPN container via --net=container:. The Plex app on my LG CX TV (WebOS 6.0) times out, Android or web Plex does work though. I assume it's iptables related but couldn't figgure out what was causing it. I reported that in your binhex - Plex thread.

 

EDIT: I had to revert the proxy settings, for some reason it made my TV start transcoding stuff... :/

Edited by epp
Link to comment

Please help if you can.

I shut down the server the clean out some dust and upon restart, the Sonarr docker works but the PlexPass does not.

Could you point me in the direction I need to go for troubleshooting?

Here's some of the recent log

 

_ |__ |__| ____ | |__ ____ ___ ___
| __ \| |/ \| | \_/ __ \\ \/ /
| \_\ \ | | \ Y \ ___/ > <
|___ /__|___| /___| /\___ >__/\_ \
\/ \/ \/ \/ \/
https://hub.docker.com/u/binhex/

2021-10-11 17:04:46.366328 [info] Host is running unRAID
2021-10-11 17:04:46.401388 [info] System information Linux Tower 5.10.28-Unraid #1 SMP Wed Apr 7 08:23:18 PDT 2021 x86_64 GNU/Linux
2021-10-11 17:04:46.584147 [info] OS_ARCH defined as 'x86-64'
2021-10-11 17:04:47.023886 [info] PUID defined as '99'
2021-10-11 17:04:47.659449 [info] PGID defined as '100'
2021-10-11 17:04:49.465152 [info] UMASK defined as '000'
2021-10-11 17:04:49.490153 [info] Permissions already set for '/config'
2021-10-11 17:04:49.919886 [info] Deleting files in /tmp (non recursive)...
2021-10-11 17:04:50.269818 [info] TRANS_DIR defined as '/config/transcode'
2021-10-11 17:04:50.362725 [info] Starting Supervisor...
2021-10-11 17:04:56,356 INFO Included extra file "/etc/supervisor/conf.d/plexmediaserver.conf" during parsing
2021-10-11 17:04:56,356 INFO Set uid to user 0 succeeded
2021-10-11 17:04:56,362 INFO supervisord started with pid 7
2021-10-11 17:04:57,364 INFO spawned: 'plexmediaserver' with pid 64
2021-10-11 17:04:57,366 INFO spawned: 'shutdown-script' with pid 65
2021-10-11 17:04:57,366 INFO reaped unknown pid 8 (exit status 0)
2021-10-11 17:04:58,368 INFO success: plexmediaserver entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2021-10-11 17:04:58,368 INFO success: shutdown-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-10-11 17:05:01,464 DEBG 'plexmediaserver' stderr output:
Failed to load preferences at /config/Plex Media Server/Preferences.xml

2021-10-11 17:05:03,396 DEBG 'plexmediaserver' stderr output:
Failed to load preferences at /config/Plex Media Server/Preferences.xml

2021-10-11 17:28:59,900 WARN received SIGTERM indicating exit request
2021-10-11 17:28:59,901 DEBG killing shutdown-script (pid 65) with signal SIGTERM
2021-10-11 17:28:59,901 INFO waiting for plexmediaserver, shutdown-script to die
2021-10-11 17:28:59,901 DEBG 'shutdown-script' stdout output:
[info] Initialising shutdown of process(es) '^/usr/lib/plexmediaserver/Plex Media Server' ...

2021-10-11 17:29:02,905 INFO waiting for plexmediaserver, shutdown-script to die
2021-10-11 17:29:05,908 INFO waiting for plexmediaserver, shutdown-script to die
2021-10-11 17:29:08,911 INFO waiting for plexmediaserver, shutdown-script to die
2021-10-11 17:29:09,912 WARN killing 'shutdown-script' (65) with SIGKILL
2021-10-11 17:29:09,913 DEBG killing shutdown-script (pid 65) with signal SIGKILL
Created by...
___. .__ .__
\_ |__ |__| ____ | |__ ____ ___ ___
| __ \| |/ \| | \_/ __ \\ \/ /
| \_\ \ | | \ Y \ ___/ > <
|___ /__|___| /___| /\___ >__/\_ \
\/ \/ \/ \/ \/
https://hub.docker.com/u/binhex/

2021-10-11 17:29:27.369974 [info] Host is running unRAID
2021-10-11 17:29:27.393388 [info] System information Linux Tower 5.10.28-Unraid #1 SMP Wed Apr 7 08:23:18 PDT 2021 x86_64 GNU/Linux
2021-10-11 17:29:27.419069 [info] OS_ARCH defined as 'x86-64'
2021-10-11 17:29:27.446432 [info] PUID defined as '99'
2021-10-11 17:29:27.474477 [info] PGID defined as '100'
2021-10-11 17:29:28.311180 [info] UMASK defined as '000'
2021-10-11 17:29:28.340166 [info] Permissions already set for '/config'
2021-10-11 17:29:28.368296 [info] Deleting files in /tmp (non recursive)...
2021-10-11 17:29:28.397598 [info] TRANS_DIR defined as '/config/transcode'
2021-10-11 17:29:28.425444 [info] Starting Supervisor...
2021-10-11 17:29:28,603 INFO Included extra file "/etc/supervisor/conf.d/plexmediaserver.conf" during parsing
2021-10-11 17:29:28,603 INFO Set uid to user 0 succeeded
2021-10-11 17:29:28,605 INFO supervisord started with pid 8
2021-10-11 17:29:29,607 INFO spawned: 'plexmediaserver' with pid 65
2021-10-11 17:29:29,609 INFO spawned: 'shutdown-script' with pid 66
2021-10-11 17:29:29,609 INFO reaped unknown pid 9 (exit status 0)
2021-10-11 17:29:29,629 DEBG 'plexmediaserver' stderr output:
Failed to load preferences at /config/Plex Media Server/Preferences.xml

2021-10-11 17:29:29,630 INFO success: shutdown-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-10-11 17:29:30,631 INFO success: plexmediaserver entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2021-10-11 17:29:31,630 DEBG 'plexmediaserver' stderr output:
Failed to load preferences at /config/Plex Media Server/Preferences.xml
 

Link to comment
12 hours ago, lockrob2000 said:

Failed to load preferences at /config/Plex Media Server/Preferences.xml

i would say this file is corrupt, try renaming it and then restart the container to force regeneration, looking at the file it contains login information and name of server etc, so expect some reconfiguration, alternatively restore this file from your backups from a previous date.

Link to comment
  • 2 weeks later...

I updated to the latest release and getting the container unable to start up.

Created by...
___. .__ .__
\_ |__ |__| ____ | |__ ____ ___ ___
| __ \| |/ \| | \_/ __ \\ \/ /
| \_\ \ | | \ Y \ ___/ > <
|___ /__|___| /___| /\___ >__/\_ \
\/ \/ \/ \/ \/
https://hub.docker.com/u/binhex/

2021-10-21 10:45:45.221305 [info] Host is running unRAID
2021-10-21 10:45:45.249269 [info] System information Linux Tower 5.10.28-Unraid #1 SMP Wed Apr 7 08:23:18 PDT 2021 x86_64 GNU/Linux
2021-10-21 10:45:45.283320 [info] OS_ARCH defined as 'x86-64'
2021-10-21 10:45:45.315574 [info] PUID defined as '99'
2021-10-21 10:45:45.373661 [info] PGID defined as '100'
2021-10-21 10:45:45.450751 [info] UMASK defined as '022'
2021-10-21 10:45:45.480493 [info] Permissions already set for '/config'
2021-10-21 10:45:45.520571 [info] Deleting files in /tmp (non recursive)...
2021-10-21 10:45:45.555228 [warn] TRANS_DIR not defined,(via -e TRANS_DIR), defaulting to '/config/tmp'
2021-10-21 10:45:45.629444 [info] Starting Supervisor...
2021-10-21 10:45:45,924 INFO Included extra file "/etc/supervisor/conf.d/plexmediaserver.conf" during parsing
2021-10-21 10:45:45,924 INFO Set uid to user 0 succeeded
2021-10-21 10:45:45,927 INFO supervisord started with pid 7
2021-10-21 10:45:46,930 INFO spawned: 'plexmediaserver' with pid 71
2021-10-21 10:45:46,932 INFO spawned: 'shutdown-script' with pid 72
2021-10-21 10:45:46,932 INFO reaped unknown pid 8 (exit status 0)
2021-10-21 10:45:47,932 INFO success: plexmediaserver entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2021-10-21 10:45:47,933 INFO success: shutdown-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)

 

I made no changes to the config files just simply updated to latest release.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.