Jump to content
binhex

[Support] binhex - Plex Pass

944 posts in this topic Last Reply

Recommended Posts

First question of course is how do you know it isn't using /mnt/user/appdata/binhex-plexpass?  Do you check that folder?  Beyond that, I don't know anything about what could be causing this.

Share this post


Link to post
1 hour ago, Squid said:

First question of course is how do you know it isn't using /mnt/user/appdata/binhex-plexpass?  Do you check that folder?  Beyond that, I don't know anything about what could be causing this.

 

Thank you, for making me check again :)

Everything's in order - Plex is actually using appdata to store it's library files (all them zillions...).

 

What happened was, I opened the properties for \\THEPIT\appdata\binhex-plexpass in my windows rig, and it showed only ~250MB. I probably panicked, closed it down too fast, while it was "stuck" getting the list of files or some crap. At least it seems this way now, because I just checked the properties for the folder now, and it took more than 10 minutes to finish getting the list of files/folders and the sizes :)

But before, I closed pretty fast, because it looked like it finished. I quickly went to check how much free space was Sonarr showing in it's settings (as it only sees/shows the "inside" size of the docker.img) and it showed about 12.5GB free out of 20GB. So I thought it was plex that used it up, as I remember vaguely, yesterday it was ~17GB free.

 

Anyway - my bad, for the lack of experience with unraid, docker, plex, and linux overall. :) Sorry bout that.

 

On the other hand... the size of the plex folder in appdata is f***in ridiculous...

 

2017-11-04_11-57-40__dllhost.png.e896ee9fb1f5e16cd5bc850e2d6ecd52.png

 

This is the craziest/stupidest thing I have ever seen :/

I hope there's some bullshit going on with that 170GB on disk, because unraid webui shows, that my cache ssd is only 189GB used, and ~100GB of that are usenet and torrent downloads... So... wtf?

 

Either way, that stupidity with 174k of files and 280k of folders is even stupider.

  • Why not use some file-store, something like gridfs or litedb, or somesuch... I wouldn't think that it would impact the performance to unusable levels...
  • How in hell there are 1.5 times more folders than files :) I bet most of the files are not "alone" in them folders, that means there's not 100k+ empty folders, but probably way way more. Probably there's more empty folders that, folders that have anything in them. I seriously do not understand the logic behind this... :/

 

Like I mentioned before - that's not my full collection, far from it. That's ONLY about 1/4 of my tv shows and that's it.

How big it's gonna be, when I'll add the rest of 3/4 of my shows, all my movies, and some music?

Edited by shEiD

Share this post


Link to post
4 minutes ago, shEiD said:

On the hand, the size of the plex folder in appdata is f***in ridiculous...

Windows counts each symlinked file as a separate file, so its size is always completely out to lunch.  If I run properties on my plex folder, (and run it to completion) the size on disk (and the size) is many times larger than the cache drive.

 

The only valid way of getting the size is via the command prompt:

du -h /mnt/user/appdata/binhex-plexpass

  The last line is the total size.

Share this post


Link to post

@Squid

Thanks for the info. Symlinks - that makes sense. Because I was really struggling to explain size: 5.3GB and size on disk: 174.4GB. That's almost 33x :)

 

As I understand XFS is way better with huge numbers of files/folders, than NTFS? Because in windows, having that much crap in MFT really impacts things...

 

Ha.. Copied over the plex folder to a local ssd on my windows rig, and the size on disk is a OK :)

 

2017-11-04_12-58-27__dllhost.png.b25bb212d05f5623b62610c3c1d576dc.png

Edited by shEiD

Share this post


Link to post
5 hours ago, shEiD said:

I chose this docker, because it seems it's the only "plex-pass" version on the app store.

 

because i'm a nice guy :-)  i'm going to point out that the LinuxServer version does indeed also support Plex Pass, just im the only guy who has split plex and plex pass PMS versions.

Share this post


Link to post
On 11/3/2017 at 1:08 PM, Fredrick said:

Well, in conclusion I fucked my previous Plex container good, so I made the switch without moving any config/database :P

 

Was a bit of a pain, worst thing is loosing watched status I guess. A rescan takes time, but not too bad.

 

 

You could sign up for a Trakt account, then add the Trakt plugin (channel) to Plex and it syncs your watched statuses. Then, if you ever have to move your library without database, you can just resync trakt!

Share this post


Link to post

Hello,

 

Not sure where to post this. I read that people have created agents to help Plex search content. I'm trying to create one view my training videos. Of course there names are created  01,02, ect (then name of the training session). Most of the agent are built to work if the server is on a pc or mac not Unraid docker. Is there a better way to do this instead of renaming the files to look like TV series or seasons (S01-EP01)? Just need to be pointed in right direction to update the unraid plex server to view these file together as if they were TV series or season to keep it organized. 

 

Thank you,

Share this post


Link to post

Dear binhex, I'm running the non pass version of your docker on unraid, and it never starts up automatically. (when I reboot my server) Is this a known issue?

Share this post


Link to post
11 hours ago, busa1 said:

Dear binhex, I'm running the non pass version of your docker on unraid, and it never starts up automatically. (when I reboot my server) Is this a known issue?

in a word, no, starts automatically for me every time on boot, you have used the slider to enable it to start on boot right in the unraid web ui/docker tab?.

Share this post


Link to post
3 hours ago, binhex said:

in a word, no, starts automatically for me every time on boot, you have used the slider to enable it to start on boot right in the unraid web ui/docker tab?.

yes of course I have enabled it

Share this post


Link to post
6 hours ago, busa1 said:

yes of course I have enabled it

you got to ask the obvious, i have no idea how technical you are, ok so are you using 'unassigned devices' plugin to store your config or docker image on?, are any other docker containers not starting on boot or is this the only one?, are you using a cache drive to store your config, or are you storing your config on the array?.

 

also please attach the file /config/supervisord.log watch out for anything sensitive.

Share this post


Link to post

All other images start on startup. I don't have a cache drive. I do use unassigned devices plugin, but I don't store anything (important) on them for the docker. Where can I find that /config/supervisord.log?

Share this post


Link to post
11 hours ago, busa1 said:

I do use unassigned devices plugin, but I don't store anything (important) on them for the docker.

when you say anything important, does that include the configuration for each docker container?, what exactly are you storing on the unassigned device?, screenshot of the configuration for the plex docker would def help.

 

11 hours ago, busa1 said:

Where can I find that /config/supervisord.log?

 

its located in the host path that you volume mapped /config to, i cant tell you what that is as it could be anything, so for me its:-

 

/mnt/cache/appdata/config/plex/supervisord.log

Share this post


Link to post

Hey, thanks for your effort, I ended up trying out another version of plex, and that seems to work without any problems. Most of the time I don't have anything plugged in (unassigned drive), and as I mentioned I don't have cache, so I guess you meant, /mnt/user/appdata/...

 

Thanks again for your effort! Seems like I always have some issues with binhex dockers. :/ I really try to give them each a go tho!

Share this post


Link to post
Hey, thanks for your effort, I ended up trying out another version of plex, and that seems to work without any problems. Most of the time I don't have anything plugged in (unassigned drive), and as I mentioned I don't have cache, so I guess you meant, /mnt/user/appdata/...
 
Thanks again for your effort! Seems like I always have some issues with binhex dockers.  I really try to give them each a go tho!
Glad you got it going even if it was by using a different docker image still not sure what your issue is, you re the first person to raise this issue in over 100,000 downloads of this image so I'm confident it's not a general problem.


Sent from my SM-G935F using Tapatalk

Share this post


Link to post

Hi All

 

I've been using binhex plex and its been been great but I just can't get remote access to work. I was looking at other versions and noticed binhex plexpass.

 

What's the difference between the two versions? Should I be looking at the plexpass over the free version?

 

Thanks

 

Paul

Share this post


Link to post

Was going over some settings in my dockers, and was wondering if Privileged was needing to be turned on since the docker is ran as a Host type network?

Share this post


Link to post
On 09/12/2017 at 5:59 PM, IrishBiker said:

Hi All

 

I've been using binhex plex and its been been great but I just can't get remote access to work. I was looking at other versions and noticed binhex plexpass.

 

What's the difference between the two versions? Should I be looking at the plexpass over the free version?

 

Thanks

 

Paul

 

plexpass editions include early access to features that aren't available on the free edition, but generally the features available make it into the free edition fairly quickly, so in my opinion unless you want a particular feature that is only available in plex pass, then you might was well stick with the standard plex edition.

 

remote access works fine for both, i myself use the free edition and it works fine, im assuming you have allowed upnp on your router? or defined the port in plex and port forwarded this on your router right?.

Share this post


Link to post
On 10/12/2017 at 12:58 AM, Acps said:

Was going over some settings in my dockers, and was wondering if Privileged was needing to be turned on since the docker is ran as a Host type network?

no, privileged is not required.

Share this post


Link to post

I have been using the LSIO Plex docker for a few years. Today I bought a lifetime PlexPass membership and updated the LSIO docker by setting the proper version variable. Looks like if I continue to use that docker I will have to manually apply updates in the docker template (waiting for a confirmation of that though).

 

I haven’t completely read through all the posts here yet, but it seems that this docker uses some other method to restrict plexpass access.

 

Does this docker automatically update to the latest plexpass release?

 

How do I configure plexpass credentials?

 

Is it possible to use my current appdata folder with this docker?

Share this post


Link to post
57 minutes ago, wgstarks said:

Does this docker automatically update to the latest plexpass release?

 

yes, every time there is a "release" the image will get automatically built

 

58 minutes ago, wgstarks said:

How do I configure plexpass credentials?

 

you don't need to, just  login with your account once the docker container is running as per normal.

 

58 minutes ago, wgstarks said:

Is it possible to use my current appdata folder with this docker?

 

i would of thought so (not tested), but you may run into permissions issues and possible path differences, so just be cautious about trying it, i would imagine you could copy most of the metadata across without issue though.

Share this post


Link to post
1 hour ago, binhex said:

i would of thought so (not tested), but you may run into permissions issues and possible path differences, so just be cautious about trying it, i would imagine you could copy most of the metadata across without issue though.

Thanks. I’ll do a little testing and see what happens. I think my custom media paths should work as long as they are configured in the app. What default permissions does this docker use?

Share this post


Link to post
Thanks. I’ll do a little testing and see what happens. I think my custom media paths should work as long as they are configured in the app. What default permissions does this docker use?
The default is user 'nobody', group 'users' but you can use whatever user and group you want.

Sent from my SM-G935F using Tapatalk

Share this post


Link to post

Binhex,

 

Hello, and thank you for your enormous amount of very fine work!

 

I am running UnRAID 6.3.5, with DelugeVPN docker (yours, obviously - have an issue I have mentioned in that support thread) and PlexPass docker. When I click on the Photos library I get the following error;

 

There was an error loading the timeline for this library
The photos timeline requires Plex Media Server 1.5.4 or higher
 
Media Server installed version is: Version 1.11.0.4633 - and when I click for update version it tells me it is up to date.
 
I suspect that I am missing somethin obvious, can you assist?
 
Regards
 
Duggie
 
Just got the update - Many Thanks BinHex!
Edited by Duggie264
To Say Thank You!

Share this post


Link to post

Hi,

 

 been using plex pass version and everything was smooth, unraid server with low workload but for the last 2 weeks it just keeps getting search and download all metada again (so it seems). Every search takes hours and unraid work % goes very high of course. I've tried the upgrade unraid since the new stable version was release, i've tried every combination of library search available without any luck. I have another plex server on same network pointing to unRAID data and its behaving normally only downloading new metadata stuff and the searches are very fast.

 

 I cant be 100% sure if this started to happen on the last update on the docker that i've done or it started just before upgrading...

 

 Any pointers? I was hopping for some update on docker to see if it would bring back the good and old stable that i was getting before...

 

Some prints os spikes on usage.

 

Thanks in advance for the time to read this.

Screen Shot 2018-01-22 at 11.50.36.png

Screen Shot 2018-01-22 at 11.50.45.png

Screen Shot 2018-01-22 at 11.50.59.png

Screen Shot 2018-01-22 at 11.51.07.png

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.