Jump to content
binhex

[Support] binhex - Sonarr

355 posts in this topic Last Reply

Recommended Posts

Sonarr to RuTorrent Seedbox corruption

 

Hello again binhex.

As I stated in the Plex thread Im brand new to unraid, but fairly competent.

Everything has been going well with my build-out and past this next issues I have SFTP access left and my build is complete. 

 

Since the plex docker is working so well, I decided to go with your Sonarr client as well.

Im running into an issue though. I have a seedbox with dediseedbox, which houses RuTorrent.

I have Sonarr setup to feed torrents over there (fallback plan) through httprcp.

It seems to connect just fine and I get no error during the connection test.

 

When I add the torrent is where the trouble shows up.

It does communicate with the RuTorrent, and does push a file. The issue is that the file seems to be corrupted.

It shows up in RuTorrent as the hash for the magnet link with an extension of .meta.

It also shows up in the stopped state. If I wait about 15minutes and force it to start it does eventually rename the file based on the magnetlink and start downloading.

One other fun bit of info is that after I force it to start, it strips the label applied by Sonarr.

This is obviously not the automated method I was aiming for.

 

Seems to be a known issue that was resolved.

https://www.reddit.com/r/seedboxes/comments/3lqmnq/local_sonarr_to_seedbox/

Im just not sure if your build includes this fix.

 

PS - After that softball Plex question, bet you thought I was going to give you another easy one.  ;)

Share this post


Link to post

Sonarr to RuTorrent Seedbox corruption

 

Hello again binhex.

As I stated in the Plex thread Im brand new to unraid, but fairly competent.

Everything has been going well with my build-out and past this next issues I have SFTP access left and my build is complete. 

 

Since the plex docker is working so well, I decided to go with your Sonarr client as well.

Im running into an issue though. I have a seedbox with dediseedbox, which houses RuTorrent.

I have Sonarr setup to feed torrents over there (fallback plan) through httprcp.

It seems to connect just fine and I get no error during the connection test.

 

When I add the torrent is where the trouble shows up.

It does communicate with the RuTorrent, and does push a file. The issue is that the file seems to be corrupted.

It shows up in RuTorrent as the hash for the magnet link with an extension of .meta.

It also shows up in the stopped state. If I wait about 15minutes and force it to start it does eventually rename the file based on the magnetlink and start downloading.

One other fun bit of info is that after I force it to start, it strips the label applied by Sonarr.

This is obviously not the automated method I was aiming for.

 

Seems to be a known issue that was resolved.

https://www.reddit.com/r/seedboxes/comments/3lqmnq/local_sonarr_to_seedbox/

Im just not sure if your build includes this fix.

 

PS - After that softball Plex question, bet you thought I was going to give you another easy one.  ;)

 

OK as this is a sonarr issue I would urge you to post this on their forum, I don't believe it's directly related to the fact this is running as a docker. If you just let them know that as of right now your running the very latest release version from github then hopefully they can give you an update on when/if the issue is resolved.

Share this post


Link to post

Hey Binhex,

 

Kudos for the Sonarr docker.

 

I've just transitioned from Sickbeard to Sickrage and now to Sonarr.

 

Not sure if I've set Sonarr up correctly but I think it's looking for downloaded files in my /config directory not my /data directory.

 

Here's my config setup for the docker file:

 

y3mIDPcERXHdgXsnODSulBv-lX77fVEu3bJ9vu6MkxHy61f76y-NMYUzA9nerDf8AkCSUUNkICkrbjUQucXy3hUiCf_TGEjY7PMqMGBp0X1vvhkD0uFwkvuE93T2P0TGOvfB0DFGruRASFQezCWXnD-ag?width=1280&height=62&cropmode=none

 

As you can see, I've specified my docker as per the instructions:

 

Configuration

/config This is where sonarr will store it's configuration file, database and logs.

/data This path is used retrieve the downloaded files by your downloader application.

/media This is where sonarr will scan for media files.

 

Unfortunately, the docker appears to be looking in the /config directory for downloaded files:

 

y3mAExY3J3nrxCWF-edFj_I99L4AY0WvrH_HpFTELl2E2IGb5tqmDqdcUeAdIGmej0g3UU_kpiYgkK10mBPaWvDOSzjz_-_rkpWYW_CSEqf8QPt0p86vYXYaRZeATpp3EhAnue3koUy33uS2a6RvVIaLA?width=1154&height=395&cropmode=none

 

Here's a screenshot of the System Page on the Sonarr GUI:

 

y3m87XMkU0KjHXO93BB4pE3U2vXuV2V05Uhk58V0eeMqk6RngPllBM3xjHhGJoO3kBR31XRgfnybljs9B0qBJH2mLUMpgMy8T62uVdEAb4gIcWRkys5Z3Qbx2IkYba5Nli6G7JH_CG3fVay8inK8ghKJg?width=1168&height=522&cropmode=none

 

I have to carry out a manual import after each show completes its download, not ideal.

 

Here's a screenshot of my log file:

 

y3mMSz1Q2PybspQwzF9QlybmrvOimD7Q2jEWXJcM54REMnV_GQ6Ljv8UvLSFwKxYjUPKe32T2-Ye3OL4QGHoUFfuCoQ6kErzZog66gJTyqnM9mNmc44zLENtxwzyE9oDcdNYPagNPX3IoRy3I73i5ZYVA?width=1272&height=1088&cropmode=none

 

Any help would be appreciated.

 

Cheers

Share this post


Link to post

Hey Binhex,

 

Kudos for the Sonarr docker.

 

I've just transitioned from Sickbeard to Sickrage and now to Sonarr.

 

Not sure if I've set Sonarr up correctly but I think it's looking for downloaded files in my /config directory not my /data directory.

 

Here's my config setup for the docker file:

 

y3mIDPcERXHdgXsnODSulBv-lX77fVEu3bJ9vu6MkxHy61f76y-NMYUzA9nerDf8AkCSUUNkICkrbjUQucXy3hUiCf_TGEjY7PMqMGBp0X1vvhkD0uFwkvuE93T2P0TGOvfB0DFGruRASFQezCWXnD-ag?width=1280&height=62&cropmode=none

 

As you can see, I've specified my docker as per the instructions:

 

Configuration

/config This is where sonarr will store it's configuration file, database and logs.

/data This path is used retrieve the downloaded files by your downloader application.

/media This is where sonarr will scan for media files.

 

Unfortunately, the docker appears to be looking in the /config directory for downloaded files:

 

y3mAExY3J3nrxCWF-edFj_I99L4AY0WvrH_HpFTELl2E2IGb5tqmDqdcUeAdIGmej0g3UU_kpiYgkK10mBPaWvDOSzjz_-_rkpWYW_CSEqf8QPt0p86vYXYaRZeATpp3EhAnue3koUy33uS2a6RvVIaLA?width=1154&height=395&cropmode=none

 

Here's a screenshot of the System Page on the Sonarr GUI:

 

y3m87XMkU0KjHXO93BB4pE3U2vXuV2V05Uhk58V0eeMqk6RngPllBM3xjHhGJoO3kBR31XRgfnybljs9B0qBJH2mLUMpgMy8T62uVdEAb4gIcWRkys5Z3Qbx2IkYba5Nli6G7JH_CG3fVay8inK8ghKJg?width=1168&height=522&cropmode=none

 

I have to carry out a manual import after each show completes its download, not ideal.

 

Here's a screenshot of my log file:

 

y3mMSz1Q2PybspQwzF9QlybmrvOimD7Q2jEWXJcM54REMnV_GQ6Ljv8UvLSFwKxYjUPKe32T2-Ye3OL4QGHoUFfuCoQ6kErzZog66gJTyqnM9mNmc44zLENtxwzyE9oDcdNYPagNPX3IoRy3I73i5ZYVA?width=1272&height=1088&cropmode=none

 

Any help would be appreciated.

 

Cheers

Because your download client is storing the completed download within ITS /config folder and then passing that path name to sonarr.

 

Move completed downloads to (in this case /data) a separate download folder that is mapped to all apps that require access to it.

Share this post


Link to post

Hey Squid,

 

Thanks for the reply.

 

I'm not so sure that is my problem. I use SabNZBD as my download client and specify the downloads to go to it's /data location...

 

y3mmlLZsgEhit2zYJ9OV93_33oIeRxToH_DdvbQQ1CkFm2kWlHka-319QfAu19Y-q0eY39sDUiYUXsgeS6iSDu_2ambizaN-y3XSLBu3fYkovoeKnUZPDkrvopgE1KCZPifEsw752RMB7Z_RixPyE1NNw?width=1302&height=60&cropmode=none

 

That's the same /data location I map for sonarr, so I effectively have in place already what you suggest (unless I'm missing something)

 

Kev

Share this post


Link to post

Are you sure.  The answer lies in sab settings

 

Sent from my LG-D852 using Tapatalk

 

 

Share this post


Link to post

Hey Squid,

 

At the risk of hijacking this thread...

 

Thank you, you are correct. The problem was within Sabnzbd settings. However, I still can't seem to get sonarr to automatically import the downloaded file.

y3ms2sExkjK_TtFpj1dYgYFqEzu-JwRHoraQRQhiCueOcnBF_m9QBWNyTP_rZ46qIGRcr452NVHggXPs4CnppIEBzmGLODrEMHMgD-Pru1ThwuzaNqy9m5TEMgzU1DT48lPxTOCy7yslMhHFQejUqJ_IQ?width=1307&height=548&cropmode=none

 

I can manually import it so the location is accessible from within the sonarr docker.

 

y3mR7H4mrvX5b4Vv83N4oh-V4HTvwS6Ab71icl_Qs6XQt6GrxHQI75PsrKNCFmQjs6feLN2NP28yY_hPFpqt98lo41MezzZayTjGDzFBAvsuthO92sYJpVavYHW3GFSB9S0Tm4ReioDGKeDoR-pZp0d9g?width=1017&height=478&cropmode=none

 

y3mXpB637tVp_NMJmkNQGamm6zg5t1s0d0UOytlKrNw5nxm8gnPP92SxKgpk13U4F5t15YUvcRd8H6zLGbYTdU2LmB8h57mDg2pJy3u3v2w7zDLjFF4Ku0eQW_MYl9-xDw2FuvxNcZTVpxdPqTy2LHfiQ?width=2032&height=1285&cropmode=none

 

Here's the log output:

 

y3m4LQg1FBZSyZ5ec2aZ59QF4SO8o87q8dTb57LjiEYlKdOHfKVAuCWxT1zkqqeVD9UXEZP5LQ2g46KpYMBgH9giH7FmS2AhV5wdTTBUt6Nzr42zg4KBH3m2jCKg95kCen24GdwKwQSdl8LzdeLZhvFDg?width=1240&height=825&cropmode=none

 

I've even tried mapping a remote path for the download client in sonarr settings:

 

y3m0aaMNY1DXqzOSEekarj8vNEmQey25m64wTpwkE8_7INmmjEQl33Rn1JmLIwtZfdTyB_cqkx1NJGpIUEVACMBR5Up8QIkRJPh3jrGaN0cSSaEauRBQJzZuTCdrYm_uIL7_lAy7JjrQiUthpSKdjLktw?width=1195&height=172&cropmode=none

 

I'm sure its just something simple I've overlooked.

 

Thanks again.

Share this post


Link to post

the key here is that on all the docker apps which are required to talk to each other (in this case, sonarr, sab, and probably cp) the mappings (host and container) on the template (edit screen) for the download location (in your case the /data) have to match EXACTLY.  If you've mapped /data to /mnt/cache/downloads/completed on one app, and mapped /data to /mnt/cache/downloads on another the imports are going to fail

 

Share this post


Link to post

the key here is that on all the docker apps which are required to talk to each other (in this case, sonarr, sab, and probably cp) the mappings (host and container) on the template (edit screen) for the download location (in your case the /data) have to match EXACTLY.  If you've mapped /data to /mnt/cache/downloads/completed on one app, and mapped /data to /mnt/cache/downloads on another the imports are going to fail

 

 

This solved my problem!!!

 

Thanks Squid.

Share this post


Link to post

Warning: mkdir(): File exists in /usr/local/emhttp/plugins/dynamix.docker.manager/include/CreateDocker.php on line 23

 

Getting stuck with this error, well atleast i think this is causing me issues. Every time i try and install the sonarr container i end up with "orphan image" in my docker list.

 

Anyone help with a fix?

 

Thanks

Share this post


Link to post

Warning: mkdir(): File exists in /usr/local/emhttp/plugins/dynamix.docker.manager/include/CreateDocker.php on line 23

 

Getting stuck with this error, well atleast i think this is causing me issues. Every time i try and install the sonarr container i end up with "orphan image" in my docker list.

 

Anyone help with a fix?

 

Thanks

Update all of your plugins, there is an WebGUI update which should fix your problems

Share this post


Link to post

Any idea on why I'm getting this error?

 

2016-05-28 21:48:11,965 DEBG fd 8 closed, stopped monitoring <POutputDispatcher at 47665999831192 for <Subprocess at 47665997520192 with name sonarr in state STARTING> (stderr)>

2016-05-28 21:48:11,965 DEBG fd 6 closed, stopped monitoring <POutputDispatcher at 47665997520336 for <Subprocess at 47665997520192 with name sonarr in state STARTING> (stdout)>

2016-05-28 21:48:11,965 INFO exited: sonarr (exit status 1; not expected)

2016-05-28 21:48:11,965 DEBG received SIGCLD indicating a child quit

2016-05-28 21:48:14,969 INFO spawned: 'sonarr' with pid 21

2016-05-28 21:48:14,976 DEBG 'sonarr' stdout output:

The file /usr/lib/mscorlib.dll is an invalid CIL image

Share this post


Link to post

Hey, Im just hoping you'd be able to help.

 

I'm trying to install sonarr on my unraid. I previously had it installed but then uninstalled it. I think.

 

However I keep getting this error when trying to reinstall it.

 

Any ideas?

 

IMAGE ID [latest]: Pulling from binhex/arch-sonarr.
IMAGE ID [3690474eb5b4]: Already exists.
IMAGE ID [ef9dce18c134]: Already exists.
IMAGE ID [4d65b3715530]: Already exists.
IMAGE ID [d8ae627c19db]: Already exists.
IMAGE ID [f9351fdd03b0]: Already exists.
IMAGE ID [1dc4c896bee1]: Already exists.
IMAGE ID [ca7ab442b0d9]: Already exists.
IMAGE ID [09c7e884c149]: Already exists.
IMAGE ID [c6796f6667c7]: Already exists.
IMAGE ID [1a1d7c58a991]: Already exists.
IMAGE ID [3dee3dbe29f0]: Already exists.
IMAGE ID [bbe50559617a]: Already exists.
IMAGE ID [3bfb0b145fdb]: Already exists.
IMAGE ID [62952e5e2d02]: Already exists.
IMAGE ID [10d960fa795b]: Already exists.
IMAGE ID [042d939f522a]: Already exists.
IMAGE ID [eeb5217886db]: Already exists.
IMAGE ID [6519f24e5957]: Already exists.
IMAGE ID [c4279a4cc343]: Already exists.
IMAGE ID [67fba2c47947]: Already exists.
IMAGE ID [34a6dc8d8dad]: Already exists.
IMAGE ID [3540eae68c5b]: Already exists.
IMAGE ID [3a1ebcf2f409]: Already exists.
IMAGE ID [9c694e2ad64a]: Already exists.
IMAGE ID [3b0c0daaaf13]: Already exists. Digest: sha256:5fb24f387957c4272470446e58002fa985ac3a5863f3da89547cd2152510b6ec. Status: Image is up to date for binhex/arch-sonarr:latest.

TOTAL DATA PULLED: 0 B

Share this post


Link to post

It's already installed.  When you uninstalled it you merely removed the container, not the container and image.  Perfectly normal

 

Sent from my LG-D852 using Tapatalk

 

 

Share this post


Link to post

It's already installed.  When you uninstalled it you merely removed the container, not the container and image.  Perfectly normal

 

Sent from my LG-D852 using Tapatalk

 

Thank you, this is what I suspected.

 

Do you have any idea on how I can fix this issue?

 

I have no way off accessing the Sonarr app. I have no idea where to find the particular files to delete them to start again.

 

I have turned off docker and delete the docker.img file and started again, with no luck.

 

Any ideas of what to do?

Share this post


Link to post

It's already installed.  When you uninstalled it you merely removed the container, not the container and image.  Perfectly normal

 

Sent from my LG-D852 using Tapatalk

 

Thank you, this is what I suspected.

 

Do you have any idea on how I can fix this issue?

 

I have no way off accessing the Sonarr app. I have no idea where to find the particular files to delete them to start again.

 

I have turned off docker and delete the docker.img file and started again, with no luck.

 

Any ideas of what to do?

So on a completely empty docker.img its still pulling 0B and telling you the layer exists?

Share this post


Link to post

Hey, Im just hoping you'd be able to help.

 

I'm trying to install sonarr on my unraid. I previously had it installed but then uninstalled it. I think.

 

However I keep getting this error when trying to reinstall it.

 

Any ideas?

 

IMAGE ID [latest]: Pulling from binhex/arch-sonarr.
IMAGE ID [3690474eb5b4]: Already exists.
IMAGE ID [ef9dce18c134]: Already exists.
IMAGE ID [4d65b3715530]: Already exists.
IMAGE ID [d8ae627c19db]: Already exists.
IMAGE ID [f9351fdd03b0]: Already exists.
IMAGE ID [1dc4c896bee1]: Already exists.
IMAGE ID [ca7ab442b0d9]: Already exists.
IMAGE ID [09c7e884c149]: Already exists.
IMAGE ID [c6796f6667c7]: Already exists.
IMAGE ID [1a1d7c58a991]: Already exists.
IMAGE ID [3dee3dbe29f0]: Already exists.
IMAGE ID [bbe50559617a]: Already exists.
IMAGE ID [3bfb0b145fdb]: Already exists.
IMAGE ID [62952e5e2d02]: Already exists.
IMAGE ID [10d960fa795b]: Already exists.
IMAGE ID [042d939f522a]: Already exists.
IMAGE ID [eeb5217886db]: Already exists.
IMAGE ID [6519f24e5957]: Already exists.
IMAGE ID [c4279a4cc343]: Already exists.
IMAGE ID [67fba2c47947]: Already exists.
IMAGE ID [34a6dc8d8dad]: Already exists.
IMAGE ID [3540eae68c5b]: Already exists.
IMAGE ID [3a1ebcf2f409]: Already exists.
IMAGE ID [9c694e2ad64a]: Already exists.
IMAGE ID [3b0c0daaaf13]: Already exists. Digest: sha256:5fb24f387957c4272470446e58002fa985ac3a5863f3da89547cd2152510b6ec. Status: Image is up to date for binhex/arch-sonarr:latest.

TOTAL DATA PULLED: 0 B

 

*sigh* i wish somebody at LT would get this sorted, its a massive PITA, @jonp @tom any word on a fix for this?, ive raised a defect for this if you want to look at it, lots of people are reporting this on lots of different repo's, its been a problem for around 2 weeks now, probably just a tweak to dockerman for the new way to get and compare docker image id, defect:- http://lime-technology.com/forum/index.php?topic=50022.0

Share this post


Link to post

Is it OK to use Sonarr's own 'Install Latest' feature or should we wait for binhex?

 

Thanks.

Share this post


Link to post

Is it OK to use Sonarr's own 'Install Latest' feature or should we wait for binhex?

 

Thanks.

No don't use the built in updaters for any of my dockers, I have already updated this one but your not seeing the update due to unraid bug, to get around this left click the icon in the unraid ui and select edit don't change anything and just click save.

 

Sent from my SM-G900F using Tapatalk

 

 

Share this post


Link to post

Hi

I am really sorry I am total newbie to UNRAID although long time user of SAB, CP and Sonarr for NZB, in windows server. I installed UNRAID, Plex, SAB, CP and Sonarr and paid for UNRAID service to check it all over(and correct some errors).

  I used all Binhex plugins as was told they were well supported and good (will make beer donation when sorted). Now everything is perfect and I am now happy with server with one big exception. My downloads all download fine, unpack and repair then I dont know where they go, they dont appear anywhere in my media folders, please help as I don't want to go back to Winblows.

Many thanks

K

SAB.png.414a446951f7022cd87200e76056adfe.png

Share this post


Link to post

Is it OK to use Sonarr's own 'Install Latest' feature or should we wait for binhex?

 

Thanks.

No don't use the built in updaters for any of my dockers, I have already updated this one but your not seeing the update due to unraid bug, to get around this left click the icon in the unraid ui and select edit don't change anything and just click save.

 

Sent from my SM-G900F using Tapatalk

Many thanks.

Share this post


Link to post

Hi

I am really sorry I am total newbie to UNRAID although long time user of SAB, CP and Sonarr for NZB, in windows server. I installed UNRAID, Plex, SAB, CP and Sonarr and paid for UNRAID service to check it all over(and correct some errors).

  I used all Binhex plugins as was told they were well supported and good (will make beer donation when sorted). Now everything is perfect and I am now happy with server with one big exception. My downloads all download fine, unpack and repair then I dont know where they go, they dont appear anywhere in my media folders, please help as I don't want to go back to Winblows.

Many thanks

K

You probably have to specify in both SAB and sonarr that you need to save the downloads to /downloads.

Also you should map /downloads to /mnt/user/downloads for sonarr too, and instead use /downloads/completed/tv inside sonarr.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now