Jump to content
binhex

[Support] binhex - Sonarr

389 posts in this topic Last Reply

Recommended Posts

Yes.  Your config data is all stored in the appdata file.  So delete the container NOT the appdata then reinstall the container and it'll be exactly the same minus the downloaded files that are stored somewhere in the docker.img

 

Sent from my LG-H815 using Tapatalk

 

 

Share this post


Link to post

Hi

wow, it has worked......I am so happy you will never know. I want to sincerely thank you both for your perseverance with me and your words of encouragement.

Best wishes

K

 

P.S. Just made a small donation

 

High five chbmb :-) and thanks for the donation keymaster, really appreciated.

Wait..... this isn't one of our containers?! lol....

 

What is this arch you speak of?

 

Sent from my LG-H815 using Tapatalk

 

 

Share this post


Link to post

Yes.  Your config data is all stored in the appdata file.  So delete the container NOT the appdata then reinstall the container and it'll be exactly the same minus the downloaded files that are stored somewhere in the docker.img

 

Sent from my LG-H815 using Tapatalk

Reinstall the app via CA's previous apps section.  All of the mappings, ports, etc will all be the exact same as they were.

 

Reinstalling via Available Apps will default the app so you will have to re-enter the mappings, ports, etc

Share this post


Link to post

Hi

wow, it has worked......I am so happy you will never know. I want to sincerely thank you both for your perseverance with me and your words of encouragement.

Best wishes

K

 

P.S. Just made a small donation

 

High five chbmb :-) and thanks for the donation keymaster, really appreciated.

Wait..... this isn't one of our containers?! lol....

 

What is this arch you speak of?

 

Sent from my LG-H815 using Tapatalk

Arch....rival? :-)

 

Sent from my SM-G900F using Tapatalk

 

 

Share this post


Link to post

Hi

thank you I will do that. I am almost scared to say this though - while messing around over last 24 hours I now cannot find my media in Couch potato/ Manage my movies or Headphones scan my albums.....Sorry guys - once these work I am done,,,that is all I have on my server.

Thanks

K

Share this post


Link to post

Unfortunately keymaster until you understand what is happening with folder mappings you'll struggle.  But trust us on this one.

 

Because you got jon to install everything for you it means you never learned how anything works.  Once you understand it, it's very simple, unfortunately it's difficult to explain.

 

Sent from my LG-H815 using Tapatalk

 

 

Share this post


Link to post

Hi

Thank you, Jon didn't install anything, I installed UNRAID and used CA plugin to install Dockers and Fix Common problems to highlight issues as advised in a post some time ago, I had trouble with an Port conflict and some mappings and only then did I hire Jons services to sort that out, after this all my media libraries were visible by the docker apps, but when media downloaded it got lost - now its the other way around :-)

Although Sonarr still sees my media, couch potato and Headphones do not.

Many thanks again

K

Share this post


Link to post

Unfortunately keymaster until you understand what is happening with folder mappings you'll struggle.  But trust us on this one.

 

Because you got jon to install everything for you it means you never learned how anything works.  Once you understand it, it's very simple, unfortunately it's difficult to explain.

 

Sent from my LG-H815 using Tapatalk

 

 

Hi

I read through them but they all seem contradictory, with I use this way and others do this way, this being my issue (I think) => http://lime-technology.com/forum/index.php?topic=40937.msg387919#msg387919

 

But having changed from windows server 2012 R2 for no other reason than I liked the look of unraid, with my pocket $150 lighter and my server mostly offline for 2 weeks I am begining to think this was no more than a folly. My thinking is that if Mr Panozzo's version of the mappings didn't work what chance do I have with my very limited understanding.

  I am giving it one last go this morning then, off back to Mr Gates with tail between legs, thank you very much for your help however, much appreciated.

Frustrated from UK

 

Understanding mappings is a bitch to wrap your head around, and unfortunately like CHBMB (esq.) stated once you understand it, you'll understand it.

 

This is probably the reason for what you stated about contradictory information in the docker FAQ. 

 

The "proper" way of doing it is what I advocated in the FAQ (and what CHBMB (CBE) et al are advocating here)  The contradiction that you noticed is what JustinChase posted in the FAQ about a simpler way of doing it (eg: map /mnt to /mnt) so that how you reference something within the app is the exact same way you wind up referencing it within unRaid itself.  Which direction you take is ultimately up to you, and CHBMB (BRCS) et al will adjust accordingly.

Share this post


Link to post

Although Sonarr still sees my media, couch potato and Headphones do not.

Many thanks again

K

To make everything easier, post screen shots of the edit container screens for CP, headphones and sonarr (and wouldn't hurt to do the same for your dl client)

Share this post


Link to post

I've had sonarr up and running for a few months, but just noticed that folders it creates have the correct nobody/users user and group. However, the folders are set to 755 instead of, what I think it supposed to the correct permissions, of 777.

 

Am I wrong or is 755 correct? If I am right, how do I get sonarr to do it with 777?

Share this post


Link to post

I've had sonarr up and running for a few months, but just noticed that folders it creates have the correct nobody/users user and group. However, the folders are set to 755 instead of, what I think it supposed to the correct permissions, of 777.

 

Am I wrong or is 755 correct? If I am right, how do I get sonarr to do it with 777?

 

This will be related to the umask setting, i dont really use sonarr, can you just double check there isnt a setting in the sonarr ui for this before i implement a manual umask setting, it might be ref as "permissions for files/folder created" or some such wording.

Share this post


Link to post

Pretty sure there is a setting in Sonarr for this.  May need to switch advanced options on.  As always I may be wrong.

 

Sent from my LG-H815 using Tapatalk

 

 

Share this post


Link to post

For some reason, my sonarr instance just stopped working after having no problems for months. No idea when it stopped working, and when I try to restart the container, the icon stays in a "stopped" state and the logs don't update with any new infromation (all datetime stamps are logs from yesterday 7/18/2016 instead of today)

 

Update: Got this re-working by doing a "Force Update" after turning on advanced view on the Unraid docker page.

Share this post


Link to post

Just updated and I now get this error -

 

your mono version 4.4.0 has a bug that causes issues connecting to indexers/download clients

 

How do I update Mono?

Share this post


Link to post

Just updated and I now get this error -

 

your mono version 4.4.0 has a bug that causes issues connecting to indexers/download clients

 

How do I update Mono?

Short answer, you don't.

 

You wait for arch linux to update it in their repository and then either wait for binhex to update the docker or exec in and update it manually.

 

From what I've read I'm not even sure an upgrade is what we want, it may be fixed by downgrading to 4.2.

 

This doesn't look like a simple issue.

 

 

Share this post


Link to post

Any idea what this error I'm getting is? Trying to connect to delugevpn and it won't work. This is what supervisord.log says...

 

2016-10-28 22:07:06,065 DEBG 'sonarr' stdout output:
[Fatal] NzbDroneErrorPipeline: Request Failed 

[v2.0.0.4370] System.FormatException: Input string was not in a correct format.
  at System.Number.StringToNumber (System.String str, NumberStyles options, System.NumberBuffer& number, System.Globalization.NumberFormatInfo info, Boolean parseDecimal) <0x2ac214267110 + 0x000e1> in <filename unknown>:0 
  at System.Number.ParseInt32 (System.String s, NumberStyles style, System.Globalization.NumberFormatInfo info) <0x2ac214265ef0 + 0x00094> in <filename unknown>:0 
  at System.Int32.Parse (System.String s, NumberStyles style, IFormatProvider provider) <0x2ac214244b40 + 0x00034> in <filename unknown>:0 
  at System.Convert.ToInt32 (System.String value, IFormatProvider provider) <0x2ac2141dfc00 + 0x0002b> in <filename unknown>:0 
  at System.String.System.IConvertible.ToInt32 (IFormatProvider provider) <0x2ac2142ed6c0 + 0x00011> in <filename unknown>:0 
  at System.Convert.ToInt32 (System.Object value) <0x2ac2141df580 + 0x000ce> in <filename unknown>:0 
  at NzbDrone.Api.ClientSchema.SchemaBuilder.ReadFromSchema (System.Collections.Generic.List`1 fields, System.Type targetType) <0x40b69e00 + 0x00336> in <filename unknown>:0 
  at NzbDrone.Api.ProviderModuleBase`3[TProviderResource,TProvider,TProviderDefinition].MapToModel (NzbDrone.Api.TProviderDefinition definition, NzbDrone.Api.TProviderResource resource) <0x40b69ab0 + 0x00123> in <filename unknown>:0 
  at NzbDrone.Api.DownloadClient.DownloadClientModule.MapToModel (NzbDrone.Core.Download.DownloadClientDefinition definition, NzbDrone.Api.DownloadClient.DownloadClientResource resource) <0x40b69a50 + 0x0001f> in <filename unknown>:0 
  at NzbDrone.Api.ProviderModuleBase`3[TProviderResource,TProvider,TProviderDefinition].GetDefinition (NzbDrone.Api.TProviderResource providerResource, Boolean includeWarnings, Boolean validate) <0x40b699b0 + 0x00053> in <filename unknown>:0 
  at NzbDrone.Api.ProviderModuleBase`3[TProviderResource,TProvider,TProviderDefinition].Test (NzbDrone.Api.TProviderResource providerResource) <0x40b69920 + 0x0001b> in <filename unknown>:0 
  at NzbDrone.Api.ProviderModuleBase`3[TProviderResource,TProvider,TProviderDefinition].<.ctor>b__1_1 (System.Object x) <0x40b64a70 + 0x0002f> in <filename unknown>:0 
  at (wrapper dynamic-method) System.Object:CallSite.Target (System.Runtime.CompilerServices.Closure,System.Runtime.CompilerServices.CallSite,System.Func`2<object, object>,object)
  at Nancy.Routing.Route+<>c__DisplayClass4.<Wrap>b__3 (System.Object parameters, CancellationToken context) <0x40ac8ef0 + 0x0014f> in <filename unknown>:0 

Share this post


Link to post

Just updated and I now get this error -

 

your mono version 4.4.0 has a bug that causes issues connecting to indexers/download clients

 

How do I update Mono?

Short answer, you don't.

 

You wait for arch linux to update it in their repository and then either wait for binhex to update the docker or exec in and update it manually.

 

From what I've read I'm not even sure an upgrade is what we want, it may be fixed by downgrading to 4.2.

 

This doesn't look like a simple issue.

Whilst I investigate this if anybody wants to roll back then simply edit the sonarr container and insert the tagged version that last worked for you after the repository name, using a colon to separate from tag name. List of tagged versions here:-

 

https://hub.docker.com/r/binhex/arch-sonarr/tags/

 

Sent from my SM-G900F using Tapatalk

 

Share this post


Link to post

I was worried it wasn't going to grab anything but last night it did so I'm hoping we're good for now. Thanks.

Share this post


Link to post

Quick FYI, i have now updated the base image, which will now ref the latest version of mono (4.6.3.1), so please pull down the latest built docker image and give it a whirl.

 

p.s there has also been an update to sonarr, so this is now built with sonarr v2.0.0.4374

Share this post


Link to post

Quick FYI, i have now updated the base image, which will now ref the latest version of mono (4.6.3.1), so please pull down the latest built docker image and give it a whirl.

 

p.s there has also been an update to sonarr, so this is now built with sonarr v2.0.0.4374

Looks ok. I never had any issues except the warning, so I'm not sure there ever was a widespread issue, probably just some specific indexers would have problems.

Share this post


Link to post

Hey all,

I am currently having an issue where Sonarr will send files to nzbget and download successfully but in the queue I am getting "no files are eligible for import" My nzb get saves to /mnt/user/Completed_Downloads . The tv shows download into a folder called 'tv' at completed_downloads/completed/

 

and my sonarr /data points to

 

/mnt/user/Completed_Downloads/downloads/completed/

 

this is where the tv folder is.

 

Please Help! everything was working before I updated!!

 

Thanks

 

T

Share this post


Link to post

Hey all,

I am currently having an issue where Sonarr will send files to nzbget and download successfully but in the queue I am getting "no files are eligible for import" My nzb get saves to /mnt/user/Completed_Downloads . The tv shows download into a folder called 'tv' at completed_downloads/completed/

 

and my sonarr /data points to

 

/mnt/user/Completed_Downloads/downloads/completed/

 

this is where the tv folder is.

 

Please Help! everything was working before I updated!!

 

Thanks

 

T

http://lime-technology.com/forum/index.php?topic=40937.msg488507#msg488507

Share this post


Link to post

Just found your dockers and love them.  Moved all my download stuff from a windows box where they have sat for 3 years and onto dockers on my unraid box.  So far I have been really impressed.  The only issue is that sonarr gui will not accept connections after it is restarted.  I get it all configured and its happy and working.  Reboot the server or stop and start the array and it starts rejecting connections.

 

It SEEMS to be listening

root@Hypnotoad:/mnt/user/appdata/binhex-sonarr/logs# netstat -an | grep 8082

tcp        0      0 0.0.0.0:8082            0.0.0.0:*              LISTEN

 

and when i check logs after startup it doesnt show any errors that just jump out

 

17-1-17 10:47:27.0|Info|AppFolderInfo|Data directory is being overridden to [/config]

17-1-17 10:47:27.3|Info|MigrationLogger|*** Migrating data source=/config/nzbdrone.db;cache size=-10485760;datetimekind=Utc;journal mode=Wal;pooling=True;version=3 ***

17-1-17 10:47:27.5|Info|MigrationLogger|*** Migrating data source=/config/logs.db;cache size=-10485760;datetimekind=Utc;journal mode=Wal;pooling=True;version=3 ***

17-1-17 10:47:27.5|Info|Router|Application mode: Interactive

17-1-17 10:47:27.5|Info|OwinHostController|Listening on the following URLs:

17-1-17 10:47:27.5|Info|OwinHostController|  http://*:8082/

17-1-17 10:47:27.7|Info|NancyBootstrapper|Starting NzbDrone API

17-1-17 10:51:28.6|Info|RssSyncService|Starting RSS Sync

17-1-17 10:51:52.1|Info|DownloadDecisionMaker|Processing 714 releases

17-1-17 10:52:03.5|Info|RssSyncService|RSS Sync Completed. Reports found: 714, Reports grabbed: 0, Reports pending: 19

 

But just refuses connections

I am waiting to see if it is just that slow to finish loading but i can not imagine it would be. 

Share this post


Link to post

Just found your dockers and love them.  Moved all my download stuff from a windows box where they have sat for 3 years and onto dockers on my unraid box.  So far I have been really impressed.  The only issue is that sonarr gui will not accept connections after it is restarted.  I get it all configured and its happy and working.  Reboot the server or stop and start the array and it starts rejecting connections.

 

It SEEMS to be listening

root@Hypnotoad:/mnt/user/appdata/binhex-sonarr/logs# netstat -an | grep 8082

tcp        0      0 0.0.0.0:8082            0.0.0.0:*              LISTEN

 

and when i check logs after startup it doesnt show any errors that just jump out

 

17-1-17 10:47:27.0|Info|AppFolderInfo|Data directory is being overridden to [/config]

17-1-17 10:47:27.3|Info|MigrationLogger|*** Migrating data source=/config/nzbdrone.db;cache size=-10485760;datetimekind=Utc;journal mode=Wal;pooling=True;version=3 ***

17-1-17 10:47:27.5|Info|MigrationLogger|*** Migrating data source=/config/logs.db;cache size=-10485760;datetimekind=Utc;journal mode=Wal;pooling=True;version=3 ***

17-1-17 10:47:27.5|Info|Router|Application mode: Interactive

17-1-17 10:47:27.5|Info|OwinHostController|Listening on the following URLs:

17-1-17 10:47:27.5|Info|OwinHostController|  http://*:8082/

17-1-17 10:47:27.7|Info|NancyBootstrapper|Starting NzbDrone API

17-1-17 10:51:28.6|Info|RssSyncService|Starting RSS Sync

17-1-17 10:51:52.1|Info|DownloadDecisionMaker|Processing 714 releases

17-1-17 10:52:03.5|Info|RssSyncService|RSS Sync Completed. Reports found: 714, Reports grabbed: 0, Reports pending: 19

 

But just refuses connections

I am waiting to see if it is just that slow to finish loading but i can not imagine it would be.

 

hmm odd, so you cant connect to the webui at all i am assuming right? there are no error messages displayed in your browser?, this is probably one for the sonarr forum tbh, as they will have experience with diagnosing issues specific to sonarr, i wouldn't of thought this is related to the fact its running as a docker container, but feel free to post back here if the sonarr guys think otherwise :-).

 

one other thought is this could be firewall related, i have no idea if you are a unraid user or not, if your not using unraid as your host os then it could be a software firewall running on your host that is causing the issue so that might be worth looking into too.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now