[Support] binhex - Sonarr


1047 posts in this topic Last Reply

Recommended Posts

  • Replies 1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

So, Sonarr v3 is FINALLY here, its out of beta and is now the latest release, if you want to switch from Sonarr v2 to v3 then simply pull down the 'latest' tagged image.   However, if you wa

@SavagelyCalm I have the same problem.   Edit your Docker repository link to this "binhex/arch-sonarr:v3" and it'll re-download a working version.  Worked for me. 

guys it looks like sonarr V3 has finally dropped and is now the latest release so I need to make some minor adjustments for the image and this will fix it all up Sent from my CLT-L09 using Tapatalk

Posted Images

16 hours ago, idmanager said:

Hi binhex,

Any chance you can make a alpha v3 version would love to try it on my unraid box

Or an you tell me how to update your version. 

sorry, i dont build against alpha/beta versions, i only push new images when a github 'release' comes out. if you are keen on testing unstable code then you might have better luck using the linuxserver version which may allow you to specify the version you want to use.

Link to post
  • 2 weeks later...

Please forgive me, im still new to servers and network. So im not sure if its Sonarr related or due to my download clients run though VPN aswell.

 

Anyway, I have an issue with Sonarr not connecting to rTorrentNPN or SABnbdVPN in br0 mode. Sonarr cant find my downloaders then.

The reason I want to do this, is because I have several downloaders and I run with remote path mapping to make sure Sonarr grabs files from the correct folder (my downloaders are mapped directly to the subfolders)

 

My optimal solution was to keep the containers in bridge mode and connect to the downloaders with hostname :) ( have added a hostname parameter to containers)

 

I have made a workarround, but imo not a viable solution if I get more downloaders.

image.thumb.png.082dfa08fad386b703697eb0db37eea3.png

 

Link to post

Hi binhex.

 

I've got a couple of seedboxes and i've confirmed that the details are correct but from sonarr, I cant add rtorrent and i'm getting the following error:

 

"Unknown exception: Unable to connect to rTorrent, please check your settings"

 

This is in the log:

 

NzbDrone.Core.Download.Clients.DownloadClientUnavailableException: Unable to connect to rTorrent, please check your settings ---> System.Net.WebException: Error getting response stream (ReadDone1): ReceiveFailure ---> System.IO.IOException: Unable to read data from the transport connection: Connection reset by peer. ---> System.Net.Sockets.SocketException: Connection reset by peer
  at System.Net.Sockets.Socket.EndReceive (System.IAsyncResult asyncResult) [0x00012] in <d20fbe87d63d4e8fbcf29be00955552d>:0 
  at System.Net.Sockets.NetworkStream.EndRead (System.IAsyncResult asyncResult) [0x00057] in <d20fbe87d63d4e8fbcf29be00955552d>:0 
   --- End of inner exception stack trace ---
  at Mono.Security.Protocol.Tls.SslStreamBase.EndRead (System.IAsyncResult asyncResult) [0x0004b] in <84ba6a01d7f34e6198d3216656f7c79a>:0 
  at Mono.Net.Security.Private.LegacySslStream.EndRead (System.IAsyncResult asyncResult) [0x00006] in <d20fbe87d63d4e8fbcf29be00955552d>:0 
  at System.Net.WebConnection.ReadDone (System.IAsyncResult result) [0x00027] in <d20fbe87d63d4e8fbcf29be00955552d>:0 
   --- End of inner exception stack trace ---
  at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00058] in <d20fbe87d63d4e8fbcf29be00955552d>:0 
  at System.Net.HttpWebRequest.GetResponse () [0x0000e] in <d20fbe87d63d4e8fbcf29be00955552d>:0 
  at CookComputing.XmlRpc.XmlRpcClientProtocol.GetWebResponse (System.Net.WebRequest request) [0x00014] in <9d687fb9c46d481292a78781773c6116>:0 
  at CookComputing.XmlRpc.XmlRpcClientProtocol.Invoke (System.Object clientObj, System.Reflection.MethodInfo mi, System.Object[] parameters) [0x0015a] in <9d687fb9c46d481292a78781773c6116>:0 
  at CookComputing.XmlRpc.XmlRpcClientProtocol.Invoke (System.Reflection.MethodInfo mi, System.Object[] Parameters) [0x00000] in <9d687fb9c46d481292a78781773c6116>:0 
  at XmlRpcProxy435e6772-8fa5-4abf-8b45-99bd85ffcb75.GetVersion () [0x00011] in <e1d1386d165d4fbfa3b6ea2fe273df78>:0 
  at NzbDrone.Core.Download.Clients.RTorrent.RTorrentProxy+<>c__DisplayClass2_0.<GetVersion>b__0 () [0x00000] in <85e2f5295c104ca3a3bcaa59e805585a>:0 
  at NzbDrone.Core.Download.Clients.RTorrent.RTorrentProxy.ExecuteRequest[T] (System.Func`1[TResult] task) [0x00000] in <85e2f5295c104ca3a3bcaa59e805585a>:0 
   --- End of inner exception stack trace ---
  at NzbDrone.Core.Download.Clients.RTorrent.RTorrentProxy.ExecuteRequest[T] (System.Func`1[TResult] task) [0x00022] in <85e2f5295c104ca3a3bcaa59e805585a>:0 
  at NzbDrone.Core.Download.Clients.RTorrent.RTorrentProxy.GetVersion (NzbDrone.Core.Download.Clients.RTorrent.RTorrentSettings settings) [0x00023] in <85e2f5295c104ca3a3bcaa59e805585a>:0 
  at NzbDrone.Core.Download.Clients.RTorrent.RTorrent.TestConnection () [0x0000c] in <85e2f5295c104ca3a3bcaa59e805585a>:0 

Link to post
  • 3 weeks later...

It's me again!!

I'm getting this message in the sonarr log:

 

Import failed, path does not exist or is not accessible by Sonarr: /downloads/Sort/TV/The.Circus.S03E12.HDTV.x264-aAF[rarbg]

 

My docker paths look like this:

image.thumb.png.bf04032e6cfbcbb6ffcc64139825661b.png

 

This is how qbit is setup.

 

image.png.81efd4644e35cf270ff48de17a86176d.png

 

Thanks

 

EDIT:

I changed my share from "Downloads" to "downloads" remapped everything in sonarr, and in qbit, and changed the /media to /downloads in the sonarr container and my media is being sorted now, i do now see this in sonarr though.

 

image.png.066db7ad4c7f5a3f8aadff1b60d67d62.png

Edited by karldonteljames
Link to post

Because the host path mappings don't match between containers. The other two are using /data and qbit is using /downloads. Edit qbit accordingly then change its settings to store into /data

Sent from my SM-T560NU using Tapatalk

Link to post

Does anyone have a solution to having sonarr continue to import downloaded files? I will get my setup to work for a few days and then it stops importing files. I have to manually import under the wanted tab. The files are being sent to deluge or nzbget. It doesn't appear that sonarr is either being notified or looks in the folder. I read that there can be issues with the directories staying active over different operating systems. I am using the ben-hex delugevpn docker and this sonarr docker. Any settings I can change to be able to have the log pull up more details? THhe log right now does not show files being passed back to sonarr.

Link to post
2 minutes ago, torn8o said:

Does anyone have a solution to having sonarr continue to import downloaded files? I will get my setup to work for a few days and then it stops importing files. I have to manually import under the wanted tab. The files are being sent to deluge or nzbget. It doesn't appear that sonarr is either being notified or looks in the folder. I read that there can be issues with the directories staying active over different operating systems. I am using the ben-hex delugevpn docker and this sonarr docker. Any settings I can change to be able to have the log pull up more details? THhe log right now does not show files being passed back to sonarr.

You're sure the log doesn't state "failed to import...."

Link to post

I do have the error but it is only for a file that I deleted and sonarr is trying to import it. Trying to figure out how to clear that out of the logs. This maybe because I deleted all the downloaded files in the download folder. I will clear my logs and check it in a bit.

Link to post

Hi all, thanks in advance for support, it's much appreciated.

 

My situation is I'm moving to Unraid from a windows sonarr/sabnzbd host. I was able to take a backup from radarr and shove it into /mnt/user/appdata/binhex-radarr then startup then use the UI to change the root folders of everything. However I don't get that far with Sonarr, it starts up, log file attached, but then it complains heavily about all the paths not being *nix paths, but you can't get into the web ui. 

 

I thought I'd get around this by just editing the SQLite database. I can see the RootFolders table which is easy enough to update, I can fix the index (because I did have 5 folders, now I'll have only 1), but I went looking at where RootFolders.Id is referenced and for the life of me It's just not that obvious. So I didn't proceed.

 

Can anyone tell me the best method to successfully migrate a DB from windows to linux? Or why my Web UI won't spin up? Or what SQL paths to update if I go ahead and update the database?

sonarr.txt

 

[edit] I noticed that RootFolders isn't referenced by foreign key, it's just used to form the first part of series.path so I updated those to be correct, reset the rootfolders table and updated episodefiles.relativepath to have a / instead of \. However it still doesn't start up. Now it's much more pleasant though, it just says starting web server in the log (sonarr2.txt). [/edit]

 

[edit] DISREGARD! Figured it out. I was copying in a config.xml file with the wrong port... dah...[/edit]

Edited by dgwharrison
Link to post

Question, from binhex-sonarr I add my download client with hostname binhex-sabnzbd but when I test it fails. However if I use the 172.17.0.2 IP address assigned to the binhex-sabnzbd docker it works. I've tried with and without the local TLD (fritz.box in my case, from my router). Any ideas?

Edited by dgwharrison
Link to post
3 hours ago, dgwharrison said:

Question, from binhex-sonarr I add my download client with hostname binhex-sabnzbd but when I test it fails. However if I use the 172.17.0.2 IP address assigned to the binhex-sabnzbd docker it works. I've tried with and without the local TLD (fritz.box in my case, from my router). Any ideas?

Generally, you would reference the IP address of the server with the applicable port number

Link to post
  • 2 weeks later...

Hey all,

 

Has anyone had an issue with Sonarr hammering your CPU (regardless of any pinning settings) at 100%? This has been happening for a while to me. Looking at top, I get:  /usr/bin/mono --debug /usr/lib/sonarr/NzbDrone.exe -nobrowser -data=/config

 

I have around 16 or so lines of that in top with each one using 10-20% CPU. Restarting Sonarr solves it until it (seemingly) randomly starts again. I've gotten to the point where I have a script restarting Sonarr every few hours, but lately I've still had to check it manually and see if it is out of control.

 

Anyone seeing this or have any ideas?

 

Thanks!

Link to post

I know that when I re setup my sonarr / radarr (in conjunction with NZBGet), one of them failed the test if I didn't include the category

 

Doesn't cost anything to try (and only helps with the organization in the completed downloads folder)

Link to post

Ok that worked so thankyou for that tip, now I am having issues with TV shows not being renamed correctly or moved, again this is not an issue for Radarr only Sonarr. I followed the setup guide in the video below when it came to setting up the downloads folder, I then set it up the same in Sab and Sonarr and Radarr as per the video. I noticed while watching the video that the Downloads folder location appears to be different depending on the Docker install, I added a couple of screenshots below showing all the points in the videos where SpaceinvaderOne sets up a share, docker etc.

 

 

 

 

delugevpnSIO.PNG

downloadsshareSIO.PNG

radarrSIO.PNG

sabsetupSIO.PNG

sonarrSIO.PNG

Link to post

Your path mappings don't match between the containers

 

Some of the containers are using /data for /mnt/user/downloads, and others are using /downloads.  You've got to keep it consistent between all of them.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.