Jump to content
binhex

[Support] binhex - Sonarr

836 posts in this topic Last Reply

Recommended Posts

2 minutes ago, wgstarks said:

Is the episode actually in the completed folder?

Yes. They are moved to the completed folder after they have finished downloading.

 

Share this post


Link to post
24 minutes ago, Lien1454 said:

Yes. They are moved to the completed folder after they have finished downloading.

 

On Sonarr if I go into Console then into Data folder I can access the competed folder and see the folders with the episode in.

Edited by Lien1454

Share this post


Link to post
12 minutes ago, Lien1454 said:

On Sonarr if I go into Console then into Data folder I can access the competed folder and see the folders with the episode in.

That's the problem. Sonarr is looking in /downloads, not /data. Somewhere in one of your mappings you have that set wrong.

Share this post


Link to post
1 minute ago, jonathanm said:

That's the problem. Sonarr is looking in /downloads, not /data. Somewhere in one of your mappings you have that set wrong.

Where could that be? In Sonarr GUI ?

Share this post


Link to post

Why don’t you post a screenshot of your docker tab showing the port mappings for  Sonarr and Deluge.

Share this post


Link to post

OK, apparently, Radarr can still add items to Deluge, but the "connection test" fails.  Honestly, at that point, it doesn't matter now that I have a Deluge 2.0 client (I run Linux Mint so I don't have the "windows" problem that others do.

 

I'll go back to the other threads and edit them.

Share this post


Link to post

Hey Friends,

 

Been running Unraid fine for a few months now with Sonarr/Radarr etc....the basics will you. 

 

Went to go add a new show to my Sonarr today and I can't seem to access the WebUI....I have tried restarting the docker, stopping other dockers, reinstalling the docker, as well as rebooting the server.  All to no avail.

 

Any help would be greatly appreciated.

 

Edit: I should add all other dockers seem to be working fine.

 

image.png.5c8ee411cec6f6c293dc29125ec70495.png

 

Edited by WhatPlantsCrave

Share this post


Link to post
45 minutes ago, WhatPlantsCrave said:

Hey Friends,

 

Been running Unraid fine for a few months now with Sonarr/Radarr etc....the basics will you. 

 

Went to go add a new show to my Sonarr today and I can't seem to access the WebUI....I have tried restarting the docker, stopping other dockers, reinstalling the docker, as well as rebooting the server.  All to no avail.

 

Any help would be greatly appreciated.

 

Edit: I should add all other dockers seem to be working fine.

 

image.png.5c8ee411cec6f6c293dc29125ec70495.png

 

https://forums.unraid.net/topic/57181-real-docker-faq/#comment-564345

 

Share this post


Link to post
3 hours ago, WhatPlantsCrave said:

Hope you have a backup :)
[v2.0.0.5322] NzbDrone.Core.Datastore.CorruptDatabaseException: Database file: /config/nzbdrone.db is corrupt, restore from backup if available. See: https://github.com/Sonarr/Sonarr/wiki/FAQ#i-am-getting-an-error-database-disk-image-is-malformed ---> System.Data.SQLite.SQLiteException: database disk image is malformed database disk image is malformed

This is from your log ^^

Share this post


Link to post
1 hour ago, ProZac said:

Hope you have a backup :)
[v2.0.0.5322] NzbDrone.Core.Datastore.CorruptDatabaseException: Database file: /config/nzbdrone.db is corrupt, restore from backup if available. See: https://github.com/Sonarr/Sonarr/wiki/FAQ#i-am-getting-an-error-database-disk-image-is-malformed ---> System.Data.SQLite.SQLiteException: database disk image is malformed database disk image is malformed

This is from your log ^^

Don't think I do :/  Mostly just followed spaceinvader's guides when getting setup and I don't think that covered a back up.  What exactly should I be backing up in the future?

 

Edit:  Also pardon me for being a bit new to this side of computing....I am not really sure after reading through that guide how I would execute that in an Unraid platform?  Sorry mostly windows based user prior to this server build.

 

Second Edit:  It looks like Sonarr was potentially backing itself up?  Within the appdata it has a Backups -> scheduled folder with 4 backups in it between now and 05/15

 

Ok Final Edit: Removing the old Database and replacing with a backup worked.  TY for the help everyone :)

Edited by WhatPlantsCrave

Share this post


Link to post
18 minutes ago, WhatPlantsCrave said:

What exactly should I be backing up in the future

Use CA Backup/Restore to backup your appdata.

Share this post


Link to post
12 hours ago, WhatPlantsCrave said:

Ok Final Edit: Removing the old Database and replacing with a backup worked.  TY for the help everyone :)

Great that your backup worked :) There have been some issues for various people with sqlite database corruption since Unraid v 6.7, so I would pay attention to it during the next days/weeks to make sure it stays stable :)

 

Share this post


Link to post

Hi guys,

 

I was wondering if i add a serie would sonarr create a folder for it and move the data for me ?

 

Or do i have to use another docker also ?

 

thx

Share this post


Link to post
On 6/25/2019 at 11:29 AM, francrouge said:

Hi guys,

 

I was wondering if i add a serie would sonarr create a folder for it and move the data for me ?

 

Or do i have to use another docker also ?

 

thx

If you add a show in sonarr, and you have given sonarr the correct access, it will create the folder yes. It will also move files if it finds them in the correct location. Just fyi, if you have downloaded/added the files before you add the show to sonarr, you might have to manualy import them.

Share this post


Link to post

Hey guys just set this up with Unraid + Sonarr + Sab + Plex.   Everything works except it doesn't grab automatically, i have to click the automatic search, then it downloads and puts it into Plex.  How do i make it grab automatically?

Share this post


Link to post
8 hours ago, xman111 said:

Hey guys just set this up with Unraid + Sonarr + Sab + Plex.   Everything works except it doesn't grab automatically, i have to click the automatic search, then it downloads and puts it into Plex.  How do i make it grab automatically?

It all depends on how you add the show. The monitor status will tell your system if it should actively search for episodes or not. Then you have the add button on the end, where you can select just Add or the Add and Search for missing episodes.
image.png.d604786c9fdc5a747ab8f6a261a51dd1.png

Share this post


Link to post

I just selected future shows then hit add, is that right?  Or should i have selected the seach icon instead?  i didn't care about the past shows.

Edited by xman111

Share this post


Link to post

I searched and didn't see any previous discussion, but does the HTTPS/SSL port not work?

I noticed that Sonarr is configured to run HTTPS on 9898, which doesn't match the default exposed container port of 9897.

But even after getting those to match, I can't access sonarr over SSL. Before I look more into https://github.com/Sonarr/Sonarr/wiki/SSL I thought I'd ask here.

 

Share this post


Link to post

Small problem, when download completes, Sonarr moves the file(s), and it deletes the file at the download location. 

Is there someway to stop the deletion, as I did not have this on my last setup, as I move the downloads for other use,  I know that this will leave me with two copies.

Share this post


Link to post
7 hours ago, Leverz said:

Small problem, when download completes, Sonarr moves the file(s), and it deletes the file at the download location. 

Is there someway to stop the deletion, as I did not have this on my last setup, as I move the downloads for other use,  I know that this will leave me with two copies.

on the Download Client tab>Completed Download Handling>Remove>set to No.

Share this post


Link to post
5 hours ago, wgstarks said:

on the Download Client tab>Completed Download Handling>Remove>set to No.

I have this at no already, I'm sorry I was tired last when I posed, I thought I had added that I had already set that to no.
image.png.5c13d6967e32c92fa1d9de6aa4c28b5d.png

Share this post


Link to post

I'm having an issue with Sonarr not moving completed downloads. I believe it's related to this error found in the logs:
oz1TCNj.png

[v2.0.0.5322] Marr.Data.DataMappingException: The DataMapper was unable to load the following field: 'InitialFailure' value: ''. String was not recognized as a valid DateTime. ---> System.FormatException: String was not recognized as a valid DateTime.

Has anyone run into this error before and maybe know a solution? I've tried searching but I can only find general info on Stackoverflow not related to Sonarr.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.