[Support] binhex - Sonarr

1069 posts in this topic Last Reply

Recommended Posts

For the past few months I've been struggling to keep Sonarr and Radarr connected to DelugeVPN. They'll disconnect from Deluge throwing an error saying "Maximum number of open connections reached" and I haven't been able to find anything to fix it aside from restart the Deluge docker and retry the connection in Sonarr and Radarr. It'll work for about 5 minutes after connecting and then drop again. 


20-2-5 09:32:09.2|Warn|HttpClient|HTTP Error - Res: [POST] 503.ServiceUnavailable
Maximum number of open connections reached.

20-2-5 09:32:09.3|Warn|DownloadMonitoringService|Unable to retrieve queue and history items from Deluge

[v2.0.0.5338] NzbDrone.Core.Download.Clients.DownloadClientException: Unable to connect to Deluge, please check your settings ---> NzbDrone.Common.Http.HttpException: HTTP request failed: [503:ServiceUnavailable] [POST] at []
  at NzbDrone.Common.Http.HttpClient.Execute (NzbDrone.Common.Http.HttpRequest request) [0x00133] in M:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Common\Http\HttpClient.cs:100 
  at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.ExecuteRequest[TResult] (NzbDrone.Common.Http.JsonRpcRequestBuilder requestBuilder, System.String method, System.Object[] arguments) [0x0000e] in M:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:245 
   --- End of inner exception stack trace ---
  at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.ExecuteRequest[TResult] (NzbDrone.Common.Http.JsonRpcRequestBuilder requestBuilder, System.String method, System.Object[] arguments) [0x00062] in M:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:261 
  at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.ProcessRequest[TResult] (NzbDrone.Core.Download.Clients.Deluge.DelugeSettings settings, System.String method, System.Object[] arguments) [0x00008] in M:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:212 
  at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.GetTorrentsByLabel (System.String label, NzbDrone.Core.Download.Clients.Deluge.DelugeSettings settings) [0x00012] in M:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:96 
  at NzbDrone.Core.Download.Clients.Deluge.Deluge.GetItems () [0x00012] in M:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Deluge\Deluge.cs:96 
  at NzbDrone.Core.Download.TrackedDownloads.DownloadMonitoringService.ProcessClientDownloads (NzbDrone.Core.Download.IDownloadClient downloadClient) [0x0000c] in M:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\TrackedDownloads\DownloadMonitoringService.cs:89 



The DelugeVPN docker seems to be working fine as far as I can tell. 

Link to post
  • Replies 1.1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

So, Sonarr v3 is FINALLY here, its out of beta and is now the latest release, if you want to switch from Sonarr v2 to v3 then simply pull down the 'latest' tagged image.   However, if you wa

@SavagelyCalm I have the same problem.   Edit your Docker repository link to this "binhex/arch-sonarr:v3" and it'll re-download a working version.  Worked for me. 

guys it looks like sonarr V3 has finally dropped and is now the latest release so I need to make some minor adjustments for the image and this will fix it all up Sent from my CLT-L09 using Tapatalk

Posted Images

I'm wondering if the Sonarr & Radarr docker containers will be updated to reflect the changes in TLS to 1.2 & 1.3. I'm now getting protocol errors since 1.0 & 1.1 are no longer supported on an indexer and I believe that is the issue. Thanks in advance! 

Link to post
On 2/7/2020 at 3:06 PM, Kmfq said:

I'm wondering if the Sonarr & Radarr docker containers will be updated to reflect the changes in TLS to 1.2 & 1.3. I'm now getting protocol errors since 1.0 & 1.1 are no longer supported on an indexer and I believe that is the issue. Thanks in advance! 

These dockers do not include the latest version of mono required to support TLS 1.2 & 1.3. I'm having the same problem.

Link to post

Hey All,


   I have recently noticed an issue where Sonarr shows items in the activity tab that are no longer active in NZBGet, either failed or finished successfully. I have them linked in the Sonarr settings under download client and it tests successfully. Im not sure where the communication is failing. 


Any help or guidance is greatly appreciated 

Link to post
On 2/7/2020 at 3:06 PM, Kmfq said:

I'm wondering if the Sonarr & Radarr docker containers will be updated to reflect the changes in TLS to 1.2 & 1.3. I'm now getting protocol errors since 1.0 & 1.1 are no longer supported on an indexer and I believe that is the issue. Thanks in advance! 

Same here, still no update?

If we could update mono via console on the docker.

Link to post

I have been using Sabnzbd and Sickbeard for years on a VM and recently decided to give Sonarr a shot, so I installed the Dockers for Sab and Sonarr. I really want to use Sonarr, but I have run into an issue with automatic imports. I can pick a show in Sonarr and do either a manual or auto search and they both work fine to send the selected show to Sab for download. Category is set to 'tv' in both. The show downloads to the folders as configured in Sab...first a temp folder and then to the final download folder. The download completes just find and then it just sits in the folder. It never gets imported into Sonarr. Now, if I go in Sonarr under 'Wanted' and select to do a Manual Import and point to the folder/file in the download folder and select either Automatic or Manual import...it all works fine. So, I have been digging through all of the logs (I have trace/debug on) and I can't find anything offending. As a test, a did a specific download and then reviewed the logs...can't find anything that would show that it even tried to import. I then did the manual import and reviewed the logs again. I can definitely see all the activity for the import and I definitely didn't see any of those entries after the automatic download. Oh, also, in the 'Activity' menu, when I have it download automatically, I can watch it work and when it is done it just removes the entry. I can go into 'History' and see the entry which is titles "Grabbed". The details shows a summary of the NZB grabbed. This is different from a history item that I manually processed. It shows "Episode Imported" and provides the details of the name and location change. I can't seem to figure out why it's not automatically importing. If anyone has any ideas...! I'm at the point that I have to use one of my favorite lines from a favorite movie..."I'd piss on a spark plug if I thought it do any good!". Thanx!


I should also probably mention that I do have the "Completed Download Handling" enabled.

Edited by _vern_
Link to post

I'm not sure that I understand your question. Your question would suggest there is somewhere to turn on/off to have a video imported, but I don't know where that would be. I presume that if a show is selected and is flagged as monitored that it would import the show as well. The "Importing" configuration section only has three settings, but none of those turn off/on importing of video. Can you be more specific as to the setting in Sonarr itself? I totally may be missing something...Thanx!

Link to post

Thank you for the additional details...I changed the setting "Use Hardlinks Instead of Copy" from Yes to No, but the behavior didn't change. I ran a test and no change in behavior. In fact...I had a show that aired tonight download shortly after and it made it to the download folder after being downloaded by Sab and it just sat there...looking lonely...really wanting to make it to it's place on the Unraid shares. So sad... Anyway...the change didn't seem to have an effect.

Link to post

The path is no longer set in Sonarr...this data is supposed to be passed from the download client (Sabnzbd) to Sonarr. There is no configuration for providing a path to the expected location of a downloaded file as far as I can tell. This seems to be a fairly new feature which was documented eight days ago (https://github.com/Sonarr/Sonarr/wiki/Completed-Download-Handling). Thanx for the reply, but I have explored that particular thread many times now and I think it no longer applies based on the recent changes that have been made.

Link to post
On 2/13/2020 at 11:31 PM, gandalf027 said:

Same here, still no update?

If we could update mono via console on the docker.

are you sure this is mono related?, can you post a link to the issue?.

Link to post

I did a full install on an Ubuntu VM server and after all that, I get the exact same behavior. The folder/file makes it to the completed folder and then just sits there. The record is removed for the Activity tab and history just says that it was grabbed. No attempt to import it. The version in the Docker and the full install are the same ( Can anyone confirm that automatic imports work for them? I'm trying to determine if I have some configured wrong of if there is something wrong with the software. Thanx!

Link to post

I ended up installing NZBget just to see if I would get any different behavior. It worked right out of the box which would seem to indicate that something isn't communicating correctly between Sonarr and Sabnzbd. No idea what...but it's working now. Being that I want to use Sonarr, I guess I'll be using NZBget as well...

Link to post

Hello everyone,


I've updated the Sonarr docker on unRaid and suddenly I keep getting the following error:

Couldn't import episode /data/completed/Series/showivedownloaded.mkv: Access to the path is denied.


I can see Sonarr copying the file to the destination, which is an unassigned drive by the way, but when it's basically complete I get the error above.

I worked fine before I updated.


Anybody has any idea how to fix this?

Thanks in advance!


Link to post
  • 2 weeks later...

I'm still getting the sqlite error, espite having upated Sonarr (and I'm running Unraid 6.8.2). Just in the last week, I've noticed that shows aren't correctly updating to reflect whether I have episodes, and similarly I can't add new series to monitor.

2020-02-27 22:13:50,270 DEBG 'sonarr' stdout output:
[Error] TaskExtensions: Task Error

[v2.0.0.5338] System.Data.SQLite.SQLiteException (0x80004005): database disk image is malformed
database disk image is malformed
at System.Data.SQLite.SQLite3.Reset (System.Data.SQLite.SQLiteStatement stmt) [0x00083] in <61a20cde294d4a3eb43b9d9f6284613b>:0
at System.Data.SQLite.SQLite3.Step (System.Data.SQLite.SQLiteStatement stmt) [0x0003c] in <61a20cde294d4a3eb43b9d9f6284613b>:0
at System.Data.SQLite.SQLiteDataReader.NextResult () [0x0016b] in <61a20cde294d4a3eb43b9d9f6284613b>:0
at System.Data.SQLite.SQLiteDataReader..ctor (System.Data.SQLite.SQLiteCommand cmd, System.Data.CommandBehavior behave) [0x00090] in <61a20cde294d4a3eb43b9d9f6284613b>:0
at (wrapper remoting-invoke-with-check) System.Data.SQLite.SQLiteDataReader..ctor(System.Data.SQLite.SQLiteCommand,System.Data.CommandBehavior)
at System.Data.SQLite.SQLiteCommand.ExecuteReader (System.Data.CommandBehavior behavior) [0x0000c] in <61a20cde294d4a3eb43b9d9f6284613b>:0
at System.Data.SQLite.SQLiteCommand.ExecuteScalar (System.Data.CommandBehavior behavior) [0x00006] in <61a20cde294d4a3eb43b9d9f6284613b>:0
at System.Data.SQLite.SQLiteCommand.ExecuteScalar () [0x00006] in <61a20cde294d4a3eb43b9d9f6284613b>:0
at Marr.Data.QGen.InsertQueryBuilder`1[T].Execute () [0x00046] in M:\BuildAgent\work\5d7581516c0ee5b3\src\Marr.Data\QGen\InsertQueryBuilder.cs:140
at Marr.Data.DataMapper.Insert[T] (T entity) [0x0005d] in M:\BuildAgent\work\5d7581516c0ee5b3\src\Marr.Data\DataMapper.cs:728
at NzbDrone.Core.Datastore.BasicRepository`1[TModel].Insert (TModel model) [0x0002d] in M:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Datastore\BasicRepository.cs:111
at NzbDrone.Core.Messaging.Commands.CommandQueueManager.Push[TCommand] (TCommand command, NzbDrone.Core.Messaging.Commands.CommandPriority priority, NzbDrone.Core.Messaging.Commands.CommandTrigger trigger) [0x0013d] in M:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Messaging\Commands\CommandQueueManager.cs:82
at NzbDrone.Core.Messaging.Commands.CommandQueueManager.Push (System.String commandName, System.Nullable`1[T] lastExecutionTime, NzbDrone.Core.Messaging.Commands.CommandPriority priority, NzbDrone.Core.Messaging.Commands.CommandTrigger trigger) [0x000b7] in M:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Messaging\Commands\CommandQueueManager.cs:95
at NzbDrone.Core.Jobs.Scheduler.ExecuteCommands () [0x00043] in M:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Jobs\Scheduler.cs:42
at System.Threading.Tasks.Task.InnerInvoke () [0x0000f] in /build/mono/src/mono/external/corert/src/System.Private.CoreLib/src/System/Threading/Tasks/Task.cs:2476
at System.Threading.Tasks.Task.Execute () [0x00000] in /build/mono/src/mono/external/corert/src/System.Private.CoreLib/src/System/Threading/Tasks/Task.cs:2319

I even tried removing the docker and re-adding it, although now that I think about it I didn't think to clear the appdata.

Link to post
5 hours ago, IcarusFountain said:

although now that I think about it I didn't think to clear the appdata.

this will be the solution, in short you have sonarr sqlite database corruption, until this is fixed by either deleting the database and allowing it to re-create a blank database, or by restoring your config from a backup (recommended!) then you will continue to see issues. 


if you go down the route of deleting the existing database then you will no doubt have to re-import all your tv series again and may loose some config as well, so just be prepared for this.

Link to post

was just having an issue with files not moving over correctly and being deleted from cache. I saw on reddit someone said that there is a brand new update ( that will fix this issue. Is the docker going to be updated soon to 3.0?

Link to post

so i would like my workflow to look like>>>> use radarr or sonarr to get the files using jacket imported int delugevpn ( it does this part no issues), but uppon completion radarr or sonarr needs to cut down the file name lossing all the extra stuff and place the file into a folder in either movies for radarr or plex tv shows for sonarr. which it did do before but no longer

Link to post

Quick question. I created a secondary Binhex-sonarr for just my anime, so i can have TV-Sonarr, and Anime-Sonarr. My question is, is there a way to edit the Anime-Sonarr gui so that i can change it from blue to green and change the logo a little so that i can differentiate easily which one i have open? I am not looking to release it, i just want to do this for my own personal server? Thank you!

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.