Jump to content
binhex

[Support] binhex - Sonarr

870 posts in this topic Last Reply

Recommended Posts

@binhex I was wondering if there is any idea on a timeline for v3? I would like to start converting to hevc, and the current must contain/must not contain doesn't really work for that. v3 is supposed to implement preferred words.

Share this post


Link to post
@binhex I was wondering if there is any idea on a timeline for v3? I would like to start converting to hevc, and the current must contain/must not contain doesn't really work for that. v3 is supposed to implement preferred words.
As soon as it's out of beta it will get built

Sent from my CLT-L09 using Tapatalk

Share this post


Link to post
Posted (edited)

Hi folks,

 

I had a really rough day, spending my whole day fixing my unraid array, and now everything is somewhat back to normal except few things about Sonarr... First of all, I do not understand why I cannot see the Logs in Table sonarr, it keeps saying "Oh snap! Failed to load logs, your ad blocker might be blocking the api calls.", I have disabled all adblock, I even tried other browser same issues... but at least the logs are still written in files (attached file show this below:

  Quote

20-3-14 00:29:03.5|Error|NzbDroneErrorPipeline|[GET /api/log]

So there is an error in the GET. I have tried many different thing, such as re-installing Sonarr as whole because there is another error about database disk image is malformed... I have even change the /config path to disk1 (I do not have cache drive). Nothing changed, I have restored backup from 3 previous one and nothing changed, (it was working really fine yesterday). This error is always coming back, I am getting really frustrated and tired, it does not seems to prevent my sonarr to function but there is no logs, no activity shown at all... it still fetch information for my sabnzbd but the Table error logs show nothing in Sonarr... I am starting to slowly lose my mind over it, the issues I had before was the cable for my disk1 was defective, I recreate the docker.img file based on the guide posted here and restored apps and so far everything seems to work fine (radarr, sabnzbd and plex), the only issues is about Sonarr...

 

Can someone help me, I feel like I have overlooked something, I have tried restoring, changing the mapping, restarting the docker and yet it still not working.

 

As a standard way that things go there, I have also attached my unraid diagnostics.

 

Sonarr repos: binhex-sonarr

Sonarr version: 2.0.0.5338

 

Thank you all for your help

tower-diagnostics-20200314-0042.zip sonarr-2020-3-14.txt

Edited by noax
Added Sonarr version

Share this post


Link to post

Unable to connect to indexer: Error: ProtocolError:

 

System.Net.WebException: Error: ProtocolError:

 

Can anything be done for these errors?

Share this post


Link to post
Posted (edited)

After the update, I am no longer able to access my Download Client (binhex-qbittorrent). Surprisingly, Radarr has no issues.

 

I checked the logs and it shows:

[Warn] NzbDroneErrorPipeline: Invalid request Validation failed:

Any idea what happened? How is it that Radarr doesn't have the same issue?

 

Btw, I have clean-reinstalled the Docker container, but the error still persists.

Edited by hkgnp

Share this post


Link to post

I'm wondering if anyone has a good solution to prevent Sonarr from copying between mounted volumes instead of just moving the files?  I'd like to prevent the additional writes on my drives if at all possible.

Share this post


Link to post
5 minutes ago, binarymelon said:

I'm wondering if anyone has a good solution to prevent Sonarr from copying between mounted volumes instead of just moving the files?  I'd like to prevent the additional writes on my drives if at all possible.

Only solution is to map say /mnt/user to /mnt/user and have both downloads directory and the destination to be referencing /mnt/user/whatever within sonarr.  Also make the same change to your download client

Share this post


Link to post
22 hours ago, Squid said:

Only solution is to map say /mnt/user to /mnt/user and have both downloads directory and the destination to be referencing /mnt/user/whatever within sonarr.  Also make the same change to your download client

Hmmm, this didn't actually seem to work.  My client has read only set to false.  I'm not really sure what else to do.

Share this post


Link to post
On 3/14/2020 at 5:45 PM, joecool169 said:

Unable to connect to indexer: Error: ProtocolError:

 

System.Net.WebException: Error: ProtocolError:

 

Can anything be done for these errors?

So I am a newbie. I was getting this error when trying to connect to an indexer. If anyone else happens to see this post and has a similar issue I want them to know that my problem was actually simple. I setup a vpn "privoxy" and I had put the wrong port number in Sonarr's settings.

Share this post


Link to post

I am pretty new to all of this and reading a lot as I go.

I am having an issue with Sonarr not moving files once sabnzbd downloads them getting the error "no files found are eligible for import".  I have seen many examples of this when I search google. Most of them point to the directories not being the same between the dockers or access privileges being wrong. 

 

I have tried my best and spent a few hours researching but I think it is above my knowledge level.  I try not to bother you all with these questions because usually I can figure it out on my own but no dice this time.  I attached a picture of my directories.

 

Thanks in advance!

sonarr.jpg

Share this post


Link to post
4 minutes ago, sgpigeon said:

"no files found are eligible for import". 

post the FULL error.  It'll have the path listed that it's talking about

Share this post


Link to post
8 minutes ago, Squid said:

post the FULL error.  It'll have the path listed that it's talking about

Sorry: No files found are eligible for import in /config/Downloads/complete/Last.Week.720p

Share this post


Link to post
1 minute ago, sgpigeon said:

/config/Downloads/complete/Last.Week.720p

in Sab's UI, you've got the downloads going to Downloads/complete  (There is a line there stating that the default base forlder is /config)

 

You need to set it to /data/Downloads/complete.  After that change, everything will work correctly.  However I cannot remember if files existing in your queue will pick up the change

Share this post


Link to post
Posted (edited)
14 minutes ago, Squid said:

in Sab's UI, you've got the downloads going to Downloads/complete  (There is a line there stating that the default base forlder is /config)

 

You need to set it to /data/Downloads/complete.  After that change, everything will work correctly.  However I cannot remember if files existing in your queue will pick up the change

I thought that was a problem at one point in my search but there is nothing showing in data when I browse from the sab UI.

Do I need to create a downloads and complete folder in the data folder? If so where do I go to do that. 

Thanks! Sorry for the trouble.

 

Edit:updated screen shot of the completed folder

 

sab.jpg

Edited by sgpigeon

Share this post


Link to post

It'll probably create it itself if you just type it in.  But creating it yourself won't hurt. 

Share this post


Link to post
8 minutes ago, Squid said:

It'll probably create it itself if you just type it in.  But creating it yourself won't hurt. 

By GOLLY you did it!

Thank you so much.  

Have a beer on me:)

Share this post


Link to post
7 minutes ago, sgpigeon said:

Have a beer on me:)

Thank you very much.  Always appreciated :) 

Share this post


Link to post
Posted (edited)

Hi everyone, my Sonarr is giving me some trouble. I have not been able to add any new series and I have the following errors:

  • All indexers are unavailable due to failures
  • All search-capable indexers are temporarily unavailable due to recent indexer errors
  • Failed to test proxy: http://services.sonarr.tv/v1/ping
  • Unable to communicate with DelugeVPN. Unable to write data to the transport connection: The socket has been shut down.
  • All download clients are unavailable due to failures
  • All rss-capable indexers are temporarily unavailable due to recent indexer errors

When I do the "test" on all of my Jackett indexers, they say they're working. Deluge is still kind of downloading. It added some of the episodes, but hasn't really been downloading. Radarr hasn't been working quite right either, but there are no longer errors on it. I'm not sure where to locate any additional logs or what you all need, but I'm more than willing to do whatever I need to do to get it up and running again.

 

*Edited to add diagnostics

alienblood-diagnostics-20200323-1029.zip

Edited by xd84
added diagnostics

Share this post


Link to post

Hi everyone,

 

Once again, I am posting, since nobody answered me previously, I have an issue where i can't see logs in Table, I have disabled all adblocks and authorize it and the issues still pertain... here is the logs from text file.

 

I have tried googling it without any luck so far...

 

Thank everyone for your help.

sonarr-2020-03-25.txt

Share this post


Link to post

Hello,

 

Top notch work with your plugins and support.

 

I hope this is fairly straight forwards for you but I've setup DelugeVPN with Privoxy enabled and set Sonarr to use Privoxy. When testing via console on the Sonarr docker to check the IP address it's reporting Unraids external IP and not the Privoxy IP from the VPN. 

 

Is this normal behaviour that the console would still report as if the Proxy wasn't in place or is somehting wrong here? I've also checked the Privoxy with Windows 10 and it works correctly when using the proxy but this one has stumped be a little bit.

 

Any help would be appreciated, I just don't want to set things live until I know its under the Privoxy tunnel.

Share this post


Link to post
11 minutes ago, mint said:

Is this normal behaviour that the console would still report as if the Proxy wasn't in place or is somehting wrong here? I've also checked the Privoxy with Windows 10 and it works correctly when using the proxy but this one has stumped be a little bit.

completely normal behaviour, a proxy server is not a vpn - proxy servers do not operate at a system level, thus any non http(s) traffic will not be proxied and will go out via your isp's connection (this includes things like curl and wget which are not aware of the proxy), but as sonarr is primarily using http(s) to download metadata this is not an issue.

Share this post


Link to post
3 minutes ago, binhex said:

completely normal behaviour, a proxy server is not a vpn - proxy servers do not operate at a system level, thus any non http(s) traffic will not be proxied and will go out via your isp's connection (this includes things like curl and wget which are not aware of the proxy), but as sonarr is primarily using http(s) to download metadata this is not an issue.

I assumed something to this degree but I wasn't sure on the specifics of it, either way thanks for your quick response.

 

Donation coming soon :)

Share this post


Link to post
41 minutes ago, noax said:

Hi everyone,

 

Once again, I am posting, since nobody answered me previously, I have an issue where i can't see logs in Table, I have disabled all adblocks and authorize it and the issues still pertain... here is the logs from text file.

 

I have tried googling it without any luck so far...

 

Thank everyone for your help.

sonarr-2020-03-25.txt 15.47 kB · 0 downloads

This is your problem in a nutshell:-

[v2.0.0.5344] System.Data.SQLite.SQLiteException (0x80004005): database disk image is malformed

You have sqlite database corruption, until this is fixed by either deleting the database and allowing it to re-create a blank database, or by restoring your config from a backup (recommended!) then you will continue to see issues. 

 

if you go down the route of deleting the existing database then you will no doubt have to re-import all your tv series again and may loose some config as well, so just be prepared for this.

 

To delete and start from scratch delete all files and folders in the host path for /config for this container, otherwise stop the container and restore from backup.

Share this post


Link to post
Posted (edited)

Hey.  New to this stuff.  By using a combination of Google and Space Invader One's excellent videos I was able to get Plex, QBittorrentvpn, Sonarr, and Jackett up and running yesterday.  Couple of minor issues that I'm hoping you guys can help me with.

 

1.  When Sonarr tells Qbittorrent to download shows, they are correctly moving from incomplete folder to complete folder.  Sonarr is then correctly moving the show to my media folder for Plex.  However, it is leaving a copy of the show in the complete folder.  Is there a way for it to automatically delete that or will I continue to have to remove it manually?

 

2.  How long does it take for new shows to be identified?  I have several series setup, all of them set to future episodes only.  3 of them had new episodes last night, but as of now, sonarr has only downloaded 1 of them.   I have index's setup through rarbg and 1337x.

 

Thanks binhex for all your hard work!  All of the dockers that I'm using for this stuff are your work!  Will be donating to you so you can enjoy several daddy soda's on me!

Edited by hahler2
typo's

Share this post


Link to post

Is something weird going on with Sonaar?  Docker worked excellent since initial configuration, quite some time ago.  No system changes made, aside from potentially auto updates on dockers.

 

Starting today - Errors to Sab and Indexer

I checked Radarr, and that is still working with the same configuration settings to Sab and Indexer.

 

Version 2.0.0.5344

6.4.0

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.