[Support] binhex - Sonarr


1069 posts in this topic Last Reply

Recommended Posts

  • Replies 1.1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

So, Sonarr v3 is FINALLY here, its out of beta and is now the latest release, if you want to switch from Sonarr v2 to v3 then simply pull down the 'latest' tagged image.   However, if you wa

@SavagelyCalm I have the same problem.   Edit your Docker repository link to this "binhex/arch-sonarr:v3" and it'll re-download a working version.  Worked for me. 

guys it looks like sonarr V3 has finally dropped and is now the latest release so I need to make some minor adjustments for the image and this will fix it all up Sent from my CLT-L09 using Tapatalk

Posted Images

Anyone able to help?
A new image was built with the latest mono please try pulling that image down and try again

Sent from my CLT-L09 using Tapatalk

Link to post
13 minutes ago, binhex said:

A new image was built with the latest mono please try pulling that image down and try again

Sent from my CLT-L09 using Tapatalk
 

Thanks, just did that. The mono version doesn't appear to have changed, it's still on 6.4.0? Still fails 😕

 

I've checked the docker image digest and they are exactly correct to the latest version published a day ago:

root@NAS:~# docker inspect --format='{{index .RepoDigests 0}}' 32e9325565e
binhex/arch-sonarr@sha256:0638d6841fa26c130b0d41d5042f4efa2f5c0e8606857f6188f171c3f22f9856

 

Link to post
Thanks, just did that. The mono version doesn't appear to have changed, it's still on 6.4.0? Still fails

 

I've checked the docker image digest and they are exactly correct to the latest version published a day ago:

root@NAS:~# docker inspect --format='{{index .RepoDigests 0}}' 32e9325565ebinhex/arch-sonarr@sha256:0638d6841fa26c130b0d41d5042f4efa2f5c0e8606857f6188f171c3f22f9856

 

 

Ok then it won't be an out of date mono version. Your best bet is to post the issue on the sonarr GitHub repo, link in first post.

 

Edit actually they link is to the official website, here is the GitHub repo link:- https://github.com/Sonarr/Sonarr/issues

 

Sent from my CLT-L09 using Tapatalk

 

 

 

Link to post

Ok I think I know what was wrong...

 

Since I'm using binhex/arch-delugevpn, I've re-downloaded all of the PIA OpenVPN certificates and ensured I had France in it to ensure port forwarding is enabled (I had France originally, so their certs might have changed, somehow). Suddenly everything is working!

 

For those who also have this issue, flush your certs, re-download and try again. Make sure you restart all of your containers as well if you fiddle with Deluge. I've also just enabled privoxy on the deluge container, not sure if that made any difference.

Edited by Maelstromeous
Link to post

Hi all, seeing "database is locked" errors in SQLite for Sonarr on downloads.  Sometimes Sonarr imports fine, sometimes I get the error and while the file is moved, Sonarr never recognizes this because of the database locked error.  While attempting to resolve this I have confirmed/tried a few things:

  • Check all my paths between SAB and Sonarr (both have exactly the same path set in docker, i.e., /data -> /mnt/cache/Downloads/)
  • Ensured all docker containers /config maps to /mnt/cache/appdata
  • Looked at permissions for my /mnt/cache/Downloads files and folders, which were all set to 777

Log file attached as an example.  Any ideas of what else I can try short of just blowing Sonarr away and starting over?

20200524 Sonarr log with issues - truncated.txt

Link to post
On 3/25/2020 at 11:55 AM, binhex said:

This is your problem in a nutshell:-


[v2.0.0.5344] System.Data.SQLite.SQLiteException (0x80004005): database disk image is malformed

You have sqlite database corruption, until this is fixed by either deleting the database and allowing it to re-create a blank database, or by restoring your config from a backup (recommended!) then you will continue to see issues. 

 

if you go down the route of deleting the existing database then you will no doubt have to re-import all your tv series again and may loose some config as well, so just be prepared for this.

 

To delete and start from scratch delete all files and folders in the host path for /config for this container, otherwise stop the container and restore from backup.

 

It looks like I've got this same sqlite database corruption. Unfortunately I have my appdata backups set to delete daily so restoring didn't solve the problem since it's been going on for a few days. I'm trying to follow what you have written here to recreate but I don't see a /config anywhere. Do you mean the appdata folder? Will the nzbdrone backup in the appdata folder help at all? I do have a few weeks of that. I'd like to minimize recreating my settings as much as possible.

 

Edit: I messed up something with my database trying some fixes and had to rebuild from scratch. Still curious about the /config folder.

 

sonarr.txt

Edited by eman31
Link to post
On 5/24/2020 at 9:15 AM, onyx00 said:

Hi all, seeing "database is locked" errors in SQLite for Sonarr on downloads.  Sometimes Sonarr imports fine, sometimes I get the error and while the file is moved, Sonarr never recognizes this because of the database locked error.  While attempting to resolve this I have confirmed/tried a few things:

  • Check all my paths between SAB and Sonarr (both have exactly the same path set in docker, i.e., /data -> /mnt/cache/Downloads/)
  • Ensured all docker containers /config maps to /mnt/cache/appdata
  • Looked at permissions for my /mnt/cache/Downloads files and folders, which were all set to 777

Log file attached as an example.  Any ideas of what else I can try short of just blowing Sonarr away and starting over?

20200524 Sonarr log with issues - truncated.txt 5.54 kB · 1 download

No help on this?  I've tried blowing away my entire docker/appdata, confirmed docker puts everything on the cache drive, and followed Space Invader's youtube videos exactly...same issues.  Any other ideas short of starting from scratch on my unraid configuration?

Link to post

Hi everyone! I am trying to troubleshoot an issue with Sonarr and Delugevpn. Sonarr is able to grab torrents and send them to Deluge to download just fine. Deluge downloads the file and moves it from "Incomplete" to "Complete" in my main Downloads share. The file is then shown as 'seeding' in Deluge. So far so good...

 

After this however, Sonarr does not pick up the file and add it to the TV share. Sabnzbd works just fine, but deluge doesn't. I have Radarr and Lidarr set up and they are able to process the completed torrent files, but for some reason Sonarr is having trouble. 

 

Looking at the system log in Sonarr there is a fatal error and I've pasted it below:

Request Failed. POST /api/release: Failure: [Failure instance: Traceback (failure with no frames): <class 'deluge.error.WrappedException'>: Unknown Label
Traceback (most recent call last):
  File "/usr/lib/python3.8/site-packages/deluge/core/rpcserver.py", line 326, in dispatch
    ret = self.factory.methods[method](*args, **kwargs)
  File "/usr/lib/python3.8/site-packages/deluge/plugins/Label-0.3-py3.8.egg/deluge_label/core.py", line 320, in set_torrent
    check_input((not label_id) or (label_id in self.labels), _('Unknown Label'))
  File "/usr/lib/python3.8/site-packages/deluge/plugins/Label-0.3-py3.8.egg/deluge_label/core.py", line 68, in check_input
    raise Exception(message)
Exception: Unknown Label

] (code 4)
NzbDrone.Core.Download.Clients.Deluge.DelugeException: Failure: [Failure instance: Traceback (failure with no frames): <class 'deluge.error.WrappedException'>: Unknown Label
Traceback (most recent call last):
  File "/usr/lib/python3.8/site-packages/deluge/core/rpcserver.py", line 326, in dispatch
    ret = self.factory.methods[method](*args, **kwargs)
  File "/usr/lib/python3.8/site-packages/deluge/plugins/Label-0.3-py3.8.egg/deluge_label/core.py", line 320, in set_torrent
    check_input((not label_id) or (label_id in self.labels), _('Unknown Label'))
  File "/usr/lib/python3.8/site-packages/deluge/plugins/Label-0.3-py3.8.egg/deluge_label/core.py", line 68, in check_input
    raise Exception(message)
Exception: Unknown Label

] (code 4)
  at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.ProcessRequest[TResult] (NzbDrone.Core.Download.Clients.Deluge.DelugeSettings settings, System.String method, System.Object[] arguments) [0x00072] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:232 
  at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.SetLabel (System.String hash, System.String label, NzbDrone.Core.Download.Clients.Deluge.DelugeSettings settings) [0x00000] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:190 
  at NzbDrone.Core.Download.Clients.Deluge.Deluge.AddFromTorrentFile (NzbDrone.Core.Parser.Model.RemoteEpisode remoteEpisode, System.String hash, System.String filename, System.Byte[] fileContent) [0x00058] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Deluge\Deluge.cs:74 
  at NzbDrone.Core.Download.TorrentClientBase`1[TSettings].DownloadFromWebUrl (NzbDrone.Core.Parser.Model.RemoteEpisode remoteEpisode, System.String torrentUrl) [0x00208] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\TorrentClientBase.cs:189 
  at NzbDrone.Core.Download.TorrentClientBase`1[TSettings].Download (NzbDrone.Core.Parser.Model.RemoteEpisode remoteEpisode) [0x00148] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\TorrentClientBase.cs:117 
  at NzbDrone.Core.Download.DownloadService.DownloadReport (NzbDrone.Core.Parser.Model.RemoteEpisode remoteEpisode) [0x00191] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\DownloadService.cs:76 
  at NzbDrone.Api.Indexers.ReleaseModule.DownloadRelease (NzbDrone.Api.Indexers.ReleaseResource release) [0x0002d] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Api\Indexers\ReleaseModule.cs:67 
  at NzbDrone.Api.Indexers.ReleaseModule.<.ctor>b__7_0 (System.Object x) [0x00000] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Api\Indexers\ReleaseModule.cs:46 
  at (wrapper dynamic-method) System.Object.CallSite.Target(System.Runtime.CompilerServices.Closure,System.Runtime.CompilerServices.CallSite,System.Func`2<object, object>,object)
  at Nancy.Routing.Route+<>c__DisplayClass4.<Wrap>b__3 (System.Object parameters, System.Threading.CancellationToken context) [0x00049] in <63c44d6f8d7e4f339a987bf9eb94d931>:0 

Thank you so much for any help/insight you can provide!

Link to post
On 6/2/2020 at 8:40 PM, lukewarmtauntaun said:

Hi everyone! I am trying to troubleshoot an issue with Sonarr and Delugevpn. Sonarr is able to grab torrents and send them to Deluge to download just fine. Deluge downloads the file and moves it from "Incomplete" to "Complete" in my main Downloads share. The file is then shown as 'seeding' in Deluge. So far so good...

 

After this however, Sonarr does not pick up the file and add it to the TV share. Sabnzbd works just fine, but deluge doesn't. I have Radarr and Lidarr set up and they are able to process the completed torrent files, but for some reason Sonarr is having trouble. 

 

Looking at the system log in Sonarr there is a fatal error and I've pasted it below:


Request Failed. POST /api/release: Failure: [Failure instance: Traceback (failure with no frames): <class 'deluge.error.WrappedException'>: Unknown Label
Traceback (most recent call last):
  File "/usr/lib/python3.8/site-packages/deluge/core/rpcserver.py", line 326, in dispatch
    ret = self.factory.methods[method](*args, **kwargs)
  File "/usr/lib/python3.8/site-packages/deluge/plugins/Label-0.3-py3.8.egg/deluge_label/core.py", line 320, in set_torrent
    check_input((not label_id) or (label_id in self.labels), _('Unknown Label'))
  File "/usr/lib/python3.8/site-packages/deluge/plugins/Label-0.3-py3.8.egg/deluge_label/core.py", line 68, in check_input
    raise Exception(message)
Exception: Unknown Label

] (code 4)

NzbDrone.Core.Download.Clients.Deluge.DelugeException: Failure: [Failure instance: Traceback (failure with no frames): <class 'deluge.error.WrappedException'>: Unknown Label
Traceback (most recent call last):
  File "/usr/lib/python3.8/site-packages/deluge/core/rpcserver.py", line 326, in dispatch
    ret = self.factory.methods[method](*args, **kwargs)
  File "/usr/lib/python3.8/site-packages/deluge/plugins/Label-0.3-py3.8.egg/deluge_label/core.py", line 320, in set_torrent
    check_input((not label_id) or (label_id in self.labels), _('Unknown Label'))
  File "/usr/lib/python3.8/site-packages/deluge/plugins/Label-0.3-py3.8.egg/deluge_label/core.py", line 68, in check_input
    raise Exception(message)
Exception: Unknown Label

] (code 4)
  at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.ProcessRequest[TResult] (NzbDrone.Core.Download.Clients.Deluge.DelugeSettings settings, System.String method, System.Object[] arguments) [0x00072] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:232 
  at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.SetLabel (System.String hash, System.String label, NzbDrone.Core.Download.Clients.Deluge.DelugeSettings settings) [0x00000] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:190 
  at NzbDrone.Core.Download.Clients.Deluge.Deluge.AddFromTorrentFile (NzbDrone.Core.Parser.Model.RemoteEpisode remoteEpisode, System.String hash, System.String filename, System.Byte[] fileContent) [0x00058] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Deluge\Deluge.cs:74 
  at NzbDrone.Core.Download.TorrentClientBase`1[TSettings].DownloadFromWebUrl (NzbDrone.Core.Parser.Model.RemoteEpisode remoteEpisode, System.String torrentUrl) [0x00208] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\TorrentClientBase.cs:189 
  at NzbDrone.Core.Download.TorrentClientBase`1[TSettings].Download (NzbDrone.Core.Parser.Model.RemoteEpisode remoteEpisode) [0x00148] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\TorrentClientBase.cs:117 
  at NzbDrone.Core.Download.DownloadService.DownloadReport (NzbDrone.Core.Parser.Model.RemoteEpisode remoteEpisode) [0x00191] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\DownloadService.cs:76 
  at NzbDrone.Api.Indexers.ReleaseModule.DownloadRelease (NzbDrone.Api.Indexers.ReleaseResource release) [0x0002d] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Api\Indexers\ReleaseModule.cs:67 
  at NzbDrone.Api.Indexers.ReleaseModule.<.ctor>b__7_0 (System.Object x) [0x00000] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Api\Indexers\ReleaseModule.cs:46 
  at (wrapper dynamic-method) System.Object.CallSite.Target(System.Runtime.CompilerServices.Closure,System.Runtime.CompilerServices.CallSite,System.Func`2<object, object>,object)
  at Nancy.Routing.Route+<>c__DisplayClass4.<Wrap>b__3 (System.Object parameters, System.Threading.CancellationToken context) [0x00049] in <63c44d6f8d7e4f339a987bf9eb94d931>:0 

Thank you so much for any help/insight you can provide!

According to you log it complains about a unknown label. Maybe you have set the wrong label in sonarr? Have you set up deluge to move the completed downloads to the correct folder? I assume you have at least 2 labels in deluge? What are your labels called? Post your deluge settings and the docker run command for both deluge and sonarr

Link to post
50 minutes ago, strike said:

According to you log it complains about a unknown label. Maybe you have set the wrong label in sonarr? Have you set up deluge to move the completed downloads to the correct folder? I assume you have at least 2 labels in deluge? What are your labels called? Post your deluge settings and the docker run command for both deluge and sonarr

Did you enable Labels in Deluge by going to preferences, plugins?  My sonarr downloads in Deluge are all labelled tv-sonarr.  When you enable plugins, go to the label section on the left in the main panel and create a label called tv-sonarr.

Edited by DigitalDivide
forgot something
Link to post
18 hours ago, DigitalDivide said:

Did you enable Labels in Deluge by going to preferences, plugins?  My sonarr downloads in Deluge are all labelled tv-sonarr.  When you enable plugins, go to the label section on the left in the main panel and create a label called tv-sonarr.

Thank you both. You were absolutely right. One of my labels didn't match what deluge was looking for. Big facepalm when I saw that! Thank you for helping out a newbie!

Link to post

Hi all,

 

I had setup my server awhile ago and it was working great. I let my NZBgeek, PIA, and Usenet.Farm subscriptions lapse and hadn't used Sonarr, Radarr, or SABnzbd in 6 months or so.

 

I reactivated my supscriptions to all of those without otherwise changing anything.

 

When trying to test the connection to NZBgeek indexer, I am getting the "Unable to connect to indexer, check the log for more details" error. Upon looking at the log, I see: 

 

2020-06-04 17:49:11,444 DEBG 'sonarr' stdout output:
[Warn] NzbDroneErrorPipeline: Invalid request Validation failed:

 

This continues on the Download Clients tab, where testing the connection in Deluge gives me a "Unknown exception: The operation has timed out.: 'https://192.168.2.87:8112/json'".

 

Testing the connection to SABnzbd gives this message in the log:

 

2020-06-04 18:00:35,989 DEBG 'sonarr' stdout output:
[Warn] NzbDroneErrorPipeline: Invalid request Validation failed:
-- Unable to connect to SABnzbd

 

I went back to confirm that the current IP address setting were correct in each program, and that they matched the mappings in the Docker tab of Unraid. Everything that I can see matches, including all the API keys.

 

I'm not sure what's wrong here or where to look to figure it out. Any help would be appreciated, and please let me know what else I can provide for you to help make this easier.

 

Thank you!

Link to post

Ok so I figured out some of my issue. tl;dr I didn't have the current IP address set in my delugeVPN Privoxy, so the other programs routing traffic through there were just hitting a dead end.

 

I went through and rewatched all of SpaceInvaderOne's setup videos one by one for Setting up a privoxy and setting up Radarr. I made sure all of my subscriptions were up to date and had the right information in them.

 

Now, Sonarr keeps giving me an "Unknown exception: The operation has timed out.: 'https://192.168.2.87:8112/json'" error when trying to connect to Deluge, and an immediate "Test was aborted due to an error: Unable to connect to SABnzbd, please check your settings" error when trying to connect to SABnzbd. 

 

Both Sonarr and Radarr have the exact same Host, Port, and API settings. Radarr works but Sonarr doesn't. I've tried stopping and starting the container to see if that changes anything and it has no effect.

 

Why would this be happening?

Link to post
13 minutes ago, Arcaeus said:

Ok so I figured out some of my issue. tl;dr I didn't have the current IP address set in my delugeVPN Privoxy, so the other programs routing traffic through there were just hitting a dead end.

 

I went through and rewatched all of SpaceInvaderOne's setup videos one by one for Setting up a privoxy and setting up Radarr. I made sure all of my subscriptions were up to date and had the right information in them.

 

Now, Sonarr keeps giving me an "Unknown exception: The operation has timed out.: 'https://192.168.2.87:8112/json'" error when trying to connect to Deluge, and an immediate "Test was aborted due to an error: Unable to connect to SABnzbd, please check your settings" error when trying to connect to SABnzbd. 

 

Both Sonarr and Radarr have the exact same Host, Port, and API settings. Radarr works but Sonarr doesn't. I've tried stopping and starting the container to see if that changes anything and it has no effect.

 

Why would this be happening?

Disable "use ssl" and it should work

Link to post
16 minutes ago, Arcaeus said:

Why would SSL prevent that from communicating? Especially when Radarr has SSL enabled?

Are you sure you've set up ssl in deluge? If not, that's the reason it's not working when you have enabled use ssl in sonarr. 

Link to post
2 minutes ago, strike said:

Are you sure you've set up ssl in deluge? If not, that's the reason it's not working when you have enabled use ssl in sonarr. 

Looking at Deluge in the Interface Tab, SSL is unchecked. Seems odd that one would work and one wouldn't.

Link to post
1 minute ago, Arcaeus said:

Looking at Deluge in the Interface Tab, SSL is unchecked. Seems odd that one would work and one wouldn't.

Then radarr is probably not using ssl either. Just check the radarr log if it's connecting to deluge over https or http. If it really connecting over https, then yeah it's really weird that it's working when deluge has ssl unchecked. If it's connecting over http its either a bug in radarr or maybe you remembered wrong and it does not have use ssl enabled. :)

Link to post
5 minutes ago, strike said:

Then radarr is probably not using ssl either. Just check the radarr log if it's connecting to deluge over https or http. If it really connecting over https, then yeah it's really weird that it's working when deluge has ssl unchecked. If it's connecting over http its either a bug in radarr or maybe you remembered wrong and it does not have use ssl enabled. :)

Haha that could be the case!

 

So now that's working, it seems like Sonarr is downloading the files, but not renaming them and moving the to the Media directory so Plex can see them. I downloaded a tv series in Sonarr (and a movie in Radarr) and then it just sat there, not renaming it or moving it anywhere.

 

Wasn't this a feature that Sonarr (or SABnzbd) would do? And then once it's moved it to the main Media Library delete it from the usenet_completed folder? or am I thinking of something else? In the Sonarr settings I have "Rename Episodes" turned on.

Edited by Arcaeus
Link to post

Yeah sonarr/radarr should be moving the files provided you have set up your volume mappings correct and deluge/sab is moving the completed files to the correct folder. if you have both sonarr and radarr you probably have at least 2 labels set up in deluge? Post your docker run command for radarr,sonarr,deluge and sab and the download and label settings in deluge, same for sab. For all of the apps to work together they all should share the same volume mappings and settings. If not, you get issues like the one you're having.

Link to post
4 minutes ago, strike said:

Yeah sonarr/radarr should be moving the files provided you have set up your volume mappings correct and deluge/sab is moving the completed files to the correct folder. if you have both sonarr and radarr you probably have at least 2 labels set up in deluge? Post your docker run command for radarr,sonarr,deluge and sab and the download and label settings in deluge, same for sab. For all of the apps to work together they all should share the same volume mappings and settings. If not, you get issues like the one you're having.

Ok good to know.

 

What is the "Docker run command"? Is that where you edit the mappings, ports, and such?

 

There are a couple labels in Deluge, but they have nothing in them as I'm just using Deluge for the Privoxy/VPN component. Seems like the network traffic is the only thing Deluge should worry about as the rest of the "file management" is handled by SAB or Radarr/Sonarr?

2020-06-05 15_36_01-MediaVault_Docker Mappings.png

2020-06-05 15_37_04-Media Server download file locations.png

2020-06-05 15_39_17-Deluge Download Settings.png

2020-06-05 15_40_46-SABnzbd Config - Categories.png

2020-06-05 15_42_53-Radarr_UpdateContainer.png

2020-06-05 15_43_36-Sonarr_UpdateContainer.png

2020-06-05 15_44_51-DelugeVPN_UpdateContainer.png

2020-06-05 15_45_31-SABnzbd_UpdateContainer.png

Deluge labels.png

Link to post

The docker run command is the command that starts/creates the container and shows all your mappings/ports. But a screenshot works just as good :) If someone ask you to post your docker run command you can get it by editing the container, change one setting and change it back then hit apply. Then a window will pop up with the docker run command.

 

All your volume mappings looks good btw :) But you don't use deluge to download torrents? You only use the privoxy part?

 

I see you have 37 torrents there but none of them have labels. You really need to use labels, if you don't use them all your movies and shows will all end up in the complete folder. Then sonarr/radarr will have a headache trying to figure out what is a movie and what is a show (since they all end up in the same place) and your log will be filled with errors.

 

I see you have created 2 labels in deluge, so you should set them up in sonarr/radarr under the downloader section so they pass the label to deluge. Then right click the label in deluge and go to the location tab and apply the location settings and put in the correct path. Should be /data/completed/rararr and /data/completed/tv-sonarr.

 

If done correctly deluge should put all the completed movies in a folder called radarr and all the completed shows in tv-sonarr on the complete folder. I don't use sab, but it seems like it has the same thing, but it's called categories? If so they should be named the same as the labels. 

 

When you have done all that it should theoretically work. If not take a look at the log in sonarr/radarr to see what the issue is. That being said it should theoretically work the way you have set it up now too, but as I said sonarr/radarr might be fighting a headache trying to find out whats what since everything now ends up in the same place.

 

Link to post

OH so that's what that's called! Thank you for explaining that.

19 hours ago, strike said:

All your volume mappings looks good btw :) But you don't use deluge to download torrents? You only use the privoxy part?

 

Thanks! Good to know that's not an issue. I do use Deluge to download torrents, but as of late haven't really known any good places to find torrents. Therefore I generally just stick with NZBs, as the quality and download speed generally seems to be better. I'm open to torrent site recommendations if you know of some.

 

I also only have one indexer (NZBgeek), so if you or anyone knows of a secondary, that would also be much appreciated. Possibly one that does a good amount of anime too. I have an option via Hexchat which works, but it's kinda clunky.

 

Sure, I'm happy to use labels if that would make things work better, just never knew how to. All of the torrents that I've downloaded so far have been directly put into Deluge, and not via Sonarr/Radarr (hence why they don't have any labels). I believe I have the Sonarr/Radarr label settings correct, have created  directories that match the labels, and set the "Move completed to" settings for the tv-sonarr/radarr labels in Deluge.

 

Now is that going to be an issue with Sonarr/Radarr picking up the file, renaming it, and placing it in the correct Media directory so Plex can see it?

 

Looks like Sonarr finally got all of the video files over to the Media directory so Plex can see them. But it took like 12 hours to finally move over, where it was just sitting in the queue seemingly not doing anything. It also keeps pulling up an error that it can't connect to the indexer, but then I open the settings and hit test and it says "test succeeded". Attached are the logs in a txt file.

 

I'm having the same issue with some movies being stuck in Radarr and not processing through to the Media library, but I can move over to the binhex-radarr thread for that if that's better?

2020-06-06 08_34_11-Settings - Radarr.png

2020-06-06 08_59_38-Settings - Sonarr.png

2020-06-06 09_06_16-label options tv-sonarr.png

2020-06-06 09_11_19-Activity - Radarr - Movies stuck.png

 

Sonarr Logs 6.6 9.51am

Edited by Arcaeus
Link to post
1 hour ago, Arcaeus said:

But it took like 12 hours to finally move over

Really? Well, at least then it's working. But are you sure they were finished downloads and not in the process of being downloaded? Didn't really see anything special in the log.

 

1 hour ago, Arcaeus said:

I'm having the same issue with some movies being stuck in Radarr and not processing through to the Media library

What does the log say?

 

And please remove that last screenshot, don't show what you're downloading unless it's completely legal.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.