[Support] binhex - Sonarr


1045 posts in this topic Last Reply

Recommended Posts

  • Replies 1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

So, Sonarr v3 is FINALLY here, its out of beta and is now the latest release, if you want to switch from Sonarr v2 to v3 then simply pull down the 'latest' tagged image.   However, if you wa

@SavagelyCalm I have the same problem.   Edit your Docker repository link to this "binhex/arch-sonarr:v3" and it'll re-download a working version.  Worked for me. 

guys it looks like sonarr V3 has finally dropped and is now the latest release so I need to make some minor adjustments for the image and this will fix it all up Sent from my CLT-L09 using Tapatalk

Posted Images

4 hours ago, binhex said:

Thank you! I tried it and it worked perfect after some trial and error on my part. I definitely need to learn how to navigate GitHub, Im terrible. I know v3 of Radarr is more beta then v3 for Sonarr, but is it possible to do this with binhex-radarr aswell?

Link to post
2 minutes ago, kim_sv said:

I know v3 of Radarr is more beta then v3 for Sonarr, but is it possible to do this with binhex-radarr aswell?

doing the same for radarr makes me more nervous, i would expect it to be more 'beta' than production ready, and i can imagine there would be a lot more support caused by this which i would not be able to respond to (time constraints), so for now im going to say no.

  • Like 1
  • Thanks 1
Link to post
10 hours ago, binhex said:

Thanks for this binhex.  I guess I was just a little too eager to get it working, rather than wait for your response.  I always try to figure things out myself, but this time took it in a different direction.  I can change to your v3 branch of course.  Can I ask if you are keeping that up to date as much as the normal one - or is too much change (i.e more beta) something you frown upon ?

Link to post
7 hours ago, wgstarks said:

Took a shot at updating to v3 using the faq that @binhex linked. Can't connect to the webui now. Tried with several browsers. Supervisord log linked below. It looks like the docker is running to me.

 

SafariScreenSnapz217.jpg.6ed8f3f5a980ed652d8c13afbafa3db3.jpg

 

supervisord.log.5 10 MB · 1 download

try http or https, also make sure the port is correct on the host side.

Link to post
Took a shot at updating to v3 using the faq that @binhex linked. Can't connect to the webui now. Tried with several browsers. Supervisord log linked below. It looks like the docker is running to me.
 
SafariScreenSnapz217.jpg.6ed8f3f5a980ed652d8c13afbafa3db3.jpg
 
supervisord.log.5
Not sure if your issue is same as mine but had the same problem your having then noticed that I had used this from the faq "/mnt/cache/appdata/binhex-sonarr-v3" but mine needed to be mapped to "/mnt/user/appdata/binhex-sonarr-v3" as soon as I made that change I could connect.

Sent from my Pixel 2 XL using Tapatalk

Link to post
13 minutes ago, klipp01 said:

Not sure if your issue is same as mine but had the same problem your having then noticed that I had used this from the faq "/mnt/cache/appdata/binhex-sonarr-v3" but mine needed to be mapped to "/mnt/user/appdata/binhex-sonarr-v3" as soon as I made that change I could connect.

Sent from my Pixel 2 XL using Tapatalk
 

This was the problem. Cant say I really understand why though? The appdata share is cache only so /mnt/cache/ should be a valid path. It shows in the file browser when setting the path and that path has always worked before for all my other dockers including the default version of this one.

Link to post
This was the problem. Cant say I really understand why though? The appdata share is cache only so /mnt/cache/ should be a valid path. It shows in the file browser when setting the path and that path has always worked before for all my other dockers including the default version of this one.
Might be mapping issue? I was bewildered as well since my appdata is on my cache. But my v2 install was mapped using /mnt/user so I tried that and it worked. Glad it worked for you.

Sent from my Pixel 2 XL using Tapatalk

Link to post

Anyone having connection issues to Deluge from sonarr and radarr?  I think I updated the containers a few days ago (all of them are currently up to date) and sonarr and radarr can't reach deluge (unable to communicate with deluge. Error: ConnectFailure (No route to host): 'http://...:8112/json).  I can get to the webgui for deluge just fine, I can get to sonarr, radarr.  Sonarr and Radarr can reach sabnzb just fine in another docker container.  Also, privoxy works just fine with jackett through the container.

Edited by mlody
Link to post

Regarding the instructions to use v3 of Sonarr, I believe I followed Binhex's instructions on Github but when I start the Sonarr container I receive an error (full log here):

 

Quote

2020-11-27 11:32:11,630 DEBG 'sonarr' stdout output:
EPIC FAIL! NzbDrone.Core.Datastore.CorruptDatabaseException: Database file: /config/sonarr.db is corrupt, restore from backup if available. See: https://github.com/Sonarr/Sonarr/wiki/FAQ#i-am-getting-an-error-database-disk-image-is-malformed ---> System.Data.SQLite.SQLiteException: attempt to write a readonly database

 

Am I missing something or is there something else wrong in Unraid/Docker that would explain why I am seeing this?

Link to post

I am using binhex's sonarr and deluge dockers.  What I'm trying to do is have a torrent automatically delete once a seeding ratio has been reached.  Setting the seed ration in the indexer setup in Sonarr seems to pause the torrent in deluge, but does not delete it.  Setting the seed ratio in deluge also pauses it, even though I have the box checked for remove, it doesn't remove.

 

Am I doing it wrong, or is this just not possible?

Link to post
Just now, wgstarks said:

It’s probably still broken in deluge. You can install the auto remove plugin in deluge and that should work.

I tried installing that plugin 3 times, but had ZERO luck.  I downloaded the python v26 and v27 (I think, they are the only 2 offered on the plugin page), but after installing, neither one showed as a plugin in deluge.

 

Oh well, it'd be nice to have it work, but I have probably spent 5 times more time trying to automate this, than what it would take to just do it manually every time.  I'll just set it up in Deluge again, in the normal settings, and maybe one day it will just start working properly for me.

 

thanks for the guidance.

Link to post
On 11/27/2020 at 12:44 PM, onyx00 said:

Regarding the instructions to use v3 of Sonarr, I believe I followed Binhex's instructions on Github but when I start the Sonarr container I receive an error (full log here😞

 

 

Am I missing something or is there something else wrong in Unraid/Docker that would explain why I am seeing this?

I am getting the same error.  I switched back to V2 and the error goes away.

Link to post

Looking for some help, I have error
"[v3.0.4.1023] System.Data.SQLite.SQLiteException (0x80004005): database disk image is malformed
database disk image is malformed"

A quick google shows I am far from the first person to deal with this but I am out of my element with all this and can't understand anything beyond it is a sqlite error. help? :D

thanks

sonarr.txt

Edited by mctavish01
added logs
Link to post

Just switched over to this image from linuxserverio image for path consistency and noticed on versions something I've never seen before (also switched radarr without this issue)

 

Unable to update Sonarr directly, flag sonarr-phantom out-of-date, use an aur helper or the manual method to update.

 

I assume that 3.0.4.1023 was the version that I was running on linuxserverio

 

I also assume that this isn't a docker issue as the sonarr-phantom package seems to not be updated as quickly as the linuxserverio images are released, but want to try to understand if I have a configuration issue or this is all "normal".

 

2020-12-07_7-42-39.png

Link to post
18 hours ago, mctavish01 said:

Looking for some help, I have error
"[v3.0.4.1023] System.Data.SQLite.SQLiteException (0x80004005): database disk image is malformed
database disk image is malformed"

A quick google shows I am far from the first person to deal with this but I am out of my element with all this and can't understand anything beyond it is a sqlite error. help? :D

you will need to restore your sonarr database file from backup or delete the corrupted database file and re-import all your tv series, the database file will be located at /config/sonarr.db

Link to post
7 minutes ago, Gonzo-the-great said:

I also assume that this isn't a docker issue as the sonarr-phantom package seems to not be updated as quickly as the linuxserverio images are released, but want to try to understand if I have a configuration issue or this is all "normal".

it can safely be ignored, its simply saying latest commit is ahead of the current app running, at some point i will press the button and update to the latest commit on github.

Link to post

I am lost and could use some help.  I am running Unraid 6.8.3 and could never get Sonarr to process a download and add it to my media till I added the "download folder" to Drone Factory options then everything worked great (had to live with message stating the Drone Factory was depreciated).  Moved to Sonarr v3 and now I am back to downloads not being added to media.  Files appear to download correctly and can see no issue in the logs.  Any suggestions?

 

2020-12-07 19:11:28,017 DEBG 'sonarr' stdout output:
[Info] NzbSearchService: Searching 1 indexers for [BattleBots (2015) : S05E01]

2020-12-07 19:11:28,017 DEBG 'sonarr' stdout output:
[Info] NzbSearchService: Searching 1 indexers for [BattleBots (2015) : S05E01]

2020-12-07 19:11:31,220 DEBG 'sonarr' stdout output:
[Info] DownloadDecisionMaker: Processing 5 releases

2020-12-07 19:11:41,080 DEBG 'sonarr' stdout output:
[Info] Sabnzbd: Adding report [BattleBots.2015.S05E01.Return.of.the.Bots.720p.HEVC.x265-MeGusta] to the queue.

2020-12-07 19:11:41,196 DEBG 'sonarr' stdout output:
[Info] DownloadService: Report sent to SabNzdb. BattleBots.2015.S05E01.Return.of.the.Bots.720p.HEVC.x265-MeGusta

2020-12-07 19:13:44,733 DEBG 'sonarr' stdout output:
[Info] RssSyncService: Starting RSS Sync

2020-12-07 19:13:46,356 DEBG 'sonarr' stdout output:
[Info] DownloadDecisionMaker: Processing 100 releases

2020-12-07 19:13:46,356 DEBG 'sonarr' stdout output:
[Info] DownloadDecisionMaker: Processing 100 releases

2020-12-07 19:13:46,514 DEBG 'sonarr' stdout output:
[Info] RssSyncService: RSS Sync Completed. Reports found: 100, Reports grabbed: 0

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.