[Support] binhex - Sonarr


Recommended Posts

I am lost and could use some help.  I am running Unraid 6.8.3 and could never get Sonarr to process a download and add it to my media till I added the "download folder" to Drone Factory options then everything worked great (had to live with message stating the Drone Factory was depreciated).  Moved to Sonarr v3 and now I am back to downloads not being added to media.  Files appear to download correctly and can see no issue in the logs.  Any suggestions?  Attached are my mappings:

 

 

binhex.jpg

Link to comment
2 hours ago, sigfreund said:

I am lost and could use some help.  I am running Unraid 6.8.3 and could never get Sonarr to process a download and add it to my media till I added the "download folder" to Drone Factory options then everything worked great (had to live with message stating the Drone Factory was depreciated).  Moved to Sonarr v3 and now I am back to downloads not being added to media.  Files appear to download correctly and can see no issue in the logs.  Any suggestions?  Attached are my mappings:

 

 

binhex.jpg

To get mine to work, I had to set my mappings such that they are all on the same mount point.  

For Sonarr:

 

/data-------------/mnt/user/media/TV Shows/
/config---------/mnt/user/appdata/binhex-sonarr-v3
/media---------/mnt/user/media
 

For Radarr:

 

/data-----------/mnt/user/media/Movies/
/media--------/mnt/user/media
/config-------/mnt/user/appdata/binhex-radarr

 

So, the common mount point is /mnt/user/media

 

My downloads directory is located at /mnt/user/media/downloads/

Radarr and Sonarr put their files in the following folders during download, and then radarr and sonarr move them to my /mnt/user/media/Movies or /mnt/user/media/TV Shows folders

 

/mnt/user/media/downloads/sonarr

/mnt/user/media/downloads/radarr

 

I hope this helps.

Link to comment

Issue: Recently added series are not updating the episode counts. These also do not show in the "missing episodes" filter.

Example: Season one on this particular show has 10 episodes, sonarr reports 0/0 episodes for the season. Even though the series is set to monitored Sonarr shows 0 episodes as monitored, since 0 episodes are listed.

 g6hsTEc.png

 

dgUG7T2.png

Currently using the V3 version of binhex-sonarr. Had the same issue on the previous version.  

Work around: I can force sonarr to search and find episodes by either using the automatic or manual search. 

 

Link to comment

When adding new shows they are going to the very top of my downloads list. I have a list of 200+ movies in que currently , when I added a show in sonarr it stopped the movies that were downloading and added this show to the very top of the que. I cannot find any settings within sonarr that cause this. 

Link to comment
10 minutes ago, heathhd09 said:

When adding new shows they are going to the very top of my downloads list. I have a list of 200+ movies in que currently , when I added a show in sonarr it stopped the movies that were downloading and added this show to the very top of the que. I cannot find any settings within sonarr that cause this. 

Likely the settings are in your download client. “Add new torrents to top of queue” or something similar. There may also be settings for limiting the number of concurrent downloads.

Link to comment

Not sure if this is the right place, but I'm running out of ideas.  setup unraid server. trying to setup sonarr (never used it before). following spaceinvader on video and get to point of pointing sonarr at the seedbox. I'm using feral hosting. I follow the instructions between the video and and feral wiki and wind up here with a failed test. Any help you can provide would be great. I've tried using both my username and "rutorrent" in the username box.

sonarr fail.png

Solved it, not sure what I did, just kept trying the same things in different ways.  Might have been a spelling error somewhere

Edited by crusemm
Link to comment
  • 2 weeks later...

I'm trying to understand the difference between the sonarr and radarr Docker compose when it comes to port mapping.

 

Sonarr port host 1: 7878 (I understand this)

 

Radarr port host 1: 8989

Port host 2: 9897

 

This is where I get confused. Why is there a need for 2? The webui opens to port 8989 so where does 9897 come into play? Why does sonarr not have two ports? 

Edited by bilinz
Spelling
Link to comment

Hi, So when I search for an episode in Sonarr, for instance bar rescue I see s03E21 but when I click on the manual search button it only shows S04E01.  

 

image.thumb.png.d4b3816eb02dfeaabd9f2dd9f3bf5b22.png

 

This happens for a few episodes.  And when I hover over the red circle it just says that the file is larger than the maximum allowed.  It does not say "Wrong Series".  I read a post that says refreshing the series in drone fixed this but I think they were running docker on an actual PC and not in unraid.

 

https://forums.sonarr.tv/t/wrong-season-numbering/1008/8

 

Can anyone help with getting sonarr to show the correct episodes when I click manual search?

 

Thanks

Link to comment

Hi, a few months ago my qbittorrentvpn stopped working with this docker. I eventually removed the docker image, then deleted the app folder. Reinstalled qbittorrentvpn and got that going again, but for some reason it won't connect when adding it as a download client. Not that big of a deal, because I also setup binhex-delugevpn, which after finally configuring it right do I have it working again and connected to this Sonarr docker. Not sure why qbittorrentvpn won't connect, but at least deluge is working again (for the most part) with it. 

 

My only issue now is I have Completed Download Handling Enabled and Removed both checked. But when I download something from Sonarr, after it finishes moving it won't delete the torrent. Is there something else I need to do in deluge that I'm missing? This option worked great before, so would like to have it set so it'd delete Torrents setup with Sonarr. Not sure where to go from here. Any suggestions? Any help would be much appreciated! 

Link to comment

Try setting the torrent to a paused state when it finished in the download client (deluge or qbittorrent) as opposed to having the download client delete it. Sonarr should then move the file and remove it from the client. Try restarting both containers after changing the settings. Let us know if you still have an issue and if so send us some screenshots of your settings.

Link to comment

Deluge does move the torrent after it finishes, just doesn't delete it. It's moved out of the Sonarr client Activity section, but doesn't delete it from Deluge. Tried Pausing the torrent after it finished, stopped and restarted both dockers and still having the issue. Attached a couple screenshots, and my logs. If you need something specific, please let me know. Thanks for the help! 

 

Screen Shot 2021-01-08 at 23.36.58 PM.png

Screen Shot 2021-01-08 at 23.40.08 PM.png

tower-syslog-20210109-0444.zip

Link to comment

@yanksno1

Can you also post screenshots of Deluge - Downloads, Queue? So far everything looks ok as far as settings.

 

In your syslog, there are Disk Read errors for Disk 1. I'm not sure if this is of consequence, but that drive may be having issues. I would do research on this forum how to repair/rebuild/replace that drive if necessary.

Link to comment

Yup, here they are. I first got a couple of those Disk SMART errors a few months ago. At the time, there were only 2 but looks like I now have 5. Asked here if I should replace the HDD, but someone thought it wasn't that big of an issue since it was 2 and I just got a clean SMART test result. Just did a new one and got back errors, 5 this time. Think it's time to replace the HDD that's causing this issue? The downloading is being done on my SATA cache drive, then moved over fine (just deluge doesn't delete it). Looks like it did get moved over to the Disk 1. Posted the screen shots and the SMART test log. Your thoughts are much appreciated! 

 

 

Screen Shot 2021-01-09 at 9.51.57 AM.png

Screen Shot 2021-01-09 at 9.52.13 AM.png

tower-smart-20210109-0952.zip

Link to comment

Thanks for sending those.

 

I'd say try these changes and see if you have success:

  1. Change your download folder directory. Right now, your completed downloads are 'upstream' of your downloads in progress. I'm not sure if you HAVE to do this, but it might be worth a try. Create a /Downloads/complete directory and keep your current /Downloads/incomplete.
  2. Check the box for 'Share Ratio', then keep the bubble checked for 'Pause torrent.' Make the share ratio as low or high as you'd like. Maybe turn it down as low as you can while testing. Also, your downloads may not have been removed because they are set to seed for high share/time ratios. Decrease all the numbers for 'Seeding Rotation' while you are testing, then bump them back up to whatever you'd like.
  • Like 1
Link to comment

Made those suggested changes and still behaving the same way. Did move it after it finished to the Completed folder! But the torrent in deluge and the original file is still there in the Completed folder on Disk 1. Think those SMART errors are the problem and it's time to replace the drive? Here's how I have the Queue set up now:

 

88186011_ScreenShot2021-01-10at2_48_57PM.thumb.png.3ab9e10c31958c184d556d01c6543861.png

 

EDIT: Also should mention if I manually delete the torrent in deluge, it WILL delete the file in the Completed folder. Any other suggestions to try? 

Edited by yanksno1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.